Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SIP Trunk Configuration For Voice Pulse ISP

Hello,

I recently purchased a Voice Pulse SIP trunk. Ive added the configuration to my UC540, the configuration was added via the command line not CCA.

I dont appear to be registering with VoicePulses specified SIP server. When I run debugs I see no attempts from the UC540 to connect to the SIP server and register. This makes me think somethng globaly is configured incorrect or there is an important statement Im missing. I do have one 3rd party SIP soft phone registered on the system and a number of Cisco handset 7900 series. Up until this point the system has been using a pots line to dial out. I havnt got to the dial plan yet I just wanted to see if I could actually register. A sample of my config is below. Ive also opened a ticket with VoicePulse to see if they have to do anything on there end to establish the connection.

Just wonderd if anyone see's something obvious that I'm missing. Appreciate any advise.

Andy

I can ping the two Voicepulse SIP servers

uc540#

uc540#ping jfk-primary.voicepulse.com

Translating "jfk-primary.voicepulse.com"...domain server (68.87.85.102) [OK]

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 64.61.93.190, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms

uc540#ping jfk-backup.voicepulse.com

Translating "jfk-backup.voicepulse.com"...domain server (68.87.85.102) [OK]

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 209.31.18.12, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms

uc540#

!

interface FastEthernet0/0

description $FW_OUTSIDE$

bandwidth 4000

ip address dhcp client-id FastEthernet0/0

ip access-group 104 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip nat outside

ip inspect SDM_MEDIUM out

ip virtual-reassembly

load-interval 30

duplex auto

speed auto

!

access-list 104 remark *****Below VoicePulse Sip ACL*************

access-list 104 permit udp host 64.61.93.190 eq 5060 any

access-list 104 permit udp host 64.61.93.190 any eq 5060

access-list 104 permit udp host 209.31.18.12 eq 5060 any

access-list 104 permit udp host 209.31.18.12 any eq 5060

access-list 104 permit udp host 192.168.10.1 eq 5060 any

access-list 104 permit udp host 192.168.10.1 any eq 5060

access-list 104 permit udp any any range 16384 32767

access-list 104 deny   ip any any log

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

fax protocol none

no fax-relay sg3-to-g3

sip

  registrar server expires max 600 min 60

  localhost dns:networkwise.net

  no update-callerid

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

codec preference 3 g711alaw

!

voice class sip-profiles 1000

request ANY sdp-header Connection-Info remove

response ANY sdp-header Connection-Info remove

!

!

voice class cause-code 1

no-circuit

!

voice register global

mode cme

source-address 10.1.10.2 port 5060

max-dn 4

max-pool 4

create profile sync 0428016071226797

!

voice register dn  1

number 240

name Andy's Phone

label 240

!

voice register pool  1

id mac 7CC3.A1A1.EF11

number 1 dn 1

dtmf-relay rtp-nte

voice-class codec 1

username 240 password siptestpw

no vad

!

sip-ua

authentication username xxxxxx password 7 063637111A1A28183C4540 realm jfk-primary.voicepulse.com

authentication username xxxxxx password 7 02363C6B5D522E20751C5B realm jfk-backup.voicepulse.com

no remote-party-id

retry invite 2

retry register 10

timers connect 100

registrar dns:jfk-primary.voicepulse.com expires 60

registrar dns:jfk-backup.voicepulse.com expires 60 secondary

sip-server dns:jfk-primary.voicepulse.com

host-registrar

!

1 REPLY
Hall of Fame Super Gold

SIP Trunk Configuration For Voice Pulse ISP

Do you have "term mon" with debugs ?

Also, you will need to register some meaningful number, not just '240'.

1200
Views
0
Helpful
1
Replies
CreatePlease to create content