Cisco Support Community
Community Member

SPA502G - Can't factory reset: needs Admin login

Does anyone know how to factory reset the phone without the Admin login? (If I had this,I wouldn't need to reset!) If I use the phone menu for reset I just get a login, but my existing VOIP provider doesn't know it!

Thanks in advance

Everyone's tags (4)
Community Member

SPA502G - Can't factory reset: needs Admin login

Hello Steve,

Are you able to press the Setup button and choose the Factory Reset option?

That seems to be the easiest way to do it.

Community Member

SPA502G - Can't factory reset: needs Admin login

Hi Joshua

Unfortunately its at this point that it asks for the Admin password. No-one seems to have it, and the default (admin) doesn't work either

Cisco Employee

SPA502G - Can't factory reset: needs Admin login

Hi Steve,

You can try downloading the new firmware from the cisco site click here and run the recovery.exe which might set it to the default values and you might be able to login with default credentials.


Please mark and rate for helpful posts.

Thanks, Prithvi Please mark answered and rate for helpful posts.
Community Member

I have this issue with a 502

I have this issue with a 502 and i have figured out a solution for anyone who cares to try this.

Firstly do not connect to the internet if it is provisioned offsite

Secondly either have another computer or a VM

After you have this in place download windows server 2012 R2 or whatever is newest at the point of reading this.

Setup a server as you would out of the box and install iis and create a new site lets pretend the server is a web server (your provider in the provision) for example http//


Then create a config file based on the longer url and create the directory depth using lower and upper-case to match.


When you boot your phone it will resolve the url to a local server and grab your spacnfg.xml obviously named as the one in the url


Make sure you have some lines in that like this

<Enable_Web_Server group="System/System_Configuration">Yes</Enable_Web_Server>
<Web_Server_Port group="System/System_Configuration">80</Web_Server_Port>
<Enable_Web_Admin_Access group="System/System_Configuration">Yes</Enable_Web_Admin_Access>
<Admin_Password group="System/System_Configuration"/>
<User_Password group="System/System_Configuration"/>


and when it grabs the config it will unlock you could also set an alternative password etc.


This is  a longer work round from calling the original provider but some are funny about unlocking.

If this helps anyone please let me know

CreatePlease to create content