Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

SPA900 Caller ID problems

I have a SPA9000, SPA 400 configured with 4 handsets and sip account. The software version of the SPA9000 is 6.1.5 and of the SPA400. The firmware version of the SPA 400 is 1.1.2.2

I'm very happy with call quality etc having spent some time tweaking the settings. The problem I'm having is caller ID. Having received various settings from the reseller, the caller ID now works occasionally - approximately about 1 in 7 times.

Does anyone have any suggestions on how to improve this further. I located in Ireland

Thanks

Michael

58 REPLIES
Cisco Employee

Re: SPA900 Caller ID problems

Hi Michael,

I am aware of the problems you're experiencing with Caller ID in Ireland. We're actively working on the issue.

Please contact me at paborn at Cisco.com so that I can work closer with you.

Regards,

Patrick

----------

Cisco Employee

Re: SPA900 Caller ID problems

Michael,

We've been working on the caller id issue in the background with Cisco Ireland.

I now have new firmware that resolves the caller id problem in Ireland and will send you the firmware for testing.

I appreciate your patience and apologize that the fix has taken so long.

Regards,

Patrick

----------

Community Member

Re: SPA900 Caller ID problems

Thanks Patrick,

I know that these problems can take a while to resolve. Its great that you have put in the time and got to the bottom of it. I have upgraded the firmware that you sent and so far so good, it all seems to be working perfectly.

Thanks,

Michael.

Cisco Employee

Re: SPA900 Caller ID problems

Michael,

You just made my day. Thanks for letting me know that your caller id is now functional.

Regards,

Patrick

-----------

Community Member

Re: SPA900 Caller ID problems

Hi,

I apologize if I interferes but I have the same problem with CallerID,

but from Italy. I have 3 spa-system configured and updated (SPA400 1.1.2.2 SPA9000 6.1.5 SPA941 5.1.8 spa942 6.1.5a) connect to

telecom italia analog line and CallerID don't work. Do you have a

modified firmware for my problems?.

Thanks for Support

Thomas



Cisco Employee

Re: SPA900 Caller ID problems

Hi Thomas,

I'm aware of SPA400 caller id problems in Italy. We're currently actively working on resolving this.

Please contact me at paborn at Cisco.com so I can work closer with you.

Regards,

Patrick

----------

Community Member

Re: SPA900 Caller ID problems

I'm from Italy too and I have the same problem with CallerID since Jan 2009.

My spa-system (SPA400 1.1.2.2 / SPA9000 6.1.5 / SPA962 6.1.3(a) SPA942 6.1.3(a)) connected to telecom italia ISDN line.

I hope the new firmware is released soon.

Best regards

Cisco Employee

Re: SPA900 Caller ID problems

Hi Paolo,

We're actively working on identifying the root cause of caller id issues in Italy. I will contact you as soon as I am able to share a firmware update with you.

Regards,

Patrick

----------

Cisco Employee

Re: SPA900 Caller ID problems

Update for the community:

I've sent Paolo test firmware and instructions for installing on the SPA400.

Paolo will install and test as his schedule permits.

Regards,

Patrick

----------

Community Member

Re: SPA900 Caller ID problems

Hi,

thanks,

I look forward to results from tests, or send me a new firmware i test this one in my system



bye

Thomas

Cisco Employee

Re: SPA900 Caller ID problems

Hi Thomas,

Thanks for the offer. I've sent you some test firmware and instructions.

Please let me know of any progress.

Regards,

Patrick

-----------

Community Member

Re: SPA900 Caller ID problems

Hello, Patrick

Can I Test the beta firmware in my structure

Regards,

Massimiliano

Cisco Employee

Re: SPA900 Caller ID problems

Hi Massimiliano,

Please contact me at paborn at Cisco.com so we can determine if it is appropriate.

Regards,

Patrick

-----------

Community Member

Re: SPA900 Caller ID problems

I've found a working solutions for me (italy, telecom).

Without the new beta firmware this is the setting I've mod:

From SPA400:

TAB Setup ==> Voice ==> Set "Caller ID/CP Tone Method" to North American From

SPA9000:

TAB Voice ==> Regional  ==> Miscellaneous ==> Set "Caller ID Method" to Bellcore

TAB Voice ==> Regional  ==> Miscellaneous ==> "Caller ID FSK Standard" to V.23

Good luck to all.

Cisco Employee

Re: SPA900 Caller ID problems

Hi Paolo,

Great news. Thanks for sharing your success with the community.

It would be great if you could capture and share a screen shot of the relevant pages that you modified. This way others who search on SPA400 Italy caller id will locate your success story.

Regards,

Patrick

-----------

Community Member

Re: SPA900 Caller ID problems

Ok patrick,

I've attached the printscreen of the SPA400, in the SPA9000 the only settings i've modified for caller ID are reported before in the post.

For anything else, I'm here.

Best regards

Community Member

Re: SPA900 Caller ID problems

Hi,

in my system new beta firmware work ok and caller id are ok in 2 systems:

N.1 spa9000 + 4 x spa941 + 2 x spa400 (one analog line in ISDN NT1 Plus from Telecom Italia and one in GSM adapter)

N.2 spa900 + 4x spa942 + 1 x spa400 in PSTN line from telecom italia.

if i configure with bellcore work only via GSM adapter and PSTN line not analog line of ISDN NT1 Plus.

bye

Thomas

Community Member

Re: SPA900 Caller ID problems

and

for your knowledge

i attach print screnn of my SPA400 config (SPA9000 use localization italy from Wizard 2.1)

bye

Thomas

Community Member

Re: SPA900 Caller ID problems

In SPA9000 voice regional "Caller ID Method:" and "Caller ID FSK Standard:" what are your settings?

The setting for the "Caller ID/CP Tone Method" in SPA400 (missing in printscreen) is "European (FSK)"?

Thanks

Community Member

Re: SPA900 Caller ID problems

i attach more files with config in pdf (sorry for printscreen)

bye

Thomas

Community Member

Re: SPA900 Caller ID problems

Ok Paolo

Thank you for settings, whit North American (default) it's Ok,

but in

Call progress tone detection

Repeat count is 1 for me and not 2

Thanks

Bye

Community Member

Re: SPA900 Caller ID problems

The call progress tone detection is only for:

"The number of times that the cadence needs to repeat to be considered as a valid CP tone" (from the manual)

I think isn't a significant value for the caller id but only for the detection of a valid tone or not.

Now the base functionality is ok, but with my caller id setting when an incoming call arrive I see on display:

If the caller isn't in the Personal Directory:

No Name - "Name of Port ID 1"(in my case "ISDN_1") - caller number

If is in Personal Directory:

"Name" (saved in Personal Directory) - caller number

Is the same for you?

Thanks

Community Member

Re: SPA900 Caller ID problems

Hi,

it gives me the same..

if I do not believe that you can change only by SPA9x2 Phone (SPA942, SPA962, SPA922, etc..)


under SIP / Caller ID Header

apparent to you? I have not tried

bye

Thomas

Community Member

Re: SPA900 Caller ID problems

I think can work, but before I'll wait for an explain from Patrick (if he can) to the available options:

- PAID

- RPID

- FROM

All phones are in a production enviroment and I can't make test everytime I want.

The only thing I've found about Caller ID header (from manual) is:

"Provides the option to take the caller ID from PAID-RPIDFROM, P-ASSERTEDIDENTITY, REMOTE-PARTY-ID, or FROM header."



And on an unofficial forum I've found:

"Caller ID Header responsible for Caller Id source"

With this little information I think the caller id header cannot work to mod the information visualization on the phone.

Regards

Cisco Employee

Re: SPA900 Caller ID problems

Hi Paolo,

"ISDN_1" can be changed to whatever you prefer: SPA400 web-ui > Setup tab > SPA9000 Interface tab > Port ID > Port ID N: [replace ISDN_1 with 7775551212 or anything you'd prefer]

Regards,

Patrick

----------

Community Member

Re: SPA900 Caller ID problems

I've set up ISDN_1 on the Port ID 1, i need this setting, but only in case of malfunctions on phone line.

Every port ID have a description with the attached line, I've not to troble and loose time in case of problems.

The only thing I need is not view ISDN_1 on phones display, but this isn't an important setting.

If isn't possible remove it is better, if no it's ok too.

Regards

Paolo

Cisco Employee

Re: SPA900 Caller ID problems

Thank you Paolo.

Regards,

Patrick

----------

Community Member

Re: SPA900 Caller ID problems

Hi Patrick,

I've the same problem in Italy with a N°1 SPA9000 [fw 6.1.5] + N°1 SPA400 [fw 1.1.1.2] (Line 1&2 in ISDN NT1 plus TELECOM) + N°1 SPA942 + N°1 WIP330.

In this environment the Paolo's workaround solution is not working for me. The Call ID is missing (anonymous call)

Can you send me the beta fw to try to solve the issue ?

Thank you for attention.

Fabio.

Cisco Employee

Re: SPA900 Caller ID problems

Hi Fabio,

The updated firmware for the SPA400 is currently undergoing regression testing. Provided the firmware passes all tests, it should be available as version 1.1.2.3 by June 19, 2009.

Regards,

Patrick

-----------

26896
Views
0
Helpful
58
Replies
CreatePlease to create content