Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Strange problem with incoming calls on UC540 (POTS)

I have a strange problem with incoming calls with a UC540.  4 POTS lines in a trunk group by carrier (Verizon) is feeding the system.

This problem does not happen all the time but randomly here and there so it's very hard to troubleshoot - I would say maybe once every 8-10 calls or so.

When a caller from outside calls our main number and a user picks up the call, the call never connects, disappears for awhile and starts ringing again on the phones.

To give you more detail, this is what's happening in steps -

1. caller calls the main number

2. office phone rings with caller id and user tries to pick up the call

3. when the user picks up the handset or presses the speaker button, call is not connected and phone does not display any connected calls

4. caller keeps hearing the phone ring

5. after 2 rings or so, phone rings again this time with NO caller id

6. when the user picks up the handset or presses the speaker button, the call is connected

Has anyone had a problem like this in the past?  When I just tried to replicate the issue, the call actually disappeared on me 3 times before I was able to pick up the call.

I've attached a debug voip ccapi inout just incase someone can analyze it.

10 REPLIES
Community Member

Re: Strange problem with incoming calls on UC540 (POTS)

Hi pro4ianyc,

Has anyone had a problem like this in the past?  When I just tried to
replicate the issue, the call actually disappeared on me 3 times before I
was able to pick up the call.

I certainly have, the only problem is it was a while ago and it was due to a buggy IOS .20 (T1) and an IOS upgrade resolved the problem for us. The issue you describe is an identical one to what i experienced.

However the issue here now is, this is on a UC540 which means it is running the latest CME/IOS version 8+ and i cant see how this issues would have been reintroduced, in fact i would say it is highly un likely.

Is it possible for you to post your running config, just make sure you remove all usernames and passwords from the config, and any other sensitive information like phone numbers and user details.

I would like to see your call flow topology and try to work out if something along the way is breaking the system.

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Community Member

Re: Strange problem with incoming calls on UC540 (POTS)

David, glad to hear I'm not the only one.  As you know, this device being a UC540, I'm better off coming here than going to the Small Business Support for any advanced troubleshooting. ;)

Please see the config below -

!
version 15.0
parser config cache interface
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
service compress-config
service sequence-numbers
!
hostname SPUC540
!
boot-start-marker
boot system flash uc500-advipservicesk9-mz.150-1.XA1a
boot-end-marker
!
no logging buffered
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login sdm_vpn_xauth_ml_1 local
aaa authorization exec default local
!
aaa session-id common
!
!
!
clock timezone EST -5
clock summer-time PST recurring
!
ip source-route
ip cef
!
!
ip dhcp relay information trust-all
ip dhcp excluded-address 10.1.1.1 10.1.1.10
!
ip dhcp pool phone
   network 10.1.1.0 255.255.255.0
   default-router 10.1.1.1
   option 150 ip 10.1.1.1
!
!
ip name-server 4.2.2.2
ip inspect name SDM_LOW cuseeme
ip inspect name SDM_LOW dns
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW https
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW imap
ip inspect name SDM_LOW pop3
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW esmtp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp router-traffic
ip inspect name SDM_LOW udp
ip inspect name SDM_LOW vdolive
ip inspect name dmzinspect tcp
ip inspect name dmzinspect udp
no ipv6 cef
!
!
stcapp ccm-group 1
stcapp
!
stcapp feature access-code
!
!
!
stcapp supplementary-services
port 0/0/0
  fallback-dn 301
port 0/0/1
  fallback-dn 302
port 0/0/2
  fallback-dn 303
port 0/0/3
  fallback-dn 304
!
!
multilink bundle-name authenticated
!
!
trunk group ALL_FXO
max-retry 5
voice-class cause-code 1
hunt-scheme sequential
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
sip
  no update-callerid
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
voice class custom-cptone CCAleavetone
dualtone conference
  frequency 400 800
  cadence 400 50 200 50 200 50
!
voice class custom-cptone CCAjointone
dualtone conference
  frequency 600 900
  cadence 300 150 300 100 300 50
!
!
voice class cause-code 1
no-circuit
!
voice register global
!
!
voice logout-profile 1
user shared password 1234
number 150 type normal
!
voice user-profile 1
user mn
number 199 type normal
!
voice user-profile 2
user gg
number 203 type normal
!
voice user-profile 3
user jh
number 201 type normal
!
voice user-profile 4
user nb
number 202 type normal
!
voice user-profile 5
user tr
number 204 type normal
!
!
voice translation-rule 1112
rule 1 /^9/ //
!
voice translation-rule 2001
!
voice translation-rule 2002
rule 1 /^8/ //
!
voice translation-rule 2222
rule 1 /^91900......./ //
rule 2 /^91976......./ //
!
voice translation-rule 3333
rule 1 // /91\1/
!
!
voice translation-profile ADD91
translate calling 3333
!
voice translation-profile CALLER_ID_TRANSLATION_PROFILE
translate calling 1111
!
voice translation-profile CallBlocking
translate called 2222
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
translate called 1112
!
voice translation-profile XFER_TO_VM_PROFILE
translate redirect-called 2002
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
license udi pid UC540W-FXO-K9 sn FHK140674B7
archive
log config
  logging enable
  logging size 600
  hidekeys
!
process-max-time 150
!
ip tftp source-interface Loopback0
!
class-map match-all _class_Voice0
match ip dscp ef
class-map match-all _class_Voice1
match ip dscp cs3
!
!
policy-map Voice
class _class_Voice0
  set cos 6
class _class_Voice1
  set cos 3
!
!
!
!
bridge irb
!
!
!
!
interface Loopback0
description $FW_INSIDE$
ip address 10.1.10.2 255.255.255.252
ip access-group 101 in
ip nat inside
ip inspect SDM_LOW in
ip virtual-reassembly
!
!
interface Loopback1
ip address 50.50.50.50 255.255.255.0
ip nat inside
ip virtual-reassembly
!
!
interface Loopback2
no ip address
ip nat inside
ip virtual-reassembly
!
!
interface Loopback4
ip address 52.52.52.52 255.255.255.0
ip nat inside
ip virtual-reassembly
!
!
interface Loopback5
ip address 51.51.51.51 255.255.255.0
ip nat inside
ip virtual-reassembly
!
!
interface FastEthernet0/0
description $FW_OUTSIDE$
ip address 98.113.xxx.xxx 255.255.255.0
ip access-group 106 in
ip verify unicast reverse-path
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
!
interface Integrated-Service-Engine0/0
description cue is initialized with default IMAP group$FW_INSIDE$
ip unnumbered Loopback0
ip access-group 100 in
ip nat inside
ip inspect SDM_LOW in
ip virtual-reassembly
service-module ip address 10.1.10.1 255.255.255.252
service-module ip default-gateway 10.1.10.2
!
!
interface FastEthernet0/1/0
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/1
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/2
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/3
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/4
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/5
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/6
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
!
interface FastEthernet0/1/7
switchport access vlan 200
macro description cisco-desktop
spanning-tree portfast
!
!
interface FastEthernet0/1/8
switchport mode trunk
macro description cisco-switch
!
!
!
interface Virtual-Template1 type serial
ip unnumbered Loopback1
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template2 type serial
ip unnumbered Loopback2
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template3 type serial
no ip address
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template4 type serial
no ip address
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template5 type serial
ip unnumbered Loopback5
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template6 type serial
no ip address
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template7 type serial
no ip address
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template8 type serial
no ip address
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template9 type serial
no ip address
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template10 type serial
no ip address
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template11 type serial
no ip address
ip nat inside
ip virtual-reassembly
!
!
interface Virtual-Template13 type serial
ip unnumbered Loopback4
ip nat inside
ip virtual-reassembly
!
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
!
interface Vlan100
no ip address
bridge-group 100
bridge-group 100 spanning-disabled
!
!
interface Vlan200
no ip address
bridge-group 200
!
!
interface BVI1
description $FW_INSIDE$
ip address 192.168.10.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip inspect SDM_LOW in
ip virtual-reassembly
!
!
interface BVI100
description $FW_INSIDE$
ip address 10.1.1.1 255.255.255.0
ip access-group 103 in
ip nat inside
ip inspect SDM_LOW in
ip virtual-reassembly
!
!
interface BVI200
description VLAN for MFP$FW_DMZ$
ip address 10.0.0.254 255.255.255.0
ip access-group 105 in
ip nat inside
ip inspect dmzinspect out
ip virtual-reassembly
!
!
ip local pool SDM_WEBVPN_POOL_1 192.168.50.10 192.168.50.30
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
ip dns server
ip nat inside source static tcp 192.168.10.5 80 interface FastEthernet0/0 80
ip nat inside source static tcp 192.168.10.5 443 interface FastEthernet0/0 443
ip nat inside source static tcp 192.168.10.5 25 interface FastEthernet0/0 25
ip nat inside source static tcp 192.168.10.5 993 interface FastEthernet0/0 993
ip nat inside source route-map SDM_RMAP_1 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 98.113.xxx.xxx
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
access-list 100 remark auto generated by SDM firewall configuration##NO_ACES_7##
access-list 100 remark SDM_ACL Category=1
access-list 100 deny   ip 10.0.0.0 0.0.0.255 any
access-list 100 deny   ip 10.1.1.0 0.0.0.255 any
access-list 100 deny   ip 192.168.10.0 0.0.0.255 any
access-list 100 deny   ip 98.113.167.0 0.0.0.255 any
access-list 100 deny   ip host 255.255.255.255 any
access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 remark auto generated by SDM firewall configuration##NO_ACES_9##
access-list 101 remark SDM_ACL Category=1
access-list 101 permit tcp 10.1.1.0 0.0.0.255 eq 2000 any
access-list 101 permit udp 10.1.1.0 0.0.0.255 eq 2000 any
access-list 101 deny   ip 10.0.0.0 0.0.0.255 any
access-list 101 deny   ip 10.1.1.0 0.0.0.255 any
access-list 101 deny   ip 192.168.10.0 0.0.0.255 any
access-list 101 deny   ip 98.113.167.0 0.0.0.255 any
access-list 101 deny   ip host 255.255.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 permit ip any any
access-list 102 remark auto generated by SDM firewall configuration##NO_ACES_8##
access-list 102 remark SDM_ACL Category=1
access-list 102 deny   ip 10.1.10.0 0.0.0.3 any
access-list 102 deny   ip 10.0.0.0 0.0.0.255 any
access-list 102 deny   ip 10.1.1.0 0.0.0.255 any
access-list 102 deny   ip 98.113.167.0 0.0.0.255 any
access-list 102 deny   ip host 255.255.255.255 any
access-list 102 deny   ip 127.0.0.0 0.255.255.255 any
access-list 102 permit ip any any
access-list 103 remark auto generated by SDM firewall configuration##NO_ACES_10##
access-list 103 remark SDM_ACL Category=1
access-list 103 permit tcp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 permit udp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 deny   ip 10.1.10.0 0.0.0.3 any
access-list 103 deny   ip 10.0.0.0 0.0.0.255 any
access-list 103 deny   ip 192.168.10.0 0.0.0.255 any
access-list 103 deny   ip 98.113.167.0 0.0.0.255 any
access-list 103 deny   ip host 255.255.255.255 any
access-list 103 deny   ip 127.0.0.0 0.255.255.255 any
access-list 103 permit ip any any
access-list 104 remark SDM_ACL Category=2
access-list 104 deny   ip any host 192.168.50.10
access-list 104 deny   ip any host 192.168.50.11
access-list 104 deny   ip any host 192.168.50.12
access-list 104 deny   ip any host 192.168.50.13
access-list 104 deny   ip any host 192.168.50.14
access-list 104 deny   ip any host 192.168.50.15
access-list 104 deny   ip any host 192.168.50.16
access-list 104 deny   ip any host 192.168.50.17
access-list 104 deny   ip any host 192.168.50.18
access-list 104 deny   ip any host 192.168.50.19
access-list 104 deny   ip any host 192.168.50.20
access-list 104 deny   ip any host 192.168.50.21
access-list 104 deny   ip any host 192.168.50.22
access-list 104 deny   ip any host 192.168.50.23
access-list 104 deny   ip any host 192.168.50.24
access-list 104 deny   ip any host 192.168.50.25
access-list 104 deny   ip any host 192.168.50.26
access-list 104 deny   ip any host 192.168.50.27
access-list 104 deny   ip any host 192.168.50.28
access-list 104 deny   ip any host 192.168.50.29
access-list 104 deny   ip any host 192.168.50.30
access-list 104 permit ip 10.1.1.0 0.0.0.255 any
access-list 104 permit ip 10.0.0.0 0.0.0.255 any
access-list 104 permit ip 51.51.51.0 0.0.0.255 any
access-list 104 permit ip 10.1.10.0 0.0.0.3 any
access-list 104 permit ip 50.50.50.0 0.0.0.255 any
access-list 104 permit ip 192.168.10.0 0.0.0.255 any
access-list 104 permit ip 192.168.50.0 0.0.0.255 any
access-list 105 remark auto generated by SDM firewall configuration##NO_ACES_6##
access-list 105 remark SDM_ACL Category=1
access-list 105 permit tcp any host 10.0.0.254 eq 993 log
access-list 105 permit tcp any host 10.0.0.254 eq 443 log
access-list 105 permit tcp any host 10.0.0.254 eq smtp log
access-list 105 permit tcp any host 10.0.0.254 eq 3389 log
access-list 105 permit tcp any host 10.0.0.254 eq www log
access-list 105 permit ip any any
access-list 106 remark auto generated by SDM firewall configuration##NO_ACES_21##
access-list 106 remark SDM_ACL Category=1
access-list 106 permit tcp any host 98.113.xxx.xxx eq 993 log
access-list 106 permit tcp any host 98.113.xxx.xxx eq 443 log
access-list 106 permit tcp object-group FOREFRONT host 98.113.xxx.xxx eq smtp log
access-list 106 permit tcp any host 98.113.xxx.xxx eq 3389 log
access-list 106 permit tcp any host 98.113.xxx.xxx eq www log
access-list 106 deny   ip 10.1.10.0 0.0.0.3 any
access-list 106 deny   ip 10.0.0.0 0.0.0.255 any
access-list 106 deny   ip 10.1.1.0 0.0.0.255 any
access-list 106 deny   ip 192.168.10.0 0.0.0.255 any
access-list 106 permit udp host 4.2.2.2 eq domain any
access-list 106 permit icmp any host 98.113.xxx.xxx echo-reply
access-list 106 permit icmp any host 98.113.xxx.xxx time-exceeded
access-list 106 permit icmp any host 98.113.xxx.xxx unreachable
access-list 106 permit tcp any host 10.0.0.15 eq www
access-list 106 deny   ip 10.0.0.0 0.255.255.255 any
access-list 106 deny   ip 172.16.0.0 0.15.255.255 any
access-list 106 deny   ip 192.168.0.0 0.0.255.255 any
access-list 106 deny   ip 127.0.0.0 0.255.255.255 any
access-list 106 deny   ip host 255.255.255.255 any
access-list 106 deny   ip host 0.0.0.0 any
access-list 106 deny   ip any any log
access-list 199 remark SDM_ACL Category=16
access-list 199 permit ip host 10.0.0.15 any
access-list 199 permit ip any any
!
!
!
!
route-map SDM_RMAP_1 permit 1
match ip address 104
!
snmp-server community public RO
control-plane
!
!
bridge 1 route ip
bridge 100 route ip
bridge 200 protocol ieee
bridge 200 route ip
!
voice-port 0/0/0
timeouts ringing infinity
station-id number 301
caller-id enable
!
voice-port 0/0/1
timeouts ringing infinity
station-id number 302
caller-id enable
!
voice-port 0/0/2
timeouts ringing infinity
station-id number 303
caller-id enable
!
voice-port 0/0/3
timeouts ringing infinity
station-id number 304
caller-id enable
!
voice-port 0/1/0
trunk-group ALL_FXO 64
connection plar opx 100
description Configured by CCA 4 FXO-0/1/0-Custom-OP
caller-id enable
!
voice-port 0/1/1
trunk-group ALL_FXO 63
connection plar opx 100
description Configured by CCA 4 FXO-0/1/1-Custom-OP
caller-id enable
!
voice-port 0/1/2
trunk-group ALL_FXO 62
connection plar opx 100
description Configured by CCA 4 FXO-0/1/2-Custom-OP
caller-id enable
!
voice-port 0/1/3
trunk-group ALL_FXO 61
connection plar opx 100
description Configured by CCA 4 FXO-0/1/3-Custom-OP
caller-id enable
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control -15
description Music On Hold Port
!
sccp local Loopback0
sccp ccm 10.1.1.1 identifier 1 version 4.0
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register confprof1
!
dspfarm profile 1 conference 
description DO NOT MODIFY, active CCA conference profile - CCA2.0 codec711
codec g711ulaw
codec g711alaw
maximum conference-participants 16
maximum sessions 6
conference-join custom-cptone CCAjointone
conference-leave custom-cptone CCAleavetone
associate application SCCP
!
!
dial-peer voice 1 pots
service stcapp
port 0/0/0
!
dial-peer voice 2 pots
service stcapp
port 0/0/1
!
dial-peer voice 3 pots
service stcapp
port 0/0/2
!
dial-peer voice 4 pots
service stcapp
port 0/0/3
!
dial-peer voice 5 pots
description ** MOH Port **
destination-pattern ABC
port 0/4/0
no sip-register
!
dial-peer voice 50 pots
description ** incoming dial peer **
translation-profile incoming ADD91
incoming called-number .%
port 0/1/0
!
dial-peer voice 51 pots
description ** incoming dial peer **
translation-profile incoming ADD91
incoming called-number .%
port 0/1/1
!
dial-peer voice 52 pots
description ** incoming dial peer **
translation-profile incoming ADD91
incoming called-number .%
port 0/1/2
!
dial-peer voice 53 pots
description ** incoming dial peer **
translation-profile incoming ADD91
incoming called-number .%
port 0/1/3
!
dial-peer voice 2000 voip
description ** cue voicemail pilot number **
translation-profile outgoing XFER_TO_VM_PROFILE
destination-pattern 400
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1 
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 54 pots
description ** FXO pots dial-peer **
destination-pattern A0
port 0/1/0
no sip-register
!
dial-peer voice 55 pots
description ** FXO pots dial-peer **
destination-pattern A1
port 0/1/1
no sip-register
!
dial-peer voice 56 pots
description ** FXO pots dial-peer **
destination-pattern A2
port 0/1/2
no sip-register
!
dial-peer voice 57 pots
description ** FXO pots dial-peer **
destination-pattern A3
port 0/1/3
no sip-register
!
dial-peer voice 58 pots
trunkgroup ALL_FXO
corlist outgoing call-emergency
description **CCA*North American-10-Digit*Emergency**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9911
forward-digits all
no sip-register
!
dial-peer voice 59 pots
trunkgroup ALL_FXO
corlist outgoing call-emergency
description **CCA*North American-10-Digit*Emergency**
preference 5
destination-pattern 911
forward-digits all
no sip-register
!
dial-peer voice 60 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*North American-10-Digit*10-Digit Local**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]..[2-9]......
forward-digits all
no sip-register
!
dial-peer voice 61 pots
trunkgroup ALL_FXO
corlist outgoing call-local
description **CCA*North American-10-Digit*Service Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9[2-9]11
forward-digits all
no sip-register
!
dial-peer voice 62 pots
trunkgroup ALL_FXO
corlist outgoing call-national
description **CCA*North American-10-Digit*Long Distance**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91[2-9]..[2-9]......
forward-digits all
no sip-register
!
dial-peer voice 63 pots
trunkgroup ALL_FXO
corlist outgoing call-international
description **CCA*North American-10-Digit*International**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 9011T
forward-digits all
no sip-register
!
dial-peer voice 64 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*North American-10-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91800.......
forward-digits all
no sip-register
!
dial-peer voice 65 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*North American-10-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91888.......
forward-digits all
no sip-register
!
dial-peer voice 66 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*North American-10-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91877.......
forward-digits all
no sip-register
!
dial-peer voice 67 pots
trunkgroup ALL_FXO
corlist outgoing call-toll-free
description **CCA*North American-10-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 5
destination-pattern 91866.......
forward-digits all
no sip-register
!
dial-peer voice 2001 voip
description ** cue auto attendant number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 399
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1 
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 2012 voip
description ** cue prompt manager number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 398
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1 
dtmf-relay sip-notify
codec g711ulaw
no vad
!
!
no dial-peer outbound status-check pots
!
!
telephony-service
sdspfarm conference mute-on 111 mute-off 222
sdspfarm units 5
sdspfarm tag 1 confprof1
conference hardware
video
fxo hook-flash
max-ephones 40
max-dn 300
ip source-address 10.1.1.1 port 2000
auto assign 10 to 43
auto assign 5 to 8 type anl
calling-number initiator
service phone videoCapability 1
service dnis overlay
service dnis dir-lookup
timeouts interdigit 5
system message
url services http://10.1.10.1/voiceview/common/login.do
url authentication http://10.1.10.1/voiceview/authentication/authenticate.do 
load 521G-524G cp524g-8-1-17
load 525G spa525g-7-4-3
time-zone 12
voicemail 400
max-conferences 8 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh flash:/media/music-on-hold.au
multicast moh 239.10.16.16 port 2000
web admin system name cisco secret 5 $1$aKw4$Ud8Ke69t6TJu9tmeP36GD.
dn-webedit
time-webedit
transfer-system full-consult dss
transfer-pattern 9.T
transfer-pattern .T
transfer-pattern 8... blind
secondary-dialtone 9
fac standard
create cnf-files version-stamp 7960 Mar 15 2010 11:57:00
!
!
ephone-template  15
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct Park Select Join
button-layout 7931 2
!
!
ephone-template  16
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct Park Select Join
!
!
ephone-dn  3  dual-line
number 100
label Main
description Main
name Main
call-forward noan 399 timeout 20
no huntstop
hold-alert 30 originator
!
!
ephone-dn  4  dual-line
number 100
label Main
description Main
name Main
preference 1
call-forward busy 399
call-forward noan 399 timeout 20
hold-alert 30 originator
!
!
ephone-dn  5  dual-line
number 301 no-reg primary
label 301
description PhoneA Analog
name PhoneA Analog
call-forward busy 400
call-forward noan 400 timeout 10
translation-profile incoming CallBlocking
!
!
ephone-dn  6  dual-line
number 302 no-reg primary
label 302
description PhoneB Analog
name PhoneB Analog
call-forward busy 400
call-forward noan 400 timeout 10
translation-profile incoming CallBlocking
!
!
ephone-dn  7  dual-line
number 303 no-reg primary
label 303
description PhoneC Analog
name PhoneC Analog
call-forward busy 400
call-forward noan 400 timeout 10
translation-profile incoming CallBlocking
!
!
ephone-dn  8  dual-line
number 304 no-reg primary
label 304
description PhoneD Analog
name PhoneD Analog
translation-profile incoming CallBlocking
!
!
ephone-dn  9
number BCD no-reg primary
description MoH
moh out-call ABC
!
!
ephone-dn  10  dual-line
number 101 no-reg primary
label 101
description
call-forward busy 400
call-forward noan 400 timeout 20
translation-profile incoming CallBlocking
!
!
ephone-dn  11  dual-line
number 102 no-reg primary
label 102
description
call-forward busy 400
call-forward noan 400 timeout 20
translation-profile incoming CallBlocking
!
!
ephone-dn  12  dual-line
number 105 no-reg primary
label 105
description
call-forward busy 400
call-forward noan 400 timeout 20
translation-profile incoming CallBlocking
!
!
ephone-dn  13  dual-line
number 103 no-reg primary
label 103
description
call-forward busy 400
call-forward noan 400 timeout 20
translation-profile incoming CallBlocking
!
!
ephone-dn  14  dual-line
number 104 no-reg primary
label 104
description
call-forward busy 400
call-forward noan 400 timeout 20
translation-profile incoming CallBlocking
!
!
ephone-dn  15  dual-line
number 199 no-reg primary
label 199
description
call-forward busy 400
call-forward noan 400 timeout 10
hold-alert 30 originator
!
!
ephone-dn  16  dual-line
number 201 no-reg primary
label 201
description
call-forward busy 400
call-forward noan 400 timeout 20
hold-alert 30 originator
!
!
ephone-dn  17  dual-line
number 202 no-reg primary
label 202
description
call-forward busy 400
call-forward noan 400 timeout 10
hold-alert 30 originator
!
!
ephone-dn  18  dual-line
number 203 no-reg primary
label 203
description
call-forward busy 400
call-forward noan 400 timeout 10
hold-alert 30 originator
!
!
ephone-dn  19  dual-line
number 204 no-reg primary
label 204
description
call-forward busy 400
call-forward noan 400 timeout 10
hold-alert 30 originator
!
!
ephone-dn  20  dual-line
number 150 no-reg primary
label 150
description Open Phone
name Open Phone
hold-alert 30 originator
!
!
ephone-dn  282  octo-line
number 703 no-reg primary
conference meetme
preference 1
!
!
ephone-dn  283  octo-line
number 703 no-reg primary
conference meetme
no huntstop
!
!
ephone-dn  284  octo-line
number 702 no-reg primary
conference meetme
preference 1
!
!
ephone-dn  285  octo-line
number 702 no-reg primary
conference meetme
no huntstop
!
!
ephone-dn  286  octo-line
number 701 no-reg primary
conference meetme
preference 1
!
!
ephone-dn  287  octo-line
number 701 no-reg primary
conference meetme
no huntstop
!
!
ephone-dn  288  octo-line
number C003 no-reg primary
conference ad-hoc
preference 1
!
!
ephone-dn  289  octo-line
number C003 no-reg primary
conference ad-hoc
no huntstop
!
!
ephone-dn  290  octo-line
number C002 no-reg primary
conference ad-hoc
preference 1
!
!
ephone-dn  291  octo-line
number C002 no-reg primary
conference ad-hoc
no huntstop
!
!
ephone-dn  292  octo-line
number C001 no-reg primary
conference ad-hoc
preference 1
!
!
ephone-dn  293  octo-line
number C001 no-reg primary
conference ad-hoc
no huntstop
!
!
ephone-dn  294
number 404 no-reg primary
park-slot
label Park Slot 404
!
!
ephone-dn  295
number 403 no-reg primary
park-slot
label Park Slot 403
!
!
ephone-dn  296
number 402 no-reg primary
park-slot
label Park Slot 402
!
!
ephone-dn  297
number 401 no-reg primary
park-slot
label Park Slot 401
!
!
ephone-dn  298
number 8... no-reg primary
description ***CCA XFER TO VM EXTENSION***
call-forward all 400
!
!
ephone-dn  299
number A801... no-reg primary
mwi off
!
!
ephone-dn  300
number A800... no-reg primary
mwi on
!
!
ephone  1
device-security-mode none
mac-address D4FF.266A.0000
ephone-template 16
max-calls-per-button 2
username "aa"
type anl
button  1:5
!
!
!
ephone  2
device-security-mode none
mac-address D4FF.266A.0001
ephone-template 16
max-calls-per-button 2
username "ab"
type anl
button  1:6
!
!
!
ephone  3
device-security-mode none
mac-address D4FF.266A.0002
ephone-template 16
max-calls-per-button 2
username "ac"
type anl
button  1:7
!
!
!
ephone  4
device-security-mode none
mac-address D4FF.266A.0003
ephone-template 16
max-calls-per-button 2
username "ad"
type anl
button  1:8
!
!
!
ephone  5
device-security-mode none
video
mac-address 0021.1BFC.B934
ephone-template 16
max-calls-per-button 2
type 524G
button  1:10 2:3 3:4
!
!
!
ephone  6
device-security-mode none
video
mac-address 0021.1BFC.B9D6
ephone-template 16
max-calls-per-button 2
type 524G
button  1:11 2:3 3:4
!
!
!
ephone  7
device-security-mode none
video
mac-address 0021.1BFC.B931
ephone-template 16
max-calls-per-button 2
type 524G
button  1:12 2:3 3:4
!
!
!
ephone  8
device-security-mode none
video
mac-address 0021.1BFC.B932
ephone-template 16
max-calls-per-button 2
type 524G
button  1:13 2:3 3:4
!
!
!
ephone  9
device-security-mode none
video
mac-address 0021.1BFC.B930
ephone-template 16
max-calls-per-button 2
type 524G
button  1:14 2:3 3:4
!
!
!
ephone  10
device-security-mode none
mac-address 0021.1BFC.B92E
max-calls-per-button 2
type 524G
logout-profile 1
!
!
!
ephone  11
device-security-mode none
mac-address 0023.EBED.1ED4
max-calls-per-button 2
type 525G
button  1:15
!
!
!
ephone  12
device-security-mode none
mac-address 0021.1BFC.B9D0
max-calls-per-button 2
type 524G
button  1:16 2:3 3:4
!
!
alias exec cca_voice_mode PBX
banner login ^CCisco Configuration Assistant. Version: 2.2 (2). Thu Mar 11 12:57:54 EST 2010^C
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
line vty 5 100
!
ntp master
!
end    

Community Member

Re: Strange problem with incoming calls on UC540 (POTS)

Hi There,

I am not to sure what your trying to achieve, and i am having some difficulties understand your intended goals with the call routing.

I am assuming the following:

  • Call comes in on FXO this is plar'ed to pilot number 100 which is DN 1 in this case (DN 3 on your config)
  • DN 1 (Or 3 as it is on yours) is Overlayed on a reception phone or multiple phones? Unable to see this on the config, if not then this is a big problem
  • If not answered this moves onto the AA which is pilot number 399 (With matching Dial-Peer)
  • Not aware of any of the options in the AA
  • It is assumed the AA has options for DN 10-15 (The pilot numbers) as the ephones have no connection to the incoming pilot number at all

Example of Call flow:

ephone-dn  1  octo-line
number 100
label Main
description Main
name Main

call-forward busy 399
call-forward noan 399 timeout 20
no huntstop
hold-alert 30 originator

In my example above, you would have DN 1 as your incoming call pilot (Or 4X Dual-lines), since this is already set on the Voice Ports you would consider it to work this way, however i would encourage you to do the following configuration changes to make the system work smoother.

  • Pilot all calls to DN 1 and have it set as an Octo line
  • Set your call forwards to the AA pilot which is 399
  • Have DN 1 configured on button two of all the phones I.E button 1: 2:1
  • Create DN 2/3/4 with Pilot number 101/102/103/ and have this configured on the second button as an alternative to the option above

However looking at your config it looks as though you are trying to run some form of hunt groups using DN's, which is not a bad thing, just that you have nothing label as such which makes it harder to understand what you are trying to achieve. Come to think of it the more i look over your config the more i realise something is not right, and i am not quite sure what you want to achieve

I am not sure if some of that config is just excess code that is usually left behind by CCA or if they are actually being used some how in your configuration, for having such few phones it is quite a confusing setup.

If i am wrong in my thinking, or i have misread your config, is it possible if you can draft up a call flow diagram, point out how you anticipate the call flow to work, i.e calls come in on FXO line, call is plared to XXX pilot, pilot is a DN that is overlayed to a users line button, or configured to a users line button. Basically i would like to know how you wish the call flow to work, where you want AA to direct the calls, so on and so forth.

I have a sneaky suspicion that the call flow topology is broken which is causing confusion with how the call direction should work, and as such your issue is steaming from this. I also suspect that you might be able to achieve what you want using 3 main methods, Voice Hunt-Group Parallels, DN Overlay methods, or, ephone-hunt groups using the peer/sequential/idle methods. A clean method should be established, and i am not sure if you are aware of all the methods, which might have been able to assist with working this out prior to deployment.

I hope i havent made matters worse for you, but if i am having troubles reading the call flow (Come to think of it, i sometimes have troubles reading my own

) there might be something a miss, and i want to narrow down on it and see if we can end the issue you are having.

I hope you can accomodate me with a diagram.

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Community Member

Re: Strange problem with incoming calls on UC540 (POTS)

David,

Thanks for spending your time on this.. Unfortunately, the phones used in this environment are 524Gs, therefore do not support octo-lines (only dual-lines).  That is why I need 2 dns hunting to allow more than 2 incoming calls to the main dn.

You're correct with some of the extra configs you see... generated by the CCA.. I need to clean it up when I get a chance.

My call flow is very basic.

call comes in one of the 4 FXO ports (in a hunt group from the carrier).

||

\/

FXO ports plar to the Main shared extension 100 (dn 3 and 4 - since octo-line is not availble).  This main shared extension is available on most phones on two buttons - 2 and 3.

||

||=============>no pickup after 4 rings, goes to AA where the caller can dial the person's extension or leave a message in the general delivery mailbox.

\/

Pickup by live person

What problem do you see with this call flow?

Community Member

Re: Strange problem with incoming calls on UC540 (POTS)

Hi Champ,

Unfortunately, the phones used in this environment are 524Gs, therefore
do not support octo-lines (only dual-lines).

***SMACKS SELF AROUND THE HEAD***** I knew that, I was just testing your skill sets :D

You're correct with some of the extra configs you see... generated by
the CCA.. I need to clean it up when I get a chance.

It is a good habit to get into, i still have not received a clear answer as to why this happens, and why they chose for CCA to leave so much redundant code behind.

My call flow is very basic.

Indeed it is, i think i was getting confused with all the excess code and somethings just making sense at the time.

Can you look at putting in the call forward busy on DN 3 and point it too DN 4, and change the DN 4 to 101 (Make sure it doesn't conflict with any other DN's), i have never seen a config work properly when two DN's share the same number, so i guess to avoid and configuration conflicts, are you willing to make that modification and re-test?

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Community Member

Re: Strange problem with incoming calls on UC540 (POTS)

Hey David,

Sorry didn't get to respond earlier.. my first day back from jury duty. 

I will continue to work on this and give you an update.  Appreciate your help. :)

Community Member

Strange problem with incoming calls on UC540 (POTS)

Hello,

Did you ever find a solution to this problem? I have two UC540's connecting to AT&T POTS lines in two separate locations that see the exact same issue. You can even watch the front of the UC where the line is plugged in light up on the first ring, go out for the next two rings, then light up again for the remaining rings. Both UC's are running the latest firmware and a few hours on the phone with support hasn't gotten me anywhere with this unfortunately.

I have found three other details to add to this if anyone else has an idea. Everything is exactly the way it's decribed above. My current dial plan is to ring a blast group to all phones for 16 seconds then switch to the AA to redirect the caller to the proper department to leave a message.

1) If I set the incoming lines to go straight to the AA, I don't see any issues.

2) If I plug lines from a another local provider that brings everything into the building over fiber then everything works perfectly with the same UC's.

3) The two UC's with AT&T POTS lines having issues are within a block of each other. I recently installed a UC320 that's about a mile down the street using AT&T POTS lines and it worked prefectly.

Thanks in advance for any help

Community Member

Strange problem with incoming calls on UC540 (POTS)

Hi there,

I had same problem with my UC 520. This happens because when your provider try to send caller-id on UC, UC not able to catch the caller-id. By default caller-id alerting ring set to 1 which is not sufficient in your case.

Try following through CLI under all of your FXO port

caller-id alerting ring 2

If caller-id alerting ring 2 didnt work try with 3 or 4.

Let me know issue is resolved or not.

Thanks,

AJ

Community Member

Re: Strange problem with incoming calls on UC540 (POTS)

Firstly, upgrade CCA to the latest (3.0(1) as of today) and upgrade the UC540 to software pack to the latest (8.1.0 as of today). Major improvements have been made since version 2.2(2) which is the version that was used to configure your UC540, correct? Also, is this a CCA-only config or was there some CLI involved to get it working? If it's the latter, the issue will be difficult to diagnose. There's a list of 'approved CLI workarounds' but I don't think you need any CLI to get this application working, so it'd best to keep it CCA only.

Based on your call flow example, it sounds like the telco isn't understanding the UC500's connect-signal the first time you pick up, so it just keeps sending the call as if nobody has picked up. I believe this is true because the calling-user hears uninterrupted ring-back tone, correct? Also, since you're not getting caller-id the second time you pick up, that means the telco probably thinks it's the same call because they only send caller-id once per call.

If the above is true, then this is an analog signaling issue. If this is the case, debug voip ccapi wouldn't provide the necessary info because that only outputs info from the VoIP call-control API (see Cisco's Telephony Interface Architecture for more info), which doesn't handle signaling state information of the analog ports. The signaling is handled by the VPM (voice processor module), so you'll need to use 'debug vpm all' (or debug vpm signal) to see what the FXO port is thinking. You may want to run both debugs simultaneously though, to see how the two modules work together.

Lets start with the basics. Here are some questions that may help provide insight into your issue:

-What happens when you connect a simple standard analog phone to that line instead of the UC500? Does the call connect evertime? This will verify the line is OK.

-What would happen if you just set the inbound dial plan to ring one single phone? Running this test will verify it's NOT an analog signaling issue, meaning it's a config issue with the dns/button-assignments.

-What happens on outbound calls? Are outbound calls working perfectly?

-Are you installing this on a new line, or replacing the customer's old PBX over an existing line? If the latter, the telco may have their ports set to connect to a PBX (ground-start) only and not a phone (loop-start --by default, the UC's FXO port appears as a phone to the telco because it's set to loop-start)

-Ask your telco what kind of signaling is running on that line. Is it loop-start or ground-start? Do they want battery-reversal as the connect-signal, etc.? Then check/match those settings in CCA:

-Lastly, hopefully, it'll be fixed after checking the above, but if it still doesn't work, inquire with your telco about the physical condition of the line:

     -What is the distance from the telco. Is it really far?

     -Is the cabling old or new

     -Is the cabling CAT3?

     -Do you experience these issues more after it rains?

     -Have the telco run a line-test to verify there's no noise on the line.

Good luck!

-Oni

Community Member

Re: Strange problem with incoming calls on UC540 (POTS)

Thanks for the responses. I figured out the solution later last week and didn't get a chance to come update the post yet.

All I had to do was go into PSTN Trunks, go into each individual FXO port and uncheck the box to Enable Battery Reversal. That simple change made both locations work immediately and I haven't seen a single issue since. 

2399
Views
5
Helpful
10
Replies
CreatePlease to create content