Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

UC320W w SPA504G phones - incoming calls disconnect after 5 minutes.

Hello,

I have a uc320w with 3 spa504g phones configured with a SIP trunk. My SIP provider is CallCentric. I have the phone system configured so that each phone is on it's own extension. For the most part the way I have it configured works except for the fact that incoming calls get disconnected at exactly 5 minutes. I have been in contact with CallCentric tech support and they have informed me that their network is detecting only 1-way communications so it automatically disconnects aftrer 5 minutes. The phone conversation is definitely 2-way so I'm not sure why this is happeneing.

I came across some instructions for setting up SPA504G phones manually for CallCentric (

http://blog.voipdiy.com/2011/11/configuring-cisco-spa504g-ip-phone-from.html). I followed these instructions and confirmed that the settings in the instructions do indeed work, meaning incoming calls don't get disconnected after 5 minutes. The problem is that I have to perform a factory reset on the phone to get it to register with the UC320 which resets the manual settings. So the question is: how can I manually change some setting on the SPA504G phones and have it registered with the UC320?

Any help is greatly appreciated. TIA.

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

UC320W w SPA504G phones - incoming calls disconnect after 5 minu

Hi Jules,

If the inbound call is routed to Auto Attendant and then user press the button to route the call to a destination, UC320W could send reINVITE. reINVITE is a very common SIP message, it should not cause the SIP service provider to drop the call. As you stated earlier, you had 2-way audio, the reINVITE for the same call has replaced the initial INVITE and the call has 2-way audio, the statement from CallCentric "Since we are now seeing two invites for the same call eventually our  system drops it because it no longer detects audio on one of the calls  it drops." doesn't make any sense.

If you use SPA504G phone directly (bypassing UC320W), there will be no reINVITE message. That's why the call was not dropped.

Please contact CallCentric again, and ask them to modify the logic.

Best regards,

Wendy

4 REPLIES
Community Member

UC320W w SPA504G phones - incoming calls disconnect after 5 minu

I have only a single DID number and therefore am only using the defualt route for incoming calls, which is to the auto attendant. So I have never made any changes to this. Is is possible that there's a bug in the config utility if no chnages are made to the incoming routing configuration from default? I know it's probaably a strech but I'm grasping for straws here. It would be nice to get a bit of help :-(

Bronze

UC320W w SPA504G phones - incoming calls disconnect after 5 minu

Hi Jules,

There should not be any issue if you have never changed the default incoming routing. What is exactly your issue? Please provide more detail information.

Best regards,

Wendy

Community Member

UC320W w SPA504G phones - incoming calls disconnect after 5 minu

Hello,

As previously stated, incoming calls are being dropped after exactly 5 minutes. Telephony is new to me so I will just quote 2 separate responses from our SIP provider (CallCentric):

Our system is dropping calls after five minutes because it is detecting one way audio for a full 300 seconds which is 5 minutes. If your calls are actually normal two way calls then the issue is usually network related, or sometimes you can see it when your device uses reINVITE.

Looking at the SIP trace for one of your dropped calls we are seeing that after the call is connected for 22 seconds we receive a reINVITE for the same call. As we mentioned earlier, this can cause what is happening. Since we are now seeing two invites for the same call eventually our system drops it because it no longer detects audio on one of the calls it drops. This is actually what happened with SPA9000 units and what caused calls to drop there as well.

The strange thing is that I can manually configure one of the SPA504G IP phones (bypassing the UC320) for CallCentric and it works perfectly. However when I connect the same phone to the UC320, I have to factory reset the phone to get it to register with the UC320 so then incoming calls disconnects after 5 minutes again.

The problem should not be a NAT issue since the UC320 is connected directly to the modem which is put in bridge mode. I'm actually using the PPPoE client on the UC320.

Bronze

UC320W w SPA504G phones - incoming calls disconnect after 5 minu

Hi Jules,

If the inbound call is routed to Auto Attendant and then user press the button to route the call to a destination, UC320W could send reINVITE. reINVITE is a very common SIP message, it should not cause the SIP service provider to drop the call. As you stated earlier, you had 2-way audio, the reINVITE for the same call has replaced the initial INVITE and the call has 2-way audio, the statement from CallCentric "Since we are now seeing two invites for the same call eventually our  system drops it because it no longer detects audio on one of the calls  it drops." doesn't make any sense.

If you use SPA504G phone directly (bypassing UC320W), there will be no reINVITE message. That's why the call was not dropped.

Please contact CallCentric again, and ask them to modify the logic.

Best regards,

Wendy

1090
Views
0
Helpful
4
Replies
CreatePlease to create content