Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

UC520 Incoming call issue

Hi,

I change my SIP provider for Selfone (French Provider).

They use for registration an ID with a "star" in the middle. Example: 0027*001

I can register correctly and can pass ouside call.

I have an issue with incoming calls.

When I debug ccsip messages, I see the incoming call but it is rejected with a 500 Internal Server Error (see debug below).

Could someone can help ?

Thx.

Vincent.

Sent:
OPTIONS sip:109.237.253.26:5060 SIP/2.0
Via: SIP/2.0/UDP 213.219.187.2:5060;branch=z9hG4bK2AA1249E
From: <sip:213.219.187.2>;tag=383AF3A8-16D0
To: <sip:109.237.253.26>
Date: Mon, 01 Oct 2012 13:48:11 GMT
Call-ID: 794DBE99-B0511E2-9B71DD43-41074A7C@213.219.187.2
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
CSeq: 101 OPTIONS
Contact: <sip:213.219.187.2:5060>
Content-Length: 0


005893: Oct  1 15:48:11.289: //23049/000000000000/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 213.219.187.2:5060;branch=z9hG4bK2AA1249E
From: <sip:213.219.187.2>;tag=383AF3A8-16D0
To: <sip:109.237.253.26>;tag=43d2f2651b38c5c10e7b50ad918afba5.2628
Call-ID: 794DBE99-B0511E2-9B71DD43-41074A7C@213.219.187.2
CSeq: 101 OPTIONS
Server: VoipNow
Content-Length: 0


005894: Oct  1 15:48:14.485: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:0027*002@213.219.187.2:5060 SIP/2.0
Record-Route: <sip:109.237.253.26;lr=on;ftag=as29b5fdbb;did=f8b.fb03b571>
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bK5941.5d48b1d6.0
Max-Forwards: 69
From: "32475XXXXXX"<sip:32475XXXXXX@109.237.253.26>;tag=as29b5fdbb
To: <sip:0027*002@109.237.253.26>
Call-ID: 0dca7a7813b8de8560ab2c3633a579f3@109.237.253.26
Contact: <sip:32475975423@109.237.253.26:5060>
CSeq: 102 INVITE
User-Agent: SELFONE
Date: Mon, 01 Oct 2012 13:49:40 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces, timer
X-voipnow-did: 3261480153
X-voipnow-extension: 0027*002
X-voipnow-infrastructureid: e009f0a022fc
X-voipnow-did: 3261480153
Content-Type: application/sdp
Content-Length: 768

v=0
o=root 1698622377 1698622377 IN IP4 109.237.253.26
s=Asterisk PBX 1.6.1.4
c=IN IP4 109.237.253.26
b=CT:384
t=0 0
m=audio 18788 RTP/AVP 0 8 3 112 5 10 7 110 97 111 9 101
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:3 GSM/8000
a=rtpmap:112 AAL2-G726-32/8000
a=rtpmap:5 DVI4/8000
a=rtpmap:10 L16/8000
a=rtpmap:7 LPC/8000
a=rtpmap:110 speex/8000
a=rtpmap:97 iLBC/8000
a=fmtp:97 mode=30
a=rtpmap:111 G726-32/8000
a=rtpmap:9 G722/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off - - - -
a=ptime:20
a=sendrecv
m=video 14190 RTP/AVP 26 31 34 98 99 104
a=rtpmap:26 JPEG/90000
a=rtpmap:31 H261/90000
a=rtpmap:34 H263/90000
a=rtpmap:98 h263-1998/90000
a=rtpmap:99 H264/90000
a=rtpmap:104 MP4V-ES/90000
a=sendrecv

005895: Oct  1 15:48:14.497: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 500 Internal Server Error
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bK5941.5d48b1d6.0
From: "32475XXXXXX"<sip:32475XXXXXX@109.237.253.26>;tag=as29b5fdbb
To: <sip:0027*002@109.237.253.26>;tag=383B005C-B83
Date: Mon, 01 Oct 2012 13:48:14 GMT
Call-ID: 0dca7a7813b8de8560ab2c3633a579f3@109.237.253.26
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


005896: Oct  1 15:48:14.545: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:0027*002@213.219.187.2:5060 SIP/2.0
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bK5941.5d48b1d6.0
From: "32475XXXXXX"<sip:32475XXXXXX@109.237.253.26>;tag=as29b5fdbb
Call-ID: 0dca7a7813b8de8560ab2c3633a579f3@109.237.253.26
To: <sip:0027*002@109.237.253.26>;tag=383B005C-B83
CSeq: 102 ACK
Max-Forwards: 70
User-Agent: VoipNow PBX
Content-Length: 0

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: UC520 Incoming call issue

Hi,

Looking at the debug the translation rule 4000 is not working but the call is now allowed to enter the UC...So we are half way there.

Try replacing rule 4000 with this instead:

voice translation-rule 4000

rule 1 /^.*/ /10/

If this does not work also this may be an option:

voice translation-rule 4000

rule 1 /.*/ /10/

I’m sorry for the trial and error approach on this but it is very uncommon to have a “*” in the incoming caller ID.  If this works let me know.  Otherwise please post both of the debugs for the call and I will continue to work on this.

Thanks,

Jason Nickle

14 REPLIES
Community Member

UC520 Incoming call issue

Hello Vicent,

It sounds like an Access List problem.

voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL

access-list 2

access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL_EXTERNAL

access-list 2 remark SDM_ACL Category=1

access-list 2 permit 12.194.20.31

access-list 2 permit 12.194.18.31

access-list 2 deny   any

Make sure that your SIP providers address is included, so the incoming call is allowed.

Something like this:  (The Access List number (2) may be different in your config.)

voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL

access-list 2

access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL_EXTERNAL

access-list 2 permit 109.237.253.26

access-list 2 deny   any

Thank you,

Darren

An easy test to see if the Access List is causing the problem:

Config T

voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL

no access-list 2

Then make a test call.

I would not leave the access list disabled, as this could open you up for toll-fraud.

Community Member

UC520 Incoming call issue

Hello Darren,

Thx for your reply.

I try your solution: removing access-list 3 but still have the call rejected.

I have already check the access-list and the SIP IP is permit see below:

I think it's a header problem. The UC received 0027*001 instead of the CLID and have trouble to route this header correctly.

Any ideas ?

Thx.


-----------  show access-list   -----------

Standard IP access list 1
    10 permit 192.168.200.0, wildcard bits 0.0.0.255 (9673 matches)
    20 permit 10.1.1.0, wildcard bits 0.0.0.255
    30 permit 10.1.10.0, wildcard bits 0.0.0.3
Standard IP access list 2
    10 permit 192.168.200.254
    20 permit 10.1.10.0, wildcard bits 0.0.0.3
    30 permit 192.168.200.0, wildcard bits 0.0.0.255
    40 permit 10.1.1.0, wildcard bits 0.0.0.255
Standard IP access list 3
    10 permit 109.237.253.26
    20 deny   any
Extended IP access list 100
    10 deny ip 192.168.200.0 0.0.0.255 any
    20 deny ip host 255.255.255.255 any
    30 deny ip 127.0.0.0 0.255.255.255 any
    40 permit ip any any

-----------  End CLI Output  -----------

Community Member

UC520 Incoming call issue

Hello Vincent,

It may be because CME does not recognize the * in the middle of the incoming number.  If possible, I would like to see the following debugs:

debug ccsip message

debug voip ccapi inout

Would also need to see the running configuration.

Thank you,

Darren

Community Member

UC520 Incoming call issue

Hello,

Find below (debug, running config).

Thx.

Syslog logging: enabled (0 messages dropped, 3 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

No Inactive Message Discriminator.


    Console logging: disabled
    Monitor logging: disabled
    Buffer logging:  level debugging, 89 messages logged, xml disabled,
                    filtering disabled
    Exception Logging: size (4096 bytes)
    Count and timestamp logging messages: disabled
    Persistent logging: disabled

No active filter modules.

    Trap logging: level informational, 5918 message lines logged
        Logging Source-Interface:       VRF Name:

Log Buffer (5000000 bytes):

005945: Oct  1 20:45:41.198: %SYS-5-CONFIG_I: Configured from http by cisco on 192.168.200.40
005946: Oct  1 20:45:41.282: %SYS-5-CONFIG_I: Configured from http by cisco on 192.168.200.40
005947: Oct  1 20:45:49.834: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:0027*002@213.219.187.2:5060 SIP/2.0
Record-Route: <109.237.253.26>
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKcffc.54b41ad1.0
Max-Forwards: 69
From: "32475975423"<32475975423>;tag=as540a7f45
To: <0027>
Call-ID: 316a82a2171b9f21232b9dae492519a5@109.237.253.26
Contact: <32475975423>
CSeq: 102 INVITE
User-Agent: SELFONE
Date: Mon, 01 Oct 2012 18:47:15 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces, timer
X-voipnow-did: 3261480153
X-voipnow-extension: 0027*002
X-voipnow-infrastructureid: e009f0a022fc
X-voipnow-did: 3261480153
Content-Type: application/sdp
Content-Length: 768

v=0
o=root 1362107939 1362107939 IN IP4 109.237.253.26
s=Asterisk PBX 1.6.1.4
c=IN IP4 109.237.253.26
b=CT:384
t=0 0
m=audio 14274 RTP/AVP 0 8 3 112 5 10 7 110 97 111 9 101
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:3 GSM/8000
a=rtpmap:112 AAL2-G726-32/8000
a=rtpmap:5 DVI4/8000
a=rtpmap:10 L16/8000
a=rtpmap:7 LPC/8000
a=rtpmap:110 speex/8000
a=rtpmap:97 iLBC/8000
a=fmtp:97 mode=30
a=rtpmap:111 G726-32/8000
a=rtpmap:9 G722/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off - - - -
a=ptime:20
a=sendrecv
m=video 17174 RTP/AVP 26 31 34 98 99 104
a=rtpmap:26 JPEG/90000
a=rtpmap:31 H261/90000
a=rtpmap:34 H263/90000
a=rtpmap:98 h263-1998/90000
a=rtpmap:99 H264/90000
a=rtpmap:104 MP4V-ES/90000
a=sendrecv

005948: Oct  1 20:45:49.842: //-1/0DDAC2FA9DA2/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=32475975423
   ----- ccCallInfo IE subfields -----
   cisco-ani=32475975423
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=0027*002
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

005949: Oct  1 20:45:49.842: //-1/0DDAC2FA9DA2/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x87DD98B8, Call Info(
   Calling Number=32475975423,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=0027*002(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=1000, Progress Indication=NULL(0), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=23600
005950: Oct  1 20:45:49.842: //-1/0DDAC2FA9DA2/CCAPI/cc_api_call_setup_ind_common:
   SPI Call Setup Request Is Failed
005951: Oct  1 20:45:49.846: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 500 Internal Server Error
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKcffc.54b41ad1.0
From: "32475975423"<32475975423>;tag=as540a7f45
To: <0027>;tag=394B705C-17B1
Date: Mon, 01 Oct 2012 18:45:49 GMT
Call-ID: 316a82a2171b9f21232b9dae492519a5@109.237.253.26
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


005952: Oct  1 20:45:49.894: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:0027*002@213.219.187.2:5060 SIP/2.0
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKcffc.54b41ad1.0
From: "32475975423"<32475975423>;tag=as540a7f45
Call-ID: 316a82a2171b9f21232b9dae492519a5@109.237.253.26
To: <0027>;tag=394B705C-17B1
CSeq: 102 ACK
Max-Forwards: 70
User-Agent: VoipNow PBX
Content-Length: 0

Building configuration...


Current configuration : 35353 bytes
!
! Last configuration change at 20:45:41 CET Mon Oct 1 2012 by cisco
! NVRAM config last updated at 18:36:05 CET Tue Sep 25 2012 by cisco
! NVRAM config last updated at 18:36:05 CET Tue Sep 25 2012 by cisco
version 15.1
parser config cache interface
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
service internal
service compress-config
service sequence-numbers
!
hostname UC520
!
boot-start-marker
boot system flash:/uc500-advipservicesk9-mz.151-4.M4b
boot-end-marker
!
!
no logging queue-limit
logging buffered 5000000
no logging rate-limit
no logging console
no logging monitor
enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
!
clock timezone CET 1 0
clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 3:00
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2843278690
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2843278690
revocation-check none
rsakeypair TP-self-signed-2843278690
!
!
crypto pki certificate chain TP-self-signed-2843278690
certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32383433 32373836 3930301E 170D3132 30393230 31353534
  33315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 38343332
  37383639 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100DED4 F06E30C7 16F2AF4B C4BFB275 5474A6D2 06E1D2CD DDFB0429 7981F2B8
  960A82CA BEC96CEB FBCA058F E965EED5 BFF31ECA 6BB02B36 77E56DDE 540A01F1
  10619DC9 C9563DDC 5153B7C3 C4F7AEA3 D992BF52 2D9CFD6A 52BD628A 1349D5E3
  B0146A1E CC8A210C F9032685 0512C121 E42AEED9 FDF67EAF 1FD2ACE1 5078BC17
  65B10203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1439E7EB 77A15084 811BA696 445864AC 139EAB83 30301D06
  03551D0E 04160414 39E7EB77 A1508481 1BA69644 5864AC13 9EAB8330 300D0609
  2A864886 F70D0101 05050003 81810003 2BF17B70 AE5DCD1B 0FDB4DFF 2224A3A6
  72BD439A C3E9A611 42033842 09EEFBE5 6F3E5916 BEF7501F D24B7894 C64EA9DA
  96DFDA5E 089F8827 E35754A4 168680F5 E2D6DDC8 8C83303C 3FCC5540 7D9A1DC4
  5B2EA2BA C9C4AB2D 6E93D171 8A99D2F7 A6109FFF F4B92763 94172866 E8D3B6FD
  10FD51F2 68F1C2EC 39A53216 3036C3
   quit
dot11 syslog
!
dot11 ssid cisco-voice
vlan 100
authentication open
!
ip source-route
ip cef
!
!
ip dhcp relay information trust-all
ip dhcp excluded-address 10.1.1.1 10.1.1.10
!
ip dhcp pool phone
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
option 150 ip 10.1.1.1
!
!
!
ip inspect WAAS flush-timeout 10
no ipv6 cef
!
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
stcapp
!
!
!
!
trunk group ALL_FXO
max-retry 5
voice-class cause-code 1
hunt-scheme longest-idle
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
ip address trusted list
  ipv4 0.0.0.0 0.0.0.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
  registrar server expires max 3600 min 3600
  no update-callerid
  sip-profiles 1000
!
voice class codec 1
codec preference 1 g711ulaw
!
voice class sip-profiles 1000
request ANY sdp-header Connection-Info remove
response ANY sdp-header Connection-Info remove
!
!
voice class cause-code 1
no-circuit
!
voice register global
mode cme
source-address 10.1.1.1 port 5060
max-dn 56
max-pool 14
load 9971 sip9971.9-2-2
load 9951 sip9951.9-2-2
load 8961 sip8961.9-2-2
!
!
!
voice source-group CCA_SIP_SOURCE_GROUP_CUE_CME
access-list 2
translation-profile incoming SIP_Incoming
!
voice source-group CCA_SIP_SOURCE_GROUP_EXPERNAL
!
voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL
access-list 3
!
voice translation-rule 4
rule 1 /3261480153/ /10/
!
voice translation-rule 410
rule 1 /^0\(.*\)/ /\1/
rule 15 /^..$/ /3243330404/
!
voice translation-rule 411
rule 1 /^0\(.*\)/ /ABCD0\1/
!
voice translation-rule 412
rule 1 /^ABCD\(.*\)/ /\1/
!
voice translation-rule 422
rule 15 /^ABCD\(.*\)/ /\1/
!
voice translation-rule 1000
rule 1 /.*/ //
!
voice translation-rule 1111
rule 15 /^..$/ /3243330404/
!
voice translation-rule 1112
rule 1 /^0/ //
!
voice translation-rule 2222
!
!
voice translation-profile 3261480153-OP_Called_4
translate calling 3265
translate called 4
!
voice translation-profile CALLER_ID_TRANSLATION_PROFILE
translate calling 1111
!
voice translation-profile CallBlocking
translate called 2222
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
translate called 1112
!
voice translation-profile PSTN_CallForwarding
translate redirect-target 410
translate redirect-called 410
!
voice translation-profile PSTN_Outgoing
translate calling 1111
translate called 1112
translate redirect-target 410
translate redirect-called 410
!
voice translation-profile SIP_Incoming
translate called 411
!
voice translation-profile SIP_Passthrough
translate called 412
!
voice translation-profile SIP_Passthrough_CallBlocking
translate called 422
!
voice translation-profile nondialable
translate called 1000
!
!
voice-card 0
!
fax interface-type fax-mail
!
!
license udi pid UC520W-8U-4FXO-K9 sn FHK114051QD
archive
log config
  logging enable
  logging size 600
  hidekeys
username cisco privilege 15 secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
!
!
ip tftp source-interface Loopback0
!
!
!
bridge irb
!
!
!
!
interface Loopback0
ip address 10.1.10.2 255.255.255.252
ip nat inside
ip virtual-reassembly in
!
interface FastEthernet0/0
description $ETH-WAN$
no ip address
ip virtual-reassembly in
load-interval 30
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Integrated-Service-Engine0/0
description cue is initialized with default IMAP group
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly in
service-module ip address 10.1.10.1 255.255.255.252
service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1/0
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/1
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/2
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/3
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/4
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/5
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/6
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/7
switchport voice vlan 100
no ip address
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/8
switchport mode trunk
switchport voice vlan 100
no ip address
macro description cisco-switch
!
interface Dot11Radio0/5/0
no ip address
!
ssid cisco-voice
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
antenna receive right
antenna transmit right
!
interface Dot11Radio0/5/0.1
!
interface Dot11Radio0/5/0.100
encapsulation dot1Q 100
bridge-group 100
bridge-group 100 subscriber-loop-control
bridge-group 100 spanning-disabled
bridge-group 100 block-unknown-source
no bridge-group 100 source-learning
no bridge-group 100 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan100
no ip address
bridge-group 100
bridge-group 100 spanning-disabled
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostnamexxxx

ppp chap password 7 xxxx

ppp pap sent-username xxxx

ppp ipcp dns request
!
interface BVI1
ip address 192.168.200.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1412
!
interface BVI100
ip address 10.1.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1412
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
!
ip dns server
ip nat inside source list 1 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.200.0 0.0.0.255
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 10.1.10.0 0.0.0.3
access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL_INTERNAL
access-list 2 remark SDM_ACL Category=1
access-list 2 permit 192.168.200.254
access-list 2 permit 10.1.10.0 0.0.0.3
access-list 2 permit 192.168.200.0 0.0.0.255
access-list 2 permit 10.1.1.0 0.0.0.255
access-list 3 remark CCA_SIP_SOURCE_GROUP_ACL_EXTERNAL
access-list 3 remark SDM_ACL Category=1
access-list 3 permit 109.237.253.26
access-list 3 deny   any
access-list 100 remark auto generated by SDM firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny   ip 192.168.200.0 0.0.0.255 any
access-list 100 deny   ip host 255.255.255.255 any
access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
dialer-list 1 protocol ip permit
!
!
!
!
snmp-server community public RO
tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/ringtones/RingList.xml alias RingList.xml
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:/Desktops/CampusNight.png
tftp-server flash:/Desktops/TN-CampusNight.png
tftp-server flash:/Desktops/CiscoFountain.png
tftp-server flash:/Desktops/TN-CiscoFountain.png
tftp-server flash:/Desktops/CiscoLogo.png
tftp-server flash:/Desktops/TN-CiscoLogo.png
tftp-server flash:/Desktops/Fountain.png
tftp-server flash:/Desktops/TN-Fountain.png
tftp-server flash:/Desktops/MorroRock.png
tftp-server flash:/Desktops/TN-MorroRock.png
tftp-server flash:/Desktops/NantucketFlowers.png
tftp-server flash:/Desktops/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x16/List.xml
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x216x16/List.xml
tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias en_bacd_xferto_operator.au
tftp-server flash:/English_United_States/501-dictionary.xml alias English_United_States/501-dictionary.xml
tftp-server flash:/English_United_States/502-dictionary.xml alias English_United_States/502-dictionary.xml
tftp-server flash:/English_United_States/504-dictionary.xml alias English_United_States/504-dictionary.xml
tftp-server flash:/English_United_States/508-dictionary.xml alias English_United_States/508-dictionary.xml
tftp-server flash:/English_United_States/509-dictionary.xml alias English_United_States/509-dictionary.xml
tftp-server flash:/English_United_States/521-dictionary.xml alias English_United_States/521-dictionary.xml
tftp-server flash:/English_United_States/524-dictionary.xml alias English_United_States/524-dictionary.xml
tftp-server flash:/English_United_States/525G-dictionary.xml alias English_United_States/525G-dictionary.xml
tftp-server flash:/English_United_States/525G-kate.xml alias English_United_States/525G-kate.xml
tftp-server flash:/English_United_States/525G-tones.xml alias English_United_States/525G-tones.xml
tftp-server flash:/English_United_States/525G2-dictionary.xml alias English_United_States/525G2-dictionary.xml
tftp-server flash:/English_United_States/525G2-kate.xml alias English_United_States/525G2-kate.xml
tftp-server flash:/English_United_States/525G2-tones.xml alias English_United_States/525G2-tones.xml
tftp-server flash:/English_United_States/7921-dictionary.xml alias English_United_States/7921-dictionary.xml
tftp-server flash:/English_United_States/7921-font.dat alias English_United_States/7921-font.dat
tftp-server flash:/English_United_States/7921-kate.utf-8.xml alias English_United_States/7921-kate.utf-8.xml
tftp-server flash:/English_United_States/7921-kate.xml alias English_United_States/7921-kate.xml
tftp-server flash:/English_United_States/7960-tones.xml alias English_United_States/7960-tones.xml
tftp-server flash:/English_United_States/be-sccp.jar alias English_United_States/be-sccp.jar
tftp-server flash:/English_United_States/CME-locale-en_US-English-8.1.2.1.tar.cfg alias English_United_States/CME-locale-en_US-English-8.1.2.1.tar.cfg
tftp-server flash:/English_United_States/g3-tones.xml alias English_United_States/g3-tones.xml
tftp-server flash:/English_United_States/gp-sccp.jar alias English_United_States/gp-sccp.jar
tftp-server flash:/English_United_States/ipc-sccp.jar alias English_United_States/ipc-sccp.jar
tftp-server flash:/English_United_States/mk-sccp.jar alias English_United_States/mk-sccp.jar
tftp-server flash:/English_United_States/rp-sccp.jar alias English_United_States/rp-sccp.jar
tftp-server flash:/English_United_States/tags_file alias English_United_States/tags_file
tftp-server flash:/English_United_States/tc-sccp.jar alias English_United_States/tc-sccp.jar
tftp-server flash:/English_United_States/td-sccp.jar alias English_United_States/td-sccp.jar
tftp-server flash:/English_United_States/utf8_tags_file alias English_United_States/utf8_tags_file
radius-server attribute 31 send nas-port-detail
!
!
!
control-plane
!
bridge 1 route ip
bridge 100 route ip
call threshold interface FastEthernet0/0 int-calls low 3 high 3
!
voice-port 0/0/0
cptone FR
caller-id enable
!
voice-port 0/0/1
cptone FR
caller-id enable
!
voice-port 0/0/2
cptone FR
caller-id enable
!
voice-port 0/0/3
cptone FR
caller-id enable
!
voice-port 0/1/0
trunk-group ALL_FXO 64
cptone FR
connection plar 201
impedance complex2
caller-id enable
!
voice-port 0/1/1
trunk-group ALL_FXO 64
cptone FR
connection plar 202
impedance complex2
caller-id enable
!
voice-port 0/1/2
trunk-group ALL_FXO 64
cptone FR
connection plar 203
impedance complex2
caller-id enable
!
voice-port 0/1/3
trunk-group ALL_FXO 64
cptone FR
connection plar 204
impedance complex2
caller-id enable
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control -15
description Music On Hold Port
!
sccp local Loopback0
sccp ccm 10.1.1.1 identifier 1 version 3.1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
!
dial-peer cor custom
name internal
name local
name local-plus
name international
name national
name national-plus
name emergency
name toll-free
!
!
dial-peer cor list call-internal
member internal
!
dial-peer cor list call-local
member local
!
dial-peer cor list call-local-plus
member local-plus
!
dial-peer cor list call-national
member national
!
dial-peer cor list call-national-plus
member national-plus
!
dial-peer cor list call-international
member international
!
dial-peer cor list call-emergency
member emergency
!
dial-peer cor list call-toll-free
member toll-free
!
dial-peer cor list user-internal
member internal
member emergency
!
dial-peer cor list user-local
member internal
member local
member emergency
member toll-free
!
dial-peer cor list user-local-plus
member internal
member local
member local-plus
member emergency
member toll-free
!
dial-peer cor list user-national
member internal
member local
member local-plus
member national
member emergency
member toll-free
!
dial-peer cor list user-national-plus
member internal
member local
member local-plus
member national
member national-plus
member emergency
member toll-free
!
dial-peer cor list user-international
member internal
member local
member local-plus
member international
member national
member national-plus
member emergency
member toll-free
!
!
dial-peer voice 1 pots
port 0/0/0
no sip-register
!
dial-peer voice 2 pots
port 0/0/1
no sip-register
!
dial-peer voice 3 pots
port 0/0/2
no sip-register
!
dial-peer voice 4 pots
port 0/0/3
no sip-register
!
dial-peer voice 5 pots
description ** MOH Port **
destination-pattern ABC
port 0/4/0
no sip-register
!
dial-peer voice 6 pots
description ôcatch all dial peer for BRI/PRIö
translation-profile incoming nondialable
incoming called-number .%
direct-inward-dial
!
dial-peer voice 50 pots
description ** incoming dial peer **
incoming called-number ^AAAA$
port 0/1/0
!
dial-peer voice 51 pots
description ** incoming dial peer **
incoming called-number ^AAAA$
port 0/1/1
!
dial-peer voice 52 pots
description ** incoming dial peer **
incoming called-number ^AAAA$
port 0/1/2
!
dial-peer voice 53 pots
description ** incoming dial peer **
incoming called-number ^AAAA$
port 0/1/3
!
dial-peer voice 54 pots
description ** FXO pots dial-peer **
destination-pattern A0
port 0/1/0
no sip-register
!
dial-peer voice 55 pots
description ** FXO pots dial-peer **
destination-pattern A1
port 0/1/1
no sip-register
!
dial-peer voice 56 pots
description ** FXO pots dial-peer **
destination-pattern A2
port 0/1/2
no sip-register
!
dial-peer voice 57 pots
description ** FXO pots dial-peer **
destination-pattern A3
port 0/1/3
no sip-register
!
dial-peer voice 2000 voip
description ** cue voicemail pilot number **
destination-pattern 40
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1 
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 1000 voip
permission term
description ** Incoming call from SIP trunk (SELF) **
session protocol sipv2
session target sip-server
incoming called-number .%
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1001 voip
corlist outgoing call-local
description ** star code to SIP trunk (SELF) **
destination-pattern *..
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1003 voip
description ** Passthrough Inbound Calls for PSTN from CUE **
translation-profile incoming SIP_Passthrough
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
incoming called-number ABCDT
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 1005 voip
description ** Passthrough Inbound Calls for MWI from CUE **
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
incoming called-number A80T
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 1009 voip
description ** Passthrough Inbound Calls for Internal Extensions from CUE **
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
incoming called-number ^..$
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 1020 voip
corlist outgoing call-emergency
description **CCA*Belgium*Fire, Medical, Police & Children**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 010[012]
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1021 voip
corlist outgoing call-emergency
description **CCA*Belgium*Fire, Medical, Police & Children**
translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
preference 1
destination-pattern 10[012]
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1022 voip
corlist outgoing call-international
description **CCA*Belgium*International Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 000[1-9]T
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1023 voip
corlist outgoing call-toll-free
description **CCA*Belgium*Toll Free**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00800.....
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1024 voip
corlist outgoing call-national-plus
description **CCA*Belgium*Premium Rate**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00[79]0......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1025 voip
corlist outgoing call-local-plus
description **CCA*Belgium*Short codes**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 01[2345678]..
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1026 voip
corlist outgoing call-local-plus
description **CCA*Belgium*Short codes**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 01[01].
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1027 voip
corlist outgoing call-national
description **CCA*Belgium*Mobile Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 004[6-9].......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1028 voip
corlist outgoing call-national
description **CCA*Belgium*Network Independent Numbers**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 007[69]......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1029 voip
corlist outgoing call-national
description **CCA*Belgium*National Rate Services**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0078......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1030 voip
corlist outgoing call-local-plus
description **CCA*Belgium*European Social Services**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0116...
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1031 voip
corlist outgoing call-emergency
description **CCA*Belgium*Emergency**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0112
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1032 voip
corlist outgoing call-emergency
description **CCA*Belgium*Emergency**
translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
preference 1
destination-pattern 112
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1033 voip
corlist outgoing call-national-plus
description **CCA*Belgium*VPN**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00[89]8......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1034 voip
corlist outgoing call-national
description **CCA*Belgium*National Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 009[23]......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1035 voip
corlist outgoing call-national
description **CCA*Belgium*National Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0080[2-9].....
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1036 voip
corlist outgoing call-national
description **CCA*Belgium*National Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 008[1-79]......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1037 voip
corlist outgoing call-national
description **CCA*Belgium*National Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 001[0-69]......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1038 voip
corlist outgoing call-national
description **CCA*Belgium*National Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00[23][2-8]......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1039 voip
corlist outgoing call-national
description **CCA*Belgium*National Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 004[23]......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1040 voip
corlist outgoing call-national
description **CCA*Belgium*National Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 00[56].......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1041 voip
corlist outgoing call-national
description **CCA*Belgium*National Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 0071......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 3000 voip
description 3261480153-OP
translation-profile incoming 3261480153-OP_Called_4
session protocol sipv2
session target sip-server
incoming called-number 3261480153
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
!
no dial-peer outbound status-check pots
sip-ua
credentials username 0027*002 password 7 xxxxxxxxx realm 109.237.253.26
keepalive target ipv4:109.237.253.26:5060
authentication username 0027*002 password 7 xxxxxxxxxxx
no remote-party-id
retry invite 2
retry register 10
timers connect 100
timers keepalive active 100
registrar ipv4:109.237.253.26:5060 expires 3600
sip-server ipv4:109.237.253.26:5060
host-registrar
!
!
!
telephony-service
video
fxo hook-flash
max-ephones 14
max-dn 56
ip source-address 10.1.1.1 port 2000
auto assign 1 to 1 type bri
calling-number initiator
service phone videoCapability 1
service phone ehookenable 1
service dnis overlay
service dnis dir-lookup
service dss
timeouts interdigit 5
system message UC520
url services http://10.1.10.1/voiceview/common/login.do
url authentication http://10.1.10.2/CCMCIP/authenticate.asp 
cnf-file location flash:
cnf-file perphone
user-locale U4 load CME-locale-fr_FR-French-8.1.2.1.tar
network-locale U4
time-zone 23
time-format 24
date-format dd-mm-yy
keepalive 30 auxiliary 4
voicemail 40
max-conferences 8 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh flash:/media/music-on-hold.au
multicast moh 239.10.16.16 port 2000
web admin system name xxxxxxxxxxxxxxxxxxxx
dn-webedit
time-webedit
transfer-system full-consult dss
transfer-pattern 0.T
transfer-pattern .T
secondary-dialtone 0
night-service day Sun 17:00 09:00
night-service day Mon 17:00 09:00
night-service day Tue 17:00 09:00
night-service day Wed 17:00 09:00
night-service day Thu 17:00 09:00
night-service day Fri 17:00 09:00
night-service day Sat 17:00 09:00
fac standard
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-template  15
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use  Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Trnsfer Confrn Acct Park
button-layout 7931 2
!
!
ephone-template  16
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use  Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Trnsfer Confrn Acct Park
!
!
ephone-template  17
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use  CBarge Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Trnsfer Confrn Acct Park
!
!
ephone-template  18
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use  CBarge Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Trnsfer Confrn Acct Park
button-layout 7931 2
!
!
ephone-dn  9
number BCD no-reg primary
description MoH
moh out-call ABC
!
!
ephone-dn  53  dual-line
number 11 no-reg primary
label Anne 11
description xxxx
name xxxxxxxxxxxxx!
!
ephone-dn  54  dual-line
number 10 no-reg primary
label Vincent 10
description Vincent
name Vincent DENISON
!
!
ephone-dn  55
number A801.. no-reg primary
mwi off
!
!
ephone-dn  56
number A800.. no-reg primary
mwi on
!
!
ephone  5
device-security-mode none
mac-address 68EF.BD28.E6B6
ephone-template 16
max-calls-per-button 2
username "vd" password 123456
type 525G
button  1:54 2m53
!
!
!
ephone  6
device-security-mode none
mac-address CCEF.485D.496C
ephone-template 16
max-calls-per-button 2
username "ad" password 123456
type 504G
button  1:53 2m54
!
!
alias exec cca_voice_mode PBX
banner login ^Cbanner login ^Cisco Configuration Assistant. Version: 3.2 (1). Thu Sep 20 17:59:46 CEST 2012^^C
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
line vty 0 4
transport preferred none
transport input all
line vty 5 100
transport preferred none
transport input all
!
ntp master
end

Community Member

UC520 Incoming call issue

Hi,

It looks like the dial peer that you are hitting (Dial-Peer 1000) is not accounting for the “*” in the incoming message.  Dial-Peer 1000 is only expecting numbers or digits.  Try making a new incoming dial-peer in CCA using the digits being forwarded but the provider.  I would try to forward 0027*002 to an internal extension and see if this works.

Thank you,

Jason Nickle

Community Member

UC520 Incoming call issue

Hi Jason,

Thanks for the advice.

I have try this solution but the problem is CCA not support the "*" in the DID range extension.

I think this can be done with the CLI but I dont know how...

Best regards.

Vincent

Community Member

Re: UC520 Incoming call issue

Hi,

I guess you could try something like this:

voice translation-rule 4000
rule 1 /0027*002/ /10/

voice translation-profile 0027*002_Called_4000
translate calling 3265
translate called 4000

dial-peer voice 9000 voip

description 0027*002_Star_Rule
translation-profile incoming 0027*002_Called_4000
session protocol sipv2
session target sip-server
incoming called-number 0027*002
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad

Keep in mind that I did not test this and it is just off the top of my head based on your config but it should work.  Worst case scenario you could just remove these rules.  Let me know if it helps.

Thank you,

Jason Nickle

Community Member

Re: UC520 Incoming call issue

Hi,

I try your script.

Incoming call still rejected but with a different error message (404 Not Found - see below).

Thanks for your help.

Vincent

No active filter modules.

    Trap logging: level informational, 5944 message lines logged
        Logging Source-Interface:       VRF Name:

Log Buffer (5000000 bytes):

005977: Oct  2 20:35:08.567: %SYS-5-CONFIG_I: Configured from http by cisco on 192.168.200.40
005978: Oct  2 20:35:08.651: %SYS-5-CONFIG_I: Configured from http by cisco on 192.168.200.40
005979: Oct  2 20:35:18.536: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:0027*002@213.219.187.2:5060 SIP/2.0
Record-Route: <109.237.253.26>
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKd95.e26f0ca2.0
Max-Forwards: 69
From: "32475975423"<32475975423>;tag=as5abdb756
To: <0027>
Call-ID: 3243cda608654ef6080b5cea3dc8b18e@109.237.253.26
Contact: <32475975423>
CSeq: 102 INVITE
User-Agent: SELFONE
Date: Tue, 02 Oct 2012 18:36:43 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces, timer
X-voipnow-did: 3261480153
X-voipnow-extension: 0027*002
X-voipnow-infrastructureid: e009f0a022fc
X-voipnow-did: 3261480153
Content-Type: application/sdp
Content-Length: 768

v=0
o=root 1917088148 1917088148 IN IP4 109.237.253.26
s=Asterisk PBX 1.6.1.4
c=IN IP4 109.237.253.26
b=CT:384
t=0 0
m=audio 19732 RTP/AVP 0 8 3 112 5 10 7 110 97 111 9 101
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:3 GSM/8000
a=rtpmap:112 AAL2-G726-32/8000
a=rtpmap:5 DVI4/8000
a=rtpmap:10 L16/8000
a=rtpmap:7 LPC/8000
a=rtpmap:110 speex/8000
a=rtpmap:97 iLBC/8000
a=fmtp:97 mode=30
a=rtpmap:111 G726-32/8000
a=rtpmap:9 G722/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off - - - -
a=ptime:20
a=sendrecv
m=video 17768 RTP/AVP 26 31 34 98 99 104
a=rtpmap:26 JPEG/90000
a=rtpmap:31 H261/90000
a=rtpmap:34 H263/90000
a=rtpmap:98 h263-1998/90000
a=rtpmap:99 H264/90000
a=rtpmap:104 MP4V-ES/90000
a=sendrecv

005980: Oct  2 20:35:18.560: //26246/BFFCAA4CA85B/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKd95.e26f0ca2.0
From: "32475975423"<32475975423>;tag=as5abdb756
To: <0027>
Date: Tue, 02 Oct 2012 18:35:18 GMT
Call-ID: 3243cda608654ef6080b5cea3dc8b18e@109.237.253.26
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


005981: Oct  2 20:35:18.560: //26246/BFFCAA4CA85B/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKd95.e26f0ca2.0
From: "32475975423"<32475975423>;tag=as5abdb756
To: <0027>;tag=3E6819CC-1C44
Date: Tue, 02 Oct 2012 18:35:18 GMT
Call-ID: 3243cda608654ef6080b5cea3dc8b18e@109.237.253.26
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=1
Content-Length: 0


005982: Oct  2 20:35:18.612: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:0027*002@213.219.187.2:5060 SIP/2.0
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKd95.e26f0ca2.0
From: "32475975423"<32475975423>;tag=as5abdb756
Call-ID: 3243cda608654ef6080b5cea3dc8b18e@109.237.253.26
To: <0027>;tag=3E6819CC-1C44
CSeq: 102 ACK
Max-Forwards: 70
User-Agent: VoipNow PBX
Content-Length: 0

Community Member

Re: UC520 Incoming call issue

Hi,

Can you run these for me:

debug ccsip message

debug voip ccapi inout

Also is the SPA525 hooked up at this time? 

Jason Nickle

Community Member

Re: UC520 Incoming call issue

Hi,

Find the debug below:

SPA525 hooked up: YES

Thx.

Syslog logging: enabled (0 messages dropped, 3 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

No Inactive Message Discriminator.


    Console logging: disabled
    Monitor logging: disabled
    Buffer logging:  level debugging, 71 messages logged, xml disabled,
                    filtering disabled
    Exception Logging: size (4096 bytes)
    Count and timestamp logging messages: disabled
    Persistent logging: disabled

No active filter modules.

    Trap logging: level informational, 5968 message lines logged
        Logging Source-Interface:       VRF Name:

Log Buffer (5000000 bytes):

006005: Oct  3 07:42:26.063: %SYS-5-CONFIG_I: Configured from http by cisco on 192.168.200.40
006006: Oct  3 07:42:26.211: %SYS-5-CONFIG_I: Configured from http by cisco on 192.168.200.40
006007: Oct  3 07:42:33.832: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:0027*002@213.219.187.2:5060 SIP/2.0
Record-Route: <109.237.253.26>
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKacb9.9878ea97.0
Max-Forwards: 69
From: "32475975423"<32475975423>;tag=as38802621
To: <0027>
Call-ID: 6956b6292162dcd04810e72a35092ab6@109.237.253.26
Contact: <32475975423>
CSeq: 102 INVITE
User-Agent: SELFONE
Date: Wed, 03 Oct 2012 05:43:58 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces, timer
X-voipnow-did: 3261480153
X-voipnow-extension: 0027*002
X-voipnow-infrastructureid: e009f0a022fc
X-voipnow-did: 3261480153
Content-Type: application/sdp
Content-Length: 768

v=0
o=root 1710378157 1710378157 IN IP4 109.237.253.26
s=Asterisk PBX 1.6.1.4
c=IN IP4 109.237.253.26
b=CT:384
t=0 0
m=audio 15290 RTP/AVP 0 8 3 112 5 10 7 110 97 111 9 101
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:3 GSM/8000
a=rtpmap:112 AAL2-G726-32/8000
a=rtpmap:5 DVI4/8000
a=rtpmap:10 L16/8000
a=rtpmap:7 LPC/8000
a=rtpmap:110 speex/8000
a=rtpmap:97 iLBC/8000
a=fmtp:97 mode=30
a=rtpmap:111 G726-32/8000
a=rtpmap:9 G722/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off - - - -
a=ptime:20
a=sendrecv
m=video 18356 RTP/AVP 26 31 34 98 99 104
a=rtpmap:26 JPEG/90000
a=rtpmap:31 H261/90000
a=rtpmap:34 H263/90000
a=rtpmap:98 h263-1998/90000
a=rtpmap:99 H264/90000
a=rtpmap:104 MP4V-ES/90000
a=sendrecv

006008: Oct  3 07:42:33.840: //-1/F6E16105AE1D/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=32475975423
   ----- ccCallInfo IE subfields -----
   cisco-ani=32475975423
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=0027*002
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

006009: Oct  3 07:42:33.844: //-1/F6E16105AE1D/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x87DD98B8, Call Info(
   Calling Number=32475975423,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=0027*002(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=9000, Progress Indication=NULL(0), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=27713
006010: Oct  3 07:42:33.844: //-1/F6E16105AE1D/CCAPI/ccCheckClipClir:
   In: Calling Number=32475975423(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
006011: Oct  3 07:42:33.844: //-1/F6E16105AE1D/CCAPI/ccCheckClipClir:
   Out: Calling Number=32475975423(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
006012: Oct  3 07:42:33.844: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
006013: Oct  3 07:42:33.844: :cc_get_feature_vsa malloc success
006014: Oct  3 07:42:33.844: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
006015: Oct  3 07:42:33.844:  cc_get_feature_vsa count is 3
006016: Oct  3 07:42:33.844: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
006017: Oct  3 07:42:33.844: :FEATURE_VSA attributes are: feature_name:0,feature_time:2328293480,feature_id:76
006018: Oct  3 07:42:33.844: //27713/F6E16105AE1D/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=32475975423(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=0027*002(TON=Unknown, NPI=Unknown))
006019: Oct  3 07:42:33.844: //27713/F6E16105AE1D/CCAPI/cc_process_call_setup_ind:
   Event=0x887D1278
006020: Oct  3 07:42:33.844: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
   Try with the demoted called number 0027*002
006021: Oct  3 07:42:33.844: //27713/F6E16105AE1D/CCAPI/ccCallSetContext:
   Context=0x8AD7EAC0
006022: Oct  3 07:42:33.844: //27713/F6E16105AE1D/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 27713 with tag 9000 to app "_ManagedAppProcess_Default"
006023: Oct  3 07:42:33.848: //27713/F6E16105AE1D/CCAPI/ccCallProceeding:
   Progress Indication=NULL(0)
006024: Oct  3 07:42:33.852: //27713/F6E16105AE1D/CCAPI/ccCallDisconnect:
   Cause Value=1, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
006025: Oct  3 07:42:33.852: //27713/F6E16105AE1D/CCAPI/ccCallDisconnect:
   Cause Value=1, Call Entry(Responsed=TRUE, Cause Value=1)
006026: Oct  3 07:42:33.856: //27713/F6E16105AE1D/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKacb9.9878ea97.0
From: "32475975423"<32475975423>;tag=as38802621
To: <0027>
Date: Wed, 03 Oct 2012 05:42:33 GMT
Call-ID: 6956b6292162dcd04810e72a35092ab6@109.237.253.26
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


006027: Oct  3 07:42:33.856: //27713/F6E16105AE1D/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKacb9.9878ea97.0
From: "32475975423"<32475975423>;tag=as38802621
To: <0027>;tag=40CAF5EC-19E0
Date: Wed, 03 Oct 2012 05:42:33 GMT
Call-ID: 6956b6292162dcd04810e72a35092ab6@109.237.253.26
CSeq: 102 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=1
Content-Length: 0


006028: Oct  3 07:42:33.908: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:0027*002@213.219.187.2:5060 SIP/2.0
Via: SIP/2.0/UDP 109.237.253.26:5060;branch=z9hG4bKacb9.9878ea97.0
From: "32475975423"<32475975423>;tag=as38802621
Call-ID: 6956b6292162dcd04810e72a35092ab6@109.237.253.26
To: <0027>;tag=40CAF5EC-19E0
CSeq: 102 ACK
Max-Forwards: 70
User-Agent: VoipNow PBX
Content-Length: 0


006029: Oct  3 07:42:33.912: //27713/F6E16105AE1D/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x87DD98B8, Tag=0x0, Call Id=27713,
   Call Entry(Disconnect Cause=1, Voice Class Cause Code=0, Retry Count=0)
006030: Oct  3 07:42:33.912: //27713/F6E16105AE1D/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
006031: Oct  3 07:42:33.912: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
  
006032: Oct  3 07:42:33.912: :cc_free_feature_vsa freeing 8AC6F060
006033: Oct  3 07:42:33.912: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
  
006034: Oct  3 07:42:33.912:  vsacount in free is 2

Community Member

Re: UC520 Incoming call issue

Hi,

Looking at the debug the translation rule 4000 is not working but the call is now allowed to enter the UC...So we are half way there.

Try replacing rule 4000 with this instead:

voice translation-rule 4000

rule 1 /^.*/ /10/

If this does not work also this may be an option:

voice translation-rule 4000

rule 1 /.*/ /10/

I’m sorry for the trial and error approach on this but it is very uncommon to have a “*” in the incoming caller ID.  If this works let me know.  Otherwise please post both of the debugs for the call and I will continue to work on this.

Thanks,

Jason Nickle

Community Member

Re: UC520 Incoming call issue

Hello Jason,

Perfect.

It works.

You are the best.

Thanks a lot from Belgium.

Vincent.

Community Member

Re: UC520 Incoming call issue

Hello,

Another question.

How this rule will be interprated by CCA ?

When I do a modification in CCA, this rule will be deleted or altered ?

Thanks again.

Vincent

Community Member

Re: UC520 Incoming call issue

Hi,

Glad that this is working for you now.  CCA will not be able to see these rules and if you need to change them you will have to do it via CLI.  Please keep in mind that changes to the incoming dial plan in CCA could possibly affect the way this new dial-plan works but it is unlikely because the numbers are outside of the range that CCA uses.  Just in case please just keep a copy of this configuration in case you need to add it back in.

Thank you,

Jason Nickle

3360
Views
0
Helpful
14
Replies
CreatePlease to create content