Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

UC520 Reboots to ROMMON

Hi There,

I'm wondering if anyone else has experienced any similar symptoms to the ones that we have on two of our systems. To keep it as short and concise as possible:

Whenever we reload (9 out of 10 times - we counted!) from CLI or CCA they always reboot but get stuck at romon when loading, meaning it doesn't reboot and its left hanging.  When this occurs, we need to console into it and issue a reset over the console port. The device resets, then loads the config as expected.

If we issue a reload, wait until it enters rommon then power the system off from the power, then power it up again, it does the same thing. and enters romon.

If we pull the power without shutting the system down properly or reloading, it loads the config back up without error.

This has been an error which has been present on this system since almost 12 months ago, and still occured today while I was updating to the newest software bundle.

Liuttle confused and its difficult to manage the systems remotely for updates etc knowing you cannot reload the system!

Any ideas appreciated before I take this to TAC :)

Everyone's tags (2)
3 ACCEPTED SOLUTIONS

Accepted Solutions

Re: UC520 Reboots to ROMMON

Check to see if there is a statement in your CLI:

boot system flash:  <--- the image is the IOS you see on dir flash:

If the image isnt there, it could cause that.

If that statement isnt there, it could cause this

Re: UC520 Reboots to ROMMON

Do you have anything plugged into the console port?  You could have a problem that if something is plugged in, it could be sending the break sequence.

Double check that the confreg is 0x2102.  The IOS load is still on flash, correct?

Bronze

Re: UC520 Reboots to ROMMON

Check what Steven mentioned - if you have a console up on the UC520 with config register set to 0x2102 and hit Ctrl + Break (or maybe some software on the console PC does the same), you can halt the boot up of the UC520 and it will fall back into rommon. Try removing the console cable from the UC520 and attempting a reload, if you hear the fan noise stop after a couple of minutes, you know you are good to go.

10 REPLIES

Re: UC520 Reboots to ROMMON

Check to see if there is a statement in your CLI:

boot system flash:  <--- the image is the IOS you see on dir flash:

If the image isnt there, it could cause that.

If that statement isnt there, it could cause this

Community Member

Re: UC520 Reboots to ROMMON

Hi Steve D,

We did consider this option and have confirmed that that lines there and accurate.  Its the current IOS and one that was loaded with the newest software package.  Its also on the flash.

Thanks for your thoughts though!

Re: UC520 Reboots to ROMMON

Do you have anything plugged into the console port?  You could have a problem that if something is plugged in, it could be sending the break sequence.

Double check that the confreg is 0x2102.  The IOS load is still on flash, correct?

Community Member

Re: UC520 Reboots to ROMMON

Hi Steven,

This is something I hadn't considered!

To refer to your three suggestions:

I know for certain one of the affected devices has been connected almost the whole time since its installation over a console cable to an SBS server.  What your saying totally makes sense so I'm going to try this! Adding to this theory, if hyperterminal is open on the screen, it boots every time.  This leads me to think something else is attempting to make a connection to something over a serial port, maybe an obselete UPS software or something similar.

I've confirmed the confreg value is 0x2102

Yes the IOS is still on flash :)

Many thanks, you've given me an avenue to trial. It will obviously need to be after hours, so I'll schedule in a time to test it out.

Bronze

Re: UC520 Reboots to ROMMON

Check what Steven mentioned - if you have a console up on the UC520 with config register set to 0x2102 and hit Ctrl + Break (or maybe some software on the console PC does the same), you can halt the boot up of the UC520 and it will fall back into rommon. Try removing the console cable from the UC520 and attempting a reload, if you hear the fan noise stop after a couple of minutes, you know you are good to go.

Community Member

Re: UC520 Reboots to ROMMON

Hi All,

Thanks for the feedback.

We've removed the console cable and rebooted 5 times without failure.

Looks like the console cable could have been the issue!

Will advise if this changes, but thanks for everyones input :)

Andrew

Community Member

Re: UC520 Reboots to ROMMON

So if I am reading this correctly, you shouldn't reload the UC500 with a console cable plugged in?

-Brian

Community Member

Re: UC520 Reboots to ROMMON

Normally this shouldn't be a problem, but if there IS a PC or terminal connected through the console port then it is possible for a 'break' statement to be transmitted which sends the box into rommon.

Community Member

Re: UC520 Reboots to ROMMON

ok. Thanks.

-Brian

Community Member

Re: UC520 Reboots to ROMMON

We suspect in our situation it was UPS software probing for a UPS on the console port.

We haven't uninstalled the software to try yet, but I'm confident that is the cause.

4957
Views
0
Helpful
10
Replies
CreatePlease to create content