Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

UC540 8.6.0 NexVortex SIP problem - no outbound calls

Background:
Our UC540 was running 8.2.0 and working with SIP calls through NexVortex using G.729 via CLI commands.We recently upgraded our UC540 to 8.6.0 using CCA 3.2.1, and as soon as we did so, we lost the ability to receive inbound calls. When I looked in our SIP trunk configuration, I noticed that it had set our preferred coded to g711ulaw.

Knowing that it wasn't what we'd configured for in CLI pre-upgrade to 8.6.0, I clicked on the dropdown and changed it to g729r8. Once I did this, our inbound calls worked and now the outbound calls wouldn't work; fast busy signal. We've tried deleting the SIP trunk and rebuilding it. Also, factory resetting and rebuilding everything hasn't done the trick either. Does anyone have any idea why we'd have this problem?

-Chris

Everyone's tags (4)
15 REPLIES

UC540 8.6.0 NexVortex SIP problem - no outbound calls

Hi Chris,

Can you post a debug ccsip all?  Debug instructions here.

Should give a better picture of whats going on when you make a call.

Best,

David

New Member

UC540 8.6.0 NexVortex SIP problem - no outbound calls

David,

debug ccsip all gave me hardly any log at all. Like 20 lines, if that. So I did a

debug ccsip message

debug voip ccapi inout

debug voip dialpeer inout

debug voice translation

debug voice source-group

debug voip rtp session named-events

The log is quite large and I'm wary of posting it directly on the forum here. Might there be a better way to get it to you?

UC540 8.6.0 NexVortex SIP problem - no outbound calls

Chris,

Post the 20 lines from debug ccsip all. Please santize any personal info (phone #s, etc, but put something in to replace it rather than just delete).

I'll PM you my email if that doesn't get us going in the right direction.

Best,

David

New Member

Re: UC540 8.6.0 NexVortex SIP problem - no outbound calls

Syslog logging: enabled (0 messages dropped, 3 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

No Inactive Message Discriminator.


    Console logging: disabled
    Monitor logging: disabled
    Buffer logging:  level debugging, 1495 messages logged, xml disabled,
                    filtering disabled
    Exception Logging: size (4096 bytes)
    Count and timestamp logging messages: disabled
    Persistent logging: disabled

No active filter modules.

    Trap logging: level informational, 257 message lines logged
        Logging Source-Interface:       VRF Name:

Log Buffer (5000000 bytes):

      

EDIT: Obviously I'm not getting the log I want here.

Re: UC540 8.6.0 NexVortex SIP problem - no outbound calls

Chris,

That doesn't look like what I'd expect to see from a ccdebug sip all.

Look for a PM with my email. Do the other debugs have what we're looking for?

Best,

David

Cisco Employee

Re: UC540 8.6.0 NexVortex SIP problem - no outbound calls

Hi Chris,

Can you run 'debug voip ccapi inout' and 'debug ccsip mess' and attach the output here from an outbound call attempt after replacing personal info? 

Thanks,

Brandon

New Member

Re: UC540 8.6.0 NexVortex SIP problem - no outbound calls

EDIT: attached.

Cisco Employee

Re: UC540 8.6.0 NexVortex SIP problem - no outbound calls

Hi Chris,

Thank you for attaching that.  In the logs, I see the following:

000279: Jun 28 12:58:12.871: //48/0A0D25A28034/CCAPI/ccSaveDialpeerTag:

   Outgoing Dial-peer=1039

000280: Jun 28 12:58:12.875: //49/0A0D25A28034/CCAPI/cc_api_call_disconnected:

   Cause Value=3, Interface=0x87D1152C, Call Id=49

Cause Value=3 indicates no route.  If you look under the sip-ua section of your configuration, do you have a keepalive target configured?  Can you remove that and try again and see if that helps?

Thanks,

Brandon

New Member

Re: UC540 8.6.0 NexVortex SIP problem - no outbound calls

I have the show run output. See attached.

Cisco Employee

Re: UC540 8.6.0 NexVortex SIP problem - no outbound calls

Hi Chris,

In your configuration, you do have a keepalive target configured in the sip-ua section:

sip-ua

keepalive target ipv4:xx.xx.xx.xx:5060

Try removing that and then try outbound calling to see if that works.

config t

sip-ua

  no keepalive target

  end

Let me know how that works.

Thanks,

Brandon

New Member

Re: UC540 8.6.0 NexVortex SIP problem - no outbound calls

I use Nexvortex, and

keepalive target ipv4:xx.xx.xx.xx:5060

is in my config and we're having no issues.  I don't think that's the problem.

I have the following that I'm using in the sip-ua section (with 711)

sip-ua

keepalive target ipv4:66.23.129.253:5060

authentication username xxxxxxxxxxxx password 7 xxxxxxxxxxxx

no remote-party-id

retry invite 2

retry register 10

timers connect 100

timers keepalive active 100

registrar ipv4:66.23.129.253:5060 expires 3600

sip-server ipv4:66.23.129.253:5060

connection-reuse

host-registrar

You may need to check your outgoing call handling - i think you're missing some translation rules - not sure as I was only able to skim through and I have to go work on another project.  Just a thought for another helpful somebody else to review.

Cisco Employee

Re: UC540 8.6.0 NexVortex SIP problem - no outbound calls

Hi Brian,

I've seen a handful of instances where outbound calls aren't working and debugs show it hitting the outbound dial-peer and then failing with Cause Value=3, which indicates no route.  Calls start working after removing the sip-ua keepalive target.  That's why I suggested to try removing it even though I don't yet understand why it affects outbound calls and why not everyone sees it.  It's worth a try.

Thanks,

Brandon

New Member

Re: UC540 8.6.0 NexVortex SIP problem - no outbound calls

Brandon,

That did the trick!

'no keepalive target' in the sip-ua section worked like a champ. Thank you for your help

New Member

UC540 8.6.0 NexVortex SIP problem - no outbound calls

There is an error in the NexVortex setup guide. Page 3 says to use a predefined template in https://supportforums.cisco.com/docs/DOC-21472. DO NOT USE THIS TEMPLATE.

They also say not to use any Cisco Templates, but the Blank Template is fine with the settings from the setup guide.

Sorry to say, but this template does not work, but a manual configuration according to the guide does!

The template deletes some of the needed settings.

So if you have CCP 3.2 just create a new SIP trunk and follow all the   steps in the UC500 NexVortex guide, but DO NOT IMPORT THIS TEMPLATE.

You can very easily use the blank UC540 template to input your own NexVortex settings.

Also extend the Connect Timer and the Keep Alive to 100 and 600.

Make sure you open ports 5060 for UDP traffic as well.

New Member

UC540 8.6.0 NexVortex SIP problem - no outbound calls

Brandon,

Thanks for posting this fix, I'm with another SIP provider and the system has been working fine for over a year. Yesterday morning outbound calls stopped working.

After around 6 hours on call to Cisco Small Business TAC yesterday (ugh) and while I was on hold for over an HOUR this morningI stumbled accross this...

Thanks for ending my frustration.

2418
Views
0
Helpful
15
Replies
CreatePlease to create content