Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

Back to this time old problem again, i have recently updated a UC540 with the new 8.2 Package and Installed CCA3.1, alas when i did a factory restore with default config (not as easy as its supposed to be), I have no inbound SIP calls. There seems to be something screwy going on with the incoming dial-plan, i have done the usual work arounds for incoming sip issues

no permission term

removed the offending ACL entries that seem to cause so many problems

even tried re-enabling them and permitting any as the only statement

Debugs don't seem to help at all, tracing the call but no idea why its failing, a very strange one.

Anyone else recently updated the software and seeing these kind of results. I really had hoped with the new updates that Cisco would have eventually fixed the BUGS that seem to haunt using SIP on the UC500 series. I'd recommend the UC320 any day, its a piece of cake, but sadly lacks a few of the more advanced features.

Thanks in Advance

Robert

Everyone's tags (3)
14 REPLIES
New Member

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

Hello Robert,

I don't know of any "known" issues after an upgrade.  We would need to look at your debugs, and the running configuration to see if we can figure out what is going on with your inbound calls.

Thank you,

Darren

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

thanks for the reply darren!

I didnt just do an upgrade on this, I have a client with a UC540 en-situ and we were having one or two teething problems as it was a new install. Running a SR520W with UC540 and 5 SPA525G2 Handsets. I had problems with SIP from the get-go, this was on pkg 8.1 with CCA3.0, afters hours of crawling through the web, I couldnt wait on a response from TAC, this had to be done over the weekend for a go live date and the disti was no where to be seen. I discovered that there seems to be multiple issues with SIP on the UC540, a lot of people having issues with the Toll Fraud measures put in place by;

access-list 2

As i delved further, i also discovered that;

permission term

had to be removed from some of the voip dial peers, a long with a couple of other CLI steps before i could receive incoming SIP calls. All through this process, the SIP registrar was connected and the system was able to make outbound calls.

Sadly, due to me spending hours and hours trying to get this to work, finally did i made the biggest mistake ever, never took a copy of my running-config. When i seen the new update was available i presumed that some of these issues would have been rectified and i presumed that if i did a package upgrade, updated my CCA then all i would have to do was a factory reset on the uc540, start from scratch and configure a new install on the box.

Never that easy, i am now at the point where i can make outbound calls but cannot receive them. CCA3.1 seem to configure the incoming SIP calls different as it will only let me specify individual numbers on the inbound SIP, i cannot specify a range. I have configured the SIP gateway in the ACL but this made not a blind jot of difference and i now have a client going ballistic because the whole thing has collapsed like a pack of cards.

Also point to note for anyone who has done a factory reset using the new package and CCA3.1, do not add your cisco router to the site when performing this, remove it and work on the uc540 as standalone, otherwise there is an issue with the way it configures the default gateway for internet access and the Telephony Wizard will not complete. If you only specify the addres of the UC540 within the scope of the site, it defaults to DHCP and will complete, you can then change these details later.

Hope someone out there knows the pain i'm going through and can maybe help!!!

Cheers

Robert

New Member

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

Hi Robert,

This may or May not help and you may have already canvassed this already, but I don't see it mentioned so thought I would run it by you...

In this section of CCA you put in there trusted IP's of the ITSP, please contact them and get a list of these and add them, the URI may resolve to more than one IP but the IOS does not follow this and dynamically update the ACL (Which I can sort of understand this), so you need to give it a helping hand by allowing it a heads up on what it potentially could change too.

This may resolve it, it is the first thing I do now with every SIP trunk install, get a list and insert it whether there are problems with incoming calls or not.

Also if you have a Debug of the CCSIP for an incoming call that would help as well, it may not always be an ACL issue, sometimes when an ITSP sends a call to a gateway, their system may not like to negotiate Codecs or the Cisco may not have the provisions for this (Broadworx SBC's are the best so far to work with the Cisco IOS, and Asterisk/Freeswitch believe it or not).

Update us on your progress with this.

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
New Member

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

Robert,

Is your basic SIP trunk configuration from CCA or CLI?  If CCA, is this Generic option or another service provider?

CCA has been providing toll fraud protection in the configuration for some time. Your "tried and true" methods for getting inbound calls to work relate to bypassing CCA's configuration for toll fraud protection.  Well, in recent version of UC500 software pack, CME has also joined the effort. There is now a toll fraud application that by default blocks all inbound SIP.  Check out this tech note:

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080b3e123.shtml

Did  you perform software upgrade or configure SIP trunk with a more recent  version of CCA? If so, you should see the following added to your  configuration:

voice service voip
 ip address trusted list
  ipv4 0.0.0.0 0.0.0.0

If  this is not present, trying adding it.  And while this is not  recommended (It is better to get the list of IP address from your provider upfront and enter them as David mentions above), you may want to check the above tech note for how to  disable the IOS/CME toll fraud application completely.

And finally, as David also mentions above, this issue could be unrelated to toll fraud but rather some other setting between the UC500 and your provider.  You mention problem with incoming dial plans.  What do you inbound dial-peers look like?  The running configuration and any debugs would helpful.

Laura

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

Thanks for having a look at this Laura, David and Darren.

I set up the SIP trunk using the Generic Template, the provider I am using here in the UK is Gamma Telecoms, they seem to be the largest UK provider of SIP trunks.

I have already had a look at the things that you have all suggested and still having no joy, i have attatched a copy of the running config for you to have a look at. I just seem to be running round in circles, I have a few further issues with this customers site but i shall open a new thread to cover those issues after i have managed to resolve the incoming SIP call issue

My Config is as follows after doing a factory resest after upgrading the IOS package.

Thanks again

Robert

Building configuration...


Current configuration : 51018 bytes
!
! Last configuration change at 09:59:39 GMT Wed Aug 24 2011 by lts
! NVRAM config last updated at 10:06:47 GMT Tue Aug 23 2011 by lts
!
version 15.1
parser config cache interface
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
service internal
service compress-config
service sequence-numbers
!
hostname micro****
!
boot-start-marker
boot-end-marker
!
!
no logging queue-limit
no logging rate-limit
no logging console
no logging monitor
enable secret 5 $1$k0Hq$chi48t7d9/86mZ0wceG5Q.
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
!
clock timezone GMT 0 0
clock summer-time GMT recurring last Sun Mar 1:00 last Sun Oct 2:00
network-clock-participate wic 1
network-clock-select 1 BRI0/1/0
network-clock-select 2 BRI0/1/1
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2432080308
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2432080308
revocation-check none
!
!
crypto pki certificate chain TP-self-signed-2432080308
certificate self-signed 01
  30820252 308201BB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32343332 30383033 3038301E 170D3131 30383232 31343436
  35365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34333230
  38303330 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A8FB E7FB7032 7C2C3654 8B2F8111 68328F1E 4133ABBD 31613368 ADCD8000
  22D640F9 2C88709F B09219B1 B2409F03 EFEC809F 497AA5FB CC70F0BD 9FCEC518
  03419C97 E3C69AFD 3201F9B5 12B768D8 96F286A3 6984A431 BE319493 999C8886
  AC6CC53D F16C1F2B 51BE45F0 48EE3E57 44053B25 8F13D228 A63EF98A C3CE5780
  DADD0203 010001A3 7A307830 0F060355 1D130101 FF040530 030101FF 30250603
  551D1104 1E301C82 1A6D6963 726F636F 6D2E6777 332E7468 65697074 656C652E
  636F6D30 1F060355 1D230418 30168014 F8A525AE E2BAFCEC BEF5E37E 9D910666
  54F9F3DD 301D0603 551D0E04 160414F8 A525AEE2 BAFCECBE F5E37E9D 91066654
  F9F3DD30 0D06092A 864886F7 0D010104 05000381 81000114 2D98275C FF915100
  23126495 78C46960 9BD11F00 31FA6D1E 1D21B657 0402C53F 3ED2F08A 7F6A2E2D
  F115A597 4F620478 5B2F1C89 885631BE 29EF701E 5CD37A7B 3E9C263D 32440EC2
  E0BFE413 B1BCFC57 A7705C26 0FF7606A 0A035AD0 2F200CA9 28C62CF7 67D31282
  A3B03108 6038021C 3F674E4F FADE7E49 1A580FBD C0EE
   quit
dot11 syslog
!
dot11 ssid cisco-voice
vlan 100
authentication open
authentication key-management wpa
wpa-psk ascii 0 L1.*****
!
dot11 ssid mms-data
vlan 1
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 0 L1.*****
!
ip source-route
ip cef
!
!
ip dhcp relay information trust-all
ip dhcp excluded-address 10.1.1.1 10.1.1.9
ip dhcp excluded-address 10.1.1.241 10.1.1.255
ip dhcp excluded-address 192.168.10.1 192.168.10.9
ip dhcp excluded-address 192.168.10.241 192.168.10.255
!
ip dhcp pool phone
   network 10.1.1.0 255.255.255.0
   default-router 10.1.1.1
   option 150 ip 10.1.1.1
!
ip dhcp pool data
   import all
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
   dns-server 208.67.222.222 208.67.220.220
!
!
!
ip domain name gw3.theiptele.com
ip name-server 208.67.222.222
ip name-server 208.67.220.220
ip inspect WAAS flush-timeout 10
ip inspect name SDM_LOW cuseeme
ip inspect name SDM_LOW dns
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW https
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW imap
ip inspect name SDM_LOW pop3
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW esmtp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp router-traffic
ip inspect name SDM_LOW udp router-traffic
ip inspect name SDM_LOW vdolive
no ipv6 cef
!
multilink bundle-name authenticated
!
stcapp ccm-group 1
stcapp
!
!
isdn switch-type basic-net3
!
!
trunk group ALL_BRI
hunt-scheme longest-idle
translation-profile outgoing PROFILE_ALL_BRI
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
ip address trusted list
  ipv4 0.0.0.0 0.0.0.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
  registrar server expires max 3600 min 3600
  localhost dns:gw3.theiptele.com
  outbound-proxy dns:gw3.theiptele.com
  no update-callerid
  sip-profiles 1000
!
voice class codec 1
codec preference 1 g711ulaw
!
voice class sip-profiles 1000
request ANY sdp-header Connection-Info remove
response ANY sdp-header Connection-Info remove
!
!
voice register global
!
!
!
voice source-group CCA_SIP_SOURCE_GROUP_CUE_CME
access-list 4
translation-profile incoming SIP_Incoming
!
voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL
access-list 5
!
voice translation-rule 4
rule 15 /^...$/ /01698254638/
!
voice translation-rule 6
rule 1 /01698539995/ /201/
!
voice translation-rule 410
rule 1 /^9\(.*\)/ /\1/
rule 15 /^...$/ /01698539995/
!
voice translation-rule 411
rule 1 /^9\(.*\)/ /ABCD9\1/
!
voice translation-rule 412
rule 1 /^ABCD\(.*\)/ /\1/
!
voice translation-rule 1000
rule 1 /.*/ //
!
voice translation-rule 1111
rule 15 /^...$/ /01698539995/
!
voice translation-rule 1112
rule 1 /^9/ //
!
voice translation-rule 2002
rule 1 /^6/ //
!
voice translation-rule 2222
rule 1 /^909[01]......../ //
rule 2 /^9090[89]......./ //
rule 3 /^9098\(.*\)/ //
!
!
voice translation-profile CALLER_ID_TRANSLATION_PROFILE
translate calling 1111
!
voice translation-profile CallBlocking
translate called 2222
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
translate called 1112
!
voice translation-profile PROFILE_ALL_BRI
translate calling 4
!
voice translation-profile PSTN_CallForwarding
translate redirect-target 410
translate redirect-called 410
!
voice translation-profile PSTN_Outgoing
translate calling 1111
translate called 1112
translate redirect-target 410
translate redirect-called 410
!
voice translation-profile SIP_Incoming
translate called 411
!
voice translation-profile SIP_Passthrough
translate called 412
!
voice translation-profile XFER_TO_VM_PROFILE
translate redirect-called 2002
!
voice translation-profile highnet-OP_Called_6
translate calling 3265
translate called 6
!
voice translation-profile nondialable
translate called 1000
!
!
voice-card 0
!
fax interface-type fax-mail
!
!
license udi pid UC540W-BRI-K9 sn FGL150827DG
archive
log config
  logging enable
  logging size 600
  hidekeys
username lts privilege 15 secret 5 $1$A7FD$CM7t/SZl2UMR5zYkbGciN0
!
!
ip tftp source-interface Loopback0
!
class-map match-all _class_Voice0
match ip dscp ef
class-map match-all _class_Voice1
match ip dscp cs3
!
!
policy-map Voice
class _class_Voice0
  set cos 6
class _class_Voice1
  set cos 3
!
!
!
!
bridge irb
!
!
!
!
interface Loopback0
description $FW_INSIDE$
ip address 10.1.10.2 255.255.255.252
ip access-group 101 in
ip nat inside
ip virtual-reassembly in
!
interface FastEthernet0/0
description $FW_OUTSIDE$
ip address dhcp client-id FastEthernet0/0
ip access-group 104 in
ip nat outside
ip inspect SDM_LOW out
ip virtual-reassembly in
load-interval 30
duplex auto
speed auto
!
interface Integrated-Service-Engine0/0
description cue is initialized with default IMAP group
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly in
service-module ip address 10.1.10.1 255.255.255.252
service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1/0
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/1
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/2
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/3
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/4
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/5
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/6
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/7
switchport voice vlan 100
macro description cisco-phone
spanning-tree portfast
!
interface FastEthernet0/1/8
switchport mode trunk
switchport voice vlan 100
macro description cisco-switch
!
interface BRI0/1/0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn sending-complete
trunk-group ALL_BRI 64
!
interface BRI0/1/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn sending-complete
trunk-group ALL_BRI 64
!
interface Dot11Radio0/5/0
no ip address
!
encryption vlan 1 mode ciphers aes-ccm
!
encryption vlan 100 mode ciphers aes-ccm
!
ssid cisco-voice
!
ssid mms-data
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
antenna receive right
antenna transmit right
service-policy output Voice
!
interface Dot11Radio0/5/0.1
encapsulation dot1Q 1 native
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0/5/0.100
encapsulation dot1Q 100
bridge-group 100
bridge-group 100 subscriber-loop-control
bridge-group 100 spanning-disabled
bridge-group 100 block-unknown-source
no bridge-group 100 source-learning
no bridge-group 100 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan100
no ip address
bridge-group 100
bridge-group 100 spanning-disabled
!
interface BVI1
description $FW_INSIDE$
ip address 192.168.10.1 255.255.255.0
ip access-group 102 in
ip nat inside
ip virtual-reassembly in
!
interface BVI100
description $FW_INSIDE$
ip address 10.1.1.1 255.255.255.0
ip access-group 103 in
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:/gui
ip dns server
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
!
logging esm config
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 10.1.10.0 0.0.0.3
access-list 2 remark CCA_SIP_SOURCE_GROUP_ACL_INTERNAL
access-list 2 remark SDM_ACL Category=1
access-list 2 permit 192.168.10.1
access-list 2 permit 10.1.10.0 0.0.0.3
access-list 2 permit 192.168.10.0 0.0.0.255
access-list 2 permit 10.1.1.0 0.0.0.255
access-list 3 remark CCA_SIP_SOURCE_GROUP_ACL_EXTERNAL
access-list 3 remark SDM_ACL Category=1
access-list 3 permit 88.215.60.40
access-list 3 deny   any
access-list 4 remark CCA_SIP_SOURCE_GROUP_ACL_INTERNAL
access-list 4 remark SDM_ACL Category=1
access-list 4 permit 192.168.10.1
access-list 4 permit 10.1.10.0 0.0.0.3
access-list 4 permit 192.168.10.0 0.0.0.255
access-list 4 permit 10.1.1.0 0.0.0.255
access-list 4 permit any
access-list 5 remark SIP_EXTERNAL
access-list 5 permit any
access-list 100 remark auto generated by SDM firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny   ip 192.168.10.0 0.0.0.255 any
access-list 100 deny   ip host 255.255.255.255 any
access-list 100 deny   ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 remark auto generated by SDM firewall configuration##NO_ACES_7##
access-list 101 remark SDM_ACL Category=1
access-list 101 permit tcp 10.1.1.0 0.0.0.255 eq 2000 any
access-list 101 permit udp 10.1.1.0 0.0.0.255 eq 2000 any
access-list 101 deny   ip 10.1.1.0 0.0.0.255 any
access-list 101 deny   ip 192.168.10.0 0.0.0.255 any
access-list 101 deny   ip host 255.255.255.255 any
access-list 101 deny   ip 127.0.0.0 0.255.255.255 any
access-list 101 permit ip any any
access-list 102 remark auto generated by SDM firewall configuration##NO_ACES_5##
access-list 102 remark SDM_ACL Category=1
access-list 102 deny   ip 10.1.10.0 0.0.0.3 any
access-list 102 deny   ip 10.1.1.0 0.0.0.255 any
access-list 102 deny   ip host 255.255.255.255 any
access-list 102 deny   ip 127.0.0.0 0.255.255.255 any
access-list 102 permit ip any any
access-list 103 remark auto generated by SDM firewall configuration##NO_ACES_7##
access-list 103 remark SDM_ACL Category=1
access-list 103 permit tcp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 permit udp 10.1.10.0 0.0.0.3 any eq 2000
access-list 103 deny   ip 10.1.10.0 0.0.0.3 any
access-list 103 deny   ip 192.168.10.0 0.0.0.255 any
access-list 103 deny   ip host 255.255.255.255 any
access-list 103 deny   ip 127.0.0.0 0.255.255.255 any
access-list 103 permit ip any any
access-list 104 remark auto generated by SDM firewall configuration##NO_ACES_22##
access-list 104 remark SDM_ACL Category=1
access-list 104 permit udp host 88.215.60.40 eq 5060 any
access-list 104 permit udp host 88.215.60.40 any eq 5060
access-list 104 permit udp host 192.168.10.1 eq 5060 any
access-list 104 permit udp host 192.168.10.1 any eq 5060
access-list 104 permit udp any any range 16384 32767
access-list 104 deny   ip 10.1.10.0 0.0.0.3 any
access-list 104 deny   ip 10.1.1.0 0.0.0.255 any
access-list 104 deny   ip 192.168.10.0 0.0.0.255 any
access-list 104 permit udp any eq bootps any eq bootpc
access-list 104 permit icmp any any echo-reply
access-list 104 permit icmp any any time-exceeded
access-list 104 permit icmp any any unreachable
access-list 104 deny   ip 10.0.0.0 0.255.255.255 any
access-list 104 deny   ip 172.16.0.0 0.15.255.255 any
access-list 104 deny   ip 192.168.0.0 0.0.255.255 any
access-list 104 deny   ip 127.0.0.0 0.255.255.255 any
access-list 104 deny   ip host 255.255.255.255 any
access-list 104 deny   ip any any log
!
!
!
!
snmp-server community public RO
tftp-server flash:/phones/521_524/cp524g-8-1-17.bin alias cp524g-8-1-17.bin
tftp-server flash:/phones/525/spa525g-7-4-8.bin alias spa525g-7-4-8.bin
tftp-server flash:/phones/50x-30x/spa50x-30x-7-4-8a.bin alias spa50x-30x-7-4-8a.bin
tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw
tftp-server flash:/ringtones/Analog2.raw alias Analog2.raw
tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw
tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:/ringtones/RingList.xml alias RingList.xml
tftp-server flash:/ringtones/AreYouThereF.raw alias AreYouThereF.raw
tftp-server flash:/ringtones/Bass.raw alias Bass.raw
tftp-server flash:/ringtones/CallBack.raw alias CallBack.raw
tftp-server flash:/ringtones/Chime.raw alias Chime.raw
tftp-server flash:/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:/ringtones/Classic2.raw alias Classic2.raw
tftp-server flash:/ringtones/ClockShop.raw alias ClockShop.raw
tftp-server flash:/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:/ringtones/Drums2.raw alias Drums2.raw
tftp-server flash:/ringtones/FilmScore.raw alias FilmScore.raw
tftp-server flash:/ringtones/HarpSynth.raw alias HarpSynth.raw
tftp-server flash:/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:/ringtones/MusicBox.raw alias MusicBox.raw
tftp-server flash:/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:/ringtones/Piano2.raw alias Piano2.raw
tftp-server flash:/ringtones/Pop.raw alias Pop.raw
tftp-server flash:/ringtones/Pulse1.raw alias Pulse1.raw
tftp-server flash:/ringtones/Ring1.raw alias Ring1.raw
tftp-server flash:/ringtones/Ring2.raw alias Ring2.raw
tftp-server flash:/ringtones/Ring3.raw alias Ring3.raw
tftp-server flash:/ringtones/Ring4.raw alias Ring4.raw
tftp-server flash:/ringtones/Ring5.raw alias Ring5.raw
tftp-server flash:/ringtones/Ring6.raw alias Ring6.raw
tftp-server flash:/ringtones/Ring7.raw alias Ring7.raw
tftp-server flash:/ringtones/Sax1.raw alias Sax1.raw
tftp-server flash:/ringtones/Sax2.raw alias Sax2.raw
tftp-server flash:/ringtones/Vibe.raw alias Vibe.raw
tftp-server flash:/Desktops/CampusNight.png
tftp-server flash:/Desktops/TN-CampusNight.png
tftp-server flash:/Desktops/CiscoFountain.png
tftp-server flash:/Desktops/TN-CiscoFountain.png
tftp-server flash:/Desktops/CiscoLogo.png
tftp-server flash:/Desktops/TN-CiscoLogo.png
tftp-server flash:/Desktops/Fountain.png
tftp-server flash:/Desktops/TN-Fountain.png
tftp-server flash:/Desktops/MorroRock.png
tftp-server flash:/Desktops/TN-MorroRock.png
tftp-server flash:/Desktops/NantucketFlowers.png
tftp-server flash:/Desktops/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x16/List.xml
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x216x16/List.xml
tftp-server flash:/bacdprompts/en_bacd_allagentsbusy.au alias en_bacd_allagentsbusy.au
tftp-server flash:/bacdprompts/en_bacd_disconnect.au alias en_bacd_disconnect.au
tftp-server flash:/bacdprompts/en_bacd_enter_dest.au alias en_bacd_enter_dest.au
tftp-server flash:/bacdprompts/en_bacd_invalidoption.au alias en_bacd_invalidoption.au
tftp-server flash:/bacdprompts/en_bacd_music_on_hold.au alias en_bacd_music_on_hold.au
tftp-server flash:/bacdprompts/en_bacd_options_menu.au alias en_bacd_options_menu.au
tftp-server flash:/bacdprompts/en_bacd_welcome.au alias en_bacd_welcome.au
tftp-server flash:/bacdprompts/en_bacd_xferto_operator.au alias en_bacd_xferto_operator.au
radius-server attribute 31 send nas-port-detail
!
!
control-plane
!
bridge 1 route ip
bridge 100 route ip
call threshold interface FastEthernet0/0 int-calls low 3 high 3
!
voice-port 0/0/0
cptone GB
shutdown
caller-id enable
!
voice-port 0/0/1
cptone GB
shutdown
caller-id enable
!
voice-port 0/0/2
cptone GB
shutdown
caller-id enable
!
voice-port 0/0/3
cptone GB
shutdown
caller-id enable
!
voice-port 0/1/0
compand-type a-law
cptone GB
bearer-cap Speech
!
voice-port 0/1/1
compand-type a-law
cptone GB
bearer-cap Speech
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control -15
description Music On Hold Port
!
sccp local Loopback0
sccp ccm 10.1.1.1 identifier 1 version 3.1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
!
dial-peer cor custom
name internal
name local
name local-plus
name international
name national
name national-plus
name emergency
name toll-free
!
!
dial-peer cor list call-internal
member internal
!
dial-peer cor list call-local
member local
!
dial-peer cor list call-local-plus
member local-plus
!
dial-peer cor list call-national
member national
!
dial-peer cor list call-national-plus
member national-plus
!
dial-peer cor list call-international
member international
!
dial-peer cor list call-emergency
member emergency
!
dial-peer cor list call-toll-free
member toll-free
!
dial-peer cor list user-internal
member internal
member emergency
!
dial-peer cor list user-local
member internal
member local
member emergency
member toll-free
!
dial-peer cor list user-local-plus
member internal
member local
member local-plus
member emergency
member toll-free
!
dial-peer cor list user-national
member internal
member local
member local-plus
member national
member emergency
member toll-free
!
dial-peer cor list user-national-plus
member internal
member local
member local-plus
member national
member national-plus
member emergency
member toll-free
!
dial-peer cor list user-international
member internal
member local
member local-plus
member international
member national
member national-plus
member emergency
member toll-free
!
!
dial-peer voice 1 pots
port 0/0/0
no sip-register
!
dial-peer voice 2 pots
port 0/0/1
no sip-register
!
dial-peer voice 3 pots
port 0/0/2
no sip-register
!
dial-peer voice 4 pots
port 0/0/3
no sip-register
!
dial-peer voice 5 pots
description ** MOH Port **
destination-pattern ABC
port 0/4/0
no sip-register
!
dial-peer voice 6 pots
description catch all dial peer for BRI/PRI”
translation-profile incoming nondialable
incoming called-number .%
direct-inward-dial
!
dial-peer voice 50 pots
description ** incoming dial peer **
incoming called-number ^AAAA$
direct-inward-dial
port 0/1/0
!
dial-peer voice 51 pots
description ** incoming dial peer **
incoming called-number ^AAAA$
direct-inward-dial
port 0/1/1
!
dial-peer voice 2000 voip
description ** cue voicemail pilot number **
translation-profile outgoing XFER_TO_VM_PROFILE
destination-pattern 399
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1 
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 52 pots
trunkgroup ALL_BRI
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Free Numbers - 11 digit**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 9080[08].......
forward-digits all
no sip-register
!
dial-peer voice 53 pots
trunkgroup ALL_BRI
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Free Numbers - 10 digit**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 90500......
forward-digits all
no sip-register
!
dial-peer voice 54 pots
trunkgroup ALL_BRI
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Free Numbers - <= 10 digits**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 90800....T
forward-digits all
no sip-register
!
dial-peer voice 55 pots
trunkgroup ALL_BRI
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*International Toll Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 900800T
forward-digits all
no sip-register
!
dial-peer voice 56 pots
trunkgroup ALL_BRI
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Voicetext Services**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 91800.
forward-digits all
no sip-register
!
dial-peer voice 57 pots
trunkgroup ALL_BRI
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Operator**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 9100
forward-digits all
no sip-register
!
dial-peer voice 58 pots
trunkgroup ALL_BRI
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Int Operator / Blind Directory**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 91[59]5
forward-digits all
no sip-register
!
dial-peer voice 59 pots
trunkgroup ALL_BRI
corlist outgoing call-local
description **CCA*UK-6-Digit-Local-Numbers*Non-Emergency Police/Health Ser**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 91[01]1
forward-digits all
no sip-register
!
dial-peer voice 60 pots
trunkgroup ALL_BRI
corlist outgoing call-local
description **CCA*UK-6-Digit-Local-Numbers*local direct dial**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 9[2-9].....
forward-digits all
no sip-register
!
dial-peer voice 61 pots
trunkgroup ALL_BRI
corlist outgoing call-local
description **CCA*UK-6-Digit-Local-Numbers*local direct dial - 4/5 digits**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 9[2-9]...T
forward-digits all
no sip-register
!
dial-peer voice 62 pots
trunkgroup ALL_BRI
corlist outgoing call-local
description **CCA*UK-6-Digit-Local-Numbers*Local Rate NGN - 11 digit**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 90845.......
forward-digits all
no sip-register
!
dial-peer voice 63 pots
trunkgroup ALL_BRI
corlist outgoing call-local
description **CCA*UK-6-Digit-Local-Numbers*Local Rate NGN - <= 10 digits**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 90845T
forward-digits all
no sip-register
!
dial-peer voice 64 pots
trunkgroup ALL_BRI
corlist outgoing call-local-plus
description **CCA*UK-6-Digit-Local-Numbers*Speaking Clock**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 9123
forward-digits all
no sip-register
!
dial-peer voice 65 pots
trunkgroup ALL_BRI
corlist outgoing call-local-plus
description **CCA*UK-6-Digit-Local-Numbers*Level1 Services**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 915[0-4]T
forward-digits all
no sip-register
!
dial-peer voice 66 pots
trunkgroup ALL_BRI
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*National Geographic - 11 digits**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 90[123].........
forward-digits all
no sip-register
!
dial-peer voice 67 pots
trunkgroup ALL_BRI
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*National Geographic - <= 10 dig**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 901.......T
forward-digits all
no sip-register
!
dial-peer voice 68 pots
trunkgroup ALL_BRI
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*Location independent & Corporat**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 905[56]........
forward-digits all
no sip-register
!
dial-peer voice 69 pots
trunkgroup ALL_BRI
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*Mobile**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 907[1-5,7-9]........
forward-digits all
no sip-register
!
dial-peer voice 70 pots
trunkgroup ALL_BRI
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*Special Services <5ppm**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 90843.......
forward-digits all
no sip-register
!
dial-peer voice 71 pots
trunkgroup ALL_BRI
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*Internet Access**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 90844.......
forward-digits all
no sip-register
!
dial-peer voice 72 pots
trunkgroup ALL_BRI
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*National Non Geo - 11 digits**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 90870.......
forward-digits all
no sip-register
!
dial-peer voice 73 pots
trunkgroup ALL_BRI
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*Services of Social Value**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 9116...
forward-digits all
no sip-register
!
dial-peer voice 74 pots
trunkgroup ALL_BRI
corlist outgoing call-national-plus
description **CCA*UK-6-Digit-Local-Numbers*Directory Enquires**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 9118...
forward-digits all
no sip-register
!
dial-peer voice 75 pots
trunkgroup ALL_BRI
corlist outgoing call-national-plus
description **CCA*UK-6-Digit-Local-Numbers*Personal & Radio Paging**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 907[06]........
forward-digits all
no sip-register
!
dial-peer voice 76 pots
trunkgroup ALL_BRI
corlist outgoing call-national-plus
description **CCA*UK-6-Digit-Local-Numbers*Special Services <10ppm**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 9087[123].......
forward-digits all
no sip-register
!
dial-peer voice 77 pots
trunkgroup ALL_BRI
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 9999
forward-digits all
no sip-register
!
dial-peer voice 78 pots
trunkgroup ALL_BRI
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency**
preference 4
destination-pattern 999
forward-digits all
no sip-register
!
dial-peer voice 79 pots
trunkgroup ALL_BRI
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 9112
forward-digits all
no sip-register
!
dial-peer voice 80 pots
trunkgroup ALL_BRI
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency**
preference 4
destination-pattern 112
forward-digits all
no sip-register
!
dial-peer voice 81 pots
trunkgroup ALL_BRI
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency VoiceText**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 918000
forward-digits all
no sip-register
!
dial-peer voice 82 pots
trunkgroup ALL_BRI
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency VoiceText**
preference 4
destination-pattern 18000
forward-digits all
no sip-register
!
dial-peer voice 83 pots
trunkgroup ALL_BRI
corlist outgoing call-international
description **CCA*UK-6-Digit-Local-Numbers*International**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 4
destination-pattern 900[1-9]T
forward-digits all
no sip-register
!
dial-peer voice 1000 voip
description ** Incoming call from SIP trunk (Generic SIP Trunk Provider) **
session protocol sipv2
session target sip-server
incoming called-number .%
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1001 voip
corlist outgoing call-local
description ** star code to SIP trunk (Generic SIP Trunk Provider) **
destination-pattern *..
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1003 voip
description ** Passthrough Inbound Calls for PSTN from CUE **
translation-profile incoming SIP_Passthrough
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
incoming called-number ABCDT
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 1005 voip
description ** Passthrough Inbound Calls for MWI from CUE **
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
incoming called-number A80T
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 1009 voip
description ** Passthrough Inbound Calls for Internal Extensions from CUE **
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
incoming called-number ^...$
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 1020 voip
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*Mobile**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 907[1-5,7-9]........
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1021 voip
corlist outgoing call-local
description **CCA*UK-6-Digit-Local-Numbers*Local Rate NGN - <= 10 digits**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 90845T
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1022 voip
corlist outgoing call-local-plus
description **CCA*UK-6-Digit-Local-Numbers*Level1 Services**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 915[0-4]T
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1023 voip
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Int Operator / Blind Directory**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 91[59]5
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1024 voip
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Free Numbers - 10 digit**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 90500......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1025 voip
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Free Numbers - 11 digit**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9080[08].......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1026 voip
corlist outgoing call-local
description **CCA*UK-6-Digit-Local-Numbers*local direct dial - 4/5 digits**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9[2-9]...T
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1027 voip
corlist outgoing call-local
description **CCA*UK-6-Digit-Local-Numbers*Local Rate NGN - 11 digit**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 90845.......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1028 voip
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Free Numbers - <= 10 digits**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 90800....T
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1029 voip
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*National Non Geo - 11 digits**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 90870.......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1030 voip
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Operator**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9100
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1031 voip
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*Location independent & Corporat**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 905[56]........
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1032 voip
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*Internet Access**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 90844.......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1033 voip
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*National Geographic - <= 10 dig**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 901.......T
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1034 voip
corlist outgoing call-local
description **CCA*UK-6-Digit-Local-Numbers*local direct dial**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9[2-9].....
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1035 voip
corlist outgoing call-local-plus
description **CCA*UK-6-Digit-Local-Numbers*Speaking Clock**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9123
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1036 voip
corlist outgoing call-national-plus
description **CCA*UK-6-Digit-Local-Numbers*Personal & Radio Paging**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 907[06]........
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1037 voip
corlist outgoing call-national-plus
description **CCA*UK-6-Digit-Local-Numbers*Special Services <10ppm**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9087[123].......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1038 voip
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*Special Services <5ppm**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 90843.......
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1039 voip
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*National Geographic - 11 digits**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 90[123].........
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1040 voip
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency VoiceText**
translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
preference 1
destination-pattern 18000
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1041 voip
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency VoiceText**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 918000
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1042 voip
corlist outgoing call-local
description **CCA*UK-6-Digit-Local-Numbers*Non-Emergency Police/Health Ser**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 91[01]1
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1043 voip
corlist outgoing call-international
description **CCA*UK-6-Digit-Local-Numbers*International**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 900[1-9]T
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1044 voip
corlist outgoing call-national-plus
description **CCA*UK-6-Digit-Local-Numbers*Directory Enquires**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9118...
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1045 voip
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*International Toll Free**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 900800T
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1046 voip
corlist outgoing call-national
description **CCA*UK-6-Digit-Local-Numbers*Services of Social Value**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9116...
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1047 voip
corlist outgoing call-toll-free
description **CCA*UK-6-Digit-Local-Numbers*Voicetext Services**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 91800.
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1048 voip
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency**
translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
preference 1
destination-pattern 999
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1049 voip
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9999
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1050 voip
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency**
translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
preference 1
destination-pattern 112
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 1051 voip
corlist outgoing call-emergency
description **CCA*UK-6-Digit-Local-Numbers*Emergency**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9112
session protocol sipv2
session target sip-server
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
dial-peer voice 3001 voip
description highnet-OP
translation-profile incoming highnet-OP_Called_6
session protocol sipv2
session target sip-server
incoming called-number 01698539995
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad
!
!
no dial-peer outbound status-check pots
sip-ua
credentials username 0001519669989 password 7 075C28601F502F2843300F1A3E3C79107F1B1D7B0250152707 realm gw3.theiptele.com
authentication username 0001519669989 password 7 14441B275D5D1C06700A37231805552254297E004904572A05
no remote-party-id
retry invite 2
retry register 10
timers connect 100
registrar dns:gw3.theiptele.com expires 3600
sip-server dns:gw3.theiptele.com
host-registrar
!
!
!
telephony-service
video
fxo hook-flash
max-ephones 40
max-dn 300
ip source-address 10.1.1.1 port 2000
auto assign 1 to 1 type bri
calling-number initiator
service phone videoCapability 1
service phone ehookenable 1
service phone SPA525-Encryption-key L1.oasis
service phone SPA525-wifi-on yes
service phone SPA525-protocol SPCP
service phone SPA525-auto-detect-sccp yes
service phone SPA525-http-write yes
service phone SPA525-SSID cisco-voice
service phone SPA525-readonly no
service phone SPA525-Encryption-type WPA2_PSK
service dnis overlay
service dnis dir-lookup
service dss
timeouts interdigit 5
system message Cisco Small Business
url services http://10.1.10.1/voiceview/common/login.do
url authentication http://10.1.10.1/voiceview/authentication/authenticate.do 
load 521G-524G cp524g-8-1-17
load 525G spa525g-7-4-8
load 501G spa50x-30x-7-4-8a
load 502G spa50x-30x-7-4-8a
load 504G spa50x-30x-7-4-8a
load 508G spa50x-30x-7-4-8a
load 509G spa50x-30x-7-4-8a
load 525G2 spa525g-7-4-8
load 301 spa50x-30x-7-4-8a
load 303 spa50x-30x-7-4-8a
time-zone 21
keepalive 30 auxiliary 4
voicemail 399
max-conferences 8 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh flash:/media/music-on-hold.au
multicast moh 239.10.16.16 port 2000
web admin system name cisco secret 5 $1$1QpJ$cUa1M8jnJ4ClcbQJ01gNr0
dn-webedit
time-webedit
transfer-system full-consult dss
transfer-pattern 9.T
transfer-pattern .T
transfer-pattern 6... blind
secondary-dialtone 9
night-service day Sun 17:00 09:00
night-service day Mon 17:00 09:00
night-service day Tue 17:00 09:00
night-service day Wed 17:00 09:00
night-service day Thu 17:00 09:00
night-service day Fri 17:00 09:00
night-service day Sat 17:00 09:00
fac standard
create cnf-files version-stamp 7960 Aug 18 2011 00:14:42
!
!
ephone-template  15
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use  Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
button-layout 7931 2
!
!
ephone-template  16
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use  Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
!
!
ephone-template  17
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use  CBarge Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
!
!
ephone-template  18
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use  CBarge Newcall
softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login
softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback
softkeys connected  Hold Endcall Trnsfer TrnsfVM Confrn Acct Park
button-layout 7931 2
!
!
ephone-dn  9
number BCD no-reg primary
description MoH
moh out-call ABC
!
!
ephone-dn  293
number 01698539995
description SIP Main Number registration
preference 10
!
!
ephone-dn  294  dual-line
number 204 no-reg primary
label 204
description microcom bothwell
name microcom bothwell
call-forward busy 399
call-forward noan 399 timeout 20
!
!
ephone-dn  295  dual-line
number 203 no-reg primary
label 203
description microcom mwell
name microcom mwell
call-forward busy 399
call-forward noan 399 timeout 20
!
!
ephone-dn  296  dual-line
number 202 no-reg primary
label 202
description microcom irvine
name microcom irvine
call-forward busy 399
call-forward noan 399 timeout 20
!
!
ephone-dn  297  dual-line
number 201 no-reg primary
label 201
description microcom ayr
name microcom ayr
call-forward busy 399
call-forward noan 399 timeout 20
!
!
ephone-dn  298
number 6... no-reg primary
description ***CCA XFER TO VM EXTENSION***
call-forward all 399
!
!
ephone-dn  299
number A801... no-reg primary
mwi off
!
!
ephone-dn  300
number A800... no-reg primary
mwi on
!
!
ephone  5
device-security-mode none
mac-address 503D.E50F.17F0
ephone-template 16
max-calls-per-button 2
username "ayr" password 123456
type 525G2
button  1:297
!
!
!
ephone  6
device-security-mode none
mac-address 503D.E50F.0D36
ephone-template 16
max-calls-per-button 2
username "irvine" password 123456
type 525G2
button  1:296
!
!
!
ephone  7
device-security-mode none
mac-address 503D.E50F.0CB8
ephone-template 16
max-calls-per-button 2
username "mwell" password 123456
type 525G2
button  1:295
!
!
!
ephone  8
device-security-mode none
mac-address 503D.E50F.0D26
ephone-template 16
max-calls-per-button 2
username "bothwell" password 123456
type 525G2
button  1:294
!
!
alias exec cca_voice_mode PBX
banner login ^Cbanner login ^Cisco Configuration Assistant. Version: 3.1 (1). Wed Aug 17 23:32:17 BST 2011^^C
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
line vty 0 4
transport preferred none
transport input all
line vty 5 100
transport preferred none
transport input all
!
ntp master
end

New Member

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

Robert,

Aside from SIP toll fraud protections on the voip network (which appear to bypassed now),  you additionally have firewall on the WAN interface:

interface FastEthernet0/0

description $FW_OUTSIDE$

ip address dhcp client-id FastEthernet0/0

ip access-group 104 in

ip nat outside

ip inspect SDM_LOW out

ip virtual-reassembly in

load-interval 30

duplex auto

speed auto

The ACL has the following entry for your sip proxy (gw3.theiptele.com resolves 88.215.60.40):

access-list 104 permit udp host 88.215.60.40 eq 5060 any

access-list 104 permit udp host 88.215.60.40 any eq 5060

But the inbound calls may not be using this IP address (judging from changes already made this may be the case you are trying to address; trace of the call would confirm).

The recommended course of action is to get all of the allowed IP addresses for your SP and enter them via CCA as David shows above.

But for debug purpose from CLI, you could tempoarily remove the firewall or modify the firewall to allow all requests on port 5060 (CCA use to configure it this way for Generic SIP Trunk many releases ago, but at some point it was updated as per requirement to secure the firewall for Generic hosts as well).

Laura

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

sorry for the delay in my response, i was on vacation!! okay as we stand i have now done a factory restore, i have removed the permission term from the default incoming voip dial peer, i have diabled the internal uc540 firewall, and i have added the sip registrar to the acl

generic debugs provide the following output, which i think means we are getting close, any help u guys can give would be greatfully appreciated.

Thanks again

Robert

Debug List:::::

debug ccsip message

debug voip ccapi inout

debug voip dialpeer inout

debug voice translation

debug voice source-group

debug voip rtp session named-events

Syslog logging: enabled (0 messages dropped, 3 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)

No Active Message Discriminator.

 

 

No Inactive Message Discriminator.

 

Console logging: disabled

Monitor logging: disabled

Buffer logging: level debugging, 291 messages logged, xml disabled,

filtering disabled

Exception Logging: size (4096 bytes)

Count and timestamp logging messages: disabled

Persistent logging: disabled

No active filter modules.

Trap logging: level informational, 189 message lines logged

Log Buffer (5000000 bytes):

000307: Sep 6 02:36:34.939: %SYS-5-CONFIG_I: Configured from http by lts on 192.168.10.10

000308: Sep 6 02:36:46.255: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:441698539995@192.168.1.8:5060 SIP/2.0

Record-Route: <88.215.60.40>

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-375e161ff2039870-1---d8754z-ser

Via: SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-375e161ff2039870-1---d8754z-;rport=5061

Max-Forwards: 16

Contact: <07775882968>

To: <441698539995>

From: <>07775882968@gw3.theiptele.com:5061>;tag=a815aa0e7b15e27a

Call-ID: OTQ1YzM3YmVhYjY3ZGQ5N2JmYTAzZTVkYzczOTVlMGY.

CSeq: 102 INVITE

Content-Type: application/sdp

P-Asserted-Identity: <>07775882968@gw3.theiptele.com>

Remote-Party-ID: <>07775882968@gw3.theiptele.com>;party=calling;id-type=subscriber;screen=yes;privacy=off

Content-Length: 287

Reg-Proxy: 0001519669989

v=0

o=GASb2bua 9258 9072 IN IP4 88.215.60.41

s=SIP Call

c=IN IP4 88.215.60.33

t=0 0

m=audio 25842 RTP/AVP 18 8 0 101

c=IN IP4 88.215.60.33

a=fmtp:18 annexb=yes

a=fmtp:101 0-16

a=rtpmap:18 G729/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

000309: Sep 6 02:36:46.259: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Calling Number=441698539995, Called Number=441698539995, Peer Info Type=DIALPEER_INFO_SPEECH

000310: Sep 6 02:36:46.259: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Match Rule=DP_MATCH_DEST; Called Number=441698539995

000311: Sep 6 02:36:46.259: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Result=Success(0) after DP_MATCH_DEST

000312: Sep 6 02:36:46.259: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

dialstring=441698539995, saf_enabled=1, saf_dndb_lookup=1, dp_result=0

000313: Sep 6 02:36:46.259: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:

Result=SUCCESS(0)

List of Matched Outgoing Dial-peer(s):

1: Dial-peer Tag=20007

000314: Sep 6 02:36:46.259: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Calling Number=07775882968, Called Number=, Voice-Interface=0x0,

Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

Peer Info Type=DIALPEER_INFO_SPEECH

000315: Sep 6 02:36:46.259: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Result=NO_MATCH(-1) After All Match Rules Attempt

000316: Sep 6 02:36:46.263: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

000317: Sep 6 02:36:46.263: SIPG:src_grp_check_config() src_grp or src_grp acl is defined

000318: Sep 6 02:36:46.263: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 500 Internal Server Error

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-375e161ff2039870-1---d8754z-ser,SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-375e161ff2039870-1---d8754z-;rport=5061

From: <>07775882968@gw3.theiptele.com:5061>;tag=a815aa0e7b15e27a

To: <441698539995>;tag=C67FF4-FFFF8A14

Date: Tue, 06 Sep 2011 01:36:46 GMT

Call-ID: OTQ1YzM3YmVhYjY3ZGQ5N2JmYTAzZTVkYzczOTVlMGY.

CSeq: 102 INVITE

Allow-Events: telephone-event

Reason: Q.850;cause=63

Server: Cisco-SIPGateway/IOS-12.x

Content-Length: 0

 

000319: Sep 6 02:36:46.299: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

ACK sip:441698539995@192.168.1.8:5060 SIP/2.0

Max-Forwards: 10

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-375e161ff2039870-1---d8754z-ser

Via: SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-375e161ff2039870-1---d8754z-;rport=5061

To: <441698539995>;tag=C67FF4-FFFF8A14

From: <>07775882968@gw3.theiptele.com:5061>;tag=a815aa0e7b15e27a

Call-ID: OTQ1YzM3YmVhYjY3ZGQ5N2JmYTAzZTVkYzczOTVlMGY.

CSeq: 102 ACK

Content-Length: 0

Reg-Proxy: 0001519669989

 

000320: Sep 6 02:36:55.483: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:441698539995@192.168.1.8:5060 SIP/2.0

Record-Route: <88.215.60.40>

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-98e0453eee3bfc5f-1---d8754z-ser

Via: SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-98e0453eee3bfc5f-1---d8754z-;rport=5061

Max-Forwards: 16

Contact: <07775882968>

To: <441698539995>

From: <>07775882968@gw3.theiptele.com:5061>;tag=ad545836dbde2e56

Call-ID: NDAyNzFhM2YwODIwOWY3MjBkNDZmNmEyZjFmM2U1MGI.

CSeq: 102 INVITE

Content-Type: application/sdp

P-Asserted-Identity: <>07775882968@gw3.theiptele.com>

Remote-Party-ID: <>07775882968@gw3.theiptele.com>;party=calling;id-type=subscriber;screen=yes;privacy=off

Content-Length: 286

Reg-Proxy: 0001519669989

v=0

o=GASb2bua 1157 934 IN IP4 88.215.60.41

s=SIP Call

c=IN IP4 88.215.60.33

t=0 0

m=audio 26282 RTP/AVP 18 8 0 101

c=IN IP4 88.215.60.33

a=fmtp:18 annexb=yes

a=fmtp:101 0-16

a=rtpmap:18 G729/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

000321: Sep 6 02:36:55.487: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Calling Number=441698539995, Called Number=441698539995, Peer Info Type=DIALPEER_INFO_SPEECH

000322: Sep 6 02:36:55.487: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Match Rule=DP_MATCH_DEST; Called Number=441698539995

000323: Sep 6 02:36:55.487: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Result=Success(0) after DP_MATCH_DEST

000324: Sep 6 02:36:55.487: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

dialstring=441698539995, saf_enabled=1, saf_dndb_lookup=1, dp_result=0

000325: Sep 6 02:36:55.487: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:

Result=SUCCESS(0)

List of Matched Outgoing Dial-peer(s):

1: Dial-peer Tag=20007

000326: Sep 6 02:36:55.487: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Calling Number=07775882968, Called Number=, Voice-Interface=0x0,

Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

Peer Info Type=DIALPEER_INFO_SPEECH

000327: Sep 6 02:36:55.491: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Result=NO_MATCH(-1) After All Match Rules Attempt

000328: Sep 6 02:36:55.491: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

000329: Sep 6 02:36:55.491: SIPG:src_grp_check_config() src_grp or src_grp acl is defined

000330: Sep 6 02:36:55.491: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 500 Internal Server Error

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-98e0453eee3bfc5f-1---d8754z-ser,SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-98e0453eee3bfc5f-1---d8754z-;rport=5061

From: <>07775882968@gw3.theiptele.com:5061>;tag=ad545836dbde2e56

To: <441698539995>;tag=C6A400-2541

Date: Tue, 06 Sep 2011 01:36:55 GMT

Call-ID: NDAyNzFhM2YwODIwOWY3MjBkNDZmNmEyZjFmM2U1MGI.

CSeq: 102 INVITE

Allow-Events: telephone-event

Reason: Q.850;cause=63

Server: Cisco-SIPGateway/IOS-12.x

Content-Length: 0

 

000331: Sep 6 02:36:55.527: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

ACK sip:441698539995@192.168.1.8:5060 SIP/2.0

Max-Forwards: 10

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-98e0453eee3bfc5f-1---d8754z-ser

Via: SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-98e0453eee3bfc5f-1---d8754z-;rport=5061

To: <441698539995>;tag=C6A400-2541

From: <>07775882968@gw3.theiptele.com:5061>;tag=ad545836dbde2e56

Call-ID: NDAyNzFhM2YwODIwOWY3MjBkNDZmNmEyZjFmM2U1MGI.

CSeq: 102 ACK

Content-Length: 0

Reg-Proxy: 0001519669989

 

000332: Sep 6 02:37:04.087: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:441698539995@192.168.1.8:5060 SIP/2.0

Record-Route: <88.215.60.40>

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-1a31863d7769c16b-1---d8754z-ser

Via: SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-1a31863d7769c16b-1---d8754z-;rport=5061

Max-Forwards: 16

Contact: <07775882968>

To: <441698539995>

From: <>07775882968@gw3.theiptele.com:5061>;tag=fe21d4166a27ee58

Call-ID: NTcxZWY4ODViMzAwOGQzZTQ4N2RjNTViYjc5ZWZlYzM.

CSeq: 102 INVITE

Content-Type: application/sdp

P-Asserted-Identity: <>07775882968@gw3.theiptele.com>

Remote-Party-ID: <>07775882968@gw3.theiptele.com>;party=calling;id-type=subscriber;screen=yes;privacy=off

Content-Length: 287

Reg-Proxy: 0001519669989

v=0

o=GASb2bua 2263 2352 IN IP4 88.215.60.41

s=SIP Call

c=IN IP4 88.215.60.33

t=0 0

m=audio 22710 RTP/AVP 18 8 0 101

c=IN IP4 88.215.60.33

a=fmtp:18 annexb=yes

a=fmtp:101 0-16

a=rtpmap:18 G729/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

000333: Sep 6 02:37:04.091: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Calling Number=441698539995, Called Number=441698539995, Peer Info Type=DIALPEER_INFO_SPEECH

000334: Sep 6 02:37:04.091: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Match Rule=DP_MATCH_DEST; Called Number=441698539995

000335: Sep 6 02:37:04.091: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Result=Success(0) after DP_MATCH_DEST

000336: Sep 6 02:37:04.091: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

dialstring=441698539995, saf_enabled=1, saf_dndb_lookup=1, dp_result=0

000337: Sep 6 02:37:04.091: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:

Result=SUCCESS(0)

List of Matched Outgoing Dial-peer(s):

1: Dial-peer Tag=20007

000338: Sep 6 02:37:04.091: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Calling Number=07775882968, Called Number=, Voice-Interface=0x0,

Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

Peer Info Type=DIALPEER_INFO_SPEECH

000339: Sep 6 02:37:04.095: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Result=NO_MATCH(-1) After All Match Rules Attempt

000340: Sep 6 02:37:04.095: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

000341: Sep 6 02:37:04.095: SIPG:src_grp_check_config() src_grp or src_grp acl is defined

000342: Sep 6 02:37:04.095: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 500 Internal Server Error

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-1a31863d7769c16b-1---d8754z-ser,SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-1a31863d7769c16b-1---d8754z-;rport=5061

From: <>07775882968@gw3.theiptele.com:5061>;tag=fe21d4166a27ee58

To: <441698539995>;tag=C6C59C-1CF6

Date: Tue, 06 Sep 2011 01:37:04 GMT

Call-ID: NTcxZWY4ODViMzAwOGQzZTQ4N2RjNTViYjc5ZWZlYzM.

CSeq: 102 INVITE

Allow-Events: telephone-event

Reason: Q.850;cause=63

Server: Cisco-SIPGateway/IOS-12.x

Content-Length: 0

 

000343: Sep 6 02:37:04.135: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

ACK sip:441698539995@192.168.1.8:5060 SIP/2.0

Max-Forwards: 10

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-1a31863d7769c16b-1---d8754z-ser

Via: SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-1a31863d7769c16b-1---d8754z-;rport=5061

To: <441698539995>;tag=C6C59C-1CF6

From: <>07775882968@gw3.theiptele.com:5061>;tag=fe21d4166a27ee58

Call-ID: NTcxZWY4ODViMzAwOGQzZTQ4N2RjNTViYjc5ZWZlYzM.

CSeq: 102 ACK

Content-Length: 0

Reg-Proxy: 0001519669989

 

000344: Sep 6 02:37:12.807: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:441698539995@192.168.1.8:5060 SIP/2.0

Record-Route: <88.215.60.40>

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-03f2481c26b66806-1---d8754z-ser

Via: SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-03f2481c26b66806-1---d8754z-;rport=5061

Max-Forwards: 16

Contact: <07775882968>

To: <441698539995>

From: <>07775882968@gw3.theiptele.com:5061>;tag=0e465e5d9a3dae3d

Call-ID: MTUyNzY1NGI0ZDY5NDkzNjFiMDc3NjU2MDNjNzE0MDc.

CSeq: 102 INVITE

Content-Type: application/sdp

P-Asserted-Identity: <>07775882968@gw3.theiptele.com>

Remote-Party-ID: <>07775882968@gw3.theiptele.com>;party=calling;id-type=subscriber;screen=yes;privacy=off

Content-Length: 287

Reg-Proxy: 0001519669989

v=0

o=GASb2bua 8246 6587 IN IP4 88.215.60.41

s=SIP Call

c=IN IP4 88.215.60.33

t=0 0

m=audio 10622 RTP/AVP 18 8 0 101

c=IN IP4 88.215.60.33

a=fmtp:18 annexb=yes

a=fmtp:101 0-16

a=rtpmap:18 G729/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

000345: Sep 6 02:37:12.811: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Calling Number=441698539995, Called Number=441698539995, Peer Info Type=DIALPEER_INFO_SPEECH

000346: Sep 6 02:37:12.811: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Match Rule=DP_MATCH_DEST; Called Number=441698539995

000347: Sep 6 02:37:12.811: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Result=Success(0) after DP_MATCH_DEST

000348: Sep 6 02:37:12.811: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

dialstring=441698539995, saf_enabled=1, saf_dndb_lookup=1, dp_result=0

000349: Sep 6 02:37:12.811: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:

Result=SUCCESS(0)

List of Matched Outgoing Dial-peer(s):

1: Dial-peer Tag=20007

000350: Sep 6 02:37:12.815: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Calling Number=07775882968, Called Number=, Voice-Interface=0x0,

Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

Peer Info Type=DIALPEER_INFO_SPEECH

000351: Sep 6 02:37:12.815: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Result=NO_MATCH(-1) After All Match Rules Attempt

000352: Sep 6 02:37:12.815: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

000353: Sep 6 02:37:12.815: SIPG:src_grp_check_config() src_grp or src_grp acl is defined

000354: Sep 6 02:37:12.815: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 500 Internal Server Error

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-03f2481c26b66806-1---d8754z-ser,SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-03f2481c26b66806-1---d8754z-;rport=5061

From: <>07775882968@gw3.theiptele.com:5061>;tag=0e465e5d9a3dae3d

To: <441698539995>;tag=C6E7AC-137D

Date: Tue, 06 Sep 2011 01:37:12 GMT

Call-ID: MTUyNzY1NGI0ZDY5NDkzNjFiMDc3NjU2MDNjNzE0MDc.

CSeq: 102 INVITE

Allow-Events: telephone-event

Reason: Q.850;cause=63

Server: Cisco-SIPGateway/IOS-12.x

Content-Length: 0

 

000355: Sep 6 02:37:12.851: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

ACK sip:441698539995@192.168.1.8:5060 SIP/2.0

Max-Forwards: 10

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-03f2481c26b66806-1---d8754z-ser

Via: SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-03f2481c26b66806-1---d8754z-;rport=5061

To: <441698539995>;tag=C6E7AC-137D

From: <>07775882968@gw3.theiptele.com:5061>;tag=0e465e5d9a3dae3d

Call-ID: MTUyNzY1NGI0ZDY5NDkzNjFiMDc3NjU2MDNjNzE0MDc.

CSeq: 102 ACK

Content-Length: 0

Reg-Proxy: 0001519669989

 

000356: Sep 6 02:37:22.611: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

INVITE sip:441698539995@192.168.1.8:5060 SIP/2.0

Record-Route: <88.215.60.40>

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-0ed69928745a6f0c-1---d8754z-ser

Via: SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-0ed69928745a6f0c-1---d8754z-;rport=5061

Max-Forwards: 16

Contact: <07775882968>

To: <441698539995>

From: <>07775882968@gw3.theiptele.com:5061>;tag=80b8070f077b9446

Call-ID: YmM1NDAxNTgwNjJlZmMwZmM3ODZkYzc5MzQ5NDkyNmU.

CSeq: 102 INVITE

Content-Type: application/sdp

P-Asserted-Identity: <>07775882968@gw3.theiptele.com>

Remote-Party-ID: <>07775882968@gw3.theiptele.com>;party=calling;id-type=subscriber;screen=yes;privacy=off

Content-Length: 287

Reg-Proxy: 0001519669989

v=0

o=GASb2bua 2669 7335 IN IP4 88.215.60.41

s=SIP Call

c=IN IP4 88.215.60.33

t=0 0

m=audio 26130 RTP/AVP 18 8 0 101

c=IN IP4 88.215.60.33

a=fmtp:18 annexb=yes

a=fmtp:101 0-16

a=rtpmap:18 G729/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

000357: Sep 6 02:37:22.615: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Calling Number=441698539995, Called Number=441698539995, Peer Info Type=DIALPEER_INFO_SPEECH

000358: Sep 6 02:37:22.615: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Match Rule=DP_MATCH_DEST; Called Number=441698539995

000359: Sep 6 02:37:22.615: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:

Result=Success(0) after DP_MATCH_DEST

000360: Sep 6 02:37:22.615: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

dialstring=441698539995, saf_enabled=1, saf_dndb_lookup=1, dp_result=0

000361: Sep 6 02:37:22.615: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:

Result=SUCCESS(0)

List of Matched Outgoing Dial-peer(s):

1: Dial-peer Tag=20007

000362: Sep 6 02:37:22.615: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Calling Number=07775882968, Called Number=, Voice-Interface=0x0,

Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,

Peer Info Type=DIALPEER_INFO_SPEECH

000363: Sep 6 02:37:22.615: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:

Result=NO_MATCH(-1) After All Match Rules Attempt

000364: Sep 6 02:37:22.615: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:

dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1

000365: Sep 6 02:37:22.615: SIPG:src_grp_check_config() src_grp or src_grp acl is defined

000366: Sep 6 02:37:22.619: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 500 Internal Server Error

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-0ed69928745a6f0c-1---d8754z-ser,SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-0ed69928745a6f0c-1---d8754z-;rport=5061

From: <>07775882968@gw3.theiptele.com:5061>;tag=80b8070f077b9446

To: <441698539995>;tag=C70DF8-6DC

Date: Tue, 06 Sep 2011 01:37:22 GMT

Call-ID: YmM1NDAxNTgwNjJlZmMwZmM3ODZkYzc5MzQ5NDkyNmU.

CSeq: 102 INVITE

Allow-Events: telephone-event

Reason: Q.850;cause=63

Server: Cisco-SIPGateway/IOS-12.x

Content-Length: 0

 

000367: Sep 6 02:37:22.655: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

ACK sip:441698539995@192.168.1.8:5060 SIP/2.0

Max-Forwards: 10

Via: SIP/2.0/UDP 88.215.60.40;branch=z9hG4bK-d8754z-0ed69928745a6f0c-1---d8754z-ser

Via: SIP/2.0/UDP 88.215.60.41:5061;branch=z9hG4bK-d8754z-0ed69928745a6f0c-1---d8754z-;rport=5061

To: <441698539995>;tag=C70DF8-6DC

From: <>07775882968@gw3.theiptele.com:5061>;tag=80b8070f077b9446

Call-ID: YmM1NDAxNTgwNjJlZmMwZmM3ODZkYzc5MzQ5NDkyNmU.

CSeq: 102 ACK

Content-Length: 0

Reg-Proxy: 0001519669989

Bronze

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

Hi Robert,

Sorry, but you shouldn't start removing things like "permission term" without understanding the consequences. This configuration is a critical part of four toll fraud mechanisms that Cisco CCME routers provide. Three features are implemented by the CCA tool.

1. Voice source groups.

A voice source group is a way of grouping VoIP 'speakers'. By grouping them together we could apply some maniuplation templates to change some features based on where the calls are coming from.

CCA deploys two voice source  groups - one for internal - i.e. the CUE module, and one for external - i.e. the Service Provider.

The thing is, is that if you have a voice source group configured on the box, BUT if you then have a voice session being initiated from somewhere that is not caught by that (or any other) voice source group - then the call is rejected with a 500 Internal Server Error. If properly implemented we can use voice source groups to reject calls that don't come from an IP address we recognise

2. "Permission Term"

So here's the thing. You have a very powerful voice router which is capable of routing phone calls and not just IP packets. When a call arrives on the router, it is processed by an Incoming Dial-peer. There are a few ways of doing this, but with a DDI range on a router, we could have one of a few dial-peers which match the incoming called number. We then use the incoming dial-peer to carry out digit manipulation and onward route the call to the correct place (ephone-dn or CUE).

At the same time we have outbound dial-peers which route outbound calls to places like a Service provider for PSTN termination. The outbound dial-peers might match 901..+ for UK fixed line calls prefixed with a 9.

We need a way of making sure that inbound calls from an unsolicited source couldn't be routed back to the Service Provider for termination. If they could you WILL end up with a very big bill within a few days.

The Permission Term keyword is applied on a special inbound dial-peer that matches ALL incoming calls. There will be a statement on this dial-peer with something like "incoming called number .+" which means match everything.

If this special dial-peer is matched by an incoming call - the permission term keyword caused the call to by blackholed. Again the router will respond back with a 500.

Legitimate incoming calls will work, as there will be better match incoming dial-peers.

3. WAN access list.

Yes there is an Access list which protects the router.

4. voice-service voip - IP adddress trusted list

This isn't implemented by CCA (is sets the router to allow all voice speakers), but recent code IOS routers have a global configuration list that identifes legitamate voice speakers. This works in a similar way as the voice-source groups, but the router will respond back with a 404 if the source isn't allowed.

The reason your router isn't working is because your incoming dial-peers use the number is UK format - i.e.

dial-peer voice 3001 voip

incoming called-number 01698539995

!

but the SP is sending in E.164

INVITE sip:441698539995

Use the CCA tool to amend your incoming DDI's to E.164.

Didn't your SP help you with this ?

Adam

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

Hi adam, thanks for your reply! I'm finding that with each day my knowledge of how these cisco boxes seems to be increasing! At the moment, i have set the DDI's to E.164, this happened after doing a complete factory restore of the UC540. The only things that i have manipulated in the configuration now is removing permission term from the voip dial-peer. Should i reinstate this? I haven't changed any of the ACL lists but i have added the gateway of the SIP provider (gamma in this instance) to the advanced section of the sip config in CCA.

This is really driving me bonkers, as i can still make the calls, just not receive them, and the debugs seem to suggest that the traffic is arriving at the UC540 but it is just not being passed on to an appropriate dialpeer!

Bronze

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

OK,

Please can you re-post your config and debugs as attachments.

Re: UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

thanks adam for having a look at this. i have just changed the registered incoming sip number to e164 and i am now getting a 400 error from the debug!!! which i think is to do with nat? i have attached the running config and debugs here. Let me know what you think?

Cheers

Robert

Bronze

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

Yes This problem is a NAT issue.

The incoming call is being sent by gamma to the "registered contact" which is the record gamma holds for your phone system. Gamma will know this vis the SIP registration process. The device which is Natting is manipulating the SIP headers the Cisco sends in the outbound direction, but is not reversing these changes on the way back in.

Is this a Lab enviroment of a critical live issue ?

You could try to get a public IP address on to the Cisco but be very sure you've all the security settings in place, you could fix the Nat stuff, or we (over at voip.co.uk) fix up these sorts of nat issues in the network, if you want to try something else.

Adam

Re: UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

this is a critical live issue!!! need to resolve it today! never a good thing when ur under pressure!

What i cant understand is that i had everything running perfectly until i upgraded to cca3.1 and the new 8.2pkg. I have tried having the uc540 sitting behind a sr520 router, a cisco877 router and it is currently sitting behind a cheap ass tp-link router, which runs perfectly when i test it with uc320's!!! in fact out the 30 or so uc320 installs i've done, ive never had any problem with SIP. This is the first time i've tried using SIP on the UC540 and all hell breaks loose, its normally been ISDN installs that i have performed.

I think i need to look at how to sort the NAT issue, its got to be something ridiculous but i dont want to turn off the ACL completely as i have discovered already that someone has placed about a dozen calls to Yemen in the middle of the night!!! and it certainly wasn't me!!

Think i'm going to be grey and have no fingernails by the end of this afternoon!!

Any pointers you could give on what to change on NAT would be appreciated.

I take it you guys supply trunks as well, might be interesting to have a look at pricing etc... currently deal with Gamma and HighNet.

Robert

Bronze

UC540 w/ CCA3.1 Pkg 8.2 No Incoming SIP Calls

Hi Robert.

When you upgraded the system it might me that CCA came along and applied some standard configuration templates that over-wrote some of the bespoke settings you had in place before. But fundamentally the IOS code is very stable and mature so it's the templating that you should be fixing within CCA to stop this happening again.

With regards to the NAT issue - which xdsl router did you have in place before? Put it back and you should fix the UC with CCA. Personally I would use the c887, but that's only because I'm a cisco bloke.

Would you like somebody over here to give you a call to help you fix this this ? Send me a PM or call the office.

Adam

3905
Views
0
Helpful
14
Replies
CreatePlease to create content