Cisco Support Community
Community Member

UC560 Issues with SIP 8900/9900 Phones

The UC560 is running the latest version 8.6 uc500-advipservicesk9-mz.151-4.M4b

I cannot get Trnsfr-to-VM to work for these phones. Right now I have a ephone-dn setup as so:

ephone-dn  100

number 6... no-reg primary

call-forward all 500

These phones only have a hard button for Transfer, with no option for a Transfer/Trnsfr-to-VM softkey. When someone calls in and asks to be transferred to an extensions mailbox, the user hits the transfer button, dials 6xxx (e.g. 6320), and hits transfer again. The person who got transferred only hears dead air.

I have tried using both a E.164 number in cue (e.g. set to 6320) and a translation-rule that drops the 6 going to voicemail:

     voice translation-rule 1

      rule 1 /^6\(.*\)/ /\1/

     voice translation-profile VM_Conditioning

      translate redirect-called 1

     dial-peer voice 10 voip


      translation-profile outgoing VM_Conditioning


Any ideas as to why this feature will not work? Or at least a work-around?

I've included debugs for when someone internally dials 6 then the extension and when someone gets transferred to that

Everyone's tags (4)
Hall of Fame Super Gold

Re: UC560 Issues with SIP 8900/9900 Phones

That should work...

It seems like the transaltion is not stripping 6, not sure why


INVITE sip:500@ SIP/2.0


Diversion: <6320>;privacy=off;reason=unconditional;counter=1;screen=no

If you're using three digits, should become sip:320

Community Member

Re: UC560 Issues with SIP 8900/9900 Phones

I tested the translation rule and it does strip the 6. If you look further down the debug you'll start seeing the extension without the 6 in front.

This is also a problem if a user call-forward all to voicemail and someone is transferred to their extension. They get dead air just as they would transferring straight to voicemail

Hall of Fame Super Gold

Re: UC560 Issues with SIP 8900/9900 Phones

Maybe something is wrong with CUE because in no situation calling VM one should get dead air.

Community Member

Re: UC560 Issues with SIP 8900/9900 Phones

Well these phones are not fully supported with 8.6, so that seems to be the underlining issue here.

I just wanted to know if anyone else has run into this issue, and if they figured out a work around.

Hall of Fame Super Gold

Re: UC560 Issues with SIP 8900/9900 Phones

Trying doing the same for another, supported phone.

If still fails, is not phone issue.

Cisco Employee

Re: UC560 Issues with SIP 8900/9900 Phones

Hello Samuel,

If the CUE works, please try the following configuration just put the correct addresses for the CUE under the dialpeer config:

voice translation-rule 50

rule 1 /^6/ //

voice translation-profile XFER_TO_VM_PROFILE

translate redirect-called 50

dial-peer voice 2000 voip

description ** cue voicemail pilot number **

translation-profile outgoing XFER_TO_VM_PROFILE

destination-pattern 500


session protocol sipv2

session target ipv4:x.x.x.x

voice-class sip outbound-proxy ipv4:x.x.x.x 

dtmf-relay rtp-nte

codec g711ulaw

no vad


transfer-pattern 6... blind



*Please rate helpful posts

CreatePlease to create content