Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Unable to make calls

Hi

I have setup a UC540 for SIP voice. Unfortunately i haven't been able to make it work

Can anybody propose me any hints to check for by reviewing the attached debug log output?

Thanks

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Unable to make calls

Well, I looked at the config and the debugs.  I can't say that I have an exact answer as to your problem, but I did notice a few things.  First off, when looking at the config, it seems that you are running an IOS version that is about 5 versions behind.  I can't say that this has anything to do with your current SIP issue, but I would suggest upgrading to avoid other issues down the road.  It also looks like you SIP invites are going out with a codec of G729, which isn't configured on your UC.  You do have a "voice class codec" statement, but it is not applied to your outgoing dial-peer.  I would add "voice-class codec 1" to your outgoing dial-peers.

Other general things: You are using Vlan 2 on this unit, but also have BVI's configured.  I would suggest that you use BVI's across the board to avoid confusion.  You also have "no ip nat service sip tcp port 5060" configured for both tcp and udp.  I will not say I am a SIP expert, but I don't think we want to diable nat for SIP in this case.

Steering Digit:  The 9 is configured by default as the steering digit for outbound dialing, and in your config, it is listed as the digit to give you a secondary dial tone.  You can configure the system to use a different digit if you like, but not using a steering digit is most likely going to cause you problems.  The reason is that outgoing dial-peers are matched on a per-digit basis, with the first match found being used.  So, you would have problems if you tried to dial any number that had its first three digits the same as any of your internal extensions.  Example: If you tried to dial 20514141, and you had an extension 205 in the system, you would never be able to dial the full number.  As soon as you enter the 205, that extension would start ringing.


My suggestion at this point, since you only have a few phones configured.  Upgrade the system, factory default with the latest configuration file and IOS.  Then reconfigure using CCA.  (I see that your config says you are using CCA 3.0.1.  Not sure IOS 12.4 was ever tested with this version of CCA.)


Thank you,
Darren

7 REPLIES
New Member

Re: Unable to make calls

Hi,

The attachments doesn't show any of the sip-ua configuration, for e.g. registrar and sip-server addresses, also the out-bound proxy server.  Did you configure this sip  trunk via CCA or CLI?  Debug doesn't show any register messages.  What's your main number?

Regards,

Marvin

New Member

Re: Unable to make calls

The ISP provided me with 2 media gateways. One for voip and one for adsl internet and gave me the below configuration

Internet Broadband Service
IP Address 40.x.x.1
Subnet 255.255.255.248
Gateway 40.x.x.6
Dns:x.x.x.x

Access to VOIP Gateway
IP Address: 172.21.17.97
Subnet : 255.255.255.252
Def.Gateway: 172.21.17.98
Sip Server:217.27.60.204

I have connected the ADSL gateway on the WAN port of UC540 and the VOIP Gateway on the Fastethernet 0/1/0 and switchport access it with new vlan configured with the VOIP gateway IP Address. I don't know if done correct that i connected the VOIP gateway like this.

My main number is 25020850 and i have configured internal extensions from 850 to 859.

You can see a partial running config attached.

Thank you in advance

New Member

Re: Unable to make calls

Hi There,

I am not entirely sure why you are using the VoIP gateway supplied by the ITSP, the UC500 is more than capable of managing this and would be a lot less complex than trying to get the UC to talk to a secondary gateway.

Please ask your ITSP if you can have all the authenticating credentials and you can then use CCA to program the SIP trunk up directly on the phone system.

If this cannot be done, then more information on the gateway would be required to understand if it is even possible to make sure it is compatible and can work.

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
New Member

Re: Unable to make calls

Ok first of all there was a problem from the ITSP SIP site and now its fixed.

I am still having the same problem though but i get different errors on the debug output now.

Also for some reason my phone gets a dial tone when i press 9 but i havent configured the 9 code for outgoing calls. I want to place calls directly without the 9 prefix. How do i remove the 9 dial code??

My main number is 25020850

Thanksl

New Member

Re: Unable to make calls

Well, I looked at the config and the debugs.  I can't say that I have an exact answer as to your problem, but I did notice a few things.  First off, when looking at the config, it seems that you are running an IOS version that is about 5 versions behind.  I can't say that this has anything to do with your current SIP issue, but I would suggest upgrading to avoid other issues down the road.  It also looks like you SIP invites are going out with a codec of G729, which isn't configured on your UC.  You do have a "voice class codec" statement, but it is not applied to your outgoing dial-peer.  I would add "voice-class codec 1" to your outgoing dial-peers.

Other general things: You are using Vlan 2 on this unit, but also have BVI's configured.  I would suggest that you use BVI's across the board to avoid confusion.  You also have "no ip nat service sip tcp port 5060" configured for both tcp and udp.  I will not say I am a SIP expert, but I don't think we want to diable nat for SIP in this case.

Steering Digit:  The 9 is configured by default as the steering digit for outbound dialing, and in your config, it is listed as the digit to give you a secondary dial tone.  You can configure the system to use a different digit if you like, but not using a steering digit is most likely going to cause you problems.  The reason is that outgoing dial-peers are matched on a per-digit basis, with the first match found being used.  So, you would have problems if you tried to dial any number that had its first three digits the same as any of your internal extensions.  Example: If you tried to dial 20514141, and you had an extension 205 in the system, you would never be able to dial the full number.  As soon as you enter the 205, that extension would start ringing.


My suggestion at this point, since you only have a few phones configured.  Upgrade the system, factory default with the latest configuration file and IOS.  Then reconfigure using CCA.  (I see that your config says you are using CCA 3.0.1.  Not sure IOS 12.4 was ever tested with this version of CCA.)


Thank you,
Darren

New Member

Re: Unable to make calls

Well we brought in a VOIP expert to fix our problem.

He removed ip outside nat from vlan2 and created a new simple translation-rule 12345678 678 and a new dial peer for incoming calls 1234567. and everything worked like a charm

However i must say a very big thanks for your help and suggestions

New Member

Re: Unable to make calls

I am glad everything is now working for you...  I would still recommend that you upgrade at some point.  At least now, you can do this when you have some time available...

UC500 IOS versions available:

IOS                    Software Pack

12.4(24)SB               7.1.3                    <-- I beleive you are using this version.

15.0.(1)XA                8.0.0

15.0.(1)XA1a             8.0.1

15.0.(1)XA2a             8.0.2

15.0.(1)XA3a             8.0.4 - 8.0.5

15.1.(2)T2                 8.1.0

Thank you,

Darren

609
Views
0
Helpful
7
Replies
CreatePlease to create content