Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

URGENT!! NEED HELP CONFIGURING AN AUTO ATTENDANT SCRIPT USING ONLY THE CURRENT UC520 CONFIG!

I am tasked with creating a basic auto attendant script for a client who's office has

only 10 users. They have a UC520 and recently their auto attendant script has

become corrupt. It now long prompts to enter extension, it simply dials the main

number and the call is able to be answered. The client is only using Cisco Configuration

Assistant 3.1 to configure the VoIP environment. How do I configure an auto attendant

script in IOS or in Cisco Configuration Assistant 3.1? I don't have access to the

network remotely so I only have this config to build a default script from. How do

I do this?

Please help.

Current configuration : 34406 bytes

!

! Last configuration change at 22:23:17 PST Wed Aug 24 2011 by 1N$P1r8T10N8L

!

version 12.4

parser config cache interface

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service internal

service compress-config

!

hostname UC520

!

boot-start-marker

boot system flash uc500-advipservicesk9-mz.124-20.T2

boot-end-marker

!

logging message-counter syslog

!

aaa new-model

UC520#

Aug 25 02:37:26.143: %IPPHONE-6-REG_ALARM: 25: Name=SEP0021A0D97AB2 Load= SCCP41.8-2-2SR2S

Last=Initialized

Aug 25 02:37:26.191: %IPPHONE-6-REGISTER: ephone-5:SEP0021A0D97AB2 IP:10.1.1.16 Socket:10

DeviceType:Phone has registered.

UC520#sh run

Building configuration...

Current configuration : 34406 bytes

!

! Last configuration change at 22:23:17 PST Wed Aug 24 2011 by 1N$P1r8T10N8L

!

version 12.4

parser config cache interface

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service internal

service compress-config

!

hostname UC520

!

boot-start-marker

boot system flash uc500-advipservicesk9-mz.124-20.T2

boot-end-marker

!

logging message-counter syslog

!

aaa new-model

!        

!

aaa authentication login default local

aaa authentication login Foxtrot_sdm_easyvpn_xauth_ml_1 local

aaa authorization exec default local

aaa authorization network Foxtrot_sdm_easyvpn_group_ml_1 local

!

!

aaa session-id common

clock timezone EST -5

clock summer-time PST recurring

!

crypto pki trustpoint TP-self-signed-2249520590

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2249520590

revocation-check none

rsakeypair TP-self-signed-2249520590

!

!

crypto pki certificate chain TP-self-signed-2249520590

certificate self-signed 01

  3082023D 308201A6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32323439 35323035 3930301E 170D3131 30383235 30323231

  31385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 32343935

  32303539 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100BD58 739EB721 FE990F4F AAE48BF3 524871B7 0F5913DF 9DB9C9B4 88B25A7A

  0F34C82E 6833D25C 80AF1E5A F79D258E 1759DEA4 CDE1319B 9744084E 271F4EB8

  415DC939 039DA57E 17E0E819 D2C01AC7 28135979 FBA67EFD 702664C2 6AABB894

  7A096B34 8D7C7897 15797292 50C4DA2A E2FB112F 85F57671 E08D3940 713FFC19

  60910203 010001A3 65306330 0F060355 1D130101 FF040530 030101FF 30100603

  551D1104 09300782 05554335 3230301F 0603551D 23041830 16801406 D58FF329

  436E8BD8 E1A73800 062B115A 99AC0F30 1D060355 1D0E0416 041406D5 8FF32943

  6E8BD8E1 A7380006 2B115A99 AC0F300D 06092A86 4886F70D 01010405 00038181

  009363CC 0B0F53AE E8FB2786 06E63879 680534A3 AEDEE63A C9E693F1 7B29627F

  2E9D4027 D3D7FA11 810AC2AD 2F5E4B98 EE5D9AA4 CA58C64B 3CCFBF94 02EAC365

  CA01FEA3 6B339220 06D1D3AA 52D9EAB3 341E0EBC E3A5F0C4 873610E2 3A563529

  406C2D9A F0DD277D 6B92E806 8BDC72E2 58440160 6A1CB3A0 345003D8 5A319069 F3

        quit

dot11 syslog

!

dot11 ssid uc520-data

   vlan 1

   authentication open

!

dot11 ssid uc520-voice

   vlan 100

   authentication open

!

ip source-route

ip cef

!

!

ip dhcp relay information trust-all

ip dhcp excluded-address 10.1.1.1 10.1.1.10

ip dhcp excluded-address 192.168.10.1 192.168.10.10

!

ip dhcp pool phone

   network 10.1.1.0 255.255.255.0

   default-router 10.1.1.1

   option 150 ip 10.1.1.1

!

ip dhcp pool data

   import all

   network 192.168.10.0 255.255.255.0

   default-router 192.168.10.1

   dns-server 4.2.2.2 63.203.35.55

!

!        

ip name-server 68.87.73.242

ip name-server 68.87.71.226

ip inspect log drop-pkt

ip inspect name SDM_LOW cuseeme

ip inspect name SDM_LOW dns

ip inspect name SDM_LOW ftp

ip inspect name SDM_LOW h323

ip inspect name SDM_LOW https

ip inspect name SDM_LOW icmp

ip inspect name SDM_LOW imap

ip inspect name SDM_LOW pop3

ip inspect name SDM_LOW netshow

ip inspect name SDM_LOW rcmd

ip inspect name SDM_LOW realaudio

ip inspect name SDM_LOW rtsp

ip inspect name SDM_LOW esmtp

ip inspect name SDM_LOW sqlnet

ip inspect name SDM_LOW streamworks

ip inspect name SDM_LOW tftp

ip inspect name SDM_LOW tcp

ip inspect name SDM_LOW udp

ip inspect name SDM_LOW vdolive

!        

no ipv6 cef

!

stcapp ccm-group 1

!

stcapp feature access-code

!

multilink bundle-name authenticated

!

!

trunk group  ALL_FXO

!

!

voice call send-alert

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

sip

  no update-callerid

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

!

!

!

!

!

!

!

!

voice register global

max-dn 88

max-pool 22

!

!

voice translation-rule 1111

!        

voice translation-rule 1112

rule 1 /^9/ //

!

voice translation-rule 2222

!

!

voice translation-profile CALLER_ID_TRANSLATION_PROFILE

translate calling 1111

!

voice translation-profile CallBlocking

translate called 2222

!

voice translation-profile OUTGOING_TRANSLATION_PROFILE

translate calling 1111

translate called 1112

!

!

voice-card 0

no dspfarm

!

!

!

!

!

crypto isakmp policy 1

encr 3des

authentication pre-share

group 2

!

crypto isakmp client configuration group EZVPN_GROUP_1

key 86753092009!

dns 68.87.73.242 68.87.71.226

pool SDM_POOL_1

acl 105

max-users 10

crypto isakmp profile sdm-ike-profile-1

   match identity group EZVPN_GROUP_1

   client authentication list Foxtrot_sdm_easyvpn_xauth_ml_1

   isakmp authorization list Foxtrot_sdm_easyvpn_group_ml_1

   client configuration address respond

   virtual-template 1

!

!

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

!

crypto ipsec profile SDM_Profile1

set transform-set ESP-3DES-SHA

set isakmp-profile sdm-ike-profile-1

!

!

archive

log config

  logging enable

  logging size 600

  hidekeys

!

process-max-time 50

!

ip tftp source-interface Loopback0

!

class-map match-any sdm_p2p_kazaa

match protocol fasttrack

match protocol kazaa2

class-map match-any sdm_p2p_edonkey

match protocol edonkey

class-map match-any sdm_p2p_gnutella

match protocol gnutella

class-map match-any sdm_p2p_bittorrent

match protocol bittorrent

!

bridge irb

!

!

!

interface Loopback0

description $FW_INSIDE$

ip address 10.1.10.2 255.255.255.252

ip access-group 103 in

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/0

description $FW_OUTSIDE$

ip address 173.15.202.245 255.255.255.252

ip access-group 104 in

ip verify unicast reverse-path

ip nat outside

ip inspect SDM_LOW out

ip virtual-reassembly

duplex auto

speed auto

snmp trap ip verify drop-rate

!

interface Integrated-Service-Engine0/0

description cue is initialized with default IMAP group

ip unnumbered Loopback0

ip nat inside

ip virtual-reassembly

service-module ip address 10.1.10.1 255.255.255.252

service-module ip default-gateway 10.1.10.2

!

interface FastEthernet0/1/0

switchport voice vlan 100

macro description cisco-phone | cisco-phone

spanning-tree portfast

!

interface FastEthernet0/1/1

switchport voice vlan 100

macro description cisco-phone | cisco-phone

spanning-tree portfast

!

interface FastEthernet0/1/2

switchport voice vlan 100

macro description cisco-phone | cisco-phone

spanning-tree portfast

!

interface FastEthernet0/1/3

switchport voice vlan 100

macro description cisco-phone | cisco-phone

spanning-tree portfast

!

interface FastEthernet0/1/4

switchport voice vlan 100

macro description cisco-phone | cisco-phone

spanning-tree portfast

!

interface FastEthernet0/1/5

switchport voice vlan 100

macro description cisco-phone

spanning-tree portfast

!

interface FastEthernet0/1/6

switchport voice vlan 100

macro description cisco-phone

spanning-tree portfast

!

interface FastEthernet0/1/7

switchport voice vlan 100

macro description cisco-phone | cisco-phone

spanning-tree portfast

!

interface FastEthernet0/1/8

switchport mode trunk

macro description cisco-switch | cisco-switch

!

interface Dot11Radio0/5/0

no ip address

shutdown

!

ssid uc520-data

!

ssid uc520-voice

!       

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio0/5/0.1

encapsulation dot1Q 1 native

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio0/5/0.100

encapsulation dot1Q 100

bridge-group 100

bridge-group 100 subscriber-loop-control

bridge-group 100 spanning-disabled

bridge-group 100 block-unknown-source

no bridge-group 100 source-learning

no bridge-group 100 unicast-flooding

!

interface Virtual-Template1 type tunnel

ip unnumbered BVI1

ip nat inside

ip virtual-reassembly

tunnel mode ipsec ipv4

tunnel protection ipsec profile SDM_Profile1

!

interface Vlan1

no ip address

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Vlan100

no ip address

bridge-group 100

bridge-group 100 spanning-disabled

!

interface BVI1

description $FW_INSIDE$

ip address 192.168.10.1 255.255.255.0

ip access-group 101 in

ip nat inside

ip virtual-reassembly

!        

interface BVI100

description $FW_INSIDE$

ip address 10.1.1.1 255.255.255.0

ip access-group 102 in

ip nat inside

ip virtual-reassembly

!

ip local pool SDM_POOL_1 192.168.50.10 192.168.50.50

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 173.15.202.246

ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0

!

ip http server

ip http authentication local

ip http secure-server

ip http path flash:

ip nat inside source list 1 interface FastEthernet0/0 overload

!

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 192.168.10.0 0.0.0.255

access-list 1 permit 10.1.1.0 0.0.0.255

access-list 1 permit 10.1.10.0 0.0.0.3

access-list 100 remark auto generated by SDM firewall configuration

access-list 100 remark SDM_ACL Category=1

access-list 100 deny   ip 192.168.10.0 0.0.0.255 any

access-list 100 deny   ip host 255.255.255.255 any

access-list 100 deny   ip 127.0.0.0 0.255.255.255 any

access-list 100 permit ip any any

access-list 101 remark auto generated by SDM firewall configuration##NO_ACES_6##

access-list 101 remark SDM_ACL Category=1

access-list 101 permit udp any host 192.168.10.1 eq non500-isakmp

access-list 101 permit udp any host 192.168.10.1 eq isakmp

access-list 101 permit esp any host 192.168.10.1

access-list 101 permit ahp any host 192.168.10.1

access-list 101 deny   ip 10.1.10.0 0.0.0.3 any

access-list 101 deny   ip 10.1.1.0 0.0.0.255 any

access-list 101 deny   ip 173.15.202.244 0.0.0.3 any

access-list 101 deny   ip host 255.255.255.255 any

access-list 101 deny   ip 127.0.0.0 0.255.255.255 any

access-list 101 permit ip any any

access-list 102 remark auto generated by SDM firewall configuration##NO_ACES_8##

access-list 102 remark SDM_ACL Category=1

access-list 102 permit udp any host 10.1.1.1 eq non500-isakmp

access-list 102 permit udp any host 10.1.1.1 eq isakmp

access-list 102 permit esp any host 10.1.1.1

access-list 102 permit ahp any host 10.1.1.1

access-list 102 permit tcp 10.1.10.0 0.0.0.3 any eq 2000

access-list 102 permit udp 10.1.10.0 0.0.0.3 any eq 2000

access-list 102 deny   ip 10.1.10.0 0.0.0.3 any

access-list 102 deny   ip 192.168.10.0 0.0.0.255 any

access-list 102 deny   ip 173.15.202.244 0.0.0.3 any

access-list 102 deny   ip host 255.255.255.255 any

access-list 102 deny   ip 127.0.0.0 0.255.255.255 any

access-list 102 permit ip any any

access-list 103 deny   ip host 255.255.255.255 any

access-list 103 deny   ip 127.0.0.0 0.255.255.255 any

access-list 103 permit ip any any

access-list 103 remark auto generated by SDM firewall configuration##NO_ACES_8##

access-list 103 remark SDM_ACL Category=1

access-list 103 permit udp any host 10.1.10.2 eq non500-isakmp

access-list 103 permit udp any host 10.1.10.2 eq isakmp

access-list 103 permit esp any host 10.1.10.2

access-list 103 permit ahp any host 10.1.10.2

access-list 103 permit tcp 10.1.1.0 0.0.0.255 eq 2000 any

access-list 103 permit udp 10.1.1.0 0.0.0.255 eq 2000 any

access-list 103 deny   ip 10.1.1.0 0.0.0.255 any

access-list 103 deny   ip 192.168.10.0 0.0.0.255 any

access-list 103 deny   ip 173.15.202.244 0.0.0.3 any

access-list 104 remark auto generated by SDM firewall configuration##NO_ACES_15##

access-list 104 remark SDM_ACL Category=1

access-list 104 permit udp any host 173.15.202.245 eq non500-isakmp

access-list 104 permit udp any host 173.15.202.245 eq isakmp

access-list 104 permit esp any host 173.15.202.245

access-list 104 permit ahp any host 173.15.202.245

access-list 104 deny   ip 10.1.10.0 0.0.0.3 any

access-list 104 deny   ip 10.1.1.0 0.0.0.255 any

access-list 104 deny   ip 192.168.10.0 0.0.0.255 any

access-list 104 deny   ip host 0.0.0.0 any

access-list 104 deny   ip any any log

access-list 104 permit udp host 68.87.73.242 eq domain any

access-list 104 permit udp host 68.87.71.226 eq domain any

access-list 104 permit icmp any host 173.15.202.245 echo-reply

access-list 104 permit icmp any host 173.15.202.245 time-exceeded

access-list 104 permit icmp any host 173.15.202.245 unreachable

access-list 104 deny   ip 10.0.0.0 0.255.255.255 any

access-list 104 deny   ip 172.16.0.0 0.15.255.255 any

access-list 104 deny   ip 192.168.0.0 0.0.255.255 any

access-list 104 deny   ip 127.0.0.0 0.255.255.255 any

access-list 104 deny   ip host 255.255.255.255 any

access-list 105 remark SDM_ACL Category=4

access-list 105 permit ip 192.168.10.0 0.0.0.255 any

access-list 105 permit ip 10.1.1.0 0.0.0.255 any

access-list 105 permit ip 10.1.10.0 0.0.0.255 any

snmp-server community public RO

!

!

!

!

!

tftp-server apps11.8-2-2TR2.sbn

tftp-server dsp70.8-2-2TR2.sbn

tftp-server jar11sccp.8-2-2TR2.sbn

tftp-server jar31sccp.8-2-2TR2.sbn

tftp-server flash:cnu42.8-3-1-22.sbn

tftp-server flash:cnu45.8-3-1-22.sbn

tftp-server flash:cnu75.8-3-1-22.sbn

tftp-server flash:cvm42sccp.8-3-1-22.sbn

tftp-server flash:cvm45sccp.8-3-1-22.sbn

tftp-server flash:WLAN-1.0.4.SBN

tftp-server flash:cp524g-08-01-07.bin

tftp-server DistinctiveRingList.xml

tftp-server RingList.xml

tftp-server flash:AreYouThereF.raw

tftp-server flash:Bass.raw

tftp-server flash:CallBack.raw

tftp-server flash:Chime.raw

tftp-server flash:Analog1.raw

tftp-server flash:Analog2.raw

tftp-server flash:AreYouThere.raw

tftp-server flash:CampusNight.png

tftp-server flash:CiscoFountain.png

tftp-server flash:Fountain.png

tftp-server flash:MorroRock.png

tftp-server flash:NantucketFlowers.png

tftp-server flash:TN-CampusNight.png

tftp-server apps31.8-2-2TR2.sbn

tftp-server apps41.8-2-2TR2.sbn

tftp-server apps70.8-2-2TR2.sbn

tftp-server cmterm_7936.3-3-13-0.bin

tftp-server cnu11.8-2-2TR2.sbn

tftp-server cnu31.8-2-2TR2.sbn

tftp-server cnu41.8-2-2TR2.sbn

tftp-server cnu70.8-2-2TR2.sbn

tftp-server CP7902080002SCCP060817A.sbin

tftp-server cvm11sccp.8-2-2TR2.sbn

tftp-server cvm31sccp.8-2-2TR2.sbn

tftp-server cvm41sccp.8-2-2TR2.sbn

tftp-server cvm70sccp.8-2-2TR2.sbn

tftp-server dsp11.8-2-2TR2.sbn

tftp-server dsp31.8-2-2TR2.sbn

tftp-server dsp41.8-2-2TR2.sbn

tftp-server jar41sccp.8-2-2TR2.sbn

tftp-server jar70sccp.8-2-2TR2.sbn

tftp-server P00308000500.bin

tftp-server P00308000500.loads

tftp-server P00308000500.sb2

tftp-server P00308000500.sbn

tftp-server S00105000200.sbn

tftp-server SCCP11.8-2-2SR2S.loads

tftp-server SCCP31.8-2-2SR2S.loads

tftp-server SCCP41.8-2-2SR2S.loads

tftp-server SCCP70.8-2-2SR2S.loads

tftp-server term06.default.loads

tftp-server term11.default.loads

tftp-server term31.default.loads

tftp-server term41.default.loads

tftp-server term61.default.loads

tftp-server term70.default.loads

tftp-server term71.default.loads

tftp-server flash:SCCP42.8-3-2S.loads

tftp-server flash:SCCP45.8-3-2S.loads

tftp-server flash:SCCP75.8-3-2S.loads

tftp-server flash:apps42.8-3-1-22.sbn

tftp-server flash:apps45.8-3-1-22.sbn

tftp-server flash:apps75.8-3-1-22.sbn

tftp-server flash:cvm75sccp.8-3-1-22.sbn

tftp-server flash:dsp42.8-3-1-22.sbn

tftp-server flash:dsp45.8-3-1-22.sbn

tftp-server flash:dsp75.8-3-1-22.sbn

tftp-server flash:jar42sccp.8-3-1-22.sbn

tftp-server flash:jar45sccp.8-3-1-22.sbn

tftp-server flash:jar75sccp.8-3-1-22.sbn

tftp-server flash:term42.default.loads

tftp-server flash:term45.default.loads

tftp-server flash:term62.default.loads

tftp-server flash:term65.default.loads

tftp-server flash:term75.default.loads

tftp-server flash:APPS-1.0.4.SBN

tftp-server flash:CP7921G-1.0.4.LOADS

tftp-server flash:GUI-1.0.4.SBN

tftp-server flash:SYS-1.0.4.SBN

tftp-server flash:TNUX-1.0.4.SBN

tftp-server flash:TNUXR-1.0.4.SBN

tftp-server flash:Classic1.raw

tftp-server flash:Classic2.raw

tftp-server flash:ClockShop.raw

tftp-server flash:Drums1.raw

tftp-server flash:Drums2.raw

tftp-server flash:FilmScore.raw

tftp-server flash:HarpSynth.raw

tftp-server flash:Jamaica.raw

tftp-server flash:KotoEffect.raw

tftp-server flash:MusicBox.raw

tftp-server flash:Piano1.raw

tftp-server flash:Piano2.raw

tftp-server flash:Pop.raw

tftp-server flash:Pulse1.raw

tftp-server flash:Ring1.raw

tftp-server flash:Ring2.raw

tftp-server flash:Ring3.raw

tftp-server flash:Ring4.raw

tftp-server flash:Ring5.raw

tftp-server flash:Ring6.raw

tftp-server flash:Ring7.raw

tftp-server flash:Sax1.raw

tftp-server flash:Sax2.raw

tftp-server flash:Vibe.raw

tftp-server flash:ash:Morropng

tftp-server flash:Nantucck.png

tftp-server flash:TN-Nantucket20x212x16/List.xml

tftp-server flash:ash:Desktops/320x216x16/List.xml

tftp-server flash:cp524g-08-01-13.bin

!

control-plane

!

bridge 1 route ip

bridge 100 route ip

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/0/2

timeouts ringing infinity

!

voice-port 0/0/3

timeouts ringing infinity

!        

voice-port 0/1/0

trunk-group ALL_FXO

connection plar opx 400

description Configured by CCA Auto Attendant

caller-id enable

!

voice-port 0/1/1

trunk-group ALL_FXO

connection plar opx 400

description Configured by CCA Auto Attendant

caller-id enable

!

voice-port 0/1/2

trunk-group ALL_FXO

connection plar opx 400

description Configured by CCA Auto Attendant

caller-id enable

!

voice-port 0/1/3

trunk-group ALL_FXO

!

voice-port 0/4/0

auto-cut-through

signal immediate

input gain auto-control -15

description Music On Hold Port

!

sccp local Loopback0

sccp ccm 10.1.1.1 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

!

dial-peer cor custom

name internal

name local

name domestic

name international

name local-plus

name national

name national-plus

name emergency

name toll-free

!

!        

dial-peer cor list call-internal

member internal

!

dial-peer cor list call-local

member local

!

dial-peer cor list call-domestic

member domestic

!

dial-peer cor list call-international

member international

!

dial-peer cor list user-internal

member internal

member emergency

!

dial-peer cor list user-local

member internal

member local

member emergency

member toll-free

!

dial-peer cor list user-domestic

member internal

member local

member domestic

member local-plus

member national

member emergency

member toll-free

!

dial-peer cor list user-international

member internal

member local

member domestic

member international

member local-plus

member national

member national-plus

member emergency

member toll-free

!

dial-peer cor list call-local-plus

member local-plus

!

dial-peer cor list call-national

member national

!

dial-peer cor list call-national-plus

member national-plus

!

dial-peer cor list call-emergency

member emergency

!

dial-peer cor list call-toll-free

member toll-free

!

dial-peer cor list user-local-plus

member internal

member local

member local-plus

member emergency

member toll-free

!

dial-peer cor list user-national

member internal

member local

member domestic

member local-plus

member national

member emergency

member toll-free

!

dial-peer cor list user-national-plus

member internal

member local

member domestic

member local-plus

member national

member national-plus

member emergency

member toll-free

!

!

dial-peer voice 1 pots

service stcapp

port 0/0/0

!

dial-peer voice 2 pots

service stcapp

port 0/0/1

!        

dial-peer voice 3 pots

service stcapp

port 0/0/2

!

dial-peer voice 50 pots

description ** incoming dial peer **

incoming called-number .%

port 0/1/0

!

dial-peer voice 51 pots

description ** incoming dial peer **

incoming called-number .%

port 0/1/1

!

dial-peer voice 55 pots

corlist outgoing call-domestic

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 91[2-9]..[2-9]......

port 0/1/0

prefix 1

no sip-register

!

dial-peer voice 56 pots

corlist outgoing call-international

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9011T

port 0/1/0

forward-digits 7

prefix 011

no sip-register

!

dial-peer voice 59 pots

corlist outgoing call-domestic

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 91[2-9]..[2-9]......

port 0/1/1

prefix 1

no sip-register

!

dial-peer voice 60 pots

corlist outgoing call-international

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9011T

port 0/1/1

prefix 011

no sip-register

!

dial-peer voice 62 pots

corlist outgoing call-local

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9[2-9]......

port 0/1/2

forward-digits 7

no sip-register

!

dial-peer voice 63 pots

corlist outgoing call-domestic

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 91[2-9]..[2-9]......

port 0/1/2

forward-digits 3

prefix 1

no sip-register

!

dial-peer voice 66 pots

corlist outgoing call-local

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9[2-9]......

port 0/1/3

forward-digits 7

prefix 011

no sip-register

!

dial-peer voice 69 pots

corlist outgoing call-local

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9[2-9]11

port 0/1/3

forward-digits 3

no sip-register

!

dial-peer voice 4 pots

service stcapp

port 0/0/3

!

dial-peer voice 5 pots

description ** MOH Port **

destination-pattern ABC

port 0/4/0

no sip-register

!

dial-peer voice 2000 voip

description ** cue voicemail pilot number **

destination-pattern 401

b2bua

session protocol sipv2

session target ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 2001 voip

description ** cue auto attendant number **

translation-profile outgoing PSTN_CallForwarding

destination-pattern 400

b2bua

session protocol sipv2

session target ipv4:10.1.10.1

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 52 pots

description ** incoming dial peer **

incoming called-number .%

port 0/1/2

!

dial-peer voice 53 pots

description ** incoming dial peer **

incoming called-number .%

port 0/1/3

!        

dial-peer voice 54 pots

corlist outgoing call-local

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9[2-9]......

port 0/1/0

forward-digits 7

no sip-register

!

dial-peer voice 57 pots

corlist outgoing call-local

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9[2-9]11

port 0/1/0

forward-digits 3

no sip-register

!

dial-peer voice 58 pots

corlist outgoing call-local

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9[2-9]......

port 0/1/1

forward-digits 7

no sip-register

!

dial-peer voice 61 pots

corlist outgoing call-local

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9[2-9]11

port 0/1/1

forward-digits 3

no sip-register

!

dial-peer voice 64 pots

corlist outgoing call-international

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9011T

port 0/1/2

prefix 011

no sip-register

!

dial-peer voice 65 pots

corlist outgoing call-local

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9[2-9]11

port 0/1/2

forward-digits 3

no sip-register

!

dial-peer voice 67 pots

corlist outgoing call-domestic

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 91[2-9]..[2-9]......

port 0/1/3

prefix 1

no sip-register

!

dial-peer voice 68 pots

corlist outgoing call-international

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9011T

port 0/1/3

prefix 011

no sip-register

!

!

no dial-peer outbound status-check pots

!

!

telephony-service

video

max-ephones 22

max-dn 88

ip source-address 10.1.1.1 port 2000

auto assign 1 to 1 type bri

calling-number initiator

service phone videoCapability 1

service dnis overlay

service dnis dir-lookup

timeouts interdigit 5

system message IYS

url services http://10.1.10.1/voiceview/common/login.do

url authentication http://10.1.10.1/voiceview/authentication/authenticate.do 

time-zone 12

voicemail 401

max-conferences 8 gain -6

call-forward pattern .T

call-forward system redirecting-expanded

moh music-on-hold.au

multicast moh 239.10.16.16 port 2000

web admin system name cisco secret 5 $1$.vjf$Z7NkttuoPiF7927xuB.661

dn-webedit

time-webedit

transfer-system full-consult dss

transfer-pattern 9.T

transfer-pattern .T

secondary-dialtone 9

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!        

ephone-template  15

softkeys remote-in-use  Newcall

softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login

softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback

softkeys connected  Hold Endcall Trnsfer Confrn Acct Park

button-layout 7931 2

!

!

ephone-template  16

softkeys remote-in-use  Newcall

softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login

softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback

softkeys connected  Hold Endcall Trnsfer Confrn Acct Park

!

!

ephone-template  17

softkeys remote-in-use  CBarge Newcall

softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login

softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback

softkeys connected  Hold Endcall Trnsfer Confrn Acct Park

!

!

ephone-template  18

softkeys remote-in-use  CBarge Newcall

softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login

softkeys seized  Cfwdall Endcall Redial Pickup Gpickup Callback

softkeys connected  Hold Endcall Trnsfer Confrn Acct Park

button-layout 7931 2

!

!

ephone-dn  1

number 101 no-reg primary

name IP-Paging1

paging ip 239.1.1.1 port 2000

!

!

ephone-dn  5  dual-line

number 301 no-reg primary

label 301

description PhoneA Analog

name PhoneA Analog

call-forward busy 401

call-forward noan 401 timeout 10

!

!

ephone-dn  6  dual-line

number 302 no-reg primary

label 302

description PhoneB Analog

name PhoneB Analog

call-forward busy 401

call-forward noan 401 timeout 10

!

!

ephone-dn  7  dual-line

number 303 no-reg primary

label 303

description PhoneC Analog

name PhoneC Analog

call-forward busy 401

call-forward noan 401 timeout 10

!

!

ephone-dn  8  dual-line

number 304 no-reg primary

label 304

description PhoneD Analog

name PhoneD Analog

call-forward busy 401

call-forward noan 401 timeout 10

!

!

ephone-dn  9

number BCD no-reg primary

description MoH

moh out-call ABC

!

!

ephone-dn  10  dual-line

number 201 no-reg primary

label 201

description Receptionist Desk

name Receptionist Desk

call-forward all 202

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  11  dual-line

number 202 no-reg primary

label 202

description Sabrina Davis

name Sabrina Davis

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  12  dual-line

number 203 no-reg primary

label 203

description Margaret Duke

name Marlene Jackson

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  13  dual-line

number 204 no-reg primary

label 204

description Doris Street

name Linda Durham

call-forward all 202

call-forward busy 401

call-forward noan 401 timeout 20

!        

!

ephone-dn  14  dual-line

number 205 no-reg primary

label 205

description Greg Brown

name Greg Brown

call-forward busy 401

call-forward noan 401 timeout 25

!

!

ephone-dn  15  dual-line

number 206 no-reg primary

label 206

description Spare Phone

name Spare Phone

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  16  dual-line

number 207 no-reg primary

label 207

description Marlene Jackson

name Spare Spare

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  17  dual-line

number 208 no-reg primary

label 208

description Spare Phone

name Spare Phone

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  18  dual-line

number 209 no-reg primary

label 209

description James Hunter

name James Hunter

call-forward busy 401

call-forward noan 401 timeout 20

!

!        

ephone-dn  19  dual-line

number 210 no-reg primary

label 210

description Jefferson Porter

name Spare Spare

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  20  dual-line

number 211 no-reg primary

label 211

description Carol Brown

name Carol Brown

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  21  dual-line

number 212 no-reg primary

label 212

description Spare Phone

name Spare Phone

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  22  dual-line

number 213 no-reg primary

label 213

description Meeting Room

name Meeting Room

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  23  dual-line

number 214 no-reg primary

label 214

description Conference Room

name Conference Room

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  24  dual-line

number 299 no-reg primary

label 299

description Strategic Solutions

name Strategic Solutions

call-forward busy 401

call-forward noan 401 timeout 10

!

!

ephone-dn  25  dual-line

number 216 no-reg primary

label 216

description Spare Phone

name Spare Phone

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  26  dual-line

number 217 no-reg primary

label 217

description Spare Phone

name Spare Phone

call-forward busy 401

call-forward noan 401 timeout 20

!

!

ephone-dn  27  dual-line

number 218 no-reg primary

label 218

description 218

name 218

!

!

ephone-dn  28

number 500

label GDM

description GDM

name GDM

hold-alert 30 originator

!

!

ephone-dn  87

number A801... no-reg primary

mwi off

!

!        

ephone-dn  88

number A800... no-reg primary

mwi on

!

!

ephone  1

device-security-mode none

mac-address 333C.946A.0000

max-calls-per-button 2

username "aa"

type anl

button  1:5

!

!

!

ephone  2

device-security-mode none

mac-address 333C.946A.0001

max-calls-per-button 2

username "ab"

type anl

button  1:6

!        

!

!

ephone  3

device-security-mode none

mac-address 333C.946A.0002

max-calls-per-button 2

username "ac"

type anl

button  1:7

!

!

!

ephone  4

device-security-mode none

mac-address 333C.946A.0003

max-calls-per-button 2

username "ad"

type anl

button  1:8

!

!

!

ephone  5

device-security-mode none

video

mac-address 0021.A0D9.7AB2

username "recept" password 12345

paging-dn 1

type 7961GE

button  1:10

!

!

!

ephone  6

device-security-mode none

video

mac-address 0024.14B4.29C3

username "sdavis" password 12345

fastdial 1 98142647 name Sabrina Davis

paging-dn 1

type 7970

button  1:11

!

!

!

ephone  7

device-security-mode none

video

mac-address 0024.14B4.2A5B

ephone-template 16

username "mduke" password trouble

type 7970

button  1:12

!

!

!

ephone  8

device-security-mode none

video

mac-address 0024.14B4.2AB1

ephone-template 16

username "nhubbard" password nadine

paging-dn 1

type 7970

button  1:13 2m28

!

!

!

ephone  9

device-security-mode none

video

mac-address 0024.14B4.2B02

username "gbrown" password 12345

paging-dn 1

type 7970

button  1:14

!

!

!

ephone  10

device-security-mode none

video

mac-address 0021.1BFC.88BF

ephone-template 16

max-calls-per-button 2

username "Spare5" password 12345

type 524G

button  1:15

!

!

!

ephone  11

device-security-mode none

video

mac-address 0021.1BFC.88BB

ephone-template 16

max-calls-per-button 2

username "mjackson" password Spare

type 524G

button  1:16

!

!

!

ephone  12

device-security-mode none

video

mac-address 0021.1BFC.88BC

ephone-template 16

max-calls-per-button 2

username "Spare4" password 12345

type 524G

button  1:17

!

!

!        

ephone  13

device-security-mode none

video

mac-address 0021.1BFC.88BE

ephone-template 16

max-calls-per-button 2

username "bmiles" password 55555

type 524G

button  1:18

!

!

!

ephone  14

device-security-mode none

video

mac-address 0021.1BFC.88C0

ephone-template 16

max-calls-per-button 2

username "jporter" password spare

type 524G

button  1:19

!

!        

!

ephone  15

device-security-mode none

video

mac-address 0021.1BFC.88BD

max-calls-per-button 2

username "cbrown" password 54321

paging-dn 1

type 524G

button  1:20

!

!

!

ephone  16

device-security-mode none

video

mac-address 0021.1BFC.88C3

ephone-template 16

max-calls-per-button 2

username "spare1" password 12345

type 524G

button  1:21

!        

!

!

ephone  17

device-security-mode none

video

mac-address 0021.1BFC.88C2

max-calls-per-button 2

username "meetingrm" password 12345

paging-dn 1

type 524G

button  1:22

!

!

!

ephone  18

device-security-mode none

video

mac-address 0004.F2E1.ED89

username "conference"

paging-dn 1

type 7937

button  1:23

!        

!

!

ephone  19

device-security-mode none

video

mac-address 001F.E152.F1FF

username "ssva"

paging-dn 1

mtp

type CIPC

button  1:24

!

!

!

ephone  20

device-security-mode none

video

mac-address 0021.706B.57FD

ephone-template 16

username "spare2"

mtp

type CIPC

button  1:25

!

!

!

ephone  21

device-security-mode none

video

mac-address 0021.7084.AFA8

ephone-template 16

username "spare3"

mtp

type CIPC

button  1:26

!

!

banner login ^CCCisco Configuration Assistant. Version: 1.8. Wed Apr 01 15:26:01 EDT 2009^C

!

line con 0

exec-timeout 0 0

no modem enable

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

line vty 5 100

!

ntp master

end

8 REPLIES
Community Member

Re: URGENT!! NEED HELP CONFIGURING AN AUTO ATTENDANT SCRIPT USIN

How do you want to auto attendant to flow? What options? Dial by name? First or last? You need to provide details for options on Auto attendant. What version of CUE?

To use CCA or Web GUI to setup you need access to the UC. If you want to use CUE Editor then we need to know the version of CUE.

Sent from Cisco Technical Support iPhone App

Community Member

Re: URGENT!! NEED HELP CONFIGURING AN AUTO ATTENDANT SCRIPT USIN

That is my exact dilemna. The client swears that they DO NOT HAVE ANY other than CCA 3.1 on site. The client did not mention Cisco Unity Express or anything other application in the environment in which they use to make VoIP changes. The client did not configure the auto attendant script that is now corrupted. I believe they hired someone to do it for them. I am hired to pretty much clean up their VoIP nightmare. I remember reading something in the CCA manual that you can modify the auto attendant settings in CCA.

What I am asking is, with what I have (the configuration only), is there a way in IOS that I can configure an auto attendant script INTO the configuration, copy the config and it go live after a copy run start, per se.

Thank you in advance for all that take the time in providing me with the insight I need to complete this.

Community Member

Re: URGENT!! NEED HELP CONFIGURING AN AUTO ATTENDANT SCRIPT USIN

AA scripts don't exist in CME, only CUE and even then I'm pretty sure you can't write a script in a the CLI interface for CUE.  Mario is pretty much giving you your two main options to do it on the unit.  An alternative that I've used before is to write the script on another 500 unit and then download and upload it to the one affected, but it takes a little planning to make sure you do the steps in the right order if you're using CLI.  Mario is also correct, you need to have access to the UC in order to affect ANY of the solutions.  The CME config looks pretty default, you should be able to access the CUE GUI by going to http://10.1.10.1 the username and password MIGHT be the same as the one used for the UC admin, depending on how it is setup.  This is your best option.

Community Member

Re: URGENT!! NEED HELP CONFIGURING AN AUTO ATTENDANT SCRIPT USIN

Trying to access that URL is not working. First thank you Bryan and Mario for even answering my question. I really need help. So CUE runs on the router right now? I know that ip is configured for the integrated service module. What I want to know now is, is there someone I can get a sample script from a UC500 and modify it based on my configuration. What do I need to use to edit the file, save and so forth? Is there a simple guide that can walk me through what to look for in the config to apply to the script just for a basic aa script?

I need this done today so any help you give...I'm definitely using.

Community Member

Re: URGENT!! NEED HELP CONFIGURING AN AUTO ATTENDANT SCRIPT USIN

You have to use either the script editor or the GUI to even edit the script, so that's why I was suggesting using the GUI because frankly, it's the easiest and quickest way. Yes, CUE does run on the UC520 as a module, that's why you have to have Dial-Peers and loopback interfaces to access it, but that's all there and you shouldn't worry about it.  You can't perse edit an existing script without using one of the tools/options above.

If you can't access the URL from a PC, it may be a simple gateway issue.  I have many installations that the gateway for the network is not the UC520 (192.168.10.1 in your case) but another firewall/router/server/etc.  You can simply add a route into the command line of the PC:  route add 10.1.10.0 mask 255.255.255.0 192.168.10.1

Copy and past the above into the command interface on the PC and try the URL again, this may solve the access issue.

Community Member

Re: URGENT!! NEED HELP CONFIGURING AN AUTO ATTENDANT SCRIPT USIN

I should have mentioned that I am not on the internal network. I'm on another network at this time so that route wouldn't work for what I'm trying to accomplish. So about the script editor...is it possible for me to acquire

1) The script editor via download (had issues finding the appropriate download link yesterday)

2) A sample UC500 script that I can edit

3) A guide for me to use that will show me what the script really means and how I can take the information contained in my config and apply it to a modified script.

I would then want to upload that script to my problem environment to see if it works.

Thanks Bryan. I can't thank you enough.

Community Member

Re: URGENT!! NEED HELP CONFIGURING AN AUTO ATTENDANT SCRIPT USIN

Your better off going onsite and using either CCA or Web GUI.  Since you do not have experience with this the CUE Editor will only make things more complicated.  Onsit should take you about 10-15 minutes max to setup, with CUE Editor could take you hours.

Community Member

Re: URGENT!! NEED HELP CONFIGURING AN AUTO ATTENDANT SCRIPT USIN

Actually, if you're using VPN to access the network, it still will work, it's how I manage all of mine.

1) Script editor is going to be dependent on the version of CUE you have on the UC.  If you can, run a sho ver on the CUE side of the UC.  This will give you the version for CUE.

2) I've attached a copy of one of the default scripts from the latest software pack.

3)  This is the first one I could find for the script editor, but I couldn't find a great one for CUE off-hand.  I know there is one around. You might also look on Youtube.  Most of the VOD's that Cisco has put out can be seen there as well for the UC series.

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/unity_exp/rel3_2/administrator/script/aasamp.html

The crux of it all is that you're going to have to access the CUE module to upload the script.  If you can get that access fixed, you'll be able to access the GUI and things will go a lot quicker and smoother.

967
Views
0
Helpful
8
Replies
CreatePlease to create content