cancelar
Mostrar resultados para 
Pesquisar em vez de 
Queria dizer: 
Comunicados
Bem-vindo à Comunidade de Suporte da Cisco, gostaríamos de ter seus comentários.
New Member

Chamada Encerra em 15 minutos

Bom dia pessoal

 

Eu tenho uma conexão SIP com a Transit, e estou enfrentando o seguinte problema:

 

Todas as vezes que eu recebo uma ligação utilizando essa conexão, em aproximadamente 15 minutos, a ligação cai. Fiz diversos testes e o problema ocorre da mesma maneira.

 

Se eu faço uma ligação utilizando essa conexão, não tenho problemas.

 

Alguém ja presenciou algo parecido ou tenha ideia por onde eu posso começar o troubleshooting?

 

Muito obrigado

5 RESPOSTAS

Olá Thiago Qual a plataforma

Olá Thiago

 

Qual a plataforma que você usa para integrar com a operadora? Poderia passar mais detalhes do seu ambiente?

 

Cheers Bruno Rangel Please remember to rate helpful responses using the stars bellow and identify helpful or correct answers .
New Member

Bruno Tenho um CUCM e o voice

Bruno

 

Tenho um CUCM e o voice gateway para essa conexão.

Poderia mostrar a

Poderia mostrar a configuração de integração?

Cheers Bruno Rangel Please remember to rate helpful responses using the stars bellow and identify helpful or correct answers .
New Member

Bom dia Bruno Segue a config

Bom dia Bruno

 

Segue a config

 

version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXX
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/0
logging buffered 10000
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
clock timezone BRT -3 0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
ip domain name XXX
!
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
stcapp
!
stcapp supplementary-services
 port 0/1/0
  fallback-dn 8504
 port 0/1/1
  fallback-dn 8505
!
!
!
!
trunk group XXX
 hunt-scheme longest-idle
!
crypto pki token default removal timeout 0
!
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
!
voice service voip
 no ip address trusted authenticate
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  call start interwork
 sip
  bind media source-interface GigabitEthernet0/0
  registrar server expires max 1200 min 300
  no update-callerid
  g729 annexb-all
!
voice class codec 1
 codec preference 1 g729r8
 codec preference 2 g729br8
 codec preference 3 g711ulaw
 codec preference 4 g711alaw
!
voice class h323 1
  h225 timeout tcp establish 3
  h225 timeout setup 3
!
!
!
!
voice translation-rule 5
 rule 1 /^8/ /551156838/
!
voice translation-rule 6
 rule 1 /^551156838/ /8/
!
voice translation-rule 10
 rule 1 /^000\(.*\)$/ /00\1/
 rule 2 /^00\(.*\)$/ /0\1/
 rule 3 /^0\(.*\)$/ /\1/
!
!
voice translation-profile VOIP-IN
 translate called 6
!
voice translation-profile VOIP-OUT
 translate calling 5
 translate called 10
!
!
license udi pid CISCO2911/K9 sn FTX1453AKJ0
license boot module c2900 technology-package securityk9
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address XXX
 ip virtual-reassembly in
 load-interval 30
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip bind srcaddr XXX
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description Link externo
 ip address XXX
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat pool web XXX prefix-length 32
ip nat inside source list 10 interface GigabitEthernet0/2 overload
ip route 0.0.0.0 0.0.0.0 XXX
ip route XXX
!
logging esm config
access-list 10 permit XXX
access-list 20 permit XXX
!
!
!
!
!
!
!
control-plane
!
!
voice-port 0/1/0
 timeouts ringing infinity
 caller-id enable
!
voice-port 0/1/1
 timeouts ringing infinity
 caller-id enable
!
!
!
sccp local GigabitEthernet0/0
sccp ccm XXX identifier 1 version 7.0
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 2 register XCODE-ITU
 associate profile 1 register CFB503de528a6c0
 signaling dscp ef
!
dspfarm profile 2 transcode
 description #### Recurso XCODE Hardware ####
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 maximum sessions 5
 associate application SCCP
!
dspfarm profile 1 conference
 description #### CFB Hardware ####
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 2
 associate application SCCP
!
dial-peer voice 1 voip
 description **** CALL MANAGER****
 destination-pattern 8[56]..
 session protocol sipv2
 session target XXX
 dtmf-relay sip-notify rtp-nte
 codec g711ulaw
!
dial-peer voice 2 voip
 description **** CME Alphaville****
 destination-pattern 47..
 session protocol sipv2
 session target XXX
 no vad
!
dial-peer voice 100 pots
 trunkgroup XXX
 description ### Dial-Per Chamadas Locais Fixo ###
 destination-pattern 0[2-5].......$
 forward-digits 8
!
dial-peer voice 101 pots
 trunkgroup XXX
 description ### Chamadas Locais Celular ####
 destination-pattern 09[0-9].......$
 forward-digits 9
!
dial-peer voice 102 pots
 trunkgroup XXX
 description ### Chamadas numeros 0800 ###
 destination-pattern 00800T
 prefix 0800
!
dial-peer voice 103 pots
 trunkgroup XXX
 description ### Chamadas Numeros 0300 e 0500 ###
 destination-pattern 00[35]00.......$
 forward-digits 11
!
dial-peer voice 104 pots
 trunkgroup XXX
 description ### Chamadas Emergencia 3 DIG ###
 destination-pattern 019.$
 forward-digits 3
!
dial-peer voice 105 pots
 trunkgroup XXX
 description ### Chamadas Servicos 4 DIG ###
 destination-pattern 010[^2].$
 forward-digits 4
!
dial-peer voice 106 pots
 trunkgroup XXX
 description ### Chamadas Interurbanas DDD ###
 destination-pattern 00[^0].[2-5].......$
 prefix 015
!
dial-peer voice 107 pots
 trunkgroup XXX
 description ### Chamadas Cel DDD 9 DIG ###
 destination-pattern 00[^0].[9][0-9].......$
 prefix 015
!
dial-peer voice 1008 pots
 trunkgroup XXX
 description # Chamadas Cel DDD 8 DIG #
 destination-pattern 00[^0].[5-9].......$
 prefix 015
!
dial-peer voice 1009 pots
 trunkgroup XXX
 description ### Chamadas Internacionais DDI ###
 destination-pattern 000T
 prefix 0015
!
dial-peer voice 1010 pots
 trunkgroup XXX
 description ### Chamadas Rotas Tarifadas ###
 destination-pattern 01....$
 forward-digits 5
!
dial-peer voice 1011 pots
 trunkgroup XXX
 description ### Chamadas Celular Nextel ###
 destination-pattern 0[7].......$
 forward-digits 8
!
dial-peer voice 1012 voip
 destination-pattern 0T
 session protocol sipv2
 session target ipv4:XXX.XXX.XXX.XXX
!
dial-peer voice 5 voip
 description ##DP TESTE ##
 translation-profile outgoing VOIP-OUT
 destination-pattern 000T
 session protocol sipv2
 session target ipv4:XXX.XXX.XXX.XXX
 session transport udp
 voice-class codec 1
 dtmf-relay rtp-nte sip-notify
 no vad
!
dial-peer voice 6 voip
 description ## 4004 ##
 translation-profile outgoing VOIP-OUT
 destination-pattern 0[4][0][0][4]T
 session protocol sipv2
 session target ipv4:XXX.XXX.XXX.XXX
 session transport udp
 voice-class codec 1
 dtmf-relay rtp-nte sip-notify
 no vad
!
dial-peer voice 7 voip
 description ## 0800 ##
 translation-profile outgoing VOIP-OUT
 destination-pattern 0[0][8][0][0]T
 session protocol sipv2
 session target ipv4:XXX.XXX.XXX.XXX
 session transport udp
 voice-class codec 1
 dtmf-relay rtp-nte sip-notify
 no vad
!
dial-peer voice 8 voip
 description ## Ligacoes Locais - DDD 11 ##
 translation-profile outgoing VOIP-OUT
 destination-pattern 0[1-5][0-9]......
 session protocol sipv2
 session target ipv4:XXX.XXX.XXX.XXX
 session transport udp
 voice-class codec 1
 dtmf-relay rtp-nte sip-notify
 no vad
!
dial-peer voice 9 voip
 description ## DDI VOIP ##
 translation-profile outgoing VOIP-OUT
 destination-pattern 000[0-9]T
 session protocol sipv2
 session target ipv4:XXX.XXX.XXX.XXX
 session transport udp
 voice-class codec 1
 dtmf-relay rtp-nte sip-notify
 no vad
!
dial-peer voice 10 voip
 description ## Nextel Local VOIP ##
 translation-profile outgoing VOIP-OUT
 destination-pattern 0[7]T
 session protocol sipv2
 session target ipv4:XXX.XXX.XXX.XXX
 session transport udp
 voice-class codec 1
 dtmf-relay rtp-nte sip-notify
 no vad
!
dial-peer voice 11 voip
 description ## Celular local VoIP ##
 translation-profile outgoing VOIP-OUT
 destination-pattern 0[9][6-9].......
 session protocol sipv2
 session target ipv4:XXX.XXX.XXX.XXX
 session transport udp
 voice-class codec 1
 dtmf-relay rtp-nte sip-notify
 no vad
!
dial-peer voice 12 voip
 description **DDD**
 translation-profile outgoing VOIP-OUT
 destination-pattern 00[1-9][0-9]T
 session protocol sipv2
 session target ipv4:XXX.XXX.XXX.XXX
 session transport udp
 voice-class codec 1
 dtmf-relay rtp-nte sip-notify
 no vad
!
dial-peer voice 13 voip
 description **** CALL MANAGER****
 destination-pattern 55115683....
 session protocol sipv2
 session target ipv4:XXX.XXX.XXX.XXX
 dtmf-relay sip-notify rtp-nte
 no vad
!
dial-peer voice 3 voip
 session protocol sipv2
 session target sip-server
 incoming called-number .
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 108 pots
 service stcapp
 port 0/1/0
!
dial-peer voice 109 pots
 service stcapp
 port 0/1/1
!
!
sip-ua
 credentials username XXXXXX password 7 XXXX realm XXXX 
 authentication username XXXX password 7 XXXX realm XXXX 
 no remote-party-id
 retry invite 2
 retry register 10
 timers connect 100
 mwi-server ipv4:XXXX  expires 3600 port 5060 transport udp unsolicited
 registrar ipv4:XXXX  expires 3600
 sip-server ipv4:XXXX 
 connection-reuse
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 sdspfarm units 5
 sdspfarm transcode sessions 6
 sdspfarm tag 1 CFB503de528a6c0
 sdspfarm tag 2 XCODE-ITU
 conference hardware
 video
 max-ephones 4
 max-dn 4
 ip source-address XXXX  port 2000
 max-conferences 8 gain -6
 transfer-system full-consult
 transfer-pattern .T
 create cnf-files version-stamp 7960 Jun 25 2015 14:52:31
!
!
ephone-dn  1  dual-line
 number 7899
 pickup-group 1
!
!
ephone  1
 device-security-mode none
 mac-address 1111.1111.1111
 type CIPC
 button  1:1
!
!
!
line con 0
line aux 0
line vty 0 4
 privilege level 15
 transport input all
!
scheduler allocate 20000 1000
ntp master
ntp server XXXX  prefer
ntp server XXXX 
end

 

 

Muito obrigado

 

New Member

Ola Thiago, 

Ola Thiago, 

Provavelmente existe um problema no update do session-Expires do SIP. Por default se utiliza 1800 e a cada 900(15 min) existe um refresh.

Precisa ser observado o invite original, para verificar de quem é a oferta de

negociação para o refresh da sessão - UAC ou UAS, ou se ela esta em aberto:

Um exemplo:

Session-Expires: 1800;refresher=uac


Uma tentativa valida 'e aumentar o campo SE timer em todos os devices envolvidos.

Poderia informar maiores detalhes do call flow da chamada?

Foi coletado algum debug no seu GW?

Segue minha sugestão de debugs a serem coletados:
 
Conf t
service sequence-numbers
service timestamps debug datetime localtime msec
service timestamps log datetime msec
logging buffered 10000000 debug
no logging console
no logging monitor
default logging rate-limit
default logging queue-limit
voice iec syslog
exit
 
CUBES:
<enable debug>
debug ccsip all
 
!
debug voip ccapi inout
 
-Enable Putty to log all output to a file here and run the failed call scenario test, then run the following and collect the output:
show debug
Undebug all
Terminal length 0
Show run
Show log
Terminal default length

 

E compartilhe o numero de A e de B da chamada.

Obrigado.

"O Nulla tenaci invia est via"

 

 

129
Apresentações
5
Kudo
5
Respostas