cancelar
Mostrar resultados para 
Pesquisar em vez de 
Queria dizer: 
Comunicados
Bem-vindo à Comunidade de Suporte da Cisco, gostaríamos de ter seus comentários.
New Member

SIP - End to end ok bu RTP stream fails sometimes

                   HI all

               We have a problem with SIP tunnel betwen some CME and/or Asterisk and also with Call Manager 6.x

Problem: SIP tunnel between all end point (CMEs and CUM 6.x) connected to an Asterisk (as a switch)

All calls are ok on SIP side but sometimes we do not have Audio.

Configuration:

End-Points:  CMexpress directly connected to ISP (No NAT for voice)

On CM side: Connected to 2811 as a SIP tunnel endoint. Second interface connected to ISP

All calls ring but sometimes we do not have audio (we must dial 2 to 3 times an remote extension to get the RTP stream)

The problem always arise:

Fom clls originated on Asterisk users to CM 6.x or to CMexpress users

From CME to CM users or other CMEs users the same problem

Any idea?

A sample configuration attached

All configs are based on this one except for the SIP gateway connected to CM 6.x

In annex one of the configs and a debug ccsip mess with a failed call (no audio both ways) and one call ok

(since the problem can be between 2 CME with this exact config)

The NAT is used for data access for Internet

Thanks for any help

  • VoIP
3 RESPOSTAS

SIP - End to end ok bu RTP stream fails sometimes

Olá Manuel, aparentemente o problema não está na sinalização entre seu Asterisk e o CUCM/CUCME mas sim no roteamento IP entre a rede onde se encontra o Ramal Asterisk para a rede onde está o ramal Cisco.

Se o telefone tocou e a chamada foi estabelecida (embora sem audio) já validamos que a sinalização entre os PABX´s está Ok (SIP, TCP, 5060), após isso é feito a  negociação da porta RTP e RTCP entre os aparalhos IP de origem e destino, e se houver algum protocolo de roteamento com balanceamento de carga, algum tipo de acelerador ou balanceador de carga dedicado em sua rede, isso pode surtir impactos na comunicação VoIP.

Se o audio não funciona é porque os pacotes podem estar sendo roteados para outro destino ....  em situações deste tipo o RTP também pode fechar em apenas um sentido (one way voice) mas a situação é mais grave quando nenhum dos lados se ouvem.

Firewall´s também são considerado inimigos do VoIP se não for devidamente configurado.

Atenciosamente,

Leonardo Oliveira
www.avvid.net

Leonardo Oliveira www.avvid.net "Scientia potentia est"
New Member

SIP - End to end ok bu RTP stream fails sometimes

Viva Leonardo

Obrigado pela resposta

Também inicialmente me inclinei para que fosse tipo de problema mas infelizmente nada indica que o mesmo esteja acontecendo.

Pois quando tento uma config mais básica (dois CUCME a falar através do Asterisk o mesmo acontece)

para despiste tenho uma situação de lab (CUCME1) instalada com o seguinte cenário (real):

CUCME1 ----->       ASTERISK -----> 2811 (SIP TUNNEL ENDPOINT) ---> CM 6.1

CUCME2 ------>   ASTERISK

CUCME3 ------->     ASTERISK

(IP Pub e IP priv))   (Ip Pub)                  (IP Pub e Ip Priv)                      (IP Priv)

O CUCME 1 está isolado apenas com dois telefones e uma conexão Internet.

Todos os tuneis são SIP inclusive entre o 2811 e o CM6.1 e Não há firewalls em nenhum percurso.

A ideia de utilizar este Asterisk como switch tem a vantagem dos DPs serem muito simples nos CME endpoints.

Alem disso há utilizadores no Asterisk também.

Ainda pensei que o problema estivesse relacionado com o CM 6.x estar numa gama de Ips privados (daí 0 2811 realizar o endpoint doSIP com um interface com Ip Publico e outro com IP Privado)

No entanto, há também falhas quando se liga dum CUCME para outro CUCME e estes têm Ip públicos num interface e os telefones numIP privado como se vê nas configurações)

O resultado obtido é o seguiinte:

Quando falha:

Call-ID: 124335dd3fe664e7669eef4b27f7033a@A.B.C.D:5060 User-Agent: Cisco-SIPGateway/IOS-12.x Max-Forwards: 70 Timestamp: 1378371783 CSeq: 101 BYE Reason: Q.850;cause=16 P-RTP-Stat: PS=945,OS=151200,PR=0,OR=0,PL=0,JI=0,LA=0,DU=19 Content-Length: 0

*Sep 5 09:03:03.056:

Aqui vemos que no áudio não foi nada recebido

Aproveito e envio a configuração do 2811 que serve de gateway SIP para o CM

Current configuration : 4433 bytes

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname SIP-GW

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

no logging console

enable secret 5 $-----------------------

enable password 7 ---------------------

!

aaa new-model

!

!

!

!

!

!

!

aaa session-id common

clock timezone Maputo 2 0

!

dot11 syslog

ip source-route

!

!

no ip cef

!

!

!

ip name-server 8.8.8.8

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

!

voice rtp send-recv

!

voice service voip

ip address trusted list

ipv4 A.B.C.0 255.255.255.0

ipv4 RA.RB.RC.RD 255.255.255.255

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

sip

rel1xx disable

header-passing sip-sip

error-passthru

registrar server expires max 36000 min 600

early-offer forced

midcall-signaling passthru

sip-profiles 100

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

codec preference 3 g728

codec preference 4 g726r16

codec preference 5 g726r24

codec preference 6 g726r32

!

voice class sip-profiles 100

response ANY sdp-header Audio-Attribute modify "sendonly" "sendrecv"

request ANY sdp-header Audio-Attribute modify "sendonly" "sendrecv"

!

!

!

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2811 sn FHK0849F0XW

archive

log config

hidekeys

username cisco password 0 cisco

username brithol password 0 brithol

username afonsob password 0 afonsob

!

!

!

!

!

!

!

interface Loopback1

ip address 10.10.200.1 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.200.251 255.255.255.0

ip virtual-reassembly in

duplex auto

speed 100

!

interface FastEthernet0/1

ip address X.Y.K.Z 255.255.255.252

ip access-group SIP-Inbound in

ip virtual-reassembly in

duplex auto

speed auto

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

no ip nat service sip udp port 5060

ip route 0.0.0.0 0.0.0.0 41.223.126.193

ip route 192.168.3.0 255.255.255.0 192.168.200.253

!

ip access-list extended SIP-Inbound

permit udp host 41.223.127.11 any eq 5060

permit udp host RA.RB.RC.RD any eq 5061

permit udp host RA.RB.RC.RD any range 4000 40000

permit tcp any host 10.10.10.2 ack

deny   udp any any eq 5060

deny   udp any any eq 5051

deny   udp any any range 16384 32767

permit tcp any any eq telnet

permit ip any any

ip access-list extended VTY_ACCESS

(CLEARED)

deny   ip any any log

!

no cdp run

!

!

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

sccp local FastEthernet0/1

sccp ccm 192.168.200.1 identifier 1 version 6.0

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

!

dspfarm profile 1 mtp

codec g711ulaw

maximum sessions software 100

associate application SCCP

shutdown

!

dial-peer voice 2121 voip

description calls 21.. to cucm

huntstop

destination-pattern 21..$

session protocol sipv2

session target ipv4:192.168.200.1

voice-class codec 1

voice-class sip early-offer forced

dtmf-relay rtp-nte

!

dial-peer voice 2000 voip

description calls to Asterisk/CUCME remote

destination-pattern [1-9]...$

session protocol sipv2

session target ipv4:41.223.127.11

voice-class codec 1

voice-class sip early-offer forced

dtmf-relay rtp-nte

!

gateway

timer receive-rtp 1200

!

sip-ua

!

!

!

line con 0

line aux 0

line vty 0 4

access-class VTY_ACCESS in

password --------------------

transport input all

!

scheduler allocate 20000 1000

end

SIP - End to end ok bu RTP stream fails sometimes

Opa Manuel, cara então acredito que a abertura de um TAC possa lhe auxiliar melhor neste problema, e com uma análise mais detalhadas dos logs e debugs (CME) você terá um diagnostico de onde ocorre a falha.

Pois em ambos os cenários o Asterisk está no meio da jogada. Há também possibilidades de exitir um bug na IOS do CME e também na versão 6.1 do CUCM.... que já em bem antiga.

Leonardo Oliveira
www.avvid.net

Leonardo Oliveira www.avvid.net "Scientia potentia est"
587
Apresentações
0
Kudo
3
Respostas