cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

Como configurar Dial Peers para recibir llamadas por un E1/T1 y reenviarlos por otro E1/T1 conectado a una planta

Hola buenos dias,

El siguiente es porque quiero conectar un router que reciba un primario de la empresa de telefonia publica, este se recibira a traves de una controller E1 y posteriormente debera reenviar las llamadas a otra controller E1 que tiene instalado el router. La razon de esto es que dispongo de un router y quiero que este sea la base de mi operacion telefonica es decir:

  1. Cuando ingrese llamadas de la calle(PSTN), las reciba por el E1 destinado a esta funcion y posteriormente las reenvie al puerto E1 que va a la planta.
  2. Cuando se requiere sacar llamadas Locales, el router recibira el prefijo que envia la planta y procedera a enviarlas por el E1 conectado a la PSTN.
  3. Cuando se requiere sacar llamadas Nacionales, Internacionales o Moviles el router de acuerdo al prefijo que reciba lo enviara por el Dial Peer VoIP que conecta con mi asterisk. 

Realmente mi problema esta en los puntos 1 y 2 ya que se que debo confgurar en ambos extremos Dial Peers POTS pero no tengo idea de como hacerlo o indicios de estos.

Topologia de la solucion

PSTN ------Numeracion Entrante 4232640------- Router 2821 ----------------------- Planta

                                                                                      |

                                                                                      |

                                                                                 INTERNET

                                                                                       |

                                                                                       |

                                                                                  Asterisk --------------(Terminacion Internacional, Nacional y Movil)

Como dato adicional les indco que cuando conecto el primario a la planta directo obviamente funciona, ademas que la señalizacion que uso es ISDN y en los dos extremos levanta correctamente es decir del lado de la PSTN como del lado de la planta, como dije se que tengo que reenviar la llamada pero no me doy maña para hacerlo.

Agradezco la ayuda que me puedan brindar.

Gracias

4 RESPUESTAS
Cisco Employee

Como configurar Dial Peers para recibir llamadas por un E1/T1 y

Buen dia

Tengo algunas preguntas para poder ayudarte a resolver tus dudas.

Podrias subir tu sh run, recuerda que es un sitio privado y evita subir informacion confidencial, decirme cuantos digitos te entregan de la PSTN y y si puedes explicar un poco mas el dial-plan que usas para tus llamadas.

Saludos

New Member

Como configurar Dial Peers para recibir llamadas por un E1/T1 y

Hola Cesar,

Estos son los datos espero me puedas ayudar, me estan entregando todos los digitos de la PSTN, y en relacion al Dial Plan cuando esta conectado a la planta marcan 0 y me da tono de marcacion, de hecho estuve pensando y cuando la planta me entrega la llamada ya me entrega la marcacion directa es decir como deberia salir asi que si recibo algun prefijo adicional al local seria el de las llamadas nacionales, internacionales y celulares.

ip cef

!

!

no ip domain lookup

multilink bundle-name authenticated

!

isdn switch-type primary-net5

!

voice-card 0

no dspfarm

!

!

!

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31

!

controller E1 0/1/0

framing NO-CRC4

pri-group timeslots 1-31

!

translation-rule 1234

Rule 1 ^01 1

Rule 2 ^02 2

Rule 3 ^03 3

Rule 4 ^04 4

Rule 5 ^05 5

Rule 6 ^06 6

Rule 7 ^07 7

Rule 8 ^08 8

Rule 9 ^09 9

!

!

!

!

!

interface GigabitEthernet0/0

description TO_LINK_ROUTER_1811

ip address 10.10.10.10 255.255.255.252

ip flow ingress

duplex full

speed auto

no cdp enable

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 10.10.10.9 name DEFAULT

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:15

!

voice-port 0/1/0:15

!

!

!

!

!

dial-peer voice 4232640 pots

description Numeracion entrante 4232640

call-block translation-profile incoming block

incoming called-number 4232640

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 4232641 pots

destination-pattern 423264..

port 0/1/0:15

forward-digits all

!

dial-peer voice 4321 pots

tone ringback alert-no-PI

description Salida_Local

max-conn 30

destination-pattern 0.

translate-outgoing called 1234

port 0/0/0:15

!

New Member

Como configurar Dial Peers para recibir llamadas por un E1/T1 y

Cesar

Agradezco me indiques si revisaste la configuracion y ver que esta mal o como deberia hacer para solucionarlo.

Saludos

Cisco Employee

Como configurar Dial Peers para recibir llamadas por un E1/T1 y

Hola Andres

La configuracion que tienes solo estaria lista si es que te marcan de ese numero y te faltaria los destinos de tus extensiones que son los numero entregados de la PSTN para la pregunta 1, aqui te pongo una posible solucion.

************************************************

dial-peer voice x pots

incoming called-number .

port PSTN (0/0/0:15 o 0/1/0:15)

Esta parte es la que tu tienes para el numero 4232640 que solo funcionaria si marcan de ese origen.

************************************************

************************************************

dial-peer voice x pots

destination-pattern xxxx------- rango de extensiones

port Planta (0/0/0:15 o 0/1/0:15)

Esta parte seria para mandar las llamadas hacia la planta, hay dos formas de hacerlo con un "forward-digits all" o con "no digit-strip" ya que los puertos POTS eliminan todos los numeros explicitos. Y lo tendrias que configurar hacia un rango con wildcards.

***********************************************

Para la pregunta 2:

***********************************************

dial-peer voice x pots

incoming called-number .

port Planta (0/0/0:15 o 0/1/0:15)

Esto es para que sea tu puerto de entrada. 

*************************************************

*************************************************

dial-peer voice x pots

destination-pattern 0[2-9].......

port PSTN (0/0/0:15 o 0/1/0:15)

Y esto seria el plan de marcado de las llamadas locales en caso de que fuera de 8 digitos ya que por ser una puerto POTS eliminaria el 0 siendo el digito que da tono.

*****************************************************

Disculpa por la demora

Saludos

8611
Visitas
0
ÚTIL
4
Respuestas