cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

Configurar SIP Trunk hacia PSTN

Hola buen día, tengo el problema siguiente: una empresa ha cambiado de carrier, el carrier anterior le entregaba sus troncales hacia la PSTN por un enlace E1, ahora el nuevo carrier se los entrega como troncales SIP, realmente estoy perdido y no sé cómo configurar las troncales SIP en el gateway que tengo; los datos de enlace que le dieron a la emresa que está adquiriendo las troncales SIP es: 

  • user ID: 557252xxxxx-abcxx
  • domain: xxx.texxx.mx
  • password: XXXXXXXxxx
  • display name: ejemplo
  • authorization name: ejemploxxxx
  • proxy: 200.xxx.xxx.xxx

la configuración que coloqué es:

ejemplo#
ejemplo#show run
Building configuration...


Current configuration : 9333 bytes
!
! Last configuration change at 18:39:27 Mexico Wed Mar 8 2017 by Interlace
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ejemplo
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 3
enable secret 5 $1$ZxMA$prU.0nLXA61tB4zsG4ThC0
enable password ejemplo
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login XAUTH local
aaa authorization network VPN_ejemlo local
!
!
!
!
!
aaa session-id common
clock timezone Mexico -6 0
network-clock-participate wic 3
!
ip cef
!
!
!
ip dhcp excluded-address 172.16.20.1 172.16.20.50
!
ip dhcp pool IP_Phone
network 172.16.20.0 255.255.255.0
default-router 172.16.20.10
option 150 ip 172.16.20.1
dns-server 172.16.0.1
!
!
!
ip domain name interlace.local
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
trunk group telmex
!
!
crypto pki trustpoint TP-self-signed-1753616530
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1753616530
revocation-check none
rsakeypair TP-self-signed-1753616530
!
!
crypto pki certificate chain TP-self-signed-1753616530
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 31373533 36313635 3330301E 170D3135 30313232 30313534
34345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 37353336
31363533 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
81009F7C 28545CEC F369FA81 C3F185E2 6642B91A 3B1568B8 D35FD1F8 50C10648
12AEADA6 9FE36AE5 785F0465 A7F20A83 09F1595F 3231F511 3EE4BB8D E6AB84F4
386460CE 5186586C A6023AF3 E4586543 BC564013 ACE3C045 4C4C69DC E13AE892
A4B8486F 360D0866 1F374D98 D08A0E4B F494AE58 7377A9C7 93C300F4 74E10C38
A4A70203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 14087F98 433A0D1D E5E8EF48 CCF70496 6610D625 5B301D06
03551D0E 04160414 087F9843 3A0D1DE5 E8EF48CC F7049666 10D6255B 300D0609
2A864886 F70D0101 05050003 81810055 3CD6F146 D785B9D7 225316FA 060CE69F
27514E6E DE9DC893 49AC2020 9F1B66E0 CCC907ED 364B95DF E2FFE4A7 38B464F5
E031741B 7BFD4054 1C570B8D 33DA71B0 9F468056 D589C242 677B0EB4 DA3E699F
BC87BD82 F1DCC91E 5EA1267A 8AFDEA91 26A9D43C 4EB4DE44 C10A3A42 66604952
39B2DFEC A1A7C508 4BE904F2 014145
quit
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
address-hiding
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
sip
registrar server expires max 600 min 60
!
!
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1833AJ1Q
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!
!
controller E1 0/3/0
framing NO-CRC4
line-termination 75-ohm
ds0-group 0 timeslots 1-10 type r2-digital r2-compelled ani
cas-custom 0
country telmex
category 2
answer-signal group-b 1
caller-digits 4
dnis-digits min 4 max 4
ani-digits min 0 max 20
dnis-complete
groupa-callerid-end
description *** E1 de Voz Telmex****
!
!
!
crypto isakmp policy 100
encr aes
authentication pre-share
group 2
crypto isakmp keepalive 30 5
!
crypto isakmp client configuration group VPN_ejemplo
key cisco123
dns 172.16.0.1
domain ejemplo
pool VPN_ejemplo
acl 101
netmask 255.255.255.0
!
!
crypto ipsec transform-set VPN_ejemplo esp-3des esp-sha-hmac
mode tunnel
!
!
!
crypto dynamic-map DYNMAP 10
set transform-set VPN_ejemplo
reverse-route
!
!
crypto map CLIENT client authentication list XAUTH
crypto map CLIENT isakmp authorization list VPN_ejemplo
crypto map CLIENT client configuration address respond
crypto map CLIENT 10 ipsec-isakmp dynamic DYNMAP
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
no mop enabled
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 1 native
ip address 172.16.0.20 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 172.16.20.10 255.255.255.0
ip nat inside
ip virtual-reassembly in
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.16.20.10
!
interface GigabitEthernet0/1
ip address 192.168.55.66 255.255.255.192
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 168.90.68.34 255.255.255.252
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
crypto map CLIENT
!
ip local pool VPN_ejemplo 172.16.30.1 172.16.30.70
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http path flash:
!
ip nat inside source list 100 interface GigabitEthernet0/2 overload
ip nat inside source static tcp 172.16.0.19 80 interface GigabitEthernet0/2 80
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip route 0.0.0.0 0.0.0.0 168.90.68.33
ip route 200.77.165.110 255.255.255.255 192.168.55.65
!
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 172.16.0.0 0.0.0.255
access-list 1 permit 172.16.20.0 0.0.0.255
access-list 100 deny ip 172.16.0.0 0.0.0.255 172.16.30.0 0.0.0.255
access-list 100 deny ip 172.16.20.0 0.0.0.255 172.16.30.0 0.0.0.255
access-list 100 permit ip any any
access-list 101 permit ip 172.16.0.0 0.0.0.255 172.16.30.0 0.0.0.255
access-list 101 permit ip 172.16.20.0 0.0.0.255 172.16.30.0 0.0.0.255
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
trunk-group telmex
supervisory disconnect dualtone mid-call
no battery-reversal
timeouts call-disconnect 1
timing hookflash-out 50
timing guard-out 1000
connection plar 5000
caller-id enable
!
voice-port 0/0/1
timing hookflash-out 50
timing guard-out 1000
caller-id enable
!
voice-port 0/0/2
timing hookflash-out 50
timing guard-out 1000
caller-id enable
!
voice-port 0/0/3
timing hookflash-out 50
timing guard-out 1000
caller-id enable
!
voice-port 0/3/0:0
cptone MX
!
!
!
!
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server 172.16.20.1
ccm-manager config
!
mgcp
mgcp call-agent 172.16.20.1 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
!
mgcp profile default
!
sccp ccm 172.16.20.1 identifier 1 version 7.0
!
dial-peer voice 1 pots
service mgcpapp
port 0/0/0
!
dial-peer voice 2 pots
service mgcpapp
port 0/0/1
!
dial-peer voice 3 pots
service mgcpapp
port 0/0/2
!
dial-peer voice 4 pots
service mgcpapp
port 0/0/3
!
dial-peer voice 99900991 pots
service mgcpapp
port 0/0/1
!
dial-peer voice 99900992 pots
service mgcpapp
port 0/0/2
!
dial-peer voice 99900993 pots
service mgcpapp
port 0/0/3
!
dial-peer voice 99900990 pots
service mgcpapp
port 0/0/0
!
dial-peer voice 99900099 pots
service mgcpapp
port 0/0/0
!
dial-peer voice 99900199 pots
service mgcpapp
port 0/0/1
!
dial-peer voice 99900299 pots
service mgcpapp
port 0/0/2
!
dial-peer voice 99900399 pots
service mgcpapp
port 0/0/3
!
dial-peer voice 30 voip
destination-pattern [8231]..
session target ipv4:172.16.20.1
dtmf-relay h245-alphanumeric
codec g711alaw
!
dial-peer voice 29 pots
description PSTN
incoming called-number .T
direct-inward-dial
port 0/3/0:0
!
dial-peer voice 31 pots
shutdown
destination-pattern .T
port 0/3/0:0
forward-digits all
!
dial-peer voice 28 voip
destination-pattern 5000
session target ipv4:172.16.20.1
dtmf-relay h245-alphanumeric
codec g711alaw
!
dial-peer voice 32 pots
destination-pattern 9T
port 0/3/0:0
!
dial-peer voice 40 voip
!
!
num-exp 7100 5000
num-exp 7101 211
num-exp 7102 305
num-exp 7103 200
num-exp 7104 201
num-exp 7107 212
num-exp 7108 301
num-exp 7109 303
num-exp 7105 111
num-exp 7106 119
num-exp 6077 5000
sip-ua
credentials username 5572521260-abc123 password 7 075E2F1F6B1B350414565E realm cts.telum.mx
authentication username interlace1260 password 7 06570172695C2518065347
registrar ipv4:200.77.165.110:5060 expires 3600
sip-server ipv4:200.77.165.110:5060
!
!
!
gatekeeper
shutdown
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password interlace
transport input all
!
scheduler allocate 20000 1000
!
end

NO SE CONECTA A LA PSTN

alguien me puede ayudar???

gracias de antemano

1 SOLUCIÓN ACEPTADA

Soluciones aceptadas

La config parece estar bien,

La config parece estar bien, si el remoto tiene habilitado ICMP puedes probar a lanzarle un ping (200.77.165.110) y confirmar que llegas?

Igualmente haria falta sacar debugs y confirmarlo...

4 RESPUESTAS

La config parece estar bien,

La config parece estar bien, si el remoto tiene habilitado ICMP puedes probar a lanzarle un ping (200.77.165.110) y confirmar que llegas?

Igualmente haria falta sacar debugs y confirmarlo...

New Member

No podemos hacer ping, el

No podemos hacer ping, el proveedor de servicios no tiene habilitado ese servicio, no sé qué más hacer

New Member

Muchas gracias Pablo

Muchas gracias Pablo Escribano por tomarte el tiempo de leer mi discusión, finalmente el proveedor de servicios no logró hacer funcionar sus troncales con los estándares y el cliente final dejó de usar sus servicios

Saludos,

Gracias a ti

Gracias a ti

384
Visitas
0
ÚTIL
4
Respuestas