cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

LLamadas entrantes y CUCM

Hola.

Quisieran si me pudiesen ayudar con el siguiente escenario;

Tengo un laboratorio con un gateway de voz 2801, con CME ( telephony-service) 8.6 y un VMware ESX 5.1 con CUCM 8.6.  He configurado correctamente las llamadas salientes desde cucm hacia el gateway, pero no he podido configurar las llamadas entrantes desde el puerto FXO en el gateway para los Ip Phone.

Cual son los comandos necesarios para implementantar que una llamada entrante sea contestada por  un anexo ( DN) .

Saludos.

47 RESPUESTAS

Re: LLamadas entrantes y CUCM

Hola Leonardo,

Parece que tienes dos call control agents (CME y CUCM). La llamada entrante por el puerto FXO hacia dónde la deseas enrutar, ¿a un teléfono en el CME o en el CUCM?.

Saludos,

- Adrián.

New Member

Re: LLamadas entrantes y CUCM

Hola Adrián.

Gracias por tu respesta.  El CUCM 8.6 se registrarán los teléfonos IP. El gateway de voz (2801) quedará en modo SRST pero de igual manera de este se tiene que enviar y recibir llamados desde el PSTN (FXO).    La llamada entrante por el FXO se desea enrutar al teléfono IP registrado en el CUCM (Vmware).

Saludos.

Dejo copy y paste del show run.

G-SRST#show run

Building configuration...

Current configuration : 2798 bytes

!

version 15.1

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname G-SRST

!

boot-start-marker

boot-end-marker

!

!

enable password cisco

!

no aaa new-model

dot11 syslog

ip source-route

!

!

!

!

!

ip cef

no ip domain lookup

ip name-server 192.168.47.1

ip name-server 8.8.8.8

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 // //

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2801 sn FHK1146F03J

!

!

!

!

!

!

!

interface Loopback0

no ip address

!

interface FastEthernet0/0

ip address 192.168.47.219 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.47.219

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip route 0.0.0.0 0.0.0.0 192.168.47.1

!

!

!

!

control-plane

!

!

voice-port 0/0/0

cptone CL

connection plar opx 2001

description PSTN-FXO

!

voice-port 0/0/1

!

voice-port 0/0/2

!

voice-port 0/0/3

!

!

!

mgcp profile default

!

!

dial-peer voice 2 voip

destination-pattern 2...

session target ipv4:192.168.47.223

!

dial-peer voice 1 pots

description CallSalidas

destination-pattern 9.[4-9]......

port 0/0/0

!

dial-peer voice 3 voip

destination-pattern 2001

codec g711ulaw

!

!

!

telephony-service

srst mode auto-provision all

srst ephone template 1

srst ephone description Telefonia caida : Nov 14 2013 21:00:36

srst dn template 1

max-ephones 5

max-dn 10

ip source-address 192.168.47.219 port 2000

system message Telefonia en Contingencia

time-zone 8

max-conferences 4 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn-template  1

!

!

ephone-template  1

keepalive 20

codec g729r8

!

!

ephone-dn  1

number 2001

label 2001

description 2001

name 2001

ephone-dn-template 1

!

!

ephone-dn  2

number 2002

label 2002

description 2002

name 2002

ephone-dn-template 1

!

!

ephone-dn  3

number 2003

label 2003

description 2003

name 2003

ephone-dn-template 1

!

!

ephone  1

description Telefonia caida : Nov 14 2013 21:00:36

mac-address 1C75.0858.6777

ephone-template 1

codec g729r8

button  1:1

!

!

!

ephone  2

description Telefonia caida : Nov 14 2013 21:00:36

mac-address 1230.9011.0011

ephone-template 1

codec g729r8

button  1:2

!

!

!

ephone  3

description Telefonia caida : Nov 14 2013 21:00:36

mac-address 4055.39AD.0E9E

ephone-template 1

codec g729r8

button  1:3

!

!

!

ephone  4

description Telefonia caida : Nov 14 2013 21:00:36

codec g729r8

!

!

!

!

line con 0

line aux 0

line vty 0 4

password cisco

login

transport input all

!

scheduler allocate 20000 1000

end

G-SRST#

Re: LLamadas entrantes y CUCM

Hola Leonardo,

Parece que tu SRST está guardando la configuración de los DNs. Esto puede ser problemático a la hora del enrutamiento, pues las llamadas a la 2001 pueden estar haciendo "match" con algún dial-peer oculto del SRST. Mi recomendación es no utilizar mode auto-provision all. Sin embargo, si lo requieres, te recomiendo la sgte modificación:

# El valor "2" en el comando de abajo le indica al router que enrute las llamadas basado en la preferencia de los dial-peers. Mientras más baja la preferencia del dial-peer, mayor prioridad de escogencia tiene. Por defecto, los dialpeers que no tienen una preferencia explícitamente configurada, tienen un valor de 0.

dial-peer hunt 2

!

telephony-service

   max-dn 10 preference 1  <--- Esto le configura a los dial-peers ocultos del SRST, una preferencia 1.

La configuración anterior le permite al router mandar la llamada por el dial-peer 2 VoIP (debido a que la preferencia que tiene es 0), por lo tanto cuando el CUCM está alcanzable la llamada siempre llegará al teléfono IP en el CUCM.

Cuando el router entra en modo SRST, el router enviará la llamada al CUCM (debido a que el dial-peer 2 tiene mayor preferencia), pero, como el CUCM no está alcanzable en ese momento, el router buscará otro dial-peer de mayor preferencia como respaldo para enrutar la llamada, es decir, va a utilizar el dial-peer oculto del SRST (que ahora tiene preferencia 1). En ese momento la llamada debería timbrar en el teléfono IP registrado al SRST.

Nota:

Revisa en tu CUCM si el gw de voz tiene el calling search space correcto que contenga la partición donde reside la extensión 2001.

Prueba y me avisas por favor.


Saludos,

- Adrián.

New Member

Re: LLamadas entrantes y CUCM

Hola Adrían.

Realizé los pasos que indicaste. Pero sigo con el problema. Las llamadas salientes funcionan ya sea desde el CUCM o en modo srst del gateway por el puerto FXO, pero las entrantes no. ya sea desde el cucm o desde el gateway modo SRST.

¿Será porque estoy usando con conversor GSM (conversor celular)  para las llamadas?

Saludos cordiales.

Re: LLamadas entrantes y CUCM

Hola,

Realiza una llamada entrante y capturas unos debugs en el router:

debug voip ccapi inout

debug dial-peer all

debug vpm all (creo que el router te va a decir que ahora es otro comando)

Saludos,

- Adrian.

New Member

Re: LLamadas entrantes y CUCM

Hola Adrián.

Realizé los comandos,;

debug voip ccapi inout

debug dial-peer all   ---> debug voip dialpeer all

debug vpm all

Hice una llamada pero no capturo nada. Alcanza a dar un tono y se corta. Realizé una llamada hacia el exterior  para comprobar que el debug ( y el terminal monitor) funcionase  y se funciona, captura detalles, pero para llamadas entrantes no captura debug.

Saludos cordiales.

Re: LLamadas entrantes y CUCM

Hola,

Al voice port quítale el connection plar opx 2001 y el cptone, y déjalo configurado sólo con el comando connection plar 2001. Si el problema persiste, prueba cambiar la troncal en otro voice port del router.

Saludos.

New Member

Re: LLamadas entrantes y CUCM

Realizé las pruebas, en todos los voice-port agregue solamente el connection plar 2001, pero en todos los puertos fxo el mismo problema.

Saludos.

Re: LLamadas entrantes y CUCM

Ok, tratemos de cambiar la señalización. Trata de poner en el voice-port el comando signal groundStart.

Saludos.

New Member

Re: LLamadas entrantes y CUCM

Hola Adrián;

Gracias por tu respuesta.  Sigo sin solucionarlo.

Me faltará algo en el dial-pattern?   el translation-rule es necesario?   Cuales debería ser  los comando necesarios para que funcionase una llamada entrante en un puerto FXO.

saludos cordiales.

Re: LLamadas entrantes y CUCM

Añade el comando no battery-reversal al voice-port.

Lo necesario es tener el connetion plar y el dialpeer voip apuntando a la IP del CUCM. En el CUCM, tener definido el GW como H.323 y asignarle a este un calling search space que contenga la partición donde reside la extensión 2001.

Saludos.

New Member

Re: LLamadas entrantes y CUCM

Hola Adrián;

En el CUCM esta configurado de esa manera.

Puede ser que el conversor celular que estoy usando no reciba llamados?

Saludos

Re: LLamadas entrantes y CUCM

Podrías validar esa parte.

Lo que me quedaría por decirte que probaras es tal vez un upgrade de IOS o abrir un caso a Cisco TAC para ver si la tarjeta presenta algo anómalo.

Saludos.

Cisco Employee

LLamadas entrantes y CUCM

Hola Leonardo,

Espero te encuentres bien. Si sería bueno colectar los debugs señalados por Adrián. ¿Podrías ingresar a configure terminal desde el voice gateway y ejecutar el comando logging monitor, das enter y luego logging console y enter de nuevo?

Una vez esto hecho, corre los debugs nuevamente y dejanos saber si esta vez si se despliega el output de los debugs.

Los debugs necesitados son:

debug voip ccapi inout

debug dial-peer all

debug vpm all

Saludos,

Felipe Segnini


New Member

LLamadas entrantes y CUCM

Hola Felipe

Como estas?

Realizé las pruebas mencionadas.

Pero solo funciona el debug de salida, para entrantes no muestra nada en consola. Tengo la impresión que es problema del conversor celular.

Como pregunta aparte al topic;

Que sucede si aplico los comandos;

h323-gateway voip interface

h323-gateway voip bind srcaddr x.x.x.x

en una interfaz que esta en producción.  ¿ influye en algo, como por ejemplo corte de servicio?  no es recomendable hacerlo en producción?   o es transparente esa configuración?

saludos cordiales.

Re: LLamadas entrantes y CUCM

Hola,

Esos comandos no tienen impacto alguno. Puedes configurarlos cuando quieras. El comando

h323-gateway voip bind srcaddr x.x.x.x es el único que ocupas en este caso de integración del gw por H.323 hacia el CUCM. Ese comando se utiliza, en teoría, cuando tienes múltiples IPs en el router, de tal forma que el router no origine el tráfico de las llamadas aleatoriamente desde varias IPs ocasionando que el CUCM las pueda rechazar. Pero aunque tengas una sola IP en el rotuer, siempre es un best-practice ponerlo por aquello.

Saludos,

- Adrián.

New Member

Re: LLamadas entrantes y CUCM

Adrian;

Gracias por tu respuesta.

Consulta; en estos momentos iniciaré una migración de varios IP Phones desde un gateway de voz 2921, a  un CUCM 9.1.  ya tengo creado los Router-pattern, grupos, calling-search-space, partitions etc.  El gateway de voz pasará a modo SRST, pero las llamadas deben seguir saliendo y entrando en ese mismo 2921. Agregue el gateway 2921 como gateway h.323 con los comandos;

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.47.219

en la interfaz.   Pero el  CUCM no lo ve.  Mi consulta es;  debo reinicar el gateway 2921 para efectuar los cambios?

Me preocupa porque estos equipos estan en producción y quiero mitigar el menor impacto en la telefonía.

saludos

Re: LLamadas entrantes y CUCM

Cuando utilizas H.323/SIP en GWs, estos no se registran ni se verán registrados en el CUCM por la naturaleza de estos protocolos. El CUCM no tiene el control sobre ellos.

En el CUCM, solamente configura la IP del GW y le das reset. En ese momento verás que pasa de "Unknown Unknown" a "Unknow 192.168.47.219".

Saludos.

.

New Member

Re: LLamadas entrantes y CUCM

Hola Adrián. Gracias.

Al colocar "reset" el 2921 se reinicia?  o es transparente? Me refiero a si habrá una interrupción al servicio.

Actualización:

Aplique el comando, pero sigue saliendo  Unknown Unknown

Saludos.

Re: LLamadas entrantes y CUCM

No, el reset no tiene efecto en la operación del router, es decir, no se va a reiniciar ni nada por el estilo.

Solamente que si el GW en algún momento está manejando llamadas activas (por ende tiene sesiones TCP de señalización con el CUCM a nivel de H.323), es posible que se caígan las llamadas (pero tal vez se puede aplicar preservación de llamadas en H.323 para que esto no suceda). Pero reitero, el reset en el CUCM no reinicia el router.

Saludos.

New Member

Re: LLamadas entrantes y CUCM

Aplique el comando, pero sigue saliendo  Unknown Unknown

Estos comando interfieren con el h.323??? 

sccp local fastEthernet 0/0

sccp ccm 192.168.47.219 identifier 1 version 7.0

sccp

Saludos

Re: LLamadas entrantes y CUCM

Mandamos un screenshot de cómo se ve en el CUCM.

Esos comandos se utilizan para registrar recursos del router en el CUCM utilizando el protocolo SCCP. No tiene relación con H.323.

- Adrián.

New Member

Re: LLamadas entrantes y CUCM

Hola.

Lo adjunto.

Re: LLamadas entrantes y CUCM

En ese screenshot no veo el h.323 gw con IP 192.168.47.219.

New Member

Re: LLamadas entrantes y CUCM

Adrian:

disculpa.  Lo que corresponde a la IP 192.168.47.219 es del gateway y CUCM del laboratorio de  pruebas que tengo.  Ahi funciona bien el H323.

En los equipos en producción, del screenshot que te envíe correponde a esos equipos, y el gateway que agregue, no se logra conectar.

saludos

New Member

Re: LLamadas entrantes y CUCM

los translation- rule impide si una llamada sale  o entra en la comunicación del gateway con el CUCM?

te copio además parte del show run del gateway 2921 ( por políticas dodne trabajo me mandaron eso)

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice call send-alert

voice call disc-pi-off

voice rtp send-recv

!

voice service pots

!

voice service voip

ip address trusted list

  ipv4 10.203.113.xx

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

supplementary-service ringback h225-info

fax protocol t38 nse force version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw

h323

  call start slow

sip

  registrar server expires max 1200 min 300

  no update-callerid

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g729br8

codec preference 3 g711ulaw

codec preference 4 g711alaw

voice class h323 1

  h225 timeout tcp establish 3

  no telephony-service ccm-compatible

  ccm-compatible

!

!

voice register global

mode cme

source-address 10.203.113.xx port 5060

max-dn 50

max-pool 5

authenticate register

authenticate realm all

tftp-path flash:

file text

create profile sync xxxxxxxx

!

voice register dn  6

number 2825

!

voice register dn  17

number 2836

!

voice register pool  1

id mac 5478.1AE1.xxxx

type ATA-187

number 1 dn 6

username ataline1 password ata1

codec g711ulaw

!

voice register pool  2

id mac 781A.E11A.xxxx

type ATA-187

number 1 dn 17

username ataline2 password ata2

codec g711ulaw

!

!

!

voice translation-rule 1

rule 1 /^32443972/ /2/

!

voice translation-rule 2

rule 3 /^2/ /432972/

!

voice translation-rule 3

rule 1 /^9131/ /9310277/

rule 2 /^9132/ /9317606/

rule 3 /^9133/ /9405600/

rule 4 /^9134/ /9312008/

!

voice translation-rule 4

rule 1 /^1/ /9/

!

voice translation-rule 5

rule 1 reject /^.*/

!

voice translation-rule 6

rule 1 /5425/ /2825/

!

!

voice translation-profile Arg-Ch

translate called 5

!

voice translation-profile Ch-Arg

translate called 4

!

voice translation-profile Fix_Auto-Attendant_Fax

translate called 6

!

voice translation-profile NroCompleto

translate calling 2

!

voice translation-profile NroEmergTraducido

translate called 3

!

voice translation-profile SDA-Internos

translate called 1

!

voice translation-profile VTPEmergencias

translate calling 2

translate called 3

!

!

hw-module ism 0

!

hw-module pvdm 0/0

!

!

!

file privilege 0

!

redundancy

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31

!

!

translation-rule 2

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 10.203.115.xx 255.255.255.xx

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.203.115.xx

!

interface ISM0/0

ip unnumbered GigabitEthernet0/0

service-module ip address 10.203.115.xx 255.255.255.xx

!Application: CUE Running on ISM

service-module ip default-gateway 10.203.115.xx

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 10.203.115.xx identifier 1 version 7.0

sccp

!

sccp ccm group 999

bind interface GigabitEthernet0/0

associate ccm 1 priority 1

associate profile 1 register CONFERENCE

associate profile 2 register TRANSCODING

!

dspfarm profile 2 transcode

codec g729abr8

codec g729ar8

codec g711alaw

codec g711ulaw

maximum sessions 5

associate application SCCP

shutdown

!

dspfarm profile 1 conference

codec g729br8

codec g729r8

codec g729abr8

codec g729ar8

codec g711alaw

codec g711ulaw

maximum sessions 4

associate application SCCP

dial-peer voice 800 voip

preference 1

destination-pattern 27..

session target ipv4:10.203.120.xx  ---> ip cucm

voice-class codec 1

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

!

dial-peer voice 901 voip

destination-pattern 2...

session target ipv4:10.203.120.xxx---  ip cucm

voice-class h323 1

!

!

!

!

gatekeeper

shutdown

!

!

telephony-service

sdspfarm units 2

sdspfarm transcode sessions 6

sdspfarm tag 1 TRANSCODING

sdspfarm tag 2 CONFERENCE

conference hardware

video

  maximum bit-rate 2048

max-ephones 30

max-dn 30

ip source-address 10.203.115.xxx port 2000

service phone videoCapability 1

timeouts interdigit 3

system message nnnn

user-locale ES

network-locale ES

load 6921 SCCP69xx.9-2-1-0

time-zone 15

time-format 24

date-format dd-mm-yy

voicemail 2840

max-conferences 8 gain -6

moh "music-on-hold.au"

multicast moh 239.10.16.xxx port 2123

web admin system name

dn-webedit

time-webedit

transfer-system full-consult

secondary-dialtone 9

create cnf-files version-stamp 7960 Nov 21 2013 19:36:16

New Member

Re: LLamadas entrantes y CUCM

Hola

El gateway si se registra al CUCM, solamenente no muestra la IP.  Probe realizando una llamada al IVR que esta en el gateway y la llamada si la redirigue al anexo conectado a CUCM. El problema que tengo es con las llamadas saliente, no se realizan.

Saludos.

Cisco Employee

LLamadas entrantes y CUCM

Hola Leonardo,

Además del problema donde no puedes ver la dirección IP del H.323 gateway en el CallManager, ¿Con qué tipo de llamadas tienes problemas? Salientes desde el CUCM? o entrantes al CUCM?

Saludos,

Felipe Segnini

New Member

LLamadas entrantes y CUCM

Hola Felipe;

Tengo problemas con las llamadas salientes externas ( moviles, local, larga distancia e internacional) por la E1 del gateway de voz llamado "Portes". Las llamadas entre anexos  ( troncales) funcionan y las llamadas entrantes, inclusive el IVR,  funciona.

He descartado que sea problema de route groups  y router list, porque en route group configuration en el members del groups lo cambio por el gateway de otra sucursal, alias "Fruit" y las llamadas salen ( he probado con moviles).

Entonces tengo la impresión que en la comunicación entre el Gateway "Portes" y el CUCM falta agregar algo. Aun cuando el CUCM no muestra la IP del GW Portes, deduzco que el H323 esta funcionando porque las llamadas entrantes se derivan a los anexos conectado al CUCM.

Saludos

8929
Visitas
0
ÚTIL
47
Respuestas
CrearPor favor para crear contenido