cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

No funciona IVR o incoming Call

Hola.

Estoy trabajando en un GW de voz 2921 que va integrado al CUCM 9x.. Los anexos se registran en el CUCM y el GW esta en modo SRST.  Las llamadas salientes funcionan sin ningún problema desde el CUCM hacia el gateway conectado a una E1.  El problema esta en el IVR que se configuró o las llamadas entrantes. Al llamar al cualquiera de los n° asignados por el proveedor de la E1, dice que el número no existe, y viendo parte del debug voice ccapi inout me he dado cuenta en vez de decir dest=2600 dice dest=600 y no sale por el dial-peer 2600 si no por el dial-peer 1 que es donde salen las llamadas.

Dejo copia del debug y parte del show run;

voice#

Dec  4 02:51:14.218: //-1/xxxxxxxxxxxx/CCAPI/ccAppShutdownMode:

   remove it from the queue

Dec  4 02:51:45.118: //-1/D88EFCDA8002/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=

   ----- ccCallInfo IE subfields -----

   cisco-ani=999135052

   cisco-anitype=2

   cisco-aniplan=1

   cisco-anipi=0

   cisco-anisi=3

   dest=600  ----> debería ser 2600

   cisco-desttype=4

   cisco-destplan=1

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

Dec  4 02:51:45.118: //-1/D88EFCDA8002/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x22E7CFF8, Call Info(

   Calling Number=999135052,(Calling Name=)(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),

   Called Number=600 ----> debería ser 2600  (TON=Subscriber, NPI=ISDN),

   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=1,----> debería ser dial-peer=2600 Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1

Dec  4 02:51:45.118: //-1/D88EFCDA8002/CCAPI/ccCheckClipClir:

   In: Calling Number=999135052(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed)

Dec  4 02:51:45.118: //-1/D88EFCDA8002/CCAPI/ccCheckClipClir:

   Out: Calling Number=999135052(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed)

Dec  4 02:51:45.118: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Dec  4 02:51:45.118: :cc_get_feature_vsa malloc success

Dec  4 02:51:45.118: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Dec  4 02:51:45.118:  cc_get_feature_vsa count is 1

Dec  4 02:51:45.118: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Dec  4 02:51:45.118: :FEATURE_VSA attributes are: feature_name:0,feature_time:599716064,feature_id:3

Dec  4 02:51:45.118: //3/D88EFCDA8002/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=999135052(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),

   Called Number=600(TON=Subscriber, NPI=ISDN))

Dec  4 02:51:45.118: //3/D88EFCDA8002/CCAPI/cc_process_call_setup_ind:

   Event=0x3D3225D8

Dec  4 02:51:45.118: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 600

Dec  4 02:51:45.118: //3/D88EFCDA8002/CCAPI/ccCallSetContext:

   Context=0x23BF1BEC

Dec  4 02:51:45.118: //3/D88EFCDA8002/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 3 with tag 1 to app "_ManagedAppProcess_Default"

Dec  4 02:51:45.122: //3/D88EFCDA8002/CCAPI/ccCallProceeding:

   Progress Indication=NULL(0)

Dec  4 02:51:45.122: //3/D88EFCDA8002/CCAPI/ccCallDisconnect:

   Cause Value=1, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Dec  4 02:51:45.122: //3/D88EFCDA8002/CCAPI/ccCallDisconnect:

   Cause Value=1, Call Entry(Responsed=TRUE, Cause Value=1)

Dec  4 02:51:45.122: //3/D88EFCDA8002/CCAPI/cc_api_get_transfer_info:

   Transfer Number=NULL

Dec  4 02:51:45.326: //3/D88EFCDA8002/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x22E7CFF8, Tag=0x0, Call Id=3,

   Call Entry(Disconnect Cause=1, Voice Class Cause Code=0, Retry Count=0)

Dec  4 02:51:45.326: //3/D88EFCDA8002/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

Dec  4 02:51:45.326: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Dec  4 02:51:45.326: :cc_free_feature_vsa freeing 23BEF0D8

Dec  4 02:51:45.326: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Dec  4 02:51:45.326:  vsacount in free is 0

2921-voice#

-------------------------- show run------------------------

voice translation-rule 1

rule 1 /.*/ /2542600/  -----> inicio n° asignao por el proveedor E1

!

voice translation-rule 2

rule 1 /^254/ //

!

!

voice translation-profile Anexos

translate called 2

!

voice translation-profile Cabecera

translate calling 1

!

!

!

!

application

service script2 flash:script2.tcl

!

service script3 flash:script3.tcl

!

service aa flash:its-CISCO.2.0.1.0.tcl

  param operator 2601

  paramspace english language en

  paramspace english index 0

  paramspace english location flash://

  param menu-timeout 1

  paramspace english prefix en

  param max-extension-length 4

  param aa-pilot 2600

!

service AA-Duke flash:script3.tcl

!

!

voice-port 0/0/0:15

translation-profile incoming Anexos

translation-profile outgoing Cabecera

!

!

!

!

!

!

mgcp profile default

!

!

dial-peer voice 1 pots

destination-pattern 9T

port 0/0/0:15

!

dial-peer voice 2 voip

destination-pattern 2...

session target ipv4:10.203.120.xxx

dtmf-relay rtp-nte h245-alphanumeric

!

dial-peer voice 2600 pots

description AutoAttendant

service aa

incoming called-number 2600

direct-inward-dial

port 0/0/0:15

---------------

Muchas gracias.

4 SOLUCIONES ACEPTADAS

Soluciones aceptadas
Cisco Employee

No funciona IVR o incoming Call

Hola Leonardo,

Podrias realizar lo siguiente:

1. Correr los siguientes comandos:

application

no service aa flash:its-CISCO.2.0.1.0.tcl

y luego volver a realizar la configuración:

service aa flash:its-CISCO.2.0.1.0.tcl

  param operator 2601

  paramspace english language en

  paramspace english index 0

  paramspace english location flash://

  param menu-timeout 1

  paramspace english prefix en

  param max-extension-length 4

  param aa-pilot 2600

Déjame saber si esto te ayuda en algo. Si mal no recuerdo, tu ya tenías una configuración IVR funcionando en otro router cierto?

Saludos,

Felipe Segnini

Cisco Employee

No funciona IVR o incoming Call

Hola Leonardo,

Es correcto. Me parece que tienes que agregar las mismas configuraciones de aa en AA-Duke. ¿Ya lo intentaste?

Saludos,

Felipe Segnini

Cisco Employee

No funciona IVR o incoming Call

Es un mensaje genérico. Nada de que preocuparse. Siempre te va a salir.

Saludos,

Felipe Segnini

New Member

No funciona IVR o incoming Call

A mi parecer creo que hay un problema de la señalización de los últimos 4 digitos que deberías de estar recibiendo sobre la E1.

controller E1 0/0/0

framing NO-CRC4

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

  country telmex

  category 2

  answer-signal group-b 1

  caller-digits 4

  trunk-group PSTN

description ENLACE HACIA PSTN

controller E1 0/0/0

framing NO-CRC4

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

  country telmex

  category 2

  answer-signal group-b 1

  caller-digits 4   ---> ESTE PARAMETRO A MI GUSTO ES EL QUE TE HACE FALTA.

    trunk-group PSTN

description ENLACE HACIA PSTN

22 RESPUESTAS

No funciona IVR o incoming Call

Hi

Try to change for this:

!

voice translation-rule 1

rule 1 /^2542\(...$\)/ /2\1/

!

!

voice translation-profile CalledNumber

translate calling 1

Best Regards,

Daniel

Daniel Sobrinho
New Member

Re: No funciona IVR o incoming Call

Hi.

Modify the changes, but did not work.

What if change was the following rule;

voice translation-rule 2

rule 1 /^254/ //                      by   / / /2/   --> associated to voice translation-profile Annexes

                                                                                      translate called 2

                                                                                      voice-port 0/0/0: 15

                                                                                         translation-profile incoming Annexes

and it worked.

for example;

The extension is 2644. Direct calling pstn number 2542644, received the call directly at extension 2644.

It does not work even with the IVR extension 2600 (2542600) is answered automatically when receiving a call.

Regards.

---------------------------------------------------------------------

Modifique los cambios, pero no funcionó.    Lo que si modifique fue la siguiente regla;

voice translation-rule 2

rule 1 /^254/ //      por    // /2/       ---->>>                 asociada al  voice translation-profile Anexos

                                                                            translate called 2

                                                                            voice-port 0/0/0:15

                                                                             translation-profile incoming Anexos

De esa manera, funcionó.

Por ejemplo;

La extension es 2644. Llamando al número directo de la pstn 2542644, se recibe la llamada directamente en la extensión 2644.

Sigue sin funcionar aún que el IVR con la extensión 2600 (2542600) sea contestado automaticamente al recibir una llamada.

saludos.

Cisco Employee

No funciona IVR o incoming Call

Hola Leonardo,

Un placer saludarte nuevamente. Una consulta, ¿Cúal es el número completo que marca el usuario externo para llegar al IVR?

Saludos,

Felipe Segnini

New Member

Re: No funciona IVR o incoming Call

Hola Felipe;

Muchas gracias por tu saludo, de igual manera mi saludos correspondiente.

El número asignado por el proveedor E1 es el:  Código de área 43  y el n° 2542600 al 2542699.

Si alguíen llama a cualquiera del rango 2542601 - 2542699 la llamada es atendida directamente por el extensión 2601 al 2699 según corresponda. Lo que no funciona es la extensión 2600 (2542600), si bien se contesta la llamada, el archivo.au que debería responder (IVR) no se escucha nada.

Saludos cordiales.

Cisco Employee

Re: No funciona IVR o incoming Call

Gracias por la información Leo, como tu mencionas, al parecer la llamada no esta utilizando el dial-peer correcto debido a que el número llega como 600 al lugar de 2600. Una prueba que podrias realizar es modificar el siguiente dial-peer con esta configuración y ver si hace alguna diferencia:

dial-peer voice 2600 pots

description AutoAttendant

service aa

incoming called-number 600

direct-inward-dial

port 0/0/0:15

Esto seria a modo de prueba, con el fin de confirmar que la llamada falla debido a los digitos del called number.

Saludos,

Felipe Segnini

New Member

Re: No funciona IVR o incoming Call

Realizé los cambios, mi dice que no existe.

Como dato;

Hace  un rato, modifiqué el translation-rule 2 a:

//  /2/

De esta forma se solucionó que anteriormente en el debug el destino era 600 , ahora sale 2600  y el dial-peer también es el que debe ser, el 2600.  Ahora, sucede que si llamo al 2542600 la llamada es contestada  pero no se escucha la grabación de bienvenida (IVR). 

Saludos

Cisco Employee

Re: No funciona IVR o incoming Call

Entendido Leonardo, podrias darnos nuevamente el debug voip ccapi inout y el output del comando show flash?

Saludos,

Felipe Segnini

New Member

Re: No funciona IVR o incoming Call

Ok, recopilaré esa información.

Mientras tanto; realizé  una  prueba.  Dede mi teléfono celular llamé al 254600, como la llamada se contesta pero no se escucha nada, dejé transcurrir 10 segundo y marque ( estando la llamada al 254600 activa) al la extensión 2644 y se hubo comunicación.

¿Será un problemade de codec?  porque cuando espere los 10 segundo se escucha algo de ruido, no voz, sino un poco de ruido.

saludos

Cisco Employee

Re: No funciona IVR o incoming Call

Es posible que si hay un problema de Codec. Sabes que codec se utiliza?

Saludos,

Felipe Segnini

New Member

Re: No funciona IVR o incoming Call

Hola.

Los  codec son:

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

Adjunto debug.

Cisco Employee

No funciona IVR o incoming Call

Hola Leonardo,

Espero te encuentres bien. Podrías adicional adjuntar el output de los siguientes comandos durante una prueba: 'call history voice' y 'debug voip application script'.

Adicional, el output del show command de los siguientes comandos:

show call application voice summary

show flash

Saludos,

Felipe Segnini

New Member

Re: No funciona IVR o incoming Call

Hola felipe.

Adjunto la información solicitada.

El único comando que no funciona es el "call history voice"

Saludos

Cisco Employee

No funciona IVR o incoming Call

Hola Leonardo,

Podrias realizar lo siguiente:

1. Correr los siguientes comandos:

application

no service aa flash:its-CISCO.2.0.1.0.tcl

y luego volver a realizar la configuración:

service aa flash:its-CISCO.2.0.1.0.tcl

  param operator 2601

  paramspace english language en

  paramspace english index 0

  paramspace english location flash://

  param menu-timeout 1

  paramspace english prefix en

  param max-extension-length 4

  param aa-pilot 2600

Déjame saber si esto te ayuda en algo. Si mal no recuerdo, tu ya tenías una configuración IVR funcionando en otro router cierto?

Saludos,

Felipe Segnini

New Member

No funciona IVR o incoming Call

Hola Felipe.

Mucgas gracias por tu respuesta, Realizé los cambios que mencionaste, pero siguíó sin resultar.  Pero, esto me hizo dar una idea y  se me ocurrió hacer  lo siguiente;

Como tengo la siguiente configuración.;

application

service script2 flash:script2.tcl

!

service script3 flash:script3.tcl

!

service aa flash:its-CISCO.2.0.1.0.tcl

  param operator 2601

  paramspace english language en

  paramspace english index 0

  paramspace english location flash://

  param menu-timeout 1

  paramspace english prefix en

  param max-extension-length 4

  param aa-pilot 2600

!

service AA-Duke flash:script3.tcl

Revisando los script, me di cuenta que el its-CISCO.2.0.1.0.tcl no tenía los archivos necesarios de audio, entonces revise el script 2 y 3 que tienen la misma configuración y me di cuenta que sí tenía los archivos.

Entonces, lo que hize en el dial-peer voice 2600 pots fue borrar el service "aa"  y colocar el service "AA-Duke" y con desde el modo EXEC con el comando call voice application load AA-Duke ( algo así si mal no recuerdo).

De esa manera, ahora al recibir la llamada se escucha el audio que dice "bienvenido a... etc..".

Lo único que me falta por solucionar, que durante el audio dice "...Si no conoce el anexo, espere en linea y será atendido...". y automaticamente debería irse la llamada al anexo 2601, pero no lo hace, sino que vuelve a repetir el audio una vez más.

Como consulta;  ¿ debo agregar las misma configuración del service aa en el service AA-Duke?

Efectivamente esta misma configuración la tengo en otro 2921 que funciona todo OK.

Lo extraño de todo, que en el otro GW 2921 funciona bien estando el service "aa" activado en el dial-peer correspondiente y con el  script its-CISCO.2.0.1.0.tcl, pero en este GW no sucede.  Tuve que hacer las modificaciones antes mencionadas.

Saludos.

Cisco Employee

No funciona IVR o incoming Call

Hola Leonardo,

Es correcto. Me parece que tienes que agregar las mismas configuraciones de aa en AA-Duke. ¿Ya lo intentaste?

Saludos,

Felipe Segnini

New Member

No funciona IVR o incoming Call

Estoy realizando las conf.

Que significa que salga este mensaje?

2921-Vo(config-app-param)# param operator 2601

Warning: parameter operator has not been registered under AA-Duke namespace

Saludos.

Cisco Employee

No funciona IVR o incoming Call

Es un mensaje genérico. Nada de que preocuparse. Siempre te va a salir.

Saludos,

Felipe Segnini

New Member

No funciona IVR o incoming Call

Hola.

Realizé las mismas configuraciones del service aa al service AA-Duke , pero no dió resultado .

cual debería ser la configuración ideal para que una llamada que es contestada por el IVR  y pasado unos segundo se redirige automaticamente a un anexo?.

saludos

New Member

No funciona IVR o incoming Call

A mi parecer creo que hay un problema de la señalización de los últimos 4 digitos que deberías de estar recibiendo sobre la E1.

controller E1 0/0/0

framing NO-CRC4

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

  country telmex

  category 2

  answer-signal group-b 1

  caller-digits 4

  trunk-group PSTN

description ENLACE HACIA PSTN

controller E1 0/0/0

framing NO-CRC4

line-termination 75-ohm

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

  country telmex

  category 2

  answer-signal group-b 1

  caller-digits 4   ---> ESTE PARAMETRO A MI GUSTO ES EL QUE TE HACE FALTA.

    trunk-group PSTN

description ENLACE HACIA PSTN

New Member

No funciona IVR o incoming Call

Hola

  Se solucionó el problema.  Era simple.   El problema que no se escuchaba el audio era que el archivo tcl tenía que agregar el "flash:".

Muchas gracias por las soluciones antes mencionada,

Saludos.

Re: No funciona IVR o incoming Call

Hola Leonardo;

Lei el post y tengo el mismo problema que tu repersentas, entiendo que lo solucionaste agregando "flash" al archivo tcl? esta parte no la comprendo para poder aplicarlo a mi central, es decir tuviste que modificar el script del archivo .tcl o por el contrario agregaste una linea de comando en el servicio de application? te agradesco si me das una mano con este tema.

Gracias y saludos.

New Member

Re: No funciona IVR o incoming Call

hola.

Cuando me refiero al flash, es porque el archivo tlc se agrega en la memoria del gateway, entonces la ruta que tenía en el tcl no tenía agregado el flash, lo agrege editando la linea que corresponde en el archivo TLC y se solucionó el problema. 

Saludos.

684
Visitas
15
ÚTIL
22
Respuestas