Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Adding remote access to existing site to site

Have 4 locations with ASA5505 in each location.  There are site to site VPN's between each location.  I want to add a remote access VPN connection to the main location but I'm having some issues.  I followed the http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a00807f9a89.shtml#newra document but I must be missing something.  I see in the logs a message that reads no matching crypto map entry for remote proxy.  I've attached my config below, if anyone can take a look and possibly point me to where I'm going wrong I would appreciate it.

Result of the command: "sh conf"

: Saved
: Written by enable_15 at 13:11:52.506 UTC Mon Sep 20 2010
!
ASA Version 8.2(3)
!
hostname Water-Plant
enable password 8kKEtnVQkY8wlIk2 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
speed 10
duplex half
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.13.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address xx.xx.xx.xx  255.255.255.240
!
banner login This device is property of the Village of Archbold.  Unauthorized access is prohibited.
boot system disk0:/asa823-k8.bin
ftp mode passive
same-security-traffic permit intra-interface
access-list CCNO_cryptomap extended permit ip 192.168.13.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.13.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.13.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.13.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.13.0 255.255.255.0 192.168.130.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.130.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.130.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.130.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list Booster_cryptomap extended permit ip 192.168.13.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list Tower_cryptomap extended permit ip 192.168.13.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_in extended permit udp any 192.168.13.0 255.255.255.0 eq 44818
access-list outside_in extended permit tcp any 192.168.13.0 255.255.255.0 eq 44818
access-list outside_in extended permit udp any 192.168.13.0 255.255.255.0 eq 2222
access-list outside_in extended permit tcp any 192.168.13.0 255.255.255.0 eq 2222
access-list outside_20_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_30_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list outside_40_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list RemoteAccess_splitunnel standard permit 192.168.13.0 255.255.255.0
access-list RemoteAccess_splitunnel standard permit 192.168.10.0 255.255.255.0
access-list RemoteAccess_splitunnel standard permit 192.168.11.0 255.255.255.0
access-list RemoteAccess_splitunnel standard permit 192.168.12.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool RAVPNPOOL 192.168.130.10-192.168.130.15 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-633.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list Inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_in in interface outside
route outside 0.0.0.0 0.0.0.0 209.173.175.65 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.13.0 255.255.255.0 inside
http 63.171.17.0 255.255.255.0 outside
http 192.168.10.0 255.255.255.0 inside
http 192.168.11.0 255.255.255.0 inside
http 192.168.12.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set Remote-trans esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 20 set transform-set Remote-trans
crypto dynamic-map dyn_map 20 set reverse-route
crypto map VPN_map 10 match address CCNO_cryptomap
crypto map VPN_map 10 set peer xx.xx.xx.xx
crypto map VPN_map 10 set transform-set ESP-3DES-SHA
crypto map VPN_map 40 match address Booster_cryptomap
crypto map VPN_map 40 set peer xx.xx.xx.xx
crypto map VPN_map 40 set transform-set ESP-3DES-SHA
crypto map VPN_map 50 match address Tower_cryptomap
crypto map VPN_map 50 set peer xx.xx.xx.xx
crypto map VPN_map 50 set transform-set ESP-3DES-SHA
crypto map VPN_map interface outside
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 5
dhcpd auto_config outside
!
dhcpd address 192.168.13.11-192.168.13.20 inside
dhcpd dns 209.143.0.10 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy RemoteAccess internal
group-policy RemoteAccess attributes
dns-server value 209.143.0.10
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value RemoteAccess_splitunnel
username mlyons password cnBZwUQB520wEhmn encrypted
tunnel-group xx.xx.xx.xx type ipsec-l2l
tunnel-group xx.xx.xx.xx ipsec-attributes
pre-shared-key *
tunnel-group xx.xx.xx.xx type ipsec-l2l
tunnel-group xx.xx.xx.xx ipsec-attributes
pre-shared-key *
tunnel-group xx.xx.xx.xx type ipsec-l2l
tunnel-group xx.xx.xx.xx ipsec-attributes
pre-shared-key *
tunnel-group RemoteAccess type remote-access
tunnel-group RemoteAccess general-attributes
address-pool RAVPNPOOL
default-group-policy RemoteAccess
tunnel-group RemoteAccess ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
call-home
profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:90f03621b08fc3bc0c5e7950cc4a374f

10 REPLIES
Cisco Employee

Re: Adding remote access to existing site to site

one thing that i find wrong is this

crypto dynamic-map outside_dyn_map 20 set transform-set Remote-trans
crypto dynamic-map dyn_map 20 set reverse-route

the 2 crypto maps do not match

secondly from where are you trying to initiate the tunnel

try using this command

crypto isakmp nat-traversal

if possible please paste the debugs

Re: Adding remote access to existing site to site

Ok , there's two things that you need to fix :-

1> as jathaval mentioned , fix the typo.

2> remove :-

crypto map outside_map  65535 ipsec-iskamp dynamic outside_dyn_map

with :-

crypto map VPN_map 65535 ipsec-iskamp dynamic outside_dyn_map

you might need to remove the crypto map from outside interface and then reply it if it doesnt work for you.

Thanks

Manish

Cisco Employee

Re: Adding remote access to existing site to site

oop's dunno how i missed that : ) thx manish

Community Member

Re: Adding remote access to existing site to site

Thank you both, not sure how I missed those either.  I have repaired those two items, the VPN tunnel connects now and I can ping the device I need to on the 192.168.13.0 network, but I must still have something wrong as I cannot ping anything on the other devices.  I've posted the HQ config again with changes.  What am I missing that would not allow access to the other networks?

Result of the command: "sh conf"

: Saved
: Written by enable_15 at 17:34:20.236 UTC Mon Sep 20 2010
!
ASA Version 8.2(3)
!
hostname Water-Plant
enable password 8kKEtnVQkY8wlIk2 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
speed 10
duplex half
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.13.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address xx.xx.xx.xx 255.255.255.240
!
banner login This device is property of the Village of Archbold.  Unauthorized access is prohibited.
boot system disk0:/asa823-k8.bin
ftp mode passive
same-security-traffic permit intra-interface
access-list CCNO_cryptomap extended permit ip 192.168.13.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.13.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.13.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.13.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.13.0 255.255.255.0 192.168.130.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.130.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.130.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list Inside_nat0_outbound extended permit ip 192.168.130.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list Booster_cryptomap extended permit ip 192.168.13.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list Tower_cryptomap extended permit ip 192.168.13.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_in extended permit udp any 192.168.13.0 255.255.255.0 eq 44818
access-list outside_in extended permit tcp any 192.168.13.0 255.255.255.0 eq 44818
access-list outside_in extended permit udp any 192.168.13.0 255.255.255.0 eq 2222
access-list outside_in extended permit tcp any 192.168.13.0 255.255.255.0 eq 2222
access-list outside_20_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_30_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list outside_40_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list RemoteAccess_splitunnel standard permit 192.168.13.0 255.255.255.0
access-list RemoteAccess_splitunnel standard permit 192.168.10.0 255.255.255.0
access-list RemoteAccess_splitunnel standard permit 192.168.11.0 255.255.255.0
access-list RemoteAccess_splitunnel standard permit 192.168.12.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool RAVPNPOOL 192.168.130.10-192.168.130.15 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-633.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list Inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_in in interface outside
route outside 0.0.0.0 0.0.0.0 xx.xx.xx.xx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.13.0 255.255.255.0 inside
http 63.171.17.0 255.255.255.0 outside
http 192.168.10.0 255.255.255.0 inside
http 192.168.11.0 255.255.255.0 inside
http 192.168.12.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set Remote-trans esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map outside_dyn_map 20 set transform-set Remote-trans
crypto dynamic-map outside_dyn_map 20 set reverse-route
crypto map VPN_map 10 match address CCNO_cryptomap
crypto map VPN_map 10 set peer xx.xx.xx.xx
crypto map VPN_map 10 set transform-set ESP-3DES-SHA
crypto map VPN_map 40 match address Booster_cryptomap
crypto map VPN_map 40 set peer xx.xx.xx.xx
crypto map VPN_map 40 set transform-set ESP-3DES-SHA
crypto map VPN_map 50 match address Tower_cryptomap
crypto map VPN_map 50 set peer xx.xx.xx.xx
crypto map VPN_map 50 set transform-set ESP-3DES-SHA
crypto map VPN_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map VPN_map interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 5
dhcpd auto_config outside
!
dhcpd address 192.168.13.11-192.168.13.20 inside
dhcpd dns 209.143.0.10 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy RemoteAccess internal
group-policy RemoteAccess attributes
dns-server value 209.143.0.10
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value RemoteAccess_splitunnel
username mlyons password cnBZwUQB520wEhmn encrypted
tunnel-group xx.xx.xx.xx type ipsec-l2l
tunnel-group xx.xx.xx.xx ipsec-attributes
pre-shared-key *
tunnel-group xx.xx.xx.xx type ipsec-l2l
tunnel-group xx.xx.xx.xx ipsec-attributes
pre-shared-key *
tunnel-group xx.xx.xx.xx type ipsec-l2l
tunnel-group xx.xx.xx.xx ipsec-attributes
pre-shared-key *
tunnel-group RemoteAccess type remote-access
tunnel-group RemoteAccess general-attributes
address-pool RAVPNPOOL
default-group-policy RemoteAccess
tunnel-group RemoteAccess ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
call-home
profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:60de1e2c0e5b3e2cf96696830d81aa84

I did put the opposite access-list commands on the other 5505's

access-list outside_20_cryptomap extended permit ip 192.168.10.0 255.255.255.0 192.168.130.0 255.255.255.0 
access-list outside_30_cryptomap extended permit ip 192.168.11.0 255.255.255.0 192.168.130.0 255.255.255.0
access-list outside_40_cryptomap extended permit ip 192.168.12.0 255.255.255.0 192.168.130.0 255.255.255.0

Maybe these are incorrect as well, not sure.

Re: Adding remote access to existing site to site

Umm,

ok ... remove :-

access-list outside_20_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_30_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list outside_40_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.12.0 255.255.255.0

On both ends .....

add :-

access-list CCNO_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.11.0 255.255.255.0

access-list Booster_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list Tower_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.10.0 255.255.255.0

make sure you create the mirror acl on remote ends.

Thanks

Manish

Community Member

Re: Adding remote access to existing site to site

I removed the following on the Water_Plant ASA

access-list outside_20_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list outside_30_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.11.0 255.255.255.0
access-list outside_40_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.12.0 255.255.255.0

and replaced with

access-list CCNO_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.11.0 255.255.255.0

access-list Booster_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.12.0 255.255.255.0
access-list Tower_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.10.0 255.255.255.0

On the CCNO ASA then would I need all the commands or just

access-list CCNO_cryptomap extended permit ip 192.168.130.0 255.255.255.0 192.168.11.0 255.255.255.0

or should it be

access-list CCNO_cryptomap extended permit ip 192.168.11.0 255.255.255.0 192.168.130.0 255.255.255.0

Sorry for the questions but I'm a little confused on this.

thanks!

Re: Adding remote access to existing site to site

Just one :-

access-list CCNO_cryptomap extended permit ip 192.168.11.0 255.255.255.0 192.168.130.0 255.255.255.0

similarly on other asa's just add one command :-

access-list whatever permit ip 192.168.12.0 255.255.255.0 192.168.130.0 255.255.255.0

Hope it helps

Manish

Community Member

Re: Adding remote access to existing site to site

Thanks for all your help, I was finally able to get it working.  Can now connect to VPN at Water Plant and access all of the other 3 locations.

Thanks again!

Re: Adding remote access to existing site to site

Ok, conside this water_pump is the hub for Remote VPN server and rest are spokes that users need to connect after they establish remote connection to your water_pump hub site.

so for ex, if water_pump site has a subnet 1.1.1.x/24 (LAN) and 1.1.2.x/24 (remote vpn ) and one of your hun site ccno with 2.2.2.x/24 subnet.

so when a user connects to water_pump remote vpn he gets an ip address 1.1.2.x and wants to access something on ccno  then you will need a nonat for that ip address ( which you have in ur case ) but you also need that remote subnet to be a part the existing site to site interesting traffic.

Incase you dont get it just post your configuration for all sites and we will fix it over here.

and the answer is yes to your question. all you need to do is add another subnet in the intersecting traffic access-list.

Thanks

Manish

Re: Adding remote access to existing site to site

Good to hear that

thanks

manish

399
Views
0
Helpful
10
Replies
CreatePlease to create content