Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Anyconnect behaviour customized XML

Hi All,

I have created a new xml with special features.

- I don't want local access for my users

- They can decide to use the start before login feature but default set to FALSE

When we have rolled out the client we also provide the xml file in the directory

C:\ProgramData\Cisco\Cisco AnyConnect Secure Mobility Client\Profile

The XML is build like

<ClientInitialization>

<UseStartBeforeLogon UserControllable="true">false</UseStartBeforeLogon>

<LocalLanAccess UserControllable="false">false</LocalLanAccess>

other settings...

</ClientInitialization>

It seems that the anyconnect client grabs the file, because default it starts with the XML that's located in the profile directory. It's showing the default name and connects to the ASA.

The problem that we facing is that it's still shows the options (step 1.png).

step 1.png

When you connect it's reading the XML file. And it is giving me the right behaviour! The settings are shown like configured. (step 2.png)

step2.png

It has not downloaded the XML of the ASA because I am not connected to the internet!

Does anyone ran into this same problem? Is this a bug? I was presuming that the whole XML file in the profile directory was being read by the Anyconnect server. It seems that it doesn't...

I hope that I'm doing something wrong, maybe that one of you can help me out.

I have tested this on version 3.05 and 3.07 anyconnect secure mobility client. I checked the documentation regarding customization to figure out to get this working.

regards,

Sander

Everyone's tags (4)
318
Views
0
Helpful
0
Replies
CreatePlease login to create content