Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Anyconnect certificate password issue

I have VPN access setup on a Small Business RVS4000 and can connect computers to it just fine using QuickVPN.

I have Anyconnect installed on an Android device and when I try to import the certificate I generated from the RVS4000, a password prompt pops up. 

I never specified a password for this certificate.  Is there a default one I can use?  I've tried the user passwords, admin password for the router, admin, password, and even 1234.

The certificate is a .pem file.

6 REPLIES

Anyconnect certificate password issue

Are you sure u didn't specify password? What if you press ok with empty passwd?

New Member

Anyconnect certificate password issue

I tried that as well, but it didn't take.

Cisco Employee

Anyconnect certificate password issue

I was looking around and found an internal defect that you cannot see so I am going to paste the inside content for your reference:

AnyConnect does not allow import of PKCS12 bundles with blank passwords

Symptom:

When importing a certificate bundle with a blank password, AnyConnect will indefinitely prompt for the password as if the password was incorrect.

Conditions:

The certificate bundle must have a blank password.

Workaround:

Set a password on the bundle when exporting or creating it, and use that password when importing the bundle into AnyConnect.

~BR
Jatin Katyal

**Do rate helpful posts**

~BR Jatin Katyal **Do rate helpful posts**
New Member

Has someone tried this ?If it

Has someone tried this ?

If it is working, why nobody updated the documentation ? :(

It would save days...

 

New Member

Hi, can you explain how to

Hi, can you explain how to set a password on a certificate from the RV180. I am unable to import the pem file into Anyconnect since I also do not know the password.

New Member

I have tested this using the

!

3324
Views
9
Helpful
6
Replies