Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Anyconnect install problem

                  We are seeing an install problem with the AnyConnect Secure Mobility Client under Windows 7. The installer stalls after a minute or so then reports:

There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected.

There has been no other install issue on these machines and we have reinstalled Windows 7 to insure that the Installer is robust.

Please advise.

D Miller

Everyone's tags (2)
13 REPLIES
Hall of Fame Super Silver

Anyconnect install problem

How are you deploying? Pre-deployment using the installer in the ISO file (anyconnect-win-3.1.01065-pre-deploy-k9.iso) or via a pkg file (anyconnect-win-3.1.01065-k9.pkg) from the ASA?

I've used both successfully on Windows 7 clients.

New Member

Anyconnect install problem

Just running the downloadable exe on a local machine. Any thoughts on a workaround?

Dennis

Hall of Fame Super Silver

Anyconnect install problem

Which file are you using specifically? The current AnyConnect pre-deploy file for VPN clients is not an .exe - it is an .msi file:

     anyconnect-win-3.1.00495-pre-deploy-k9.msi

...which is extracted from the .iso (anyconnect-win-3.1.01065-pre-deploy-k9.iso) available for download from Cisco.com here.

New Member

Anyconnect install problem

Yes, sorry. We have that MSI file - it also hangs up right after reporting "installing services"  then backs out and quits. Same message as with the earlier 3.0. Very frustrating.

Please let me know if you have any other suggestions.

Best,

Dennis

Anyconnect install problem

Hi Dennis,

Do you disable any FW / AV during this test?

Are you doing it as an Administrator?

How many computers experience the issue? Same configuration?

What if you try through the WebVPN portal?

Please try the silent installation:

"msiexec /i specific_AnyConnect.msi /norestart /quiet /lvx* install-log.txt"

Let us know.

Thanks.

Portu.

Please rate any helpful posts

New Member

Anyconnect install problem

I am also having this same issue since upgrading from XP to Win7 and the quiet install isn't working.

anyconnect-win-3.0.5080-web-deploy-k9.exe is the stand alone I download after the web-based install fails.

New Member

Anyconnect install problem

Experiencing the same issue here. Running Windows 7 x64 and am an administrator. I have checked the registry for the RunOnce key and confirmed it is there. I have also tried running the installer silently with the same result.

Trying to install 3.0.5080 msi.

New Member

Anyconnect install problem

Same problem here on Windows 8 with anyconnect-win-3.1.02026-pre-deploy-k9.msi.


I ran "msiexec /i anyconnect-win-3.1.02026-pre-deploy-k9.msi /norestart /quiet /lvx* install-log.txt"

The results can be found here: http://devgem.be/install-log.txt

Any help is appreciated.

New Member

Anyconnect install problem

I ran into a similar issue installing anyconnect 2.5 a while back and installing it with a NOISNTALLACTIVEX=1 at a CMD line resolved it.  Perhaps this will work for 3.0 as well

msiexec /i anyconnect-win-x.x.x-pre-deploy-k9.msi NOINSTALLACTIVEX=1

New Member

Anyconnect install problem

Has anyone resolved this issue.. seems i can install 2.5 versions but every newer vers 3.0 and up Fails at the same Point.

New Member

Anyconnect install problem

Hi All,

Even i get the same error messge. kindly suggest and help.

New Member

Anyconnect install problem

Team - I have been having the same issue of not being able to install on Windows 7. It gives the same install error. Any final resolution? Thank you

New Member

Anyconnect install problem

I am experiencing the same problem, and have tried the following options:

  1. Disabled all HIPS in my local machine and ran the installation with administrator privileges
  2. Tried to install anyconnect-win-3.0.5080-web-deploy-k9.exe from the ASA
  3. Tried to install anyconnect-win-3.0.08057-pre-deploy-k9.msi, because version 3.0.5080 is not available to download from Cisco anymore (version 3.0.08057 is the oldest one that can be downloaded from Cisco)
  4. Tried to install anyconnect-win-3.0.08057-pre-deploy-k9.msi with the NOINSTALLACTIVEX=1 option
  5. Tried to install anyconnect-win-3.0.08057-pre-deploy-k9.msi with the/norestart /quiet /lvx* install-log.txt options

But none of them worked

As a workaround, I manually downloaded anyconnect-win-3.1.04072-pre-deploy-k9.iso from Cisco and the install was successful. However, it seems that not all of the ASAs are configured to allow this version, just older versions

Has anybody found a solution yet?

17191
Views
0
Helpful
13
Replies