Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AnyConnect Linux 2.2.0136 - Unable to launch secure desktop

Hi,

running AnyConnect Linux client version 2.2

Using SLAX, and have also tried Slackware 12.1

I'm having problems getting connected to my ASA device. With the Windows and Mac client is works okay - but I have not been able to get a Linux client to work.

I was originally having issues with the "server certificate" which I solved by copying several missing libraries into place, but now when I try to run ./vpn connect {IP address} I get the following error:

notice: downloading Cisco Secure Desktop...

VPN> Java installation has not been found. Make sure Java is installed and environment variable JAVA_HOME is properly set

>> error: Unable to launch Cisco Secure Desktop. If you are already on the Secure Desktop, use the "Launch Login Page" button on the desktop

Any suggestions? I have tried with JRE 1.5 and 1.6 as we as the SE package (basically developers)

I've set the JAVA_HOME variable and updated the path in /etc/profile (using back)

I can echp $JAVA_HOME and it returns correctly, and I can also use 'java -version' and 'which java' from anywhere and it acts properly

I've even confirmed that it is registered properly in the browsers, and is detected if I visit a "test my java" type site.

Looking for suggestions now

Thanks!

2 REPLIES
Bronze

Re: AnyConnect Linux 2.2.0136 - Unable to launch secure desktop

Following steps may you in installing the AnyConnect client on a system Running Linux:

Step 1 : For Linux, the client files are contained in a tar/gz file. Unpack the archive with a tar command. For example:

tar xvzf AnyConnect-Linux-Release-2.2.xxxx.tar.gz

The files necessary for installation are placed in the folder ciscovpn.

Step 2 : Change to the ciscovpn folder. As a root user, run the script named vpn_install.sh. For example:

[root@linuxhost]# cd ciscovpn

[root@linuxhost]# ./vpn_install.sh

The client installs in the directory /opt/cisco/vpn. This script also installs the daemon vpnagentd and sets it up as a service that is automatically started when the system boots.

After installing the client, you can start the client manually with the Linux command /opt/cisco/vpn/bin/vpnui or with the client CLI command /opt/cisco/vpn/bin/vpn

New Member

Re: AnyConnect Linux 2.2.0136 - Unable to launch secure desktop

Hi bwilmoth,

Yup - no problems installing it.

The problems I am seeing (and the output) actually comes from running from the command prompt (/opt/cisco/vpn/bin/vpn connect {ip address}

809
Views
0
Helpful
2
Replies