Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Anyconnect Problems form Windows XP or Linux (Ubuntu 12.04)

Hi There,

im setting up the Anyconnect VPN Solution in our Lab enviroment.

It’s still a test but I’m suffering several Problems.

One of them is that connecting without Webbrowers is not working from Windows XP und Linux. Windows 7 works without problems.


Setup:

Cisco 3945 Router for VPN HUB (IOS c3900e-universalk9-mz.SPA.154-2.T.bin)

Cisco ACS in background for AAA User Authentification

Several Contexts ( ADMIN / User / External Support / ect.)

Problem:

When Connecting via Webbrowser to my VPN url  https://example.myvpn.com/mycontext the Website appear and I can authentificate successfully to the Tacacs.

After that the Automatic download / upgrade of the latest VPN client start und the Client connects successfully ( WIN XP / LINUX / WIN7)

That’s the part that works perfectly!



When I try to connect manually from the Client (Not the Browser) I have some issues:

Win7:

I have to change the VPN URL to "example.myvpn.com/mycontext" and it is working perfectly!

The Client stores the new URL and I’m done.

Win XP:

It will not work.

Error Message: the anyconnect package on the secure gateway could not be located

(Remark: opening from Browser is working!)

Linux:

It will not work.

Error Message: Connection attempt has timed out.  Please verify Internet connectivity.

(Remark: opening from Browser is working!)

Config:

webvpn gateway Cisco-WebVPN-Gateway
 ip address 1.1.1.1 port 443  
 ssl encryption rc4-md5
 ssl trustpoint server_lwvpn
 inservice
 !

!

!
!
webvpn context mycontext
 title "Welcome to mycontext Generic User Context"
 login-photo none
 logo file flash:/mycontext.png
 secondary-color white
 title-color #96bf0d
 text-color black
 login-message "Welcome to mycontext Generic User Context"
 aaa authentication list sslvpn
 aaa authentication domain @mycontext
 gateway Cisco-WebVPN-Gateway domain mycontext
 max-users 20
 !
 ssl authenticate verify all
 !
 url-list "rewrite"
 inservice
 !
 policy group webvpnpolicy-mycontext
   functions svc-enabled
   functions svc-required
   svc address-pool "mycontext-vpn-pool" netmask 255.255.255.0
   svc rekey method new-tunnel
 default-group-policy webvpnpolicy-mycontext
!
end
 

 

Thanks for your help!

 

3 REPLIES

When using Ubuntu I'd try

When using Ubuntu I'd try OpenConnect, the Linux alternative for AnyConnect.

Michael Please rate all helpful posts
VIP Green

What version of AnyConnect

What version of AnyConnect are you using for Windows and Linux?

Have you downloaded and installed the Linux version of AnyConnect on the ASA?

--

Please remember to select a correct answer and rate helpful posts

-- Please remember to rate and select a correct answer
New Member

Hi, Im Using a Router (3945).

Hi,

 

Im Using a Router (3945).

 

The Installed versions on the router are:

anyconnect-win-3.1.05170-k9.pkg

anyconnect-linux-3.1.05160-k9.pkg

anyconnect-linux-64-3.1.05160-k9.pkg

 

Thanks for your help!

 

 

453
Views
0
Helpful
3
Replies