Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AnyConnect Started Crashing on OS X

I have been using AnyConnect v2.4.1012 successfully for some time now.  I was using it at work yesterday with no issues.  When I came home and started using it again, it would crash after I select my profile and has done so eversince.

Things to note:

- no new software has been installed or updated

- I have ran memtest and Apple's hardware test, both have reported no issues.

- repair disk has been run in single user mode, found no issues

- repair disk permissions has been run in single user mode and did repair some file permissions

- I have uninstalled/reinstalled the AnyConnect client several times.  This last time I tried was the first time I did not get a tun.kext error about it not being installed properly (sorry, don't have the exact error to share).

- before I reinstalled, I removed /opt/cisco

- I have AnyConnect installed on another Mac and am not having this problem

- I do not have, nor ever had another VPN client installed on this machine.

I have attached the crash report.  At the bottom of this file is all of my system info.

Any suggestions on how I can overcome this?

Best regards,

Brenden

2 REPLIES
New Member

Re: AnyConnect Started Crashing on OS X

- I have uninstalled/reinstalled the AnyConnect client several times.  This last time I tried was the first time I did not get a tun.kext error about it not being installed properly (sorry, don't have the exact error to share).

After trying yet another reinstall, I was able to reproduct the kernel extension error:

System extension cannot be used

The system extension "/System/Library/Extensions/tun.kext" was installed improperly and cannot be used.  Please try reinstalling it, or contact the product's vendor for an update.

New Member

Re: AnyConnect Started Crashing on OS X

Using mdfind from terminal, I went through and removed or renamed all of the files that appeared to relate to the AnyConnect client on the filesystem and was never able to overcome this issue, until I created another user on my laptop.  AnyConnect worked fine.

I still would have preferred to find the root cause, but I ended up just moving my profile from the problem user to the new user.

One thing to note, when I copied ~/Library from the problem user to the new user, the problem persisted despite having removed all files that referenced Cisco/AnyConnect.  So there is something else, either a db or binary that I didn't remove.

Hope this is helpful as there aren't any other solutions to this exact problem out in the vast cloud!

Brenden

1885
Views
0
Helpful
2
Replies