Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Anyconnect VPN connects from work but not from home

Hi,

I've tried searching for this issue, but I didn't find something that I think applies to this situation.

One of the universities I work for uses an ssl vpn with Anyconnect, and while at my office at another university I can easily connect (even through a firewall). However, at home I cannot connect.  If I login to the webvpn then the connect hangs at the part where the installer is analyzing the computer and nothing happens.  If I open the Anyconnect program and type the sslvpn address into the connection field, I get a timeout error.

I have tried to turn off windows firewall and my antivirus, but this does not help, and not that it should since both are active while at my office. I have also tried connecting via wirelss and ethernet at home.

OS: Windows 7 64 bit

Thank you very much for your help!

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Anyconnect VPN connects from work but not from home

We started seeing a similar issue a few weeks ago and found that when not in the office, the users have to uncheck the proxy config in IE before AnyConnect will work.  Once they VPN in, they of course have to turn the proxy setting back on. 

As far as we can tell, IE has started to cache the proxy.pac and use it when the user is not connected to the corporate network.  We're still investigating but would be interested in hearing if this is affecting others now and if it is a recent issue for them.

6 REPLIES

Re: Anyconnect VPN connects from work but not from home

Hi Erin,

Do you manage or have access to the VPN server?

The reason I ask is because it might have a configuration with DAP policies or locations that won't allow AnyConnect connections unless they comply with some defined policies.

Federico.

New Member

Re: Anyconnect VPN connects from work but not from home

Hi Federico,

Thanks for your suggestion, but unfortunately I do not have access to the VPN server.  I am a simple end of the line user.

However, I have narrowed down the problem.  I have an old WinXP laptop which can use Anyconnect to access the ssl vpn at home.  So I think the problem may be related to the fact that my connection at work goes through a proxy server, and maybe Anyconnect on my Win7 laptop is remembering the proxy settings somewhere and does not find the proxy when I'm home so it cannot connect.

I have tried uninstalling Anyconnect, downloading it freshly, and re-installing, but no luck.  Any suggestions would be very much appreciated!

Erin

Silver

Re: Anyconnect VPN connects from work but not from home

What error message do you see when AnyConnect fails to connect? Best to follow up with your admin as there must be some logs on the ASA. You can also capture the AnyConnect DART bundle that will give better idea.

New Member

Re: Anyconnect VPN connects from work but not from home

We started seeing a similar issue a few weeks ago and found that when not in the office, the users have to uncheck the proxy config in IE before AnyConnect will work.  Once they VPN in, they of course have to turn the proxy setting back on. 

As far as we can tell, IE has started to cache the proxy.pac and use it when the user is not connected to the corporate network.  We're still investigating but would be interested in hearing if this is affecting others now and if it is a recent issue for them.

New Member

Re: Anyconnect VPN connects from work but not from home

Hi Steven,

You were absolutely right!  I don't even use IE (I use Firefox), but it seems that since at some point I had set the proxy in IE, it had stored the settings, and as soon as I unchecked the proxy box the Anyconnect worked. Also, I didn't have any problems up to about a month ago either.

Thank you very much for your help!

Erin

New Member

I guess i was able to

I guess i was able to identify the solution for this issue ,i have tested it multiple time & looks like this is the problem . Following is the solution .

1) If you are using Home Wifi router to connect your laptop to the internet & Any connect ,Then you need to change some settings into the Wifi router .

Go to router admin page & check the option WMM under Wireless advance or Sometimes it is in QOS tab (depending upon vendor) .

Here you go ,Save the settings & try to connect .This time you will be able to connect without any issues .

Let me know if this works for you or not .

Regards,

DnyanPat

12581
Views
0
Helpful
6
Replies
CreatePlease login to create content