Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ASA 5505 AnyConnect Client Issues

I have a client that is able to use the regular VPN client but one of the attorneys bought a new laptop with Windows 8 and now needs AnyConnect. I open the client and login but it says it can't login with the following messages:

AnyConnect was not able to establish a connection to the specified secure gateway. Please try again.

Then I click OK and I get:

The secure gateway has rejected the connection attempt. A new connection attempt to the same or another secure gateway is needed, which requires re-authorization.

The following message was recevied from the secue gateway: No address available for SVC connection.

I have the following running config:

: Saved

:

ASA Version 8.2(5)

!

hostname ASA

domain-name domain.local

enable password 8Ry2Yjt7RRXU24 encrypted

passwd vCGdNOPVyz.a0N encrypted

names

name 10.10.10.10 DG-Commcast description Commcast Default Gateway

name 20.20.20.20 DG-FirstCom description First Communications Default Gateway

name 10.10.10.11 ASA-Outside

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

switchport access vlan 12

!

interface Ethernet0/2

speed 100

duplex full

!

interface Ethernet0/3

switchport access vlan 22

speed 100

duplex full

!

interface Ethernet0/4

switchport access vlan 22

!

interface Ethernet0/5

switchport access vlan 22

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.0.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address ASA-Outside 255.255.255.248

!

interface Vlan12

nameif backup

security-level 0

ip address 168.93.174.130 255.255.255.248

!

interface Vlan22

nameif Phones

security-level 100

ip address 192.168.3.1 255.255.255.0

!

ftp mode passive

clock timezone CST -6

clock summer-time CDT recurring

dns domain-lookup inside

dns domain-lookup outside

dns domain-lookup backup

dns domain-lookup Phones

dns server-group DefaultDNS

domain-name domain.local

object-group service RDP tcp-udp

port-object eq 3389

object-group protocol TCPUDP

protocol-object udp

protocol-object tcp

object-group service LogMeIn tcp

description Globe

port-object eq 2002

object-group service DM_INLINE_TCP_1 tcp

group-object LogMeIn

port-object eq www

port-object eq https

access-list outside_access_in extended permit object-group TCPUDP any host 50.76

.252.34 object-group RDP

access-list outside_access_in extended permit tcp any interface Phones object-gr

oup DM_INLINE_TCP_1

access-list outside_access_in extended permit icmp any any

access-list outside_access_in extended permit tcp any host ASA-Outside eq ssh

access-list inside_access_in extended permit ip any any

access-list VPNClient_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0

access-list inside_nat0_outbound extended permit ip any 192.168.10.0 255.255.255

.128

access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 19

2.168.10.0 255.255.255.128

access-list VPNClient_splitTunnelAcl_1 standard permit 192.168.0.0 255.255.255.0

access-list backup_access_in extended permit icmp any any

pager lines 24

logging enable

logging list BackupLineAlert message 622001

logging buffered debugging

logging asdm warnings

logging mail BackupLineAlert

logging from-address ASA@domain.local

logging recipient-address jim@jim.com level informational

logging recipient-address nam@domain.com level informational

mtu inside 1500

mtu outside 1500

mtu backup 1500

mtu Phones 1500

ip local pool VPNDHCP 192.168.10.50-192.168.10.80 mask 255.255.255.0

no failover

icmp unreachable rate-limit 1 burst-size 1

icmp permit any inside

icmp permit any outside

icmp permit any backup

icmp permit any Phones

no asdm history enable

arp timeout 14400

global (outside) 1 interface

global (backup) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 0 192.168.10.0 255.255.255.128

nat (inside) 1 192.168.0.0 255.255.255.0

nat (inside) 0 0.0.0.0 0.0.0.0

nat (Phones) 1 0.0.0.0 0.0.0.0

static (inside,outside) 50.76.252.34 192.168.0.254 netmask 255.255.255.255

access-group inside_access_in in interface inside

access-group outside_access_in in interface outside

access-group backup_access_in in interface backup

route outside 0.0.0.0 0.0.0.0 DG-Commcast 128 track 1

route backup 0.0.0.0 0.0.0.0 DG-FirstCom 255

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

aaa authentication ssh console LOCAL

aaa authentication telnet console LOCAL

aaa authentication http console LOCAL

http server enable

http 192.168.0.0 255.255.255.0 inside

http 192.168.10.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

no sysopt connection permit-vpn

sla monitor 123

type echo protocol ipIcmpEcho 8.8.8.8 interface outside

num-packets 3

timeout 10000

frequency 15

sla monitor schedule 123 life forever start-time now

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1

crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128

-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256

-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5

crypto map backup_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map backup_map interface backup

crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP

crypto map outside_map interface outside

crypto ca trustpoint _SmartCallHome_ServerCA

crl configure

crypto ca certificate chain _SmartCallHome_ServerCA

certificate ca 6ecc7aa5a7032ebcf4e952d491

    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130

    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117

    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b

    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504

    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72

    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56

    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043

    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31

    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b

    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10

    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc

    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b

    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845

    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8

    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced

    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f

    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201

    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868

    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101

    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8

    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777

    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a

    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406

    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973

    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403

    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609

    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80

    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e

    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a

    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc

    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16

    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0

    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8

    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28

    6c2527b9 deb78458 c61f381e a4c4cb66

  quit

crypto isakmp enable outside

crypto isakmp enable backup

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

!

track 1 rtr 123 reachability

vpn-addr-assign local reuse-delay 5

telnet 192.168.0.0 255.255.255.0 inside

telnet 192.168.10.0 255.255.255.0 inside

telnet timeout 20

ssh 192.168.0.0 255.255.255.0 inside

ssh 0.0.0.0 0.0.0.0 outside

ssh 0.0.0.0 0.0.0.0 backup

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 192.168.0.150-192.168.0.180 inside

dhcpd dns 192.168.0.254 8.8.8.8 interface inside

dhcpd lease 604800 interface inside

dhcpd domain domain.local interface inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 averag

e-rate 200

ntp server 208.66.175.36 source outside prefer

ntp server 173.14.55.9 source outside

webvpn

enable outside

enable backup

svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 1

svc profiles AnyConnectProfile disk0:/anyconnectprofile.xml

svc enable

group-policy DfltGrpPolicy attributes

vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn

group-policy VPNClient internal

group-policy VPNClient attributes

dns-server value 192.168.0.254 8.8.8.8

vpn-tunnel-protocol IPSec svc webvpn

split-tunnel-policy tunnelspecified

split-tunnel-network-list value VPNClient_splitTunnelAcl_1

default-domain value domain.local

webvpn

  svc profiles value AnyConnectProfile

username cris password BQd7EeZN.0hvT encrypted privilege 0

username cris attributes

service-type admin

username tony password U/UxEH5l0w5Q encrypted privilege 15

username nancy password lAnhc/SvNNSSR encrypted privilege 0

tunnel-group VPNClient type remote-access

tunnel-group VPNClient general-attributes

address-pool VPNDHCP

default-group-policy VPNClient

tunnel-group VPNClient ipsec-attributes

pre-shared-key *****

!

!

smtp-server 192.168.0.254

prompt hostname context

call-home reporting anonymous

Cryptochecksum:de5e8aec62853af27945c52bf36

: end

Does the client AnyConnect version need to be the same as the version that is loaded on the ASA? I am using the 3.0.5080 client and the AnyConnect client settings on the ASA is anconnect-win-2.5.201-kr.pkg

Thanks for the help!

Tony

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: ASA 5505 AnyConnect Client Issues

The error-message gives a hint:

No address available for SVC connection

The client can not work without an assigned IP-address. But as you have assigned a pool to the tunnel-group, I assume that the client doesn't connect to the desired group but to the default-group. At least I can't see anything in the config that gives the client the right group.

Try the following config:

webvpn

  tunnel-group-list enable

tunnel-group VPNClient webvpn-attributes

  group-alias VPNClient enable

With that you get a drop-down-menu in the client to choose the right tunnel-group.

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
3 REPLIES
VIP Purple

Re: ASA 5505 AnyConnect Client Issues

The error-message gives a hint:

No address available for SVC connection

The client can not work without an assigned IP-address. But as you have assigned a pool to the tunnel-group, I assume that the client doesn't connect to the desired group but to the default-group. At least I can't see anything in the config that gives the client the right group.

Try the following config:

webvpn

  tunnel-group-list enable

tunnel-group VPNClient webvpn-attributes

  group-alias VPNClient enable

With that you get a drop-down-menu in the client to choose the right tunnel-group.

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
New Member

Re: ASA 5505 AnyConnect Client Issues

Awesome, that worked! I was trying to figure out how to do that in the ASDM interface... Sometimes I think the ASDM is really confusing!

VIP Purple

Re: ASA 5505 AnyConnect Client Issues

You find the needed Config-Elements here (out of memory, don't have an ASA here at the moment):

Configuration -> Remote-Access-VPN -> CLient (AnyConnect) -> Connection-Profiles

--

Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni


--
Don't stop after you've improved your network! Improve the world by lending money to the working poor: http://www.kiva.org/invitedby/karsteni
407
Views
0
Helpful
3
Replies