Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ASA 5505 crashes due to DHCP Client

We recently upgraded our 5505s to 8.2(5) 26 and noticed that each will crash after a cerntain amount of time.  Some crash every 30 minutes other will crash every 4 to 8 hrs.  The only difference would be the user's home ISP and/or home router, if they have one.  They are configured with a dynamic dhcp IP address for the outside interface and the crash files starts with the following:

Thread Name: DHCP Client

Page fault: Address not mapped

    vector 0x0000000e

       edi 0xc768f37c

       esi 0xca3d9518

       ebp 0xc97548e8

       esp 0xc97546b0

       ebx 0x00000bcf

       edx 0xca3d9518

       ecx 0x00000bcf

       eax 0x00000000

error code 0x00000004

       eip 0x0876ec72

        cs 0x00000073

    eflags 0x00013246

       CR2 0x0000008c

Cisco Adaptive Security Appliance Software Version 8.2(5)26

Compiled on Fri 02-Mar-12 14:04 by builders

Hardware:   ASA5505

Crashinfo collected on 15:23:43.335 EDT Mon May 14 2012

When we downgrade back to 8.2(5) 13 the problem goes away.  Is anyone aware of known bugs for this version?  I haven't been able to find anything yet.  Also we do have one 5505 that does not have this issues.  The only thing that may be different is that it was never at 8.2(5) 13.  We had downgrade it from a 8.3 version.

2 REPLIES

ASA 5505 crashes due to DHCP Client

If 8.2(5) 13 works well for you why upgrade? It seems that you are running into a bug so I'd stay away from the code where you see this behavior.

Is there something about the 8.2(5)13 code that doesn't suit your needs and therefore need to upgrade?

Kind Regards,

Kevin

**Please remember to rate helpful posts as well as mark the question as 'answered' once your issue is resolved. This will help others to find your solution faster.

Kind Regards, Kevin Sheahan, CCIE # 41349
New Member

ASA 5505 crashes due to DHCP Client

That would seem like the easy answer, but I'm being directed to upgrade do to security issues with 8.2(5) 13.  If I can clearly note a bug, I'll be better able to get a waiver for not upgradeing.

Thanks

558
Views
0
Helpful
2
Replies
CreatePlease to create content