Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ASA 5505 Site-to-Site Not Working

Hello,

I am somehwat new to Cisco ASA firewalls but do have some experience. I am configuring two 5505's for a client so their two offices can communicate. Here are my setups. Both are on the Comcast Business Class network with public IPs. The site-to-site VPN tunnel is not working. Any help would be appreciated! Going nuts over here!

Site A - ASA 5505 with 50 user license

Site B - ASA 5505 with 10 user license

ASA Version 8.2(5)

!

hostname *********************

enable password 6.De4e7UzES9wBPg encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

name 192.168.100.10 Web_Server

name 10.0.6.0 Ghost_Flower_Inside

name 10.0.5.0 San_Mateo_Inside

name 10.0.5.100 Any_Connect_100

name 10.0.5.101 Any_Connect_101

name 10.0.5.102 Any_Connect_102

name 10.0.5.103 Any_Connect_103

name 10.0.5.104 Any_Connect_104

name 10.0.5.105 Any_Connect_105

name 10.0.5.106 Any_Connect_106

name 10.0.5.107 Any_Connect_107

name 10.0.5.108 Any_Connect_108

name 10.0.5.109 Any_Connect_109

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

switchport access vlan 12

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 10.0.5.201 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 173.12.xxx.xxx 255.255.255.252

!

interface Vlan12

no forward interface Vlan1

nameif dmz

security-level 50

ip address 192.168.100.1 255.255.255.0

!

ftp mode passive

dns domain-lookup outside

dns server-group DefaultDNS

name-server 75.75.75.75

object-group protocol TCPUDP

protocol-object udp

protocol-object tcp

object-group network Any_Connect_DHCP

network-object host Any_Connect_100

network-object host Any_Connect_101

network-object host Any_Connect_102

network-object host Any_Connect_103

network-object host Any_Connect_104

network-object host Any_Connect_105

network-object host Any_Connect_106

network-object host Any_Connect_107

network-object host Any_Connect_108

network-object host Any_Connect_109

access-list outside_access_in extended permit tcp any interface outside eq www

access-list outside_access_in extended permit tcp any interface outside eq ssh

access-list outside_1_cryptomap extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0

access-list inside_nat0_outbound extended permit ip San_Mateo_Inside 255.255.255.0 Ghost_Flower_Inside 255.255.255.0

access-list inside_nat0_outbound extended permit ip object-group Any_Connect_DHCP any

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

mtu dmz 1500

ip local pool AnyConnectDHCPPool Any_Connect_100-10.0.5.110 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

global (dmz) 1 192.168.100.2 netmask 255.255.255.255

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 0.0.0.0 0.0.0.0

static (dmz,outside) tcp interface www Web_Server www netmask 255.255.255.255

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 173.12.xxx.xxx 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

aaa authentication http console LOCAL

aaa authentication ssh console LOCAL

http server enable

http 192.168.1.0 255.255.255.0 inside

http 10.0.1.0 255.255.255.0 inside

http 10.1.10.0 255.255.255.0 outside

http San_Mateo_Inside 255.255.255.255 inside

http San_Mateo_Inside 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto map outside_map 1 match address outside_1_cryptomap

crypto map outside_map 1 set peer 173.12.xxx.xxx

crypto map outside_map 1 set transform-set ESP-3DES-SHA

crypto map outside_map interface outside

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

vpn-sessiondb max-webvpn-session-limit 10

telnet timeout 5

ssh 192.168.1.0 255.255.255.0 inside

ssh 10.0.1.0 255.255.255.0 inside

ssh San_Mateo_Inside 255.255.255.0 inside

ssh 10.1.10.0 255.255.255.0 outside

ssh 0.0.0.0 0.0.0.0 outside

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 10.0.5.10-10.0.5.30 inside

dhcpd dns 75.75.75.75 75.75.76.76 interface inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

anyconnect-essentials

svc image disk0:/anyconnect-macosx-i386-2.5.2014-k9.pkg 1 regex "Intel Mac OS X"

svc profiles CATS disk0:/cats.xml

svc enable

tunnel-group-list enable

group-policy DfltGrpPolicy attributes

dns-server value 75.75.75.75

vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn

webvpn

  svc profiles value CATS

username ***** password tTq7bIZ.C4x0j.qv encrypted privilege 15

username ***** password sPxon1E6hTszm7Ko encrypted privilege 15

tunnel-group 173.12.xxx.xxx type ipsec-l2l

tunnel-group 173.12.xxx.xxx ipsec-attributes

pre-shared-key *****

!

!

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:1751532c3624a6c2eec3c1ae0c31fe03

: end

Site B:

ASA Version 8.2(5)

!

hostname ********************

enable password 6.De4e7UzES9wBPg encrypted

passwd 2KFQnbNIdI.2KYOU encrypted

names

name 10.0.6.0 Ghost_Flower_Inside_Network

name 10.0.5.0 San_Mateo_Inside_Network

name 173.10.XXX.XXX San_Mateo_Outside

name 10.0.6.2 SERVER

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 10.0.6.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 173.10.XXX.XXX 255.255.255.252

!

ftp mode passive

dns domain-lookup outside

dns server-group DefaultDNS

name-server 75.75.75.75

object-group protocol TCPUDP

protocol-object udp

protocol-object tcp

access-list outside_1_cryptomap extended permit ip Ghost_Flower_Inside_Network 255.255.255.0 San_Mateo_Inside_Network 255.255.255.0

access-list inside_nat0_outbound extended permit ip Ghost_Flower_Inside_Network 255.255.255.0 San_Mateo_Inside_Network 255.255.255.0

access-list outside_access_in extended permit tcp any interface outside eq 548

access-list outside_access_in extended permit tcp any interface outside eq ssh

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list inside_nat0_outbound

nat (inside) 1 0.0.0.0 0.0.0.0

static (inside,outside) tcp interface 548 SERVER 548 netmask 255.255.255.255

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 173.12.206.150 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

aaa authentication ssh console LOCAL

aaa authentication http console LOCAL

http server enable

http 192.168.1.0 255.255.255.0 inside

http Ghost_Flower_Inside_Network 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 outside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac

crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac

crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac

crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac

crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac

crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac

crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac

crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac

crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

crypto map outside_map 1 match address outside_1_cryptomap

crypto map outside_map 1 set peer San_Mateo_Outside

crypto map outside_map 1 set transform-set ESP-3DES-SHA

crypto map outside_map interface outside

crypto isakmp enable outside

crypto isakmp policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh 192.168.1.0 255.255.255.0 inside

ssh Ghost_Flower_Inside_Network 255.255.255.0 inside

ssh 0.0.0.0 0.0.0.0 outside

ssh timeout 5

console timeout 0

dhcpd auto_config outside

!

dhcpd address 10.0.6.10-10.0.6.15 inside

dhcpd dns 75.75.75.75 interface inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

group-policy DfltGrpPolicy attributes

vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn

username ******** password sPxon1E6hTszm7Ko encrypted privilege 15

tunnel-group 173.10.XXX.XXX type ipsec-l2l

tunnel-group 173.10.XXX.XXX ipsec-attributes

pre-shared-key *****

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny

  inspect sunrpc

  inspect xdmcp

  inspect sip

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:666e449b3e77b6090dbd29f01e2b50a1

: end

1 REPLY

Re:ASA 5505 Site-to-Site Not Working

Can you post some errorlogs from the devices, please?


Sent from Cisco Technical Support Android App

Michael Please rate all helpful posts
214
Views
0
Helpful
1
Replies
CreatePlease to create content