Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ASA 5505 site to site VPN not working

Hello,

We are having trouble configuring our site to site VPN with our ASA 5505's. We ran the wizards which seem to be straight forward, but we are having no luck getting them to talk with each other via ping or anything for that matter. Here is our configs for our two sites if someone could help us out:

Site A:

Result of the command: "sho run"

: Saved
:
ASA Version 7.2(4)
!
hostname ciscoasa
domain-name default.domain.invalid

names
dns-guard
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.45.20 255.255.255.0
ospf cost 10
!
interface Vlan2
nameif outside
security-level 0
ip address 173.xxx.xxx.249 255.255.255.252
ospf cost 10
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone est -5
clock summer-time EDT recurring
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
access-list inbound extended permit tcp host 173.xxx.xxx.249 eq www any
access-list inbound extended permit icmp any any
access-list inbound extended permit tcp any host 173.xxx.xxx.249 eq www
access-list inbound extended permit tcp host 173.xxx.xxx.249 eq https any
access-list inbound extended permit tcp any host 173.xxx.xxx.249 eq https
access-list outside_20_cryptomap extended permit ip 192.168.45.0 255.255.255.0 192.168.42.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.45.0 255.255.255.0 192.168.42.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inbound in interface outside
route inside 192.168.0.0 255.255.255.0 192.168.45.20 1
route inside 192.168.0.0 255.255.0.0 192.168.45.20 1
route outside 0.0.0.0 0.0.0.0 173.xxx.xxx.250 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
http server enable
http 192.168.45.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs
crypto map outside_map 20 set peer 50.xxx.xxx.89
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 192.168.45.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd dns 192.168.45.20 68.xxx.xxx.194
dhcpd auto_config outside
!

tunnel-group 50.xxx.xxx.89 type ipsec-l2l
tunnel-group 50.xxx.xxx.89 ipsec-attributes
pre-shared-key * (Key is the same on both ASA's)
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 1500
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
: end

Site B:

Result of the command: "sho run"

: Saved
:
ASA Version 7.2(4)
!
hostname
domain-name default.domain.invalid

names
dns-guard
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.42.12 255.255.255.0
ospf cost 10
!
interface Vlan2
nameif outside
security-level 0
ip address 50.xxx.xxx.89 255.255.255.248
ospf cost 10
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
domain-name default.domain.invalid
same-security-traffic permit inter-interface
access-list inbound extended permit tcp interface outside eq 3389 host 192.168.42.26
access-list inbound extended permit icmp any any
access-list inbound extended permit tcp interface outside eq 39000 host 192.168.42.254
access-list inbound extended permit tcp interface outside eq 39001 host 192.168.42.254
access-list inbound extended permit tcp interface outside eq 39002 host 192.168.42.254
access-list inbound extended permit udp interface outside eq 39000 host 192.168.42.254
access-list inbound extended permit udp interface outside eq 39001 host 192.168.42.254
access-list inbound extended permit udp interface outside eq 39002 host 192.168.42.254
access-list inbound extended permit tcp host 50.xxx.xxx.89 eq 3389 any
access-list inbound extended permit tcp any host 50.xxx.xxx.89 eq 3389
access-list inbound extended permit tcp host 50.xxx.xxx.89 eq www any
access-list inbound extended permit tcp any host 50.xxx.xxx.89 eq www
access-list inbound extended permit tcp host 50.xxx.xxx.89 eq https any
access-list inbound extended permit tcp any host 50.xxx.xxx.89 eq https
access-list inbound extended permit tcp host 50.xxx.xxx.89 eq 39000 any
access-list inbound extended permit tcp any host 50.xxx.xxx.89 eq 39000
access-list inbound extended permit tcp host 50.xxx.xxx.89 eq 16450 any
access-list inbound extended permit tcp any host 50.xxx.xxx.89 eq 16450
access-list outside_20_cryptomap extended permit ip 192.168.42.0 255.255.255.0 192.168.45.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.42.0 255.255.255.0 192.168.45.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational

mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 192.168.42.26 3389 netmask 255.255.255.255
static (inside,outside) tcp interface 39000 192.168.42.254 39000 netmask 255.255.255.255
static (inside,outside) udp interface 39000 192.168.42.254 39000 netmask 255.255.255.255
static (inside,outside) tcp interface 39001 192.168.42.254 39001 netmask 255.255.255.255
static (inside,outside) udp interface 39001 192.168.42.254 39001 netmask 255.255.255.255
static (inside,outside) tcp interface 39002 192.168.42.254 39002 netmask 255.255.255.255
static (inside,outside) udp interface 39002 192.168.42.254 39002 netmask 255.255.255.255
static (inside,outside) tcp interface 16450 192.168.42.254 16450 netmask 255.255.255.255
access-group inbound in interface outside
route inside 192.168.0.0 255.255.255.0 192.168.42.12 1
route inside 192.168.0.0 255.255.0.0 192.168.42.12 1
route outside 0.0.0.0 0.0.0.0 50.xxx.xxx.94 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
http server enable
http 192.168.42.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs
crypto map outside_map 20 set peer 173.xxx.xxx.249
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 192.168.42.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.42.13-192.168.42.44 inside
!

tunnel-group 173.xxx.xxx.249 type ipsec-l2l
tunnel-group 173.xxx.xxx.249 ipsec-attributes
pre-shared-key * (Same as other ASA)
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 1500
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
: end

Thank you so much as I apperciate your all's help.

Scott

1 ACCEPTED SOLUTION

Accepted Solutions

ASA 5505 site to site VPN not working

Hi Scott,

Configs looks fine. Not sure why you need 'route stmts to 192.168.0.0 255.255.0.0' network on both sides. They are pointing to inside of ASA. Remove that and try to reach the other end PC. If you need to keep it, then try adding specific routes..

A:

route outside 192.168.42.0 255.255.255.0 173.xxx.xxx.250 1

B:

route outside 192.168.45.0 255.255.255.0 50.xxx.xxx.94 1

hth

MS

3 REPLIES

ASA 5505 site to site VPN not working

Hi Scott,

Configs looks fine. Not sure why you need 'route stmts to 192.168.0.0 255.255.0.0' network on both sides. They are pointing to inside of ASA. Remove that and try to reach the other end PC. If you need to keep it, then try adding specific routes..

A:

route outside 192.168.42.0 255.255.255.0 173.xxx.xxx.250 1

B:

route outside 192.168.45.0 255.255.255.0 50.xxx.xxx.94 1

hth

MS

New Member

ASA 5505 site to site VPN not working

Hi Scott,

Could you please paste crypto isakmp and ipsec outputs?

New Member

ASA 5505 site to site VPN not working

Thank you so much mvsheik, that actually was it. I am not exactly sure how that got there, maybe just at some point when trying to get something to work, but that was definitely the issue.

It is working great now and thanks again!

Scott

1673
Views
0
Helpful
3
Replies
CreatePlease login to create content