Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ASA 5505 Site-to-Site VPN Problem

Hello,

I have a strange problem with a site-to-site VPN. I have it completely configured and I have added 3 of my internal networks to be encrypted and access the remote network on the other side of the tunnel.

For some reason, I can access the remote network from only two of the three internal networkls I have specified.

Here is a copy of my config - if someone has any info I would sure appreciate it.

Thanks,

Kevin

hostname FK-US-Raleigh-ASA
domain-name appdrugs.com
enable password 08PI8zPL2UE41XdH encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.237.0 Maridian-Primary-Net
name 192.168.237.128 Meridian-Backup-Net
name 10.239.192.141 AccessSwitch1IDFB
name 10.239.192.143 AccessSwitch1IDFC
name 10.239.192.140 AccessSwitch1MDFA
name 10.239.192.142 AccessSwitch2IDFB
name 10.195.64.206 CiscoCallManager
name 10.239.192.2 CoreSwitch1
name 10.239.192.3 CoreSwitch2
name 10.195.64.17 UnityVM
name 140.239.116.162 Outside_Interface
name 65.118.69.251 Meridian-Primary-VPN
name 65.123.23.194 Meridian_Backup_VPN
dns-guard
!
interface Ethernet0/0
shutdown
no nameif
security-level 100
no ip address
!
interface Ethernet0/1
nameif Outside
security-level 60
ip address Outside_Interface 255.255.255.224
!
interface Ethernet0/2
nameif Inside1
security-level 100
ip address 10.239.192.7 255.255.255.128
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 50
ip address 192.168.1.1 255.255.255.0
management-only
!
boot system disk0:/asa804-k8.bin
boot system disk0:/asa804.bin
ftp mode passive
dns domain-lookup Outside
dns domain-lookup Inside1
dns domain-lookup management
dns server-group DefaultDNS
name-server 10.239.192.10
domain-name appdrugs.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group network DM_INLINE_NETWORK_1
network-object 10.195.64.0 255.255.255.0
network-object 10.239.192.0 255.255.255.0
network-object 10.239.192.128 255.255.255.128
object-group service DM_INLINE_SERVICE_1
service-object ip
service-object icmp
service-object icmp echo
service-object icmp echo-reply
object-group network DM_INLINE_NETWORK_2
network-object 10.195.64.0 255.255.255.0
network-object 10.239.192.0 255.255.255.128
network-object 10.239.192.128 255.255.255.128
object-group network DM_INLINE_NETWORK_3
network-object 10.195.64.0 255.255.255.192
network-object 10.239.192.0 255.255.255.128
network-object 10.239.192.128 255.255.255.128
object-group network DM_INLINE_NETWORK_5
network-object Maridian-Primary-Net 255.255.255.128
network-object Meridian-Backup-Net 255.255.255.128
object-group network DM_INLINE_NETWORK_6
network-object Maridian-Primary-Net 255.255.255.128
network-object Meridian-Backup-Net 255.255.255.128
object-group network Vital-Network-Equipment-Access
network-object host UnityVM
network-object host CiscoCallManager
network-object host AccessSwitch1MDFA
network-object host AccessSwitch1IDFB
network-object host AccessSwitch2IDFB
network-object host AccessSwitch1IDFC
network-object host CoreSwitch1
network-object host CoreSwitch2
object-group service RDP tcp
port-object eq 3389
object-group network DM_INLINE_NETWORK_7
network-object Maridian-Primary-Net 255.255.255.128
network-object Meridian-Backup-Net 255.255.255.128
network-object host Meridian-Primary-VPN
network-object host Meridian_Backup_VPN
object-group network DM_INLINE_NETWORK_9
network-object host Outside_Interface
group-object Vital-Network-Equipment-Access
object-group service DM_INLINE_SERVICE_2
service-object gre
service-object esp
service-object ah
service-object udp eq isakmp
object-group service DM_INLINE_SERVICE_3
service-object icmp
service-object icmp echo
service-object icmp echo-reply
object-group network DM_INLINE_NETWORK_4
network-object 10.195.64.0 255.255.255.0
network-object 10.239.192.0 255.255.255.128
network-object 10.239.192.128 255.255.255.128
object-group network DM_INLINE_NETWORK_8
network-object 10.195.64.0 255.255.255.0
network-object 10.239.192.0 255.255.255.128
network-object 10.239.192.128 255.255.255.128
access-list Outside_access_in extended permit icmp any any echo-reply
access-list Outside_access_in extended permit ip Maridian-Primary-Net 255.255.255.128 object-group DM_INLINE_NETWORK_8
access-list Outside_access_in extended permit ip Meridian-Backup-Net 255.255.255.128 object-group DM_INLINE_NETWORK_3
access-list Inside_nat0_outbound extended permit ip 10.0.0.0 255.0.0.0 10.0.0.0 255.0.0.0
access-list Inside_nat0_outbound extended permit ip 10.239.192.0 255.255.255.0 Maridian-Primary-Net 255.255.255.128
access-list Inside_access_in extended permit ip 10.0.0.0 255.0.0.0 any
access-list Inside1_nat0_outbound extended permit ip 10.0.0.0 255.0.0.0 10.0.0.0 255.0.0.0
access-list Inside1_nat0_outbound extended permit ip object-group DM_INLINE_NETWORK_1 Maridian-Primary-Net 255.255.255.128
access-list Inside1_nat0_outbound extended permit ip object-group DM_INLINE_NETWORK_2 Meridian-Backup-Net 255.255.255.128
access-list Inside1_nat0_outbound extended permit ip 10.239.192.0 255.255.255.0 10.239.199.0 255.255.255.192
access-list Inside1_nat0_outbound extended permit ip 10.195.64.0 255.255.255.192 10.239.199.0 255.255.255.192
access-list Inside1_access_in extended permit ip 10.0.0.0 255.0.0.0 any
access-list Outside_1_cryptomap extended permit object-group DM_INLINE_SERVICE_1 object-group DM_INLINE_NETWORK_1 Maridian-Primary-Net 255.255.255.128
access-list Outside_2_cryptomap extended permit ip object-group DM_INLINE_NETWORK_2 Meridian-Backup-Net 255.255.255.128
access-list Vital-Network-Access_splitTunnelAcl standard permit 10.239.192.0 255.255.255.128
access-list Vital-Network-Access_splitTunnelAcl standard permit 10.195.64.0 255.255.255.0
access-list Vital-Network-Access_splitTunnelAcl standard permit 10.239.192.128 255.255.255.128
access-list Vital_VPN extended permit ip 10.239.199.0 255.255.255.192 object-group Vital-Network-Equipment-Access
access-list Vital_VPN extended permit icmp 10.239.199.0 255.255.255.192 object-group Vital-Network-Equipment-Access
access-list Vital_VPN extended permit ip any any
access-list Outside_cryptomap_1 extended permit ip object-group DM_INLINE_NETWORK_4 Maridian-Primary-Net 255.255.255.128
access-list Vital-Site-to-Site-Access extended permit ip object-group DM_INLINE_NETWORK_5 object-group Vital-Network-Equipment-Access
access-list Vital-Site-to-Site-Access extended permit object-group DM_INLINE_SERVICE_3 object-group DM_INLINE_NETWORK_6 object-group Vital-Network-Equipment-Access
access-list Vital-Site-to-Site-Access extended permit object-group DM_INLINE_SERVICE_2 object-group DM_INLINE_NETWORK_7 object-group DM_INLINE_NETWORK_9
pager lines 24
logging enable
logging asdm warnings
mtu Outside 1500
mtu Inside1 1500
mtu management 1500
ip local pool Remote-Access 10.239.199.11-10.239.199.62 mask 255.255.255.192
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-621.bin
no asdm history enable
arp timeout 14400
global (Outside) 1 interface
nat (Inside1) 0 access-list Inside1_nat0_outbound
nat (Inside1) 1 10.0.0.0 255.0.0.0
access-group Outside_access_in in interface Outside
access-group Inside1_access_in in interface Inside1
route Outside 0.0.0.0 0.0.0.0 140.239.116.161 1
route Inside1 10.192.52.0 255.255.255.0 10.239.192.1 1
route Inside1 10.195.64.0 255.255.240.0 10.239.192.1 1
route Inside1 10.239.0.0 255.255.0.0 10.239.192.1 1
route Inside1 10.239.192.0 255.255.248.0 10.239.192.1 1
route Outside Maridian-Primary-Net 255.255.255.0 Outside_Interface 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 66.104.209.192 255.255.255.224 Outside
http 192.168.1.0 255.255.255.0 management
http 10.239.172.0 255.255.252.0 Inside1
snmp-server host Inside1 10.239.132.225 community appfirestarter*#*
snmp-server location Raleigh
snmp-server contact Kevin mcdonald
snmp-server community appfirestarter*#*
snmp-server enable traps snmp authentication linkup linkdown coldstart
snmp-server enable traps entity config-change
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime seconds 28800
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set security-association lifetime kilobytes 4608000
crypto map Outside_map 1 match address Outside_cryptomap_1
crypto map Outside_map 1 set peer Meridian-Primary-VPN
crypto map Outside_map 1 set transform-set ESP-3DES-MD5
crypto map Outside_map 1 set security-association lifetime seconds 28800
crypto map Outside_map 1 set security-association lifetime kilobytes 4608000
crypto map Outside_map 2 match address Outside_2_cryptomap
crypto map Outside_map 2 set peer Meridian_Backup_VPN
crypto map Outside_map 2 set transform-set ESP-3DES-MD5
crypto map Outside_map 2 set security-association lifetime seconds 28800
crypto map Outside_map 2 set security-association lifetime kilobytes 4608000
crypto map Outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map Outside_map interface Outside
crypto isakmp enable Outside
crypto isakmp policy 5
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
management-access Outside
dhcpd address 192.168.1.2-192.168.1.254 management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
enable Outside
tunnel-group-list enable
group-policy Vital-Network-Access internal
group-policy Vital-Network-Access attributes
dns-server value 10.239.192.10
vpn-filter value Vital_VPN
vpn-tunnel-protocol IPSec webvpn
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Vital-Network-Access_splitTunnelAcl
address-pools value Remote-Access
group-policy Vital-Site-to-Site-GroupPolicy internal
group-policy Vital-Site-to-Site-GroupPolicy attributes
vpn-filter value Vital-Site-to-Site-Access
vpn-tunnel-protocol IPSec l2tp-ipsec webvpn
username APPRaleigh password m40Ls2r9N918trxp encrypted
username APPRaleigh attributes
vpn-group-policy Vital-Network-Access
service-type remote-access
username kmadmin password u8urNz44/I.ugcF. encrypted privilege 15
tunnel-group 65.118.69.251 type ipsec-l2l
tunnel-group 65.118.69.251 general-attributes
default-group-policy Vital-Site-to-Site-GroupPolicy
tunnel-group 65.118.69.251 ipsec-attributes
pre-shared-key *
tunnel-group 65.123.23.194 type ipsec-l2l
tunnel-group 65.123.23.194 general-attributes
default-group-policy Vital-Site-to-Site-GroupPolicy
tunnel-group 65.123.23.194 ipsec-attributes
pre-shared-key *
tunnel-group Vital-Network-Access type remote-access
tunnel-group Vital-Network-Access general-attributes
address-pool Remote-Access
default-group-policy Vital-Network-Access
tunnel-group Vital-Network-Access ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns migrated_dns_map_1
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny 
  inspect sunrpc
  inspect xdmcp
  inspect sip 
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:a080b1759b57190ba65d932785ad4967
: end

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: ASA 5505 Site-to-Site VPN Problem

can you confirm if we have the exact mirror image of crypto acl on the other end

i feel may be you have a /24 10.239.192.0 255.255.255.0 on the other end as remote network

can you please confirm that

also any particular reason why you are using 10.239.192.0 255.255.255.128 and 10.239.192.128 255.255.255.128 instead of 10.239.192.0 255.255.255.0

4 REPLIES
Cisco Employee

Re: ASA 5505 Site-to-Site VPN Problem

i see you have vpn filter applied and i assume you are talking abou tthe first tunnel in crypto map

try removing the vpn filter and see what results you get

also what ie the output of packet tracer???

and which is the network which is not accessible

please paste th eoutput of the command

show crypto ipsec sa peer , lets see the counyters

New Member

Re: ASA 5505 Site-to-Site VPN Problem

Hello and thanks for the reply.

I have removed the filter and still no luck. Packet Tracer fails on VPN - It says Type-VPN Subtype-encrypt Action - Drop. When I source the packet from an IP from the other two working networks, it goes though just fine.

The two networks that work are 10.239.192.0 /25 and 10.195.64.0 /24. The network that does not work is 10.239.192.128 /25.

peer address: Meridian-Primary-VPN
    Crypto map tag: Outside_map, seq num: 1, local addr: Outside_Interface

      access-list Outside_cryptomap_1 permit ip 10.195.64.0 255.255.255.0 Maridian-Primary-Net 255.255.255.128
      local ident (addr/mask/prot/port): (10.195.64.0/255.255.255.0/0/0)
      remote ident (addr/mask/prot/port): (Maridian-Primary-Net/255.255.255.128/0/0)
      current_peer: Meridian-Primary-VPN

      #pkts encaps: 231, #pkts encrypt: 231, #pkts digest: 231
      #pkts decaps: 231, #pkts decrypt: 231, #pkts verify: 231
      #pkts compressed: 0, #pkts decompressed: 0
      #pkts not compressed: 231, #pkts comp failed: 0, #pkts decomp failed: 0
      #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
      #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
      #send errors: 0, #recv errors: 0

      local crypto endpt.: Outside_Interface, remote crypto endpt.: Meridian-Primary-VPN

      path mtu 1500, ipsec overhead 58, media mtu 1500
      current outbound spi: 21A739AD

    inbound esp sas:
      spi: 0xBD2B4623 (3173729827)
         transform: esp-3des esp-md5-hmac no compression
         in use settings ={L2L, Tunnel, }
         slot: 0, conn_id: 4096, crypto-map: Outside_map
         sa timing: remaining key lifetime (kB/sec): (4373985/24494)
         IV size: 8 bytes
         replay detection support: Y
Anti replay bitmap:
        0xFFFFFFFF 0xFFFFFFFF
    outbound esp sas:
      spi: 0x21A739AD (564607405)
         transform: esp-3des esp-md5-hmac no compression
         in use settings ={L2L, Tunnel, }
         slot: 0, conn_id: 4096, crypto-map: Outside_map
         sa timing: remaining key lifetime (kB/sec): (4373985/24494)
         IV size: 8 bytes
         replay detection support: Y
Anti replay bitmap:
        0x00000000 0x00000001

    Crypto map tag: Outside_map, seq num: 1, local addr: Outside_Interface

      access-list Outside_cryptomap_1 permit ip 10.239.192.0 255.255.255.128 Maridian-Primary-Net 255.255.255.128
      local ident (addr/mask/prot/port): (10.239.192.0/255.255.255.128/0/0)
      remote ident (addr/mask/prot/port): (Maridian-Primary-Net/255.255.255.128/0/0)
      current_peer: Meridian-Primary-VPN

      #pkts encaps: 144, #pkts encrypt: 144, #pkts digest: 144
      #pkts decaps: 144, #pkts decrypt: 144, #pkts verify: 144
      #pkts compressed: 0, #pkts decompressed: 0
      #pkts not compressed: 144, #pkts comp failed: 0, #pkts decomp failed: 0
      #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
      #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
      #send errors: 0, #recv errors: 0

      local crypto endpt.: Outside_Interface, remote crypto endpt.: Meridian-Primary-VPN

      path mtu 1500, ipsec overhead 58, media mtu 1500
      current outbound spi: 6A38F471

    inbound esp sas:
      spi: 0xEF5B3FE3 (4015734755)
         transform: esp-3des esp-md5-hmac no compression
         in use settings ={L2L, Tunnel, }
         slot: 0, conn_id: 4096, crypto-map: Outside_map
         sa timing: remaining key lifetime (kB/sec): (4373991/24484)
         IV size: 8 bytes
         replay detection support: Y
Anti replay bitmap:
        0xFFFFFFFF 0xFFFFFFFF
    outbound esp sas:
      spi: 0x6A38F471 (1782117489)
         transform: esp-3des esp-md5-hmac no compression
         in use settings ={L2L, Tunnel, }
         slot: 0, conn_id: 4096, crypto-map: Outside_map
         sa timing: remaining key lifetime (kB/sec): (4373991/24484)
         IV size: 8 bytes
         replay detection support: Y
Anti replay bitmap:
        0x00000000 0x00000001

Cisco Employee

Re: ASA 5505 Site-to-Site VPN Problem

can you confirm if we have the exact mirror image of crypto acl on the other end

i feel may be you have a /24 10.239.192.0 255.255.255.0 on the other end as remote network

can you please confirm that

also any particular reason why you are using 10.239.192.0 255.255.255.128 and 10.239.192.128 255.255.255.128 instead of 10.239.192.0 255.255.255.0

New Member

Re: ASA 5505 Site-to-Site VPN Problem

Thank You - it was indeed a mismatch of subnet mask that was the problem.

5249
Views
0
Helpful
4
Replies
CreatePlease to create content