Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ASA 5505 VPN Default Gateway Issue

So I'm having a bit of a problem getting my ASA 5505 VPN Tunnel to work correctly.  I can create the tunnel but my defaul gateway is the IP address leased in the VPN IP Pool which is wrong.  I've attached the config.  Please help.  THANKS!!!

hostname ciscoasa
domain-name mydomain.com
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server 209.18.47.61
name-server 209.18.47.62
domain-name mydomain.com
same-security-traffic permit intra-interface
access-list basenine_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPN_Pool 192.168.2.1-192.168.2.10 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 (ISP_IP) 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy takeiteasy internal
group-policy takeiteasy attributes
dns-server value 209.18.47.61 209.18.47.62
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value basenine_splitTunnelAcl
default-domain value mydomain.com
http server enable
http 0.0.0.0 0.0.0.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp nat-traversal  20
tunnel-group takeiteasy type ipsec-ra
tunnel-group takeiteasy general-attributes
address-pool VPN_Pool
default-group-policy takeiteasy
tunnel-group takeiteasy ipsec-attributes
pre-shared-key *
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect icmp
!
service-policy global_policy global
client-update enable
prompt hostname context
Cryptochecksum:d77d29906107bd37419a489ab63d2640
: end

AM I MISSING SOMETHING?

Everyone's tags (3)
4 REPLIES

Re: ASA 5505 VPN Default Gateway Issue

Hi,

You don't have split tunneling configured.

Do you intend to send all Internet traffic from the VPN client through the tunnel?

Federico.

New Member

Re: ASA 5505 VPN Default Gateway Issue

Federico,

Thanks for your reply.  To answer your question.  I would prefer all internet traffic be sent through the tunnel if that is the best practice.  I'm a bit new when working with the 5505 so if there is a better practice, I'm all for implementing it.

Would that answer why the default gateway for each remote host that connects is set to the IP Address...the same IP Address that is part of the VPN_Pool I created?

Thanks,

Deez

Re: ASA 5505 VPN Default Gateway Issue

Yes, but check something please.

When you connect with the VPN client and it connects, check the yellow lock on the task bar, right click, statistics, and under Route Details, check what you have for the secure routes.

The ''secure routes'' list is what you're sending through the tunnel.

If you have 0.0.0.0 0.0.0.0 it means all traffic is sent through the tunnel (no split tunneling)

Federico.

New Member

Re: ASA 5505 VPN Default Gateway Issue

Ok, I am away from the my desk at the moment but will try what you suggested in a couple of hours and let you know the results.

Thanks,

Deez

6007
Views
0
Helpful
4
Replies
CreatePlease login to create content