Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ASA 8.2.5 point-to-point VPN problem with NAT error

This is my first post and I hope someone can help me understand and fix

I have a point to point VPN tunnell up and running but cannot communicate across the link.

Question 1: having never done this before, should this not work like a remote access vpn where the internal LAN is available once connected?

Question 2: I am not able to communicate across the tunnel even though the tunnel is up. I get  this error:

"Asymmetric NAT rules matched for forward and reverse flows; Connection for udp src outside:****** dst inside:****** denied due to NAT reverse path failure"

My show run is below                  


:
ASA Version 8.2(5)
!

domain-name ripnet.local
enable password fdafdafdasfdas encrypted
passwd fdafdafdafdas encrypted
names
name 192.168.0.6 RIPinside
name 192.168.0.7 RIPservinside
name 5x.x.x.x RIPoutside
name 5x.x.x.x RIPservoutside
name 5x.x.x.x TIMNetwork description
name 192.168.0.30 Site-RIP-Network
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.0.2 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 5x.x.x.x 255.255.255.248
!
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns server-group DefaultDNS
domain-name ripnet.local
object-group service RDC tcp
port-object eq 3389
access-list outside_access_in extended permit udp any any
access-list outside_access_in extended permit ip any any
access-list RIPVPNgroup_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 192.168.66.0 255.255.255.0
access-list inside_access_in extended permit tcp 192.168.0.0 255.255.255.0 any eq telnet
access-list inside_access_in extended permit ip any any
access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 172.x.x.x 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
ip local pool VPNRange 192.168.66.1-192.168.66.100 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (outside,inside) RIPinside RIPoutside netmask 255.255.255.255
static (inside,outside) RIPoutside RIPinside netmask 255.255.255.255
static (inside,outside) RIPservoutside RIPservinside netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 5x.x.x.x 128
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sysopt noproxyarp inside
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer 69.70.103.74
crypto map outside_map 1 set transform-set ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption des
hash md5
group 2
lifetime 28800
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 30
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 192.168.0.210-192.168.0.219 inside
dhcpd dns RIPservinside 2x.x.x.x interface inside
dhcpd wins RIPinside interface inside
dhcpd lease 86400 interface inside
dhcpd domain prinet.local interface inside
!

threat-detection basic-threat
threat-detection statistics access-list
threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
webvpn
group-policy RIPVPNgroup internal
group-policy RIPVPNgroup attributes
wins-server value 192.168.0.6
dns-server value 192.168.0.7 192.168.0.6
vpn-tunnel-protocol IPSec
split-tunnel-policy tunnelspecified
split-tunnel-network-list value RIPVPNgroup_splitTunnelAcl
default-domain value ripnet.local
username d password fdafdafdasfdafdas encrypted privilege 0
username d attributes
vpn-group-policy RIPVPNgroup
service-type remote-access
username a password fdafdafdasfdafdas encrypted privilege 0
username a attributes
vpn-group-policy RIPIVPNgroup
username b password fdafdafdasfdafdas encrypted privilege 0
username b attributes
vpn-group-policy RIPVPNgroup
service-type remote-access
tunnel-group RIPVPNgroup type remote-access
tunnel-group RIPVPNgroup general-attributes
address-pool VPNRange
default-group-policy RIPVPNgroup
tunnel-group RIPVPNgroup ipsec-attributes
pre-shared-key *****
tunnel-group 6x.x.x.x type ipsec-l2l
tunnel-group 6x.x.x.x ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:147aace7d0e90b16ab498fbb17b5af58
: end

Everyone's tags (5)
2 REPLIES
Bronze

ASA 8.2.5 point-to-point VPN problem with NAT error

Hi,

it depends on what is source and destination.

In ACL you have:

access-list outside_1_cryptomap extended permit ip 192.168.0.0 255.255.255.0 172.x.x.x 255.255.255.0

So interesting traffic is from 192.168.0.0/24 to 172.x.x.x/24

but in your NAT exemption rule is:

access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 192.168.66.0 255.255.255.0

nat (inside) 0 access-list inside_nat0_outbound

So probably if you are trying to ping 192.168.66.0 it is not exempted and return traffic is not routed back.

HTH,

Jan

New Member

ASA 8.2.5 point-to-point VPN problem with NAT error

On both sides of the tunnel is a phone system so I need to allow traffic from phone sys1 on the 172 segment at the remote site to access phone sys2 on the 192 segment locally. Knowing that, should i add the  exemption rule saying

Access-list inside_nat0_outboundexntended permit ip 192.168.0.0 255.255.255.0 172.x.x.x 255.255.255.0

The access list you show is for the remote access VPN users and not for the site-to-site. I don't know if that matters

574
Views
0
Helpful
2
Replies