Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ASA5505 Dynamic L2L Traffic Won't Pass - Phase 2 Problem

                   Hi all,

I have a Cisco ASA5505 I am setting up for a new site, and I am having trouble getting VPN Traffic to pass, despite "sh isa sa" showing the tunnel up. Internet traffic passes fine. I am also able to ping the remote endpoint. The Endpoint ASA is the central ASA for our Company Network, everything is set up in a Hub & Spoke topology. All other nodes on the network are working perfectly.

I based this new ASA config off another working Dynamic Wan ASA5505... I have checked this config a lot and can't find any problems, but was wondering if anyone sees anything wrong?? Here is my CLI outputs:

xxxxx-ASA5505# sh run
: Saved
:
ASA Version 8.2(1)
!
hostname xxxxx-ASA5505
domain-name xxxxx.local
enable password xxxxx
passwd xxxxxxxx
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.18.1 255.255.255.0
!
interface Vlan3
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 3
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
dns domain-lookup inside
dns server-group DefaultDNS
name-server 208.67.222.222
name-server 208.67.220.220
domain-name xxxxx.local
access-list to_hq extended permit ip 192.168.18.0 255.255.255.0 192.168.0.0 255.255.0.0
access-list nonat extended permit ip 192.168.18.0 255.255.255.0 192.168.0.0 255.255.0.0
pager lines 24
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map cmap1 10 match address to_hq
crypto map cmap1 10 set peer xx.xx.xx.xx
crypto map cmap1 10 set transform-set ESP-3DES-SHA
crypto map cmap1 interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 192.168.0.0 255.255.0.0 inside
ssh timeout 5
console timeout 0
dhcpd dns 192.168.9.2 208.67.222.222
!
dhcpd address 192.168.18.101-192.168.18.131 inside
dhcpd lease 10800 interface inside
dhcpd domain xxxxx.local interface inside
dhcpd option 66 ip 192.168.9.50 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username admin password xxxxx encrypted privilege 0
tunnel-group xx.xx.xx.xx type ipsec-l2l
tunnel-group xx.xx.xx.xx ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
  message-length maximum client auto
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:675a49a326675fa3b8e702b9cae337a5
: end

xxxxx-ASA5505# sh isa sa

   Active SA: 1
    Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
Total IKE SA: 1

1   IKE Peer: xx.xx.xx.xx
    Type    : L2L             Role    : initiator
    Rekey   : no              State   : MM_ACTIVE

Please help :-)

1 REPLY
New Member

ASA5505 Dynamic L2L Traffic Won't Pass - Phase 2 Problem

Okay, well it just started randomly working.

ping inside 192.168.9.x

did not work.

However when I connected a host to the ASA and tried ping in windows, traffic passed the VPN just fine.

Weird.

320
Views
0
Helpful
1
Replies