Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Broken RTP stream from IP Cameras via IPSEC or GRE Tunnel

I am experiencing very strange behavior of RTP stream from IP cameras (different vendors - D-LINK [cheap] and AXIS [expensive]).

I can get a video from camera in to ways.

!

1. MJPEG Stream - I use these type of links in Safari or FireFox:

http://admin:admin@192.168.0.251/video/mjpg.cgi !!!TCP

or

http://192.168.21.250/axis-cgi/mjpg/video.cgi?resolution=640x480 !!!TCP

And this is working excellent. The Picture is great. But it consumes a lot of expensive traffic.

!

2. MPEG4 stream - I use these types of urls in VLC, QuickTime or RealPLayer:

rtsp://192.168.0.251:554/640 !!!UDP

or

rtsp://192.168.21.250:554/mpeg4/media.amp !!!UDP

Sometime (very seldom and the picture is very unstable) I have a picture and sound, more often I do not see any picture but I hear broken sound.

At the same time the smae MPEG4 stream (rtsp://192.168.x.x:554) is working perfect if I am getting it from local lan PCs (where camera resides). But i have troubles with it outside local LAN (via tunnels).

Here is my net schema:

CAMERA - CAT2950 - C2811-IPSEC VTY via Internet (10 Mbits/s)-C3845-PIX-CAT3750-PC (VLC, QuickTime, RealPlayer)

or

CAMERA - CAT2960 - C1751V-GRE Tunnel via Internet (10 Mbits/s)-C2621XM-CAT2950-MAC (VLC, QuickTime, RealPlayer).

Also I have very similar schemas - but in all cases RTP is not working.

Something is going wrong with UDP packets during GRE/IPSEC encapsulation. But I do not know what. Please Help.

Thank you.

P.S. here is sample tunnel config, the are all similar :

interface Tunnel80

description IPsec to TOM via Comstar

bandwidth 2000

ip address 10.10.110.81 255.255.255.252

qos pre-classify

tunnel source 89.175.xx.xx

tunnel destination 77.236.xx.xx

tunnel mode ipsec ipv4

tunnel protection ipsec profile KM4

or

interface Tunnel55

description GRE to SKL via Comstar

bandwidth 10000

ip address 10.10.110.53 255.255.255.252

qos pre-classify

keepalive 3 3

tunnel source 89.175.xx.xx

tunnel destination 213.33.xx.xx

1 REPLY
Community Member

Broken RTP stream from IP Cameras via IPSEC or GRE Tunnel

did you get an answer, I'm going to guess fragmentation, but would like to know if you resolved.

1184
Views
0
Helpful
1
Replies
CreatePlease to create content