Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

c#: "new VpnApiClass()" get COM Exception 800701e7 till reboot

AnyConnect API.

Often  new VpnApiClass() throws "Retrieving the COM class factory for component with CLSID {C15C0F4F-DDFB-4591-AD53-C9A71C9C15C0} failed due to the following error: 800701e7.".

vpnui.exe is not running.

Application restart does not help.

In this case just a reboot helps.

It happens also in a small program that does almost nothing else beside 'new VpnApiClass()'.

Data: C#, .NET2.0 project on Windows 8.1, 64 bit.

 

How can this be solved?

Thank you, Ferdinand

Everyone's tags (1)
3 REPLIES
New Member

The underlying cause is a

The underlying cause is a rock-hard exception, the equivalent of an AccessViolationException. It occurs at a very critical time, just as the native DLL gets loaded and its DllMain() entrypoint runs. You can see it in the Output window if you enable unmanaged debugging. There isn't anything you can look at or do about if you don't have source code. Cisco has source code, you'll need to call them. –  Hans Passant

New Member

WorkaroundInspired by another

Workaround

Inspired by another bug regarding a similar issue here, we found a workaround. The DLL seems to have a fixed load address. When I load the DLL using LoadLibrary() right at program start, this address is free and new VpnApiClass() works.

New Member

hi, i've the same problem.

hi, i've the same problem..

when i inizialize vpnApi it work but when im going to use the connectvpn(sitename) i catch the same error and it doesnt work untill reboot..

did u load dll at program start with loadlibray in this mood?

NativeMethods.LoadLibrary(@"vpnapi.dll");

thank you

 

492
Views
0
Helpful
3
Replies