Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can a PIX-to-PIX VPN allow traffic from only one direction?

Below is the configuration from the PIX 501 that accepts incoming VPN tunnels from the other dynamic-ip PIXes.  Everything works just fine, allowing traffic to flow both directions after the tunnel comes up.  But can I somehow limit, or prevent traffic that originates on this PIX (192.168.27.2) from going to the other PIX networks?  In other words, if a tunnel exists (192.168.3.0 to 192.168.27.0), I only want to allow traffic from the 3.0 network to access the 27.0 network, and I want to prevent anyone on the 27.0 network from accessing the 3.0 network.

Thanks for any feedback.

pixfirewall# sh conf
: Saved
: Written by enable_15 at 13:29:50.396 UTC Sat Jul 3 2010
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password encrypted
passwd encrypted
hostname pixfirewall
domain-name .com
fixup protocol dns maximum-length 4096
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.27.0 255.255.255.0 10.10.10.0 255.255.255.0
access-list 102 permit ip 192.168.27.0 255.255.255.0 10.10.0.0 255.255.0.0
access-list 102 permit ip 192.168.27.0 255.255.255.0 192.168.3.0 255.255.255.0
access-list 102 permit ip 192.168.27.0 255.255.255.0 192.168.7.0 255.255.255.0
pager lines 24
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.248 255.255.255.255
ip address inside 192.168.27.2 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 10.10.10.1-10.10.10.254
pdm logging informational 100
pdm history enable
arp timeout 14400
nat (inside) 0 access-list 102
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set gvnset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set gvnset
crypto map gvnmap 10 ipsec-isakmp dynamic dynmap
crypto map gvnmap interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp keepalive 60
isakmp nat-traversal 20
isakmp policy 9 authentication pre-share
isakmp policy 9 encryption des
isakmp policy 9 hash md5
isakmp policy 9 group 2
isakmp policy 9 lifetime 86400
vpngroup gvnclient address-pool ippool
vpngroup gvnclient dns-server 192.168.27.1
vpngroup gvnclient wins-server 192.168.27.1
vpngroup gvnclient default-domain .com
vpngroup gvnclient split-tunnel 101
vpngroup gvnclient idle-time 1800
vpngroup gvnclient password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 30
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
management-access inside
console timeout 0
terminal width 80
Cryptochecksum:
pixfirewall#

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Can a PIX-to-PIX VPN allow traffic from only one direction?

Sure, definitely can.

You can configure access-list on the inside interface to deny traffic from 192.168.27.0/24 towards 192.168.3.0/24, then permit anything else.

Example:

access-list inside-acl deny ip 192.168.27.0 255.255.255.0 192.168.3.0 255.255.255.0

access-list inside-acl permit ip any any

access-group inside-acl in interface inside

Hope that helps.

2 REPLIES
Cisco Employee

Re: Can a PIX-to-PIX VPN allow traffic from only one direction?

Sure, definitely can.

You can configure access-list on the inside interface to deny traffic from 192.168.27.0/24 towards 192.168.3.0/24, then permit anything else.

Example:

access-list inside-acl deny ip 192.168.27.0 255.255.255.0 192.168.3.0 255.255.255.0

access-list inside-acl permit ip any any

access-group inside-acl in interface inside

Hope that helps.

New Member

Re: Can a PIX-to-PIX VPN allow traffic from only one direction?

Thanks for the reply.

Does that acl go on the inside or outside interface?  The VPN is established on the outside interface.

Here's a copy of the other PIX configuration:

User Access Verification

Password:
Type help or '?' for a list of available commands.
chris-pix> ena
Password: *
chris-pix# sh conf
: Saved
: Written by enable_15 at 21:25:41.407 UTC Fri Jan 1 1993
PIX Version 6.3(3)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password encrypted
passwd  encrypted
hostname chris-pix
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 209.xx.xx.xx ocean-pix-outside
name 209.xx.xx.xx cvb-pix-outside
name 24.xx.xx.xx don-pix-outside
access-list internet-traffic permit ip 192.168.3.0 255.255.255.0 any
access-list ping-permit permit icmp any any
access-list chris-to-allGvnPix-vpn permit ip 192.168.3.0 255.255.255.0 192.168.27.0 255.255.255.0
access-list chris-to-allGvnPix-vpn permit ip 192.168.3.0 255.255.255.0 192.168.28.0 255.255.255.0
access-list chris-to-allGvnPix-vpn permit ip 192.168.3.0 255.255.255.0 192.168.7.0 255.255.255.0
access-list chris-to-ocean-vpn permit ip 192.168.3.0 255.255.255.0 192.168.27.0 255.255.255.0
access-list chris-to-cvb-vpn permit ip 192.168.3.0 255.255.255.0 192.168.28.0 255.255.255.0
access-list chris-to-don-vpn permit ip 192.168.3.0 255.255.255.0 192.168.7.0 255.255.255.0
pager lines 24
logging on
logging buffered debugging
icmp deny any outside
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.3.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list chris-to-allGvnPix-vpn
nat (inside) 1 access-list internet-traffic 0 0
access-group ping-permit in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set GvnPix-set esp-des esp-md5-hmac
crypto map toGvnPix 7 ipsec-isakmp
crypto map toGvnPix 7 match address chris-to-don-vpn
crypto map toGvnPix 7 set peer don-pix-outside
crypto map toGvnPix 7 set transform-set GvnPix-set
crypto map toGvnPix 27 ipsec-isakmp
crypto map toGvnPix 27 match address chris-to-ocean-vpn
crypto map toGvnPix 27 set peer ocean-pix-outside
crypto map toGvnPix 27 set transform-set GvnPix-set
crypto map toGvnPix 28 ipsec-isakmp
crypto map toGvnPix 28 match address chris-to-cvb-vpn
crypto map toGvnPix 28 set peer cvb-pix-outside
crypto map toGvnPix 28 set transform-set GvnPix-set
crypto map toGvnPix interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp keepalive 60
isakmp policy 9 authentication pre-share
isakmp policy 9 encryption des
isakmp policy 9 hash md5
isakmp policy 9 group 2
isakmp policy 9 lifetime 86400
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 30
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 30
management-access inside
console timeout 0
dhcpd address 192.168.3.2-192.168.3.33 inside
dhcpd lease 86400
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 100
Cryptochecksum:
chris-pix#

210
Views
0
Helpful
2
Replies
CreatePlease login to create content