Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can I manage an ASA 5505 from a VPN tunnel?

If so, how?

 

I have an ASA 5500 that is working great.  But when I try to use a tunneled PC as a host for ASDM or SSH, it fails.  Am I missing something?

 

ASA Version 8.2(5) 
!
hostname INTOPS-VPN
enable password 1g7lIEBcTxxsrDvI encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.5.2 255.255.255.0 
!
interface Vlan2
nameif outside
security-level 0
ip address 10.220.6.200 255.255.255.224 
!
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
dns server-group DefaultDNS
domain-name pelco.com
access-list inside_nat0_outbound extended permit ip 192.168.5.0 255.255.255.0 192.168.5.0 255.255.255.128 
access-list inside_nat0_outbound extended permit ip any 192.168.5.0 255.255.255.128 
access-list inside_access_in extended permit ip any any 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool Pool_One 192.168.5.50-192.168.5.99 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 101 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 101 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 10.220.6.193 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL 
aaa authentication telnet console LOCAL 
aaa authentication enable console LOCAL 
aaa authentication http console LOCAL 
aaa authentication serial console LOCAL 
http server enable
http 192.168.5.0 255.255.255.0 inside
http 192.168.5.0 255.255.255.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs 
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
client-update enable
no vpn-addr-assign aaa
telnet 192.168.5.0 255.255.255.0 inside
telnet 192.168.5.0 255.255.255.0 outside
telnet timeout 5
ssh 192.168.5.0 255.255.255.0 inside
ssh 192.168.5.0 255.255.255.0 outside
ssh timeout 5
console timeout 0
management-access inside
dhcpd address 192.168.5.50-192.168.5.99 inside
dhcpd enable inside
!

no threat-detection basic-threat
no threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy Schneider internal
group-policy Schneider attributes
vpn-tunnel-protocol IPSec 
default-domain value pelco.com
group-policy intops internal
group-policy intops attributes
vpn-tunnel-protocol IPSec 
default-domain value pelco.com
client-firewall none
username intops password fLdsGLhyHBUhWQVE encrypted privilege 15
username intops attributes
vpn-group-policy ******
username ****** password 9lCVHs7/PYH72Ao0 encrypted privilege 15
tunnel-group Schneider type remote-access
tunnel-group Schneider general-attributes
address-pool Pool_One
authorization-server-group LOCAL
default-group-policy ******
tunnel-group Schneider ipsec-attributes
pre-shared-key *****
tunnel-group intops type remote-access
tunnel-group intops general-attributes
address-pool Pool_One
default-group-policy intops
tunnel-group intops ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
 message-length maximum client auto
 message-length maximum 512
policy-map global_policy
class inspection_default
 inspect dns preset_dns_map 
 inspect ftp 
 inspect h323 h225 
 inspect h323 ras 
 inspect ip-options 
 inspect netbios 
 inspect rsh 
 inspect rtsp 
 inspect skinny  
 inspect esmtp 
 inspect sqlnet 
 inspect sunrpc 
 inspect tftp 
 inspect sip  
 inspect xdmcp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
call-home
profile CiscoTAC-1
 no active
 destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
 destination address email callhome@cisco.com
 destination transport-method http
 subscribe-to-alert-group diagnostic
 subscribe-to-alert-group environment
 subscribe-to-alert-group inventory periodic monthly
 subscribe-to-alert-group configuration periodic monthly
 subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:e1b30dbad389ec90e67824abccba30ce
: end

 

Thanks in advance for any and all help.

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Thanks for confirming that

Thanks for confirming that both ASDM and SSH do work correctly when initiated from an inside device and fail when initiated from VPN. The config that you show seems correct in that it specifies the management interface as inside, and that it enables both ASDM and SSH from the address range from outside. My thoughts turn to my observation about the fact that the VPN pool duplicates the DHCP range, and that both are in the address range configured for the inside interface. I repeat my suggestion that you configure the VPN pool to be some address range that does not overlap with other address ranges (and make corresponding changes in the address ranges for ASDM and SSH).

 

HTH

 

Ric

9 REPLIES
Cisco Employee

Hi , Can you please share the

Hi ,

 

Can you please share the output of "show run all sysopt"

Regards,
Dinesh Moudgil
 

 

New Member

Certainly. INTOPS-VPN# show

Certainly.

 


INTOPS-VPN# show run all sysopt
no sysopt connection timewait
sysopt connection tcpmss 1380
sysopt connection tcpmss minimum 0
sysopt connection permit-vpn
sysopt connection reclassify-vpn
no sysopt connection preserve-vpn-flows
no sysopt nodnsalias inbound
no sysopt nodnsalias outbound
no sysopt radius ignore-secret
no sysopt noproxyarp inside
no sysopt noproxyarp outside

Hall of Fame Super Silver

It complicates (and

It complicates (and potentially confuses) things when you use the same address range for VPN addresses and DHCP pool and that these addresses are in the range of your inside address. I wonder if it would improve things if the VPN addresses were a separate range?

Also what address are you going to for ASDM and SSH?  It should be the address of the inside interface. 

 

HTH

 

rick

 

New Member

" It should be the address of

" It should be the address of the inside interface. "

 

It is.  192.168.5.2

 

 

 

Hall of Fame Super Silver

Thanks for confirming that

Thanks for confirming that you are attempting access using the inside interface address. My next question would be to ask you to confirm that ASDM and SSH do work if you do them from a host inside the network? (confirming that ASDM and SSH do work and that the issue is unique to attempt that come from VPN connection)

 

HTH

 

Rick

New Member

If I try to use either ASDM

If I try to use either ASDM or SSH from a PC on the inside, it works without issue.

Hall of Fame Super Silver

Thanks for confirming that

Thanks for confirming that both ASDM and SSH do work correctly when initiated from an inside device and fail when initiated from VPN. The config that you show seems correct in that it specifies the management interface as inside, and that it enables both ASDM and SSH from the address range from outside. My thoughts turn to my observation about the fact that the VPN pool duplicates the DHCP range, and that both are in the address range configured for the inside interface. I repeat my suggestion that you configure the VPN pool to be some address range that does not overlap with other address ranges (and make corresponding changes in the address ranges for ASDM and SSH).

 

HTH

 

Ric

New Member

Richard, it seems you were

Richard, it seems you were right.  Once I changed the DHCP address pool, I was able to start managing the ASA from a PC connected via VPN.

 

That you very much.

Hall of Fame Super Silver

I am glad that my suggestion

I am glad that my suggestion did lead to a solution for you. Thank you for posting back to the forum to indicate that you have solved the problem and how it was solved. Also thank you for using the rating system to mark this question as answered. This will help other readers of the forum to know that there is helpful information in this thread.

 

HTH

 

Rick

196
Views
0
Helpful
9
Replies
CreatePlease login to create content