Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Can't connect to Windows VPN Server behind ASA 5505

I have a Windows 2003 Server with VPN Service sitting behind an ASA 5505, and I can't connect to it via Windows VPN client. My client just hangs at the "Verifying username and password..." prompt. I've done quite a bit of searching on this problem and feel that I should have everything configured correctly (see below). While trying to connect, I watch the logs (also shown below) and see the GRE translation get built with no errors. Any advice is greatly appreciated.

ASA 5505 CONFIGURATION:

names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.50.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Vlan3
shutdown
no forward interface Vlan1
nameif dmz
security-level 50
ip address 192.168.5.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
name-server 192.168.0.1
domain-name mydomainnameismaskedforforumpost
same-security-traffic permit intra-interface
object-group protocol TCPUDP
protocol-object udp
protocol-object tcp
object-group service windows-remotedesktop tcp-udp
description Windows Remote Desktop
port-object eq 3389
access-list inside_access_in extended permit ip any any
access-list outside_access_in extended permit tcp any any eq 3389
access-list outside_access_in extended permit tcp any any eq pptp
access-list outside_access_in extended permit tcp any any eq 1701
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 192.168.50.2 3389 netmask 255.255.255.255
static (inside,outside) tcp interface 1701 192.168.50.2 1701 netmask 255.255.255.255
static (inside,outside) tcp interface pptp 192.168.50.2 pptp netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 0.0.0.0 0.0.0.0 outside
http 192.168.50.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.50.200-192.168.50.230 inside
dhcpd auto_config outside interface inside
!
dhcprelay timeout 60

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect pptp
  inspect ipsec-pass-thru
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:4c98bb8cf3e41e558664e36a9e97d861
: end

LOG OUTPUT WHILE TRYING TO CONNECT:

6|Oct 29 2010|14:30:22|302013|192.168.0.2|192.168.50.2|Built outbound TCP connection 96041 for outside:192.168.0.2/1099 (192.168.0.2/1099) to inside:192.168.50.2/3517 (70.243.242.23/47186)
6|Oct 29 2010|14:30:22|305011|192.168.50.2|70.243.242.23|Built dynamic TCP translation from inside:192.168.50.2/3517 to outside:70.243.242.23/47186
6|Oct 29 2010|14:30:19|305012|192.168.50.103|70.243.242.23|Teardown dynamic TCP translation from inside:192.168.50.103/1114 to outside:70.243.242.23/47185 duration 0:00:30
6|Oct 29 2010|14:30:14|302015|96.17.157.62|192.168.50.121|Built outbound UDP connection 96040 for outside:96.17.157.62/3478 (96.17.157.62/3478) to inside:192.168.50.121/1043 (70.243.242.23/12193)
6|Oct 29 2010|14:30:14|305012|192.168.50.2|70.243.242.23|Teardown dynamic GRE translation from inside:192.168.50.2/22024 to outside:70.243.242.23/1 duration 0:00:30
6|Oct 29 2010|14:30:10|302015|209.107.220.165|192.168.50.103|Built outbound UDP connection 96039 for outside:209.107.220.165/3478 (209.107.220.165/3478) to inside:192.168.50.103/1043 (70.243.242.23/12190)
6|Oct 29 2010|14:30:07|302016|77.67.10.135|192.168.50.121|Teardown UDP connection 96009 for outside:77.67.10.135/3478 to inside:192.168.50.121/1043 duration 0:02:02 bytes 99
6|Oct 29 2010|14:30:07|305011|192.168.50.2|70.243.242.23|Built dynamic GRE translation from inside:192.168.50.2/40656 to outside:70.243.242.23/3
6|Oct 29 2010|14:30:07|302013|74.222.200.185|192.168.50.2|Built inbound TCP connection 96036 for outside:74.222.200.185/1308 (74.222.200.185/1308) to inside:192.168.50.2/1723 (70.243.242.23/1723)

1 REPLY

Re: Can't connect to Windows VPN Server behind ASA 5505

Hi,

You're trying a PPTP, L2TP or L2TP/IPsec connection to the internal windows server?

PPTP uses TCP 1723 and GRE

L2TP uses TCP 1701 and GRE

IPsec uses UDP 500, UDP 4500 and ESP

So, if you want to connect to the outside IP of the ASA and be redirected to the windows server, you need to use the ports above in the ACL and in the NAT rules.


Federico.

1128
Views
0
Helpful
1
Replies
CreatePlease to create content