Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can your run IPSEC on multiple GRE tunnels in a 2811 router?

I have a 2811 router with multiple tunnels defined to other 2811's. I want to encrypt the traffic in each tunnel using ipsec. Since the crypto map only has one active peer and the map is applied to the physical Ethernet interface in my 2811 I have not been able to encrypt traffic on more than one tunnel. Basically my hub router has the multiple tunnels but I've only been able to successfully encrypt one tunnel at a time on that router. Any suggestions would be appreciated.

Thanks,

Dave

2 REPLIES

Re: Can your run IPSEC on multiple GRE tunnels in a 2811 router?

use tunnel protection....

crypto isakmp policy 1

encr 3des

authentication pre-share

group 2

crypto isakmp key Cisco12345 address 10.0.149.217

crypto IPsec transform-set T1 esp-3des esp-sha-hmac

crypto IPsec profile P1

set transform-set T1

!

interface Tunnel0

ip address 10.0.51.203 255.255.255.0

ip ospf mtu-ignore

load-interval 30

tunnel source 10.0.149.203

tunnel destination 10.0.149.217

tunnel protection IPsec profile P1

!

interface Ethernet3/0

ip address 10.0.149.203 255.255.255.0

duplex full

!

New Member

Re: Can your run IPSEC on multiple GRE tunnels in a 2811 router?

Thanks for the information. It worked like a charm.

Dave

211
Views
5
Helpful
2
Replies
CreatePlease login to create content