Cisco Support Community
Community Member

Cisco 2801 and Linksys RV042 VPN conf


Kindly help me out. I'm configuring a p2p vpn between a cisco 2801 with IOS 12.3 and a linksys RV042. I'm getting error

[Tunnel Negotiation Info] >>> Initiator Send Main Mode 1st packet

Dec 19 02:40:42 2011     VPN Log    Received informational payload, type NO_PROPOSAL_CHOSEN

Below are my config:


crypto isakmp policy 11

encr 3des

authentication pre-share

group 2

lifetime 28800

crypto isakmp key xxxxxx address xxxxxx

no crypto isakmp ccm

crypto ipsec transform-set STRONGER esp-3des esp-md5-hmac

crypto map myvpn 10 ipsec-isakmp

set peer xxxxxx

set transform-set STRONGER

set pfs group2

match address 103

interface FastEthernet0/0

ip address

ip nat inside

ip virtual-reassembly

no ip route-cache

duplex auto

speed auto

no mop enabled


interface FastEthernet0/1

ip address xxxx xxxx

ip nat outside

ip virtual-reassembly

no ip route-cache

duplex auto

speed auto

crypto map myvpn

ip nat pool branch xxxxxx xxxxx netmask

ip nat inside source route-map nonat pool branch overload


access-list 103 permit ip

access-list 110 deny   ip

access-list 110 permit ip any

snmp-server community public RO


route-map nonat permit 10

match ip address 110

Linksys RV042:

Keying Mode: IKE with Preshared Key

Phase1 DH Group: Group2

Phase1 Encryption: 3DES

Phase1 Authentication: MD5

Phase1 SA Life Time: 28800

Perfect forward secrecy : enabled

Phase2 DH Group: Group2

Phase2 Encryption: 3DES

Phase2 Authentication: MD5

Phase2 SA Life Time: 28800

Preshared Key: xxxxxx

CreatePlease to create content