Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco AnyConnect client failing to connect

All -

    I'd appreciate any guidance you could give me here.  I have a Cisco AnyConnect (version 2.4.1012) that is now failing to connect.  it worked just fine not long agi.  Under IE and Firefox, it does the same thing:  accepts credentials, gives me the login banner (authorized use only, etc, click Continue or Cancel), and then brings me right back to the login page.  With the standalone client, it gives me no feedback at all, it just brings be right back to the login screen.  In no case does it tell me the login failed.  it just asks me for credentials again.  In the client logs, I see this:

Function: ConnectMgr::setPromptAttributes

File: .\ConnectMgr.cpp

Line: 2662

Invoked Function: setPromptAttributes

Return Code: -33554423 (0xFE000009)


Error text:

Login failed.

This appears to be a problem with my specific host.  I have someone else who works just fine, but when we try his credentials on my host, we get the same result.  I know the credentials are correct, because if I feed it intentionally incorrect credentials, I get the "login failed" message (in the browsers, not in the standalone client).  This has worked fine in the recent past, and I am unware of any changes to the host.  My machine is Windows 7 x64, patched to current.  I have uninstalled and re-installed the standalone client (and rebooted).  Neither IE nor Firefox appear to want to install the client automatically.  IE appears to refuse to remove the web control (via Manage Add-ons -> Show all add-ons -> More Information -> Remove).  Here is what IE has for the Web Control:

Name:                   Cisco AnyConnect VPN Client Web Control

Publisher:              Cisco Systems, Inc.

Type:                   ActiveX Control

Version:                2. 3. 0281

File date:             

Date last accessed:     ‎Wednesday, ‎April ‎04, ‎2012, ‏‎8:45 AM

Class ID:               {55963676-2F5E-4BAF-AC28-CF26AA587566}

Use count:              11

Block count:            1

File:                   vpnweb.ocx

Folder:                 C:\Windows\SysWOW64

Java appears to lock up when invoked from Firefox for installing the AnyConnect client.  Firefox told me to select Yes on the security warning, which I did, and it sat there for several minutes with no activity.  Java had launched, but was performing no actions.  When I finally killed the Java process, the browser immediately acted like it was trying to install for 60 seconds, then said it failed, and offered me the manual download.

Any suggestions would be appreciated.



CreatePlease to create content