Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco ASA 5505 Dual-ISP Backup VPN

I am trying to create a backup tunnel from an ASA 5505 to a pix 501 in the case of the Main ISP failing.  The Pix external side will stay the same, but not quite sure how I can create a new crypto map and have it use the Backup ISP interface without bringing down the main tunnel.

My first thought was to add the following crypto map to the configuration below:

crypto map outside_map 2 match address outside_1_cryptomap
crypto map outside_map 2 set peer 9.3.21.13
crypto map outside_map 2 set transform-set ESP-DES-MD5
crypto map outside_map interface backupisp -->but this would break the current tunnel.


NYASA# sh run
: Saved
:
ASA Version 7.2(4)
!
hostname NYASA
domain-name girls.org
enable password CHwdJ2WMUcjxIIm8 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 10.1.2.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 9.17.5.8 255.255.255.240
!
interface Vlan3
description Backup ISP
nameif backupisp
security-level 0
ip address 6.27.9.5 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
switchport access vlan 3
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
dns server-group DefaultDNS

access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in extended permit icmp any any source-quench
access-list outside_access_in extended permit icmp any any unreachable
access-list outside_access_in extended permit icmp any any time-exceeded
access-list outside_access_in extended permit icmp any any
access-list inside_nat0_outbound extended permit ip 10.1.2.0 255.255.255.0 10.1.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.1.2.0 255.255.255.0 10.1.100.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 10.1.2.0 255.255.255.0 10.1.1.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip 10.1.2.0 255.255.255.0 10.1.100.0 255.255.255.0
access-list 150 extended permit ip any host 10.1.2.27
access-list 150 extended permit ip host 10.1.2.27 any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu backupisp 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
nat-control
global (outside) 1 interface
global (backupisp) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 9.17.5.7 1 track 1
route backupisp 0.0.0.0 0.0.0.0 6.27.9.1 254
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 10.1.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sla monitor 10
type echo protocol ipIcmpEcho 4.2.2.2 interface outside
num-packets 3
timeout 1000
frequency 3
sla monitor schedule 10 life forever start-time now
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer 9.3.21.13
crypto map outside_map 1 set transform-set ESP-DES-MD5
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption des
hash md5
group 2
lifetime 86400
crypto isakmp nat-traversal  20
!
track 1 rtr 10 reachability
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
console timeout 0
management-access inside

username ptiadmin password BtOLil2gR0VaUjfX encrypted privilege 15
tunnel-group 9.4.21.13 type ipsec-l2l
tunnel-group 9.4.21.13 ipsec-attributes
pre-shared-key *
!
!
prompt hostname context
Cryptochecksum:22bb60b07c4c1805b89eb2376683f861
: end
NYASA#

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cisco ASA 5505 Dual-ISP Backup VPN

In that case is the PIX who needs two peers (to the ASA).

The ASA will requiere the crypto map to be applied to the backup interface as well (as you mentioned)

crypto map outside_map interface backupisp -->but this would break the current tunnel.

The above command should not break the current tunnel (if the route to reach the other end goes out via the primary interface).

Additionally you need IP SLA configured in the ASA to allow it to use the primary connection and fallback to the backup connection to build-up the tunnel (as well to use again the primary interface when it recovers).

Federico.

5 REPLIES

Re: Cisco ASA 5505 Dual-ISP Backup VPN

Jason,

Do you want the ASA to have two IP addresses to establish the tunnel with the PIX? (one primary and one backup)?

If so...

crypto map outside_map 2 match address outside_1_cryptomap
crypto map outside_map 2 set peer 9.3.21.13 x.x.x.x
crypto map outside_map 2 set transform-set ESP-DES-MD5

Where x.x.x.x --> is the second IP that the ASA will try to bring up the tunnel (in case 9.3.21.13) won't answer.

Federico.

New Member

Re: Cisco ASA 5505 Dual-ISP Backup VPN

Federico,

The pix ip (9.3.21.13) will stay static.  In the event Vlan2 (outside 9.17.5.8) goes down on the ASA, I would like Vlan3 (backupisp 6.27.9.5) to establish the tunnel with the Pix.

Thanks,

Jason

Re: Cisco ASA 5505 Dual-ISP Backup VPN

In that case is the PIX who needs two peers (to the ASA).

The ASA will requiere the crypto map to be applied to the backup interface as well (as you mentioned)

crypto map outside_map interface backupisp -->but this would break the current tunnel.

The above command should not break the current tunnel (if the route to reach the other end goes out via the primary interface).

Additionally you need IP SLA configured in the ASA to allow it to use the primary connection and fallback to the backup connection to build-up the tunnel (as well to use again the primary interface when it recovers).

Federico.

New Member

Re: Cisco ASA 5505 Dual-ISP Backup VPN

Perfect. The pix side is already built. Thanks for the help.

New Member

Cisco ASA 5505 Dual-ISP Backup VPN

I came upon this article when looking for a solution to the failback situation with sla on the asa 5505's. I have dual isp's on both ends and when the primary line fails at either end it will re-negotiate to the backup isp along with renegotiating the vpn. this occurs very fast and in 10 seconds or less. but when the main isp's connection is turned back on the connection will failback but in about 30 seconds and the vpn will not re-negotiate for another 4-5 minutes. Is there a fix for this slow failback time to the primary line?

thanks

3655
Views
0
Helpful
5
Replies
CreatePlease to create content