Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Cisco ASA 5505 L2TP VPN cannot access internal network

Hi,

I'm trying to configure Cisco L2TP VPN to my office. After successful connection I cannot access to internal network.

Can you jhelp me to find out the issue?

I have Cisco ASA:

inside network - 192.168.1.0

VPN network - 192.168.168.0

I have router 192.168.1.2 and I cannot ping or get access to this router.

Here is my config:

ASA Version 8.4(3)

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

!

interface Ethernet0/4

!

interface Ethernet0/5

!

interface Ethernet0/6

!

interface Ethernet0/7

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address 198.X.X.A 255.255.255.248

!

ftp mode passive

same-security-traffic permit intra-interface

object network net-all

subnet 0.0.0.0 0.0.0.0

object network vpn_local

subnet 192.168.168.0 255.255.255.0

object network inside_nw

subnet 192.168.1.0 255.255.255.0

access-list outside_access_in extended permit icmp any any echo-reply

access-list outside_access_in extended deny ip any any log

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

ip local pool sales_addresses 192.168.168.1-192.168.168.254

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

nat (inside,outside) source dynamic net-all interface

nat (inside,outside) source static inside_nw inside_nw destination static vpn_local vpn_local

nat (outside,inside) source static vpn_local vpn_local destination static inside_nw inside_nw route-lookup

!

object network vpn_local

nat (outside,outside) dynamic interface

object network inside_nw

nat (inside,outside) dynamic interface

access-group outside_access_in in interface outside

route outside 0.0.0.0 0.0.0.0 198.X.X.B 1

timeout xlate 3:00:00

timeout pat-xlate 0:00:30

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

aaa authentication enable console LOCAL

aaa authentication ssh console LOCAL

aaa authentication http console LOCAL

http server enable

http 192.168.1.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

crypto ipsec ikev1 transform-set my-transform-set-ikev1 esp-3des esp-sha-hmac

crypto ipsec ikev1 transform-set my-transform-set-ikev1 mode transport

crypto dynamic-map dyno 10 set ikev1 transform-set my-transform-set-ikev1

crypto map vpn 20 ipsec-isakmp dynamic dyno

crypto map vpn interface outside

crypto isakmp nat-traversal 3600

crypto ikev1 enable outside

crypto ikev1 policy 10

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh 192.168.1.0 255.255.255.0 inside

ssh timeout 30

console timeout 0

management-access inside

dhcpd address 192.168.1.5-192.168.1.132 inside

dhcpd dns 75.75.75.75 76.76.76.76 interface inside

dhcpd enable inside

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

group-policy sales_policy internal

group-policy sales_policy attributes

dns-server value 75.75.75.75 76.76.76.76

vpn-tunnel-protocol l2tp-ipsec

username ----------

username ----------

tunnel-group DefaultRAGroup general-attributes

address-pool sales_addresses

default-group-policy sales_policy

tunnel-group DefaultRAGroup ipsec-attributes

ikev1 pre-shared-key *****

tunnel-group DefaultRAGroup ppp-attributes

authentication ms-chap-v2

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect rsh

  inspect rtsp

  inspect esmtp

  inspect sqlnet

  inspect skinny

  inspect sunrpc

  inspect xdmcp

  inspect sip

  inspect netbios

  inspect tftp

  inspect ip-options

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

Cryptochecksum:5d1fc9409c87ecdc1e06f06980de6c13

: end

Thanks for your help.

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: Cisco ASA 5505 L2TP VPN cannot access internal network

You have to test it with "real" traffic to 192.168.1.2 and if you use ping, you have to add icmp-inspection:

policy-map global_policy

  class inspection_default

    inspect icmp

-- 

Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

4 REPLIES
VIP Purple

Re: Cisco ASA 5505 L2TP VPN cannot access internal network

Your nat-config seems wrong:

no nat (inside,outside) source dynamic net-all interface
no nat (outside,inside) source static vpn_local vpn_local destination static inside_nw inside_nw route-lookup


Sent from Cisco Technical Support iPad App

New Member

Cisco ASA 5505 L2TP VPN cannot access internal network

Can you give me advice which nat config I should use?

I've tried to delete this nat config, but still cannot ping 192.168.1.1 and 192.168.1.2

Thanks for your help.

VIP Purple

Re: Cisco ASA 5505 L2TP VPN cannot access internal network

You have to test it with "real" traffic to 192.168.1.2 and if you use ping, you have to add icmp-inspection:

policy-map global_policy

  class inspection_default

    inspect icmp

-- 

Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

New Member

Re: Cisco ASA 5505 L2TP VPN cannot access internal network

Thanks for your help.

Also it's started to work after this:

object network inside-network

subnet 192.168.1.0 255.255.255.0

nat (inside,outside) source static inside-network inside-network destination static inside-network inside-network no-proxy-arp route-lookup

1607
Views
0
Helpful
4
Replies
CreatePlease to create content