Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco PIX VPN - No Lan Access

Hi!

Why can?t i reach resources on the Inside interface? Thanks in advance!

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list VPN permit ip 195.x.x.0 255.255.255.0 195.30.31.0 255.255.255.0

access-list out-to-in permit icmp any any time-exceeded

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside XXX.XXX.XXX.XXX 255.255.255.240

ip address inside 195.x.x.1 255.255.255.0

ip audit name idsinfo info action alarm

ip audit name idsattack attack action alarm drop reset

ip audit interface outside idsinfo

ip audit interface outside idsattack

ip audit info action alarm

ip audit attack action alarm

ip local pool VPNDHCP 195.30.31.10-195.30.31.20

pdm location 195.x.x.0 255.255.255.0 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 interface

nat (inside) 0 access-list VPN

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

access-group out-to-in in interface outside

route outside 0.0.0.0 0.0.0.0 XXX.XXX.XXX.XXX 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 195.x.x.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set matiasvpn esp-des esp-md5-hmac

crypto dynamic-map dynmapmatias 99 set transform-set matiasvpn

crypto map matiasmap 99 ipsec-isakmp dynamic dynmapmatias

crypto map matiasmap interface outside

isakmp enable outside

isakmp identity address

isakmp policy 88 authentication pre-share

isakmp policy 88 encryption des

isakmp policy 88 hash md5

isakmp policy 88 group 2

isakmp policy 88 lifetime 86400

vpngroup -matIasvpn. address-pool VPNDHCP

vpngroup -matIasvpn. dns-server 195.30.30.3

vpngroup -matIasvpn. wins-server 195.30.30.3

vpngroup -matIasvpn. default-domain mattias.com

vpngroup -matIasvpn. idle-time 1800

vpngroup -matIasvpn. password ******

telnet 195.30.30.0 255.255.255.0 inside

telnet timeout 5

ssh 195.30.30.0 255.255.255.240 inside

ssh timeout 5

console timeout 0

terminal width 80

10 REPLIES
New Member

Re: Cisco PIX VPN - No Lan Access

Try "isakmp nat-traversal"

New Member

Re: Cisco PIX VPN - No Lan Access

Strange thing...this config really works great from home with ADSL and Fiber. When i try from work (leased 100m/bit) i cannot not reach anything on Lan side. What could this depend on?

Cheers!

Re: Cisco PIX VPN - No Lan Access

Use nat-traversal and make sure UDP 500, 4500 and 10000; as well as ESP (IP 50) and ICMP are permitted on the ISP.

Also, check the SetMTU utiliy of the Cisco VPN Client and set the MTU to 1300 or below.

Rate if this helped.

Regards,

Daniel

New Member

Re: Cisco PIX VPN - No Lan Access

Thanks for the command!

More issues found. We have a webserver inside (195.30.30.3) that should be reachable from internet. The outside webserver from internet has adress xxx.xxx.xxx.90 and should make a port forward to 195.30.30.3

If i change Outside ip of the pix to xxx.xxx.xxx.90 instead of 82 that my isp suggested i get it to work but then the VPN funtion is not working anymore. Please help and thank you again!

PIX Version 6.3(5)

interface ethernet0 10baset

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password xxxx

passwd xxx

hostname ILAB

domain-name ilab.local

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list VPN permit ip 195.30.30.0 255.255.255.0 195.30.31.0 255.255.255.0

access-list out-to-in permit icmp any any echo-reply

access-list out-to-in permit icmp any any time-exceeded

access-list outside_in permit tcp any host XXX.XXX.XXX.82 eq www

access-list outside_in permit tcp any host XXX.XXX.XXX.90 eq www

pager lines 24

logging buffered notifications

mtu outside 1500

mtu inside 1500

ip address outside XXX.XXX.XXX.82 255.255.255.240

ip address inside 195.30.30.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool VPNDHCP 195.30.31.10-195.30.31.20

pdm location 192.168.1.0 255.255.255.0 inside

pdm location 195.30.31.0 255.255.255.0 outside

pdm location 195.30.30.3 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 XXX.XXX.XXX.82-XXX.XXX.XXX.90 netmask 255.255.255.240

nat (inside) 0 access-list VPN

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp interface www 195.30.30.3 www netmask 255.255.255.25

5 0 0

access-group outside_in in interface outside

route outside 0.0.0.0 0.0.0.0 XXX.XXX.XXX.81 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 195.30.30.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set matiasvpn esp-des esp-md5-hmac

crypto dynamic-map dynmapmatias 99 set transform-set matiasvpn

crypto map matiasmap 99 ipsec-isakmp dynamic dynmapmatias

crypto map matiasmap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 88 authentication pre-share

isakmp policy 88 encryption des

isakmp policy 88 hash md5

isakmp policy 88 group 2

isakmp policy 88 lifetime 86400

vpngroup -matIasvpn. address-pool VPNDHCP

vpngroup -matIasvpn. dns-server 195.30.30.3

vpngroup -matIasvpn. wins-server 195.30.30.3

vpngroup -matIasvpn. default-domain mattias.com

vpngroup -matIasvpn. idle-time 1800

vpngroup -matIasvpn. password ********

telnet 195.30.30.0 255.255.255.0 inside

telnet timeout 5

console timeout 0

dhcpd auto_config outside

terminal width 80

Cryptochecksum:xxxx

: end

ILAB(config)#

Re: Cisco PIX VPN - No Lan Access

You should keep the Interface IP clear of anything else, as you have enough IPs from the ISP, and note that the XXX.XXX.XXX.82 is used by the interface, by the NAT and static (not a good overlap).

Use instead:

ip address outside XXX.XXX.XXX.82 255.255.255.240

global (outside) 1 XXX.XXX.XXX.83-XXX.XXX.XXX.89 netmask 255.255.255.240

static (inside,outside) XXX.XXX.XXX.90 195.30.30.3 netmask 255.255.255.255

Please rate if this helped.

Regards,

Daniel

New Member

Re: Cisco PIX VPN - No Lan Access

Hello and thanks for all your help. Please check the new config. How do i config outside ipadress and vpn ipadress to be different?

PIX Version 6.3(5)

interface ethernet0 10baset

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password IFpILV3tODomCSUd encrypted

passwd IFpILV3tODomCSUd encrypted

hostname ILAB

domain-name ilab.local

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol ils 389

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list VPN permit ip 195.30.30.0 255.255.255.0 195.30.31.0 255.255.255.0

access-list out-to-in permit icmp any any echo-reply

access-list out-to-in permit icmp any any time-exceeded

access-list outside_in permit tcp any host xxx.xxx.xxx.90 eq www

access-list outside_in permit tcp any host xxx.xxx.xxx.82 eq www

pager lines 24

logging buffered notifications

mtu outside 1500

mtu inside 1500

ip address outside xxx.xxx.xxx.82 255.255.255.240

ip address inside 195.30.30.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool VPNDHCP 195.30.31.10-195.30.31.20

pdm location 192.168.1.0 255.255.255.0 inside

pdm location 195.30.31.0 255.255.255.0 outside

pdm location 195.30.30.3 255.255.255.255 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 xxx.xxx.xxx.83-xxxx.xxx.xxx.89

global (outside) 1 interface

nat (inside) 0 access-list VPN

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) tcp interface www 195.30.30.3 www netmask 255.255.255.25

5 0 0

static (inside,outside) xxx.xxx.xxx.90 195.30.30.3 netmask 255.255.255.255 0 0

access-group outside_in in interface outside

route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.81 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 195.30.30.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

service resetinbound

crypto ipsec transform-set matiasvpn esp-des esp-md5-hmac

crypto dynamic-map dynmapmatias 99 set transform-set matiasvpn

crypto map matiasmap 99 ipsec-isakmp dynamic dynmapmatias

crypto map matiasmap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 88 authentication pre-share

isakmp policy 88 encryption des

isakmp policy 88 hash md5

isakmp policy 88 group 2

isakmp policy 88 lifetime 86400

vpngroup -matIasvpn. address-pool VPNDHCP

vpngroup -matIasvpn. dns-server 195.30.30.3

vpngroup -matIasvpn. wins-server 195.30.30.3

vpngroup -matIasvpn. default-domain mattias.com

vpngroup -matIasvpn. idle-time 1800

vpngroup -matIasvpn. password ********

telnet 195.30.30.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd auto_config outside

terminal width 80

Cryptochecksum:c5f1e97c82f776606da4da4da956f8bf

: end

ILAB(config)#

Re: Cisco PIX VPN - No Lan Access

Hi,

All is done, except that you will need to remove the old line:

static (inside,outside) tcp interface www 195.30.30.3 www netmask 255.255.255.255 0 0

From now one, the http server will be visible from the internet with the xx.xx.xx.90 IP.

Please rate if this helped.

Regards,

Daniel

New Member

Re: Cisco PIX VPN - No Lan Access

Ok, thank Daniel! I will remove the line. The users complain about random access to internet www, pop3. Some users can connect while some can?t. This "feature" walks around and next morning a person who could not use internet now can use it?! With the old firewall this was not a problem.

Kr

Mattias

New Member

Re: Cisco PIX VPN - No Lan Access

you may need to clear xlate. You can remove the nat configs, but if youd ont clear it from the transaltion table, it wont work correctly

New Member

Re: Cisco PIX VPN - No Lan Access

Hello!

I found out why the connection was unsteady. User license was restricted ti 10 user. Iahve now upgraded the licens. So now it should work great but no. Now i dont get VPN or portforward to work...please look at config.

Cheers!

PIX Version 6.3(5)

interface ethernet0 10baset

interface ethernet1 100full

nameif ethernet0 outside security0

nameif ethernet1 inside security100

enable password IFpILV3tODomCSUd encrypted

passwd IFpILV3tODomCSUd encrypted

hostname pixfirewall

domain-name ciscopix.com

fixup protocol dns maximum-length 512

fixup protocol ftp 21

fixup protocol h323 h225 1720

fixup protocol h323 ras 1718-1719

fixup protocol http 80

fixup protocol rsh 514

fixup protocol rtsp 554

fixup protocol sip 5060

fixup protocol sip udp 5060

fixup protocol skinny 2000

fixup protocol smtp 25

fixup protocol sqlnet 1521

fixup protocol tftp 69

names

access-list VPN permit ip 195.30.30.0 255.255.255.0 195.30.31.0 255.255.255.0

access-list out-to-in permit icmp any any time-exceeded

access-list outside_in permit tcp any host xxx.xxx.xxx.90 eq www

access-list outside_in permit icmp any any echo-reply

access-list outside_in permit icmp any any unreachable

access-list outside_in permit icmp any any time-exceeded

pager lines 24

mtu outside 1500

mtu inside 1500

ip address outside xxx.xxx.xxx.82 255.255.255.240

ip address inside 195.30.30.1 255.255.255.0

ip audit info action alarm

ip audit attack action alarm

ip local pool VPNDHCP 195.30.31.10-195.30.31.20

pdm location 195.30.31.0 255.255.255.0 outside

pdm location 195.30.30.0 255.255.255.0 inside

pdm logging informational 100

pdm history enable

arp timeout 14400

global (outside) 1 xxx.xxx.xxx.83-xxx.xxx.xxx.89 netmask 255.255.255.240

global (outside) 1 interface

nat (inside) 0 access-list VPN

nat (inside) 1 0.0.0.0 0.0.0.0 0 0

static (inside,outside) xxx.xxx.xxx.90 195.30.30.3 netmask 255.255.255.255 0 0

access-group outside_in in interface outside

route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.81 1

timeout xlate 0:05:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00

timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00

timeout sip-disconnect 0:02:00 sip-invite 0:03:00

timeout uauth 0:05:00 absolute

aaa-server TACACS+ protocol tacacs+

aaa-server TACACS+ max-failed-attempts 3

aaa-server TACACS+ deadtime 10

aaa-server RADIUS protocol radius

aaa-server RADIUS max-failed-attempts 3

aaa-server RADIUS deadtime 10

aaa-server LOCAL protocol local

http server enable

http 195.30.30.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server community public

no snmp-server enable traps

floodguard enable

sysopt connection permit-ipsec

crypto ipsec transform-set matiasvpn esp-des esp-md5-hmac

crypto dynamic-map dynmapmatias 99 set transform-set matiasvpn

crypto map matiasmap 99 ipsec-isakmp dynamic dynmapmatias

crypto map matiasmap interface outside

isakmp enable outside

isakmp identity address

isakmp nat-traversal 20

isakmp policy 88 authentication pre-share

isakmp policy 88 encryption des

isakmp policy 88 hash md5

isakmp policy 88 group 2

isakmp policy 88 lifetime 86400

vpngroup -matIasvpn. address-pool VPNDHCP

vpngroup -matIasvpn. dns-server 195.30.30.3

vpngroup -matIasvpn. wins-server 195.30.30.3

vpngroup -matIasvpn. default-domain mattias.com

vpngroup -matIasvpn. idle-time 1800

vpngroup -matIasvpn. password ********

telnet 195.30.30.0 255.255.255.0 inside

telnet timeout 5

ssh timeout 5

console timeout 0

terminal width 80

Cryptochecksum:b20c7f4894a882d47871d98ee7da3909

: end

pixfirewall#

111
Views
4
Helpful
10
Replies