Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Cisco PPTP Vpn is connected but cant communicate with another hosts

I configure PPTP VPN on Cisco  2811, VPN Users have connected to VPN Server and recieved IP address but  cannot ping or access to inside another hosts.

Can anybody help me find missing or wrong position in my configuration ?

Thank you very much.

----------------------------

This my Configuration on Cisco 2811

Building configuration...

Current configuration : 7334 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service sequence-numbers
!
hostname R2811
!
boot-start-marker
boot system flash:/c2800nm-adventerprisek9-mz.124-25g.bin
boot-end-marker
!
logging buffered 51200 warnings
no logging console
no logging monitor
!
aaa new-model
!
!
aaa authentication login default group radius local
aaa authentication ppp default group radius local
aaa authorization exec default group radius local if-authenticated
aaa authorization network default group radius local if-authenticated
!
aaa session-id common
clock timezone gmt 7
!
!
ip cef

no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.10.200 192.168.10.254
ip dhcp excluded-address 192.168.20.200 192.168.20.254
ip dhcp excluded-address 192.168.30.200 192.168.30.254
ip dhcp excluded-address 192.168.20.1 192.168.20.10
ip dhcp excluded-address 192.168.10.1 192.168.10.100
ip dhcp excluded-address 192.168.30.1 192.168.30.100
!
ip dhcp pool VLAN30
   network 192.168.30.0 255.255.255.0
   default-router 192.168.30.1
   dns-server 8.8.8.8
!
ip dhcp pool default
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
   dns-server 8.8.8.8
!        
ip dhcp pool VLAN20
   network 192.168.20.0 255.255.255.0
   default-router 192.168.20.1
   dns-server 8.8.8.8
!
ip dhcp pool VLAN50
   network 192.168.50.0 255.255.255.0
   default-router 192.168.50.1
   dns-server 8.8.8.8
!
!
no ip domain lookup
ip domain name ms.local
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
  protocol pptp
  virtual-template 1
!
!
!
voice-card 0
no dspfarm

!
username admin privilege 15 password 0 12345
username user1 password 0 user1
!
!

!
!
!        
!
interface Loopback0
ip address 172.16.0.1 255.255.255.0
ip virtual-reassembly
!
interface FastEthernet0/0
no ip address
duplex full
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet0/1
description LAN
no ip address
duplex full
speed auto
no cdp enable
!
interface FastEthernet0/1.1
description DEFAULT
encapsulation dot1Q 1 native
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.2
description test2
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.3
description test2
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
ip helper-address 192.168.10.10
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.4
description test3
encapsulation dot1Q 40
ip address 192.168.40.1 255.255.255.0
ip helper-address 192.168.10.10
ip nat inside
ip virtual-reassembly
!        
interface FastEthernet0/1.5
encapsulation dot1Q 50
ip address 192.168.50.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Virtual-Template1
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly
peer default ip address pool pptp-pool
no keepalive
ppp authentication ms-chap ms-chap-v2
!

interface Dialer1
description WAN DIALER
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer persistent
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname xxxxxx
ppp chap password 0 999999
ppp pap sent-username xxxxx password 0 9999999
ppp ipcp dns request
!
ip local pool pptp-pool 172.16.0.250 172.16.0.254
ip forward-protocol nd
no ip forward-protocol udp tftp
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
no ip forward-protocol udp tacacs
ip route 0.0.0.0 0.0.0.0 Dialer1

!
!
ip http server
ip http authentication local
no ip http secure-server

ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static tcp 192.168.10.1 1723 interface Dialer1 1723
ip nat inside source static tcp 192.168.20.254 3366 interface Dialer1 3366
ip nat inside source static tcp 192.168.30.200 51413 interface Dialer1 51413
ip nat inside source static tcp 192.168.10.10 3355 interface Dialer1 3355
ip nat inside source static tcp 192.168.20.254 18053 interface Dialer1 18053

!
access-list 102 permit ip any any

!
!
radius-server host 192.168.10.10 auth-port 1645 acct-port 1646
radius-server key 123456
!
control-plane
!

!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
logging synchronous
transport input telnet
line vty 5 15
exec-timeout 0 0
logging synchronous
!
no scheduler allocate
ntp clock-period 17180063
ntp update-calendar
ntp server 14.0.18.136
!
end

R2811#

Everyone's tags (1)
534
Views
0
Helpful
0
Replies
CreatePlease to create content