Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Config for cisco 877 using PPOE

hi,

Does anyone have a config for a Cisco 877 DSL router that is using PPOE?

I normally use PPOA and jsut can't can't this PPOE DSL line working.

For the ATM I am using this:

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

Dor the Dialer:

interface Dialer1

ip address negotiated

ip access-group inbound in

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname eircom

ppp chap password 0 broadband1

ppp pap sent-username eircom password 0 broadband1

crypto map Crypto_Map

When I do a sh dsl int atm 0 it says showtime and the speed of the line and the CD light is constant.

I turned on debug ppp neg and debug ppp auth and see nothing!

Any ideas?

9 REPLIES

Re: Config for cisco 877 using PPOE

Working Config:

interface FastEthernet4

description OUTSIDE$ETH-WAN$

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

no cdp enable

interface Dialer0

description FW_OUTSIDE

ip address A.B.C.D 255.255.255.248

ip access-group outside_access in

ip mtu 1452

ip nbar protocol-discovery

ip nat outside

ip inspect FIREWALL out

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 1

dialer-group 1

ntp disable

no cdp enable

ppp authentication pap callin

ppp pap sent-username myusername@static.sbcglobal.net password 0 SeCrEt

!

dialer-list 1 protocol ip permit

I also have PPPoA if you need it.

New Member

Re: Config for cisco 877 using PPOE

Thanks,

Should it matter I use and ATM 0 on my Cisco 877 as it looks like your use an ethernet port on an 878 or similar.

Also I've not been asked to add and IP to the dialer like you have below, although I do have a static IP:

ip address A.B.C.D 255.255.255.248

Re: Config for cisco 877 using PPOE

ATM Config

interface Dialer0

description Virtual Public Interface

ip address A.B.C.D 255.255.255.248

ip access-group outside_in in

ip mtu 1452

ip flow ingress

ip inspect STATEFUL_FW out

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap callin

ppp chap hostname USERNAME@static.sbcglobal.net

ppp chap password 0 SeCrEt

ppp pap sent-username USERNAMEl@static.sbcglobal.net password 0 SeCrEt

dialer-list 1 protocol ip permit

New Member

Re: Config for cisco 877 using PPOE

Thanks, I have never had to add the static Ip to the dialer one port before I leave it as "ip address negotiated" is it import to include this on the dialer0 interface if I'm using PPOE?

Re: Config for cisco 877 using PPOE

If you're using DHCP use 'ip address negotiated' instead.

New Member

Re: Config for cisco 877 using PPOE

Is this if our ISP is issing a dynmaic IP address?

Re: Config for cisco 877 using PPOE

If you have a static IP use-

ip address A.B.C.D 255.255.255.248

If you have a DHCP address use-

ip address negotiate

The rest of the config is the same.

New Member

Re: Config for cisco 877 using PPOE

Thanks,

Some of the example configs use:

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

and under the dialer

dialer remote-name redback

what are these?

Re: Config for cisco 877 using PPOE

http://www.cisco.com/en/US/tech/tk801/tk703/tsd_technology_support_protocol_home.html

It's another way to connect. With my provider it doesn't work, but it may with yours.

1188
Views
0
Helpful
9
Replies
CreatePlease to create content