Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Create a VPN between 2 Host with cisco 2811 and NAT

Hi,

I need help with a remote connection, if someone can help me I´ll appreciate a lot, tanks in advance.

I want to create a VPN between two PC's, (the server "Data" and "Remote Desktop" please check the topology below), the Router Clabeck (cisco 2811 ) is connected to the internet through int f0/0 using a PPPoE connection and connects all the LAN PC's by PAT to the internet (you can see all the configurations in the Show Run below), the "Remote Desktop" is any PC with internet connection.

If someone need more information please let me know.

Best!!!

                                                                    F0/1                         F0/0

DATA--------------------SW-------------------ROUTER(Cisco 2811)---------------------INTERNET---------------REMOTE DESKTOP

192.168.1.51                                192.168.1.254              201.122.53.177                                                       192.168.1.1

Current configuration : 2116 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Clabeck

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable password 7 11391815161E0418017B7B

!

no aaa new-model

!

dot11 syslog

ip source-route

!

!

ip cef

ip dhcp excluded-address 192.168.1.1 192.168.1.50

!

ip dhcp pool CLABECK

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.254

   dns-server 8.8.8.8 8.8.4.4

!

!

ip name-server 8.8.8.8

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

voice-card 0

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface FastEthernet0/1

ip address 192.168.1.254 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

no fair-queue

clock rate 2000000

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname clabeck@prodigy.net.mx

ppp chap password 7 00051F0B055D0E515C7515

ppp pap sent-username clabeck@prodigy.net.mx password 7 1108150816140E5B577E72

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

no ip http secure-server

!

!

ip nat inside source list 1 interface Dialer1 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

!

!

control-plane

!

!

!

voice-port 0/1/0

!

voice-port 0/1/1

!

!

mgcp fax t38 ecm

mgcp behavior g729-variants static-pt

!

!

!

scheduler allocate 20000 1000

end

1 REPLY
Bronze

Create a VPN between 2 Host with cisco 2811 and NAT

http://www.cisco.com/en/US/tech/tk583/tk372/technologies_configuration_example09186a00800949db.shtml

Older document, but still mostly valid.

Just grab a Cisco VPN client, set up your router and client with the same ISAKMP/IPSec policies and pre-shared keys (unless you have RADIUS).  Assign a IP pool for the user(s) that will connect into the router and access the server.

Pretty straight forward.

481
Views
0
Helpful
1
Replies
CreatePlease to create content