Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DMVPN gre question

Hi,

I have a DMVPN setup between 1 hub & 1 spoke router.

Here's Hub tunnel config:

interface Tunnel1

ip address 10.101.0.1 255.255.255.0

no ip redirects

ip mtu 1416

ip nhrp authentication abcd

ip nhrp map multicast dynamic

ip nhrp network-id 123

no ip split-horizon eigrp 100

tunnel source FastEthernet0/1

tunnel mode gre multipoint

tunnel key 1234567

tunnel protection ipsec profile DMVPN

!

router eigrp 100

network 10.100.0.0 0.0.0.255

network 192.168.9.0

no auto-summary

!

Spoke Config:

interface Tunnel1

ip address 10.101.0.250 255.255.255.0

no ip redirects

ip mtu 1416

ip nhrp authentication abcd

ip nhrp map 10.101.0.1 publicIPhere

ip nhrp map multicast publicIPhere

ip nhrp network-id 123

ip nhrp nhs 10.101.0.1

ip nhrp cache non-authoritative

tunnel source FastEthernet0/0

tunnel mode gre multipoint

tunnel key 1234567

tunnel protection ipsec profile DMVPN

!

router eigrp 100

network 10.101.0.0 0.0.0.255

network 192.168.2.0

no auto-summary

My problem is that I cannot seem to get the EIGRP working between the HUB and the SPOKE routers. My isakmp and ipsec work fine. I am able to ping both GREtunnel IP's through the IPSEC tunnel.

If I use static routing communication works fine, is there any way to get the eigrp to go through the tunnel so I can avoid static routing?

TIA,

Fred

1 ACCEPTED SOLUTION

Accepted Solutions
joe Bronze
Bronze

Re: DMVPN gre question

Hi,

the hub has the wrong eigrp config... here is the correct config-

router eigrp 100

network 10.101.0.0 0.0.0.255

network 192.168.9.0

no auto-summary

you had

router eigrp 100

network 10.100.0.0 0.0.0.255

network 192.168.9.0

no auto-summary

2 REPLIES
joe Bronze
Bronze

Re: DMVPN gre question

Hi,

the hub has the wrong eigrp config... here is the correct config-

router eigrp 100

network 10.101.0.0 0.0.0.255

network 192.168.9.0

no auto-summary

you had

router eigrp 100

network 10.100.0.0 0.0.0.255

network 192.168.9.0

no auto-summary

New Member

Re: DMVPN gre question

Thanks! That was the problem and I kept overlooking it.

136
Views
0
Helpful
2
Replies
CreatePlease to create content