Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Dynamic Multipoint VPN configuration

I want to create VPN connection between routers.

One of them have static connection. Another one have only GSM connection with dynamic IP address.

Can I use DMVPNfor that case??

How to configure it.

12 REPLIES
Bronze

Re: Dynamic Multipoint VPN configuration

YES, make the hub static IP address, spokes can use dynamic.

Works VERY well, as I am using this setup with CDMA.

Here is a link to the doc

http://www.cisco.com/application/pdf/en/us/guest/netsol/ns171/c649/ccmigration_09186a008075ea98.pdf

Sample Hub config:

ip cef
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key bigsecret address 0.0.0.0 0.0.0.0
!
crypto ipsec transform-set vpn-test esp-3des esp-sha-hmac
no crypto ipsec nat-transparency udp-encaps
!
crypto ipsec profile vpn-dmvpn
set transform-set vpn-test
!
interface Loopback0
description Loopback0
ip address 10.57.1.255 255.255.255.255
!
interface Tunnel0
description Tunnel0
bandwidth 1000000
ip address 10.56.0.1 255.255.252.0
no ip redirects
ip hold-time eigrp 1 35
ip nhrp authentication test
ip nhrp map multicast dynamic
ip nhrp network-id 105600
ip nhrp holdtime 600
no ip split-horizon eigrp 1
ip summary-address eigrp 1 10.0.0.0 255.0.0.0 5
tunnel source GigabitEthernet0/1

tunnel mode gre multipoint
tunnel key 105600
tunnel protection ipsec profile vpn-dmvpn
!
interface GigabitEthernet0/1
description GigabitEthernet0/1
ip address 192.168.251.1 255.255.255.248
duplex auto
speed auto
media-type gbic
negotiation auto
!
interface GigabitEthernet0/2
description GigabitEthernet0/2
ip address 10.57.1.1 255.255.255.248
duplex auto
speed auto
media-type gbic
negotiation auto
!
router eigrp 1
network 10.0.0.0
no auto-summary
!
ip route 192.168.0.0 255.255.0.0 192.168.251.2

New Member

Re: Dynamic Multipoint VPN configuration

Thanks for information.

But what about spoke config??

And what with ACL rules to send traffic through VPN to hub and not internet.

Re: Dynamic Multipoint VPN configuration

You do not have to configure an ACL for the interesting traffic. You will have to work with IPSEC

Profiles.

The Routing protocol (or statics) will be in charge to define where to send the traffic. Only the HUB needs a static IP.

Cisco Employee

Re: Dynamic Multipoint VPN configuration

Yes this should be possible.

These are my favorite guides for understanding how to setup DMVPN:

Phase 1 and Phase 2 DMVPN:

http://blog.ine.com/2008/08/02/dmvpn-explained/#more-214

Phase 3 DMVPN:

http://blog.ine.com/2008/12/23/dmvpn-phase-3/

Hope this helps

-heather

Re: Dynamic Multipoint VPN configuration

If you are going to have only 2 routers in the VPN you can work with Easy VPN.

You can Work with Dynamic maps so your router with the static

IP will not need to know the peer IP Address.

Re: Dynamic Multipoint VPN configuration

The only problem with dynamic cryto maps is that only the

router with the dhcp address can initiate the connection or the vpn.

New Member

Re: Dynamic Multipoint VPN configuration

Thanks for all suggestions.

I will try it on tomorrow.

New Member

Re: Dynamic Multipoint VPN configuration

Well I managed to established connection between routers but I have one problem.

In a moment when the spoke IP address has changed it took too long to establish another connection.

In monitor (using CCP) I can see old tunnel but the new one going to established in approximately 10 minutes.

How to solve this problem??

Re: Dynamic Multipoint VPN configuration

What did you configure? DMVPN, EASY VPN or site to site using Dynamic map ??

New Member

Re: Dynamic Multipoint VPN configuration

DMVPN, hub and spoke network with p2p gre interface using OSPF routing.

Re: Dynamic Multipoint VPN configuration

configure a short holdtime in the ip nhrp

http://www.cisco.com/en/US/docs/ios/ipaddr/command/reference/iad_nhrp.html#wp1011085

maybe 120 seconds.

New Member

Re: Dynamic Multipoint VPN configuration

Yes, it helped.

But I was thinking if I can use site2site VPN connection with Dynamic Crypto Map Sets.

And this also works for me.

But in this case I found a problem when the connection is established and the peer IP has changed.

Which option is responsible to check if the peer is still connected on IP? If not, close the vpn connection and establish new one on new IP.


In Crypto map I found security association lifetime and idle time.

In IKE policy is lifetime also.

Where should I look??

482
Views
0
Helpful
12
Replies
CreatePlease to create content